source: projects/specs/trunk/r/rhino/rhino-vl.spec @ 1737

Revision 1737, 9.7 KB checked in by inagaki, 14 years ago (diff)

NEW: junit, jline, rhino, xalan-j2

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define cvs_version 1_7R2
32
33Name:           rhino
34Summary:        JavaScript for Java
35Version:        1.7
36Release:        0.r2.1%{?_dist_release}
37
38Group:          Development/Libraries
39License:        MPLv1.1 or GPLv2+
40URL:            http://www.mozilla.org/rhino/
41
42Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino%{cvs_version}.zip
43Source2:        %{name}.script
44
45#Patch0:         %{name}-build.patch
46## Patch to try several methods of loading jline library or fail gracefully
47#Patch1:         %{name}-457336.diff
48
49BuildRoot:      %{_tmppath}/%{name}-%{version}-root
50BuildArch:      noarch
51#BuildRequires:  ant
52#BuildRequires:  bea-stax-api
53#BuildRequires:  java-1.6.0-openjdk-devel >= 1:1.6.0.0
54Requires:       jpackage-utils
55Requires:       jline
56
57# Disable xmlbeans until we can get it into Fedora
58#Requires:       xmlbeans
59#BuildRequires:  xmlbeans
60
61%description
62Rhino is an open-source implementation of JavaScript written entirely
63in Java. It is typically embedded into Java applications to provide
64scripting to end users.
65
66%description -l ja
67Rhino はすべてが Java で記述された JavaScript のオープンソースな実装です.
68一般的には Java アプリケーションに組み込まれることで、エンドユーザーによる
69スクリプトの記述が可能になります.
70
71
72%package        demo
73Summary:        Examples for %{name}
74Group:          Development/Libraries
75
76%description    demo
77Examples for %{name}.
78
79#%package        manual
80#Summary:        Manual for %{name}
81#Group:          Documentation
82#
83#%description    manual
84#Documentation for %{name}.
85
86#%package        javadoc
87#Summary:        Javadoc for %{name}
88#Group:          Development/Documentation
89#
90#%description    javadoc
91#Javadoc for %{name}.
92
93%prep
94%setup -q -n %{name}%{cvs_version}
95#patch0 -p1
96#patch1 -p0 -b .jline
97
98# Fix build
99#{__perl} -pi -e 's|.*<get.*src=.*>\n||' build.xml testsrc/build.xml toolsrc/org/mozilla/javascript/tools/debugger/build.xml xmlimplsrc/build.xml
100
101# Fix manifest
102#{__perl} -pi -e 's|^Class-Path:.*\n||g' src/manifest
103
104# Add jpp release info to version
105#{__perl} -pi -e 's|^implementation.version: Rhino .* release .* \${implementation.date}|implementation.version: Rhino %{version} release %{release} \${implementation.date}|' build.properties
106
107%build
108#export CLASSPATH=
109#export OPT_JAR_LIST=:
110#ant -Dxbean.jar=$(build-classpath xmlbeans/xbean) \
111#    -Djsr173.jar=$(build-classpath bea-stax-api) deepclean jar copy-all javadoc
112
113#pushd examples
114#export CLASSPATH=../build/%{name}%{cvs_version}/js.jar:$(build-classpath xmlbeans/xbean 2>/dev/null)
115#{javac} *.java
116#{jar} cvf ../build/%{name}%{cvs_version}/%{name}-examples-%{version}.jar *.class
117#popd
118
119%install
120rm -rf $RPM_BUILD_ROOT
121
122# jars
123mkdir -p $RPM_BUILD_ROOT%{_javadir}
124install -m 644 js.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
125#%{__cp} -a build/%{name}%{cvs_version}/%{name}-examples-%{version}.jar %{buildroot}%{_javadir}/%{name}-examples-%{version}.jar
126#(cd %{buildroot}%{_javadir} && %{__ln_s} %{name}-%{version}.jar js-%{version}.jar)
127(cd %{buildroot}%{_javadir} && for jar in *-%{version}*; do %{__ln_s} ${jar} `echo $jar| %{__sed} "s|-%{version}||g"`; done)
128
129# javadoc
130#%{__mkdir_p} %{buildroot}%{_javadocdir}/%{name}-%{version}
131#%{__cp} -a build/%{name}%{cvs_version}/javadoc/* %{buildroot}%{_javadocdir}/%{name}-%{version}
132#%{__ln_s} %{name}-%{version} %{buildroot}%{_javadocdir}/%{name}
133#%{_bindir}/find %{buildroot}%{_javadocdir}/%{name}-%{version} -type f -name '*.html' | %{_bindir}/xargs %{__perl} -pi -e 's/\r$//g'
134
135## script
136mkdir -p $RPM_BUILD_ROOT%{_bindir}
137install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
138
139# examples
140mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
141cp -a examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(0644,root,root,0755)
148%doc LICENSE.txt
149%attr(0755,root,root) %{_bindir}/*
150%{_javadir}/*
151
152%files demo
153%defattr(0644,root,root,0755)
154%{_datadir}/%{name}
155
156#%files manual
157#%defattr(0644,root,root,0755)
158#%if 0
159#%doc build/%{name}%{cvs_version}/docs/*
160#%endif
161
162#files javadoc
163#defattr(0644,root,root,0755)
164#doc %{_javadocdir}/*
165
166%changelog
167* Wed Sep  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r2.1
168- Initial build for VineLinux
169
170* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.7.r2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Sun May 31 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0:1.7-0.6.r2
174- Update to rhino1_7R2
175- Add patch from Steven Elliott to fix exception in the interpreter shell.
176
177* Mon Apr 20 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.4.r2pre.1.1
178- Added jpackage-utils requirement.
179- Resolves: rhbz#496435
180
181* Thu Mar 26 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.3.r2pre.1.1
182- Updated rhino-build.patch
183- License for treetable has been fixed. Re-included this code, and removed patch.
184- Resolves: rhbz#457336
185
186* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.2.r2pre.1.1
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
188
189* Fri Feb 13 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.1.r2pre.1.1
190- Upgraded to 1.7r2pre.
191- Resolves: rhbz#485135
192
193* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.6-0.1.r5.1.3
194- drop repotag
195- fix license tag
196
197* Thu Mar 15 2007 Matt Wringe <mwringe@redhat.com> 0:1.6-0.1.r5.1jpp.2
198- Remove script from build as the debugging tool is disabled due to it
199  containing proprietary code from Sun.
200
201* Wed Mar 07 2007 Deepak Bhole <dbhole@redhat.com> 0:1.6-0.1.r5.1jpp.1
202- Upgrade to 1.6r5
203- Change release per Fedora guidelines
204- Disable dependency on xmlbeans (optional component, not in Fedora yet)
205- Disable building of debugger tool, as it needs confidential code from Sun
206- Remove post/postuns for javadoc and add the two dirs as %%doc
207
208* Wed Jun 14 2006 Ralph Apel <r.apel@r-apel.de> 0:1.6-0.r2.2jpp
209- Add bea-stax-api in order to build xmlimpl classes
210
211* Tue May 31 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r2.1jpp
212- Upgrade to RC2
213
214* Mon Apr 24 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r1.2jpp
215- First JPP 1.7 build
216
217* Thu Dec 02 2004 David Walluck <david@jpackage.org> 0:1.6-0.r1.1jpp
218- 1_6R1
219- add demo subpackage containing example code
220- add jpp release info to implementation version
221- add script to launch js shell
222- build E4X implementation (Requires: xmlbeans)
223- remove `Class-Path' from manifest
224
225* Tue Aug 24 2004 Fernando Nasser <fnasser@redhat.com> - 0:1.5-1.R5.1jpp
226- Update to 1.5R5.
227- Rebuild with Ant 1.6.2
228
229* Sat Jul 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.5-1.R4.1.1jpp
230- Update to 1.5R4.1.
231- Non-versioned javadoc dir symlink.
232
233* Fri Apr 11 2003 David Walluck <davdi@anti-microsoft.org> 0:1.5-0.R4.2jpp
234- remove build patches in favor of perl
235- add epoch
236
237* Sun Mar 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.r4.1jpp
238- Update to 1.5R4.
239- Rebuild for JPackage 1.5.
240
241* Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R3.1jpp
242- 1.5R3
243- versioned dir for javadoc
244
245* Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.9jpp
246- versioned compatibility symlink
247
248* Mon Jan 21 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.8jpp
249- section macro
250- new release scheme
251
252* Thu Jan 17 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-7jpp
253- spec cleanup
254- changelog corrections
255
256* Fri Jan 11 2002 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-6jpp
257- backward compatibility js.jar symlink
258- used original swing exemples archive
259- fixed javadoc empty package-list file
260- no dependencies for manual and javadoc packages
261
262* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-5jpp
263- javadoc in javadoc package
264- fixed offline build
265
266* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 1.5R2-4jpp
267- changed extension --> jpp
268
269* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-3jpp
270- first unified release
271- s/jPackage/JPackage
272- corrected license to MPL
273
274* Sat Sep 15 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-2mdk
275- spec cleanup
276- standardized cvs references
277
278* Thu Aug 31 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-1mdk
279- first Mandrake release
Note: See TracBrowser for help on using the repository browser.