source: projects/specs/trunk/r/rhino/rhino-vl.spec @ 9288

Revision 9288, 9.7 KB checked in by inagaki, 9 years ago (diff)

2015-01-24 Ryoichi INAGAKI <ryo1@…>

  • java_cup: added Patch
  • rhino, xerces-c, xml-common-apis, xmlcopyeditor: updated


Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistribution1s in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define scm_version 1_7R4
32
33Name:           rhino
34Version:        1.7
35Release:        0.r4.1%{?_dist_release}
36Summary:        JavaScript for Java
37Summary(ja):    Java で記述された JavaScript
38
39Group:          Development/Libraries
40License:        MPLv2.0
41URL:            http://www.mozilla.org/rhino/
42
43Source0:        https://github.com/mozilla/rhino/archive/Rhino%{scm_version}_RELEASE.zip
44Source2:        %{name}.script
45
46Patch0:         %{name}-build.patch
47# Add OSGi metadata from Eclipse Orbit project
48# Rip out of MANIFEST.MF included in this JAR:
49# http://www.eclipse.org/downloads/download.php?r=1&file=/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.mozilla.javascript_1.7.2.v201005080400.jar
50Patch1:         %{name}-addOrbitManifest.patch
51Patch2:         %{name}-shell-manpage.patch
52# Originally from https://github.com/mozilla/rhino/commit\
53#    /52e25f784cd1b927d44383aa9afb358191df97e4.patch
54# See RHBZ# 1011947
55Patch3:         %{name}-overflow-detection.patch
56
57BuildRoot:      %{_tmppath}/%{name}-%{version}-root
58BuildArch:      noarch
59BuildRequires:  ant
60BuildRequires:  java-devel
61Requires:       jpackage-utils
62Requires:       jline
63
64# Disable xmlbeans until we can get it into Fedora
65#Requires:       xmlbeans
66#BuildRequires:  xmlbeans
67
68%description
69Rhino is an open-source implementation of JavaScript written entirely
70in Java. It is typically embedded into Java applications to provide
71scripting to end users.
72
73%description -l ja
74Rhino はすべてが Java で記述された JavaScript のオープンソースな実装です.
75一般的には Java アプリケーションに組み込まれることで、エンドユーザーによる
76スクリプトの記述が可能になります.
77
78
79%package        demo
80Summary:        Examples for %{name}
81Summary(ja):    %{name} のデモプログラム
82Group:          Development/Libraries
83
84%description    demo
85Examples for %{name}.
86
87#%package        manual
88#Summary:        Manual for %{name}
89#Group:          Documentation
90#
91#%description    manual
92#Documentation for %{name}.
93
94%prep
95%setup -q -n %{name}-Rhino%{scm_version}_RELEASE
96%patch0 -p1 -b .build
97%patch1 -p1 -b .fixManifest
98%patch2 -p1 -b .manpage
99%patch3 -p1 -b .overflow
100
101# Fix build
102sed -i -e '/.*<get.*src=.*>$/d' build.xml testsrc/build.xml \
103       toolsrc/org/mozilla/javascript/tools/debugger/build.xml xmlimplsrc/build.xml
104
105# Fix manifest
106sed -i -e '/^Class-Path:.*$/d' src/manifest
107
108# Add jpp release info to version
109sed -i -e 's|^implementation.version: Rhino .* release .* \${implementation.date}|implementation.version: Rhino %{version} release %{release} \${implementation.date}|' build.properties
110
111%build
112ant deepclean jar copy-all -Dno-xmlbeans=1
113
114pushd examples
115export CLASSPATH=../build/%{name}%{scm_version}/js.jar:$(build-classpath xmlbeans/xbean 2>/dev/null)
116%{javac} *.java
117%{jar} cvf ../build/%{name}%{scm_version}/%{name}-examples.jar *.class
118popd
119
120%install
121rm -rf $RPM_BUILD_ROOT
122
123# jars
124mkdir -p $RPM_BUILD_ROOT%{_javadir}
125cp -a build/%{name}%{scm_version}/js.jar $RPM_BUILD_ROOT%{_javadir}
126ln -s js.jar $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
127cp -a build/%{name}%{scm_version}/%{name}-examples.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-examples.jar
128
129# man page
130mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/
131install -m 644 build/%{name}%{scm_version}/man/%{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1/%{name}.1
132
133## script
134mkdir -p $RPM_BUILD_ROOT%{_bindir}
135install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
136
137# examples
138mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
139cp -a examples/* $RPM_BUILD_ROOT%{_datadir}/%{name}
140find $RPM_BUILD_ROOT%{_datadir}/%{name} -name '*.build' -delete
141
142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
146%files
147%defattr(0644,root,root,0755)
148%doc LICENSE.txt
149%attr(0755,root,root) %{_bindir}/*
150%{_javadir}/*
151%{_mandir}/man1/%{name}.1*
152
153%files demo
154%defattr(0644,root,root,0755)
155%{_datadir}/%{name}
156
157#%files manual
158#%defattr(0644,root,root,0755)
159#%if 0
160#%doc build/%{name}%{scm_version}/docs/*
161#%endif
162
163%changelog
164* Fri Jan 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.7-0.r4.1
165- new upstream release
166
167* Sat Jun  2 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r3.1
168- new upstream release
169
170* Wed Sep  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.7-0.r2.1
171- Initial build for VineLinux
172
173* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.7.r2
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
175
176* Sun May 31 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0:1.7-0.6.r2
177- Update to rhino1_7R2
178- Add patch from Steven Elliott to fix exception in the interpreter shell.
179
180* Mon Apr 20 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.4.r2pre.1.1
181- Added jpackage-utils requirement.
182- Resolves: rhbz#496435
183
184* Thu Mar 26 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.3.r2pre.1.1
185- Updated rhino-build.patch
186- License for treetable has been fixed. Re-included this code, and removed patch.
187- Resolves: rhbz#457336
188
189* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.7-0.2.r2pre.1.1
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
191
192* Fri Feb 13 2009 Lillian Angel <langel@redhat.com> - 0:1.7-0.1.r2pre.1.1
193- Upgraded to 1.7r2pre.
194- Resolves: rhbz#485135
195
196* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.6-0.1.r5.1.3
197- drop repotag
198- fix license tag
199
200* Thu Mar 15 2007 Matt Wringe <mwringe@redhat.com> 0:1.6-0.1.r5.1jpp.2
201- Remove script from build as the debugging tool is disabled due to it
202  containing proprietary code from Sun.
203
204* Wed Mar 07 2007 Deepak Bhole <dbhole@redhat.com> 0:1.6-0.1.r5.1jpp.1
205- Upgrade to 1.6r5
206- Change release per Fedora guidelines
207- Disable dependency on xmlbeans (optional component, not in Fedora yet)
208- Disable building of debugger tool, as it needs confidential code from Sun
209- Remove post/postuns for javadoc and add the two dirs as %%doc
210
211* Wed Jun 14 2006 Ralph Apel <r.apel@r-apel.de> 0:1.6-0.r2.2jpp
212- Add bea-stax-api in order to build xmlimpl classes
213
214* Tue May 31 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r2.1jpp
215- Upgrade to RC2
216
217* Mon Apr 24 2006 Fernando Nasser <fnasser@redhat.com> 0:1.6-0.r1.2jpp
218- First JPP 1.7 build
219
220* Thu Dec 02 2004 David Walluck <david@jpackage.org> 0:1.6-0.r1.1jpp
221- 1_6R1
222- add demo subpackage containing example code
223- add jpp release info to implementation version
224- add script to launch js shell
225- build E4X implementation (Requires: xmlbeans)
226- remove `Class-Path' from manifest
227
228* Tue Aug 24 2004 Fernando Nasser <fnasser@redhat.com> - 0:1.5-1.R5.1jpp
229- Update to 1.5R5.
230- Rebuild with Ant 1.6.2
231
232* Sat Jul 19 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.5-1.R4.1.1jpp
233- Update to 1.5R4.1.
234- Non-versioned javadoc dir symlink.
235
236* Fri Apr 11 2003 David Walluck <davdi@anti-microsoft.org> 0:1.5-0.R4.2jpp
237- remove build patches in favor of perl
238- add epoch
239
240* Sun Mar 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 1.5-0.r4.1jpp
241- Update to 1.5R4.
242- Rebuild for JPackage 1.5.
243
244* Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R3.1jpp
245- 1.5R3
246- versioned dir for javadoc
247
248* Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.9jpp
249- versioned compatibility symlink
250
251* Mon Jan 21 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5-0.R2.8jpp
252- section macro
253- new release scheme
254
255* Thu Jan 17 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-7jpp
256- spec cleanup
257- changelog corrections
258
259* Fri Jan 11 2002 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-6jpp
260- backward compatibility js.jar symlink
261- used original swing exemples archive
262- fixed javadoc empty package-list file
263- no dependencies for manual and javadoc packages
264
265* Sat Dec 1 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-5jpp
266- javadoc in javadoc package
267- fixed offline build
268
269* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 1.5R2-4jpp
270- changed extension --> jpp
271
272* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-3jpp
273- first unified release
274- s/jPackage/JPackage
275- corrected license to MPL
276
277* Sat Sep 15 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-2mdk
278- spec cleanup
279- standardized cvs references
280
281* Thu Aug 31 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.5R2-1mdk
282- first Mandrake release
Note: See TracBrowser for help on using the repository browser.