source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 6613

Revision 6613, 7.0 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.5.0
5Release:        2%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://rednotebook.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13#Patch0:         fix_install_data.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19BuildRequires:  desktop-file-utils
20
21Requires:       PyYAML
22Requires:       pygtk2
23Requires:       gnome-python-extras
24Requires:       hicolor-icon-theme
25Requires:       pywebkitgtk
26Requires:       python-chardet
27
28%description
29RedNotebook is a desktop journal that makes it very easy for you
30to keep track of the stuff you do and the thoughts you have. This
31journal software helps you to write whole passages or just facts,
32and does so in style.
33
34%description-l ja
35RedNotebook はあなたの行動、及び考えているアイデアの推移の
36追跡を非常に簡単にするデスクトップ・ジャーナルです。
37このジャーナル・ソフトウェアは、あなたが全体の推移、
38あるいは事実の記載をスタイリッシュに行えるよう手助けします。
39
40%prep
41%setup -q
42#%patch0 -p1
43
44
45%build
46python setup.py build
47
48
49%install
50rm -rf %{buildroot}
51python setup.py install --skip-build --root %{buildroot}
52
53%find_lang %{name}
54
55%clean
56rm -rf %{buildroot}
57
58
59%post
60touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
61
62
63%postun
64if [ $1 -eq 0 ] ; then
65    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
66    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
67fi
68
69
70%posttrans
71gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
72
73
74%files -f %{name}.lang
75%defattr(-,root,root,-)
76%doc AUTHORS CHANGELOG LICENSE README
77%{_bindir}/%{name}
78%{_datadir}/applications/%{name}.desktop
79%{_datadir}/pixmaps/%{name}.png
80%{_datadir}/icons/hicolor/*/*/%{name}.*
81%{python_sitelib}/%{name}/
82%{python_sitelib}/%{name}*.egg-info
83
84%changelog
85* Sat Jul 21 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
86- replaced source
87  - fixed install data (merged patch)
88
89* Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
90- new upstream release
91- added Patch0 to fix install data
92
93* Tue Jun 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.0-1
94- new upstream release
95
96* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
97- new upstream release
98
99* Sat Oct 08 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
100- new upstream release
101
102* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.8-1
103- new upstream release
104- changed URL
105
106* Thu Jul 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.7-1
107- new upstream release
108
109* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
110- new upstream release
111
112* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
113- new upstream release
114
115* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
116- new upstream release
117
118* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
119- new upstream release
120
121* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
122- new upstream release
123
124* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
125- new upstream release
126
127* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
128- new upstream release
129
130* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
131- new upstream release
132- added Requires: pywebkitgtk, python-chardet
133
134* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
135- new upstream release
136
137* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
138- new upstream release
139
140* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
141- rebuilt with python-2.6.4-3
142
143* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
144- initial build for VineSeed
145
146* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
147- Update to 0.8.6.1, fixes #523880
148
149* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
150- Fix libglade error with GTK 2.16.6 (#523880)
151
152* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
153- Updated to new upstream version 0.8.6
154
155* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
156- Updated to new upstream version 0.8.5 (fixes #518778)
157
158* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
159- Updated to new upstream version 0.8.4
160
161* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
162- Updated to new upstream version 0.8.3
163
164* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
165- Updated to new upstream version 0.8.2
166
167* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
168- Updated to new upstream version 0.8.1
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
170
171* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
172- Updated BR python
173- Icon cache update added
174- Updated to new upstream version 0.8.0
175
176* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
177- Updated to new upstream version 0.7.6
178
179* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
180- Removed the shebang stuff, upstream changed this
181- Updated to new upstream version 0.7.5
182
183* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
184- Moved the removing of the shebang to prep section
185- Updated to new upstream version 0.7.4
186
187* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
188- Updated to new upstream version 0.7.2
189
190* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
191- Updated to new upstream version 0.7.1
192
193* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
194- Updated to new upstream version 0.6.9
195
196* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
197- Updated to new upstream version 0.6.8
198
199* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
200- Updated to new upstream version 0.6.7
201
202* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
203- Updated to new upstream version 0.6.6
204
205* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
206- Updated to new upstream version 0.6.5
207
208* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
209- Added hicolor-icon-theme as a requirement
210- Added icons directory
211- Updated to new upstream version 0.6.2
212
213* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
214- Updated to new upstream version 0.6.1
215- Renamed docs, added License file
216
217* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
218- Updated to new upstream version 0.5.5
219
220* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
221- Updated to new upstream version 0.5.2
222
223* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
224- Initial package for Fedora
225
Note: See TracBrowser for help on using the repository browser.