source: projects/specs/trunk/r/rednotebook/rednotebook-vl.spec @ 6608

Revision 6608, 6.9 KB checked in by kudoh, 12 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           rednotebook
4Version:        1.5.0
5Release:        1%{?_dist_release}
6Summary:        A desktop journal
7Summary(ja):    デスクトップダイアリー
8
9Group:          Applications/Productivity
10License:        GPLv2+
11URL:            http://rednotebook.sourceforge.net/
12Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
13Patch0:         fix_install_data.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildArch:      noarch
16
17BuildRequires:  python-devel
18BuildRequires:  python-setuptools
19BuildRequires:  desktop-file-utils
20
21Requires:       PyYAML
22Requires:       pygtk2
23Requires:       gnome-python-extras
24Requires:       hicolor-icon-theme
25Requires:       pywebkitgtk
26Requires:       python-chardet
27
28%description
29RedNotebook is a desktop journal that makes it very easy for you
30to keep track of the stuff you do and the thoughts you have. This
31journal software helps you to write whole passages or just facts,
32and does so in style.
33
34%description-l ja
35RedNotebook はあなたの行動、及び考えているアイデアの推移の
36追跡を非常に簡単にするデスクトップ・ジャーナルです。
37このジャーナル・ソフトウェアは、あなたが全体の推移、
38あるいは事実の記載をスタイリッシュに行えるよう手助けします。
39
40%prep
41%setup -q
42%patch0 -p1
43
44
45%build
46python setup.py build
47
48
49%install
50rm -rf %{buildroot}
51python setup.py install --skip-build --root %{buildroot}
52
53%find_lang %{name}
54
55%clean
56rm -rf %{buildroot}
57
58
59%post
60touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
61
62
63%postun
64if [ $1 -eq 0 ] ; then
65    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
66    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
67fi
68
69
70%posttrans
71gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
72
73
74%files -f %{name}.lang
75%defattr(-,root,root,-)
76%doc AUTHORS CHANGELOG LICENSE README
77%{_bindir}/%{name}
78%{_datadir}/applications/%{name}.desktop
79%{_datadir}/pixmaps/%{name}.png
80%{_datadir}/icons/hicolor/*/*/%{name}.*
81%{python_sitelib}/%{name}/
82%{python_sitelib}/%{name}*.egg-info
83
84%changelog
85* Fri Jul 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
86- new upstream release
87- added Patch0 to fix install data
88
89* Tue Jun 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.0-1
90- new upstream release
91
92* Sat Jan 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
93- new upstream release
94
95* Sat Oct 08 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
96- new upstream release
97
98* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.8-1
99- new upstream release
100- changed URL
101
102* Thu Jul 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.7-1
103- new upstream release
104
105* Fri May 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.6-1
106- new upstream release
107
108* Wed May 4 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.5-1
109- new upstream release
110
111* Fri Apr 29 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.4-1
112- new upstream release
113
114* Tue Dec 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.2-1
115- new upstream release
116
117* Mon Aug 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.1-1
118- new upstream release
119
120* Wed Aug 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.0-1
121- new upstream release
122
123* Wed Jun 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
124- new upstream release
125
126* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.5-1
127- new upstream release
128- added Requires: pywebkitgtk, python-chardet
129
130* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.4-1
131- new upstream release
132
133* Wed Feb 24 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.3-1
134- new upstream release
135
136* Sun Feb 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-2
137- rebuilt with python-2.6.4-3
138
139* Fri Jan 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.2-1
140- initial build for VineSeed
141
142* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6.1-1
143- Update to 0.8.6.1, fixes #523880
144
145* Thu Sep 17 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-2
146- Fix libglade error with GTK 2.16.6 (#523880)
147
148* Fri Sep 04 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
149- Updated to new upstream version 0.8.6
150
151* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.5-1
152- Updated to new upstream version 0.8.5 (fixes #518778)
153
154* Fri Aug 14 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
155- Updated to new upstream version 0.8.4
156
157* Fri Aug 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.3-1
158- Updated to new upstream version 0.8.3
159
160* Wed Jul 29 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
161- Updated to new upstream version 0.8.2
162
163* Sat Jul 25 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.1-1
164- Updated to new upstream version 0.8.1
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
166
167* Wed Jul 22 2009 Fabian Affolter <fabian@bernewireless.net> - 0.8.0-1
168- Updated BR python
169- Icon cache update added
170- Updated to new upstream version 0.8.0
171
172* Wed Jul 15 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.6-1
173- Updated to new upstream version 0.7.6
174
175* Mon Jul 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.5-1
176- Removed the shebang stuff, upstream changed this
177- Updated to new upstream version 0.7.5
178
179* Mon Jun 29 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.4-1
180- Moved the removing of the shebang to prep section
181- Updated to new upstream version 0.7.4
182
183* Thu May 26 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.2-1
184- Updated to new upstream version 0.7.2
185
186* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.7.1-1
187- Updated to new upstream version 0.7.1
188
189* Wed May 06 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.9-1
190- Updated to new upstream version 0.6.9
191
192* Sun May 03 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.8-1
193- Updated to new upstream version 0.6.8
194
195* Tue Apr 21 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.7-1
196- Updated to new upstream version 0.6.7
197
198* Tue Apr 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.6-1
199- Updated to new upstream version 0.6.6
200
201* Fri Apr 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.5-1
202- Updated to new upstream version 0.6.5
203
204* Wed Mar 18 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.2-1
205- Added hicolor-icon-theme as a requirement
206- Added icons directory
207- Updated to new upstream version 0.6.2
208
209* Sat Mar 07 2009 Fabian Affolter <fabian@bernewireless.net> - 0.6.1-1
210- Updated to new upstream version 0.6.1
211- Renamed docs, added License file
212
213* Thu Feb 12 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.5-1
214- Updated to new upstream version 0.5.5
215
216* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.2-1
217- Updated to new upstream version 0.5.2
218
219* Sat Jan 24 2009 Fabian Affolter <fabian@bernewireless.net> - 0.5.1-1
220- Initial package for Fedora
221
Note: See TracBrowser for help on using the repository browser.