source: projects/specs/trunk/r/readline/readline-vl.spec @ 521

Revision 521, 11.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): readline ライブラリ
3
4Name: readline
5Version: 5.2
6Release: 3%{?_dist_release}
7License: GPLv2
8Group: System Environment/Libraries
9URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
10Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
11
12# upstream patches
13Patch1: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-001
14Patch2: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-002
15Patch3: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-003
16Patch4: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-004
17Patch5: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-005
18Patch6: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-006
19Patch7: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-007
20Patch8: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-008
21Patch9: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-009
22Patch10: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-010
23Patch11: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-011
24Patch12: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline52-012
25
26Patch20: readline-5.2-shlib.patch
27
28Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: sed
30BuildRequires: ncurses-devel
31Requires(post): /sbin/install-info, /sbin/ldconfig
32Requires(preun): /sbin/install-info
33Requires(postun): /sbin/ldconfig
34
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
40
41%description
42The readline library reads a line from the terminal and returns it,
43allowing the user to edit the line with standard emacs editing keys.
44The readline library allows programmers to provide an easy to use and
45more intuitive interface for users.
46
47If you want to develop programs that will use the readline library,
48you'll also need to install the readline-devel package.
49
50
51%description -l ja
52"readline" ライブラリを用いると、端末から読みこんだ一行を、emacs の標準キー
53と同キーバインディングで編集できるようになります。これをプログラム中で使うと、
54より使いやすいインタフェースをユーザに提供できます。
55
56
57%package devel
58Summary: Files needed to develop programs which use the readline library.
59Summary(ja): readline ライブラリを使うプログラムための開発用ライブラリ
60Group: Development/Libraries
61Requires: readline = %{version}
62Requires: ncurses-devel
63
64%description devel
65The readline library will read a line from the terminal and return it.
66Use of the readline library allows programmers to provide an easy
67to use and more intuitive interface for users.
68
69If you want to develop programs which will use the readline library,
70you'll need to have the readline-devel package installed.  You'll also
71need to have the readline package installed.
72
73
74%package -n compat32-%{name}
75Summary: A library for editing typed in command lines.
76Summary(ja): readline ライブラリ
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79
80%description -n compat32-%{name}
81The readline library reads a line from the terminal and returns it,
82allowing the user to edit the line with standard emacs editing keys.
83The readline library allows programmers to provide an easy to use and
84more intuitive interface for users.
85
86If you want to develop programs that will use the readline library,
87you'll also need to install the readline-devel package.
88
89
90%description -n compat32-%{name} -l ja
91"readline" ライブラリを用いると、端末から読みこんだ一行を、emacs の標準キー
92と同キーバインディングで編集できるようになります。これをプログラム中で使うと、
93より使いやすいインタフェースをユーザに提供できます。
94
95
96%package -n compat32-%{name}-devel
97Summary: Files needed to develop programs which use the readline library.
98Summary(ja): readline ライブラリを使うプログラムための開発用ライブラリ
99Group: Development/Libraries
100Requires: %{name} = %{version}-%{release}
101Requires: %{name}-devel = %{version}-%{release}
102Requires: compat32-ncurses-devel
103
104
105%description -n compat32-%{name}-devel
106The readline library will read a line from the terminal and return it.
107Use of the readline library allows programmers to provide an easy
108to use and more intuitive interface for users.
109
110If you want to develop programs which will use the readline library,
111you'll need to have the readline-devel package installed.  You'll also
112need to have the readline package installed.
113
114
115%prep
116%setup -q
117
118# upstream patches
119%patch1 -p0 -b .001
120%patch2 -p0 -b .002
121%patch3 -p0 -b .003
122%patch4 -p0 -b .004
123%patch5 -p0 -b .005
124%patch6 -p0 -b .006
125%patch7 -p0 -b .007
126%patch8 -p0 -b .008
127%patch9 -p0 -b .009
128%patch10 -p0 -b .010
129%patch11 -p0 -b .011
130%patch12 -p0 -b .012
131
132%patch20 -p1 -b .shlib
133
134%build
135export CPPFLAGS="-I%{_includedir}/ncurses"
136%configure
137make %{?_smp_mflags} all shared
138
139
140%install
141[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
142mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
143
144
145%makeinstall
146
147mkdir $RPM_BUILD_ROOT/%{_lib}
148mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
149for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
150    ln -sf $(echo %{_libdir} | \
151     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
152done
153
154rm -f $RPM_BUILD_ROOT%{_infodir}/dir
155
156%clean
157[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
158
159%post
160/sbin/ldconfig
161/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir
162/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir
163
164%postun -p /sbin/ldconfig
165
166%post -n compat32-%{name} -p /sbin/ldconfig
167
168%postun -n compat32-%{name} -p /sbin/ldconfig
169
170%preun
171if [ $1 = 0 ]; then
172   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir
173   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir
174fi
175
176%files
177%defattr(-,root,root)
178%doc CHANGELOG CHANGES COPYING INSTALL MANIFEST README USAGE
179%doc doc/*.{html,pdf}
180%{_mandir}/man*/*
181%{_infodir}/*.info*
182/%{_lib}/libreadline*.so.*
183%{_libdir}/libhistory*.so.*
184
185
186%files devel
187%defattr(-,root,root)
188%doc examples/
189%{_includedir}/readline
190%{_libdir}/lib*.a
191%{_libdir}/lib*.so
192
193%if %{build_compat32}
194%files -n compat32-%{name}
195%defattr(-,root,root)
196/%{_lib}/libreadline*.so.*
197%{_libdir}/libhistory*.so.*
198
199%files -n compat32-%{name}-devel
200%defattr(-,root,root)
201%{_libdir}/lib*.a
202%{_libdir}/lib*.so
203%endif
204
205%changelog
206* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
207- rebuilt with new toolchain
208- add Requires(post,pre): /sbin/ldconfig
209
210* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
211- build with ncurses-devel
212- spec in utf8
213- move libncurses.so.* to %%_lib from %%_libdir
214
215* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
216- added upstream patches (patch8-12)
217
218* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
219- new upstream release
220- update upstream patches (patch1-7)
221
222* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
223- new upstream release
224- update upstream patches (patch1-4)
225- add doc/*.{html,pdf} instead of doc/
226
227* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
228- s/Copyright/License/
229- add URL
230- update source URL
231- add PreReq: ldconfig
232- move outdated.patch (patch1) to patch10
233- add upstream patches (patch1-5)
234- add no_rpath.patch (patch11)
235
236* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
237- added compat32- packages for x86_64 architecture support
238- fixed %files section (TODO* has been removed)
239
240* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
241- new upstream release 4.3
242- merged with rawhide package.
243  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
244  - rebuild in current collinst
245  - BuildRequires autoconf only
246  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
247  - Fixed Esc-O-M stack overflow bug.
248  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
249  - Updated to latest readline release 4.3
250  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
251  - Fixed problem with alpha build.
252  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
253  - Fixed utf8 problem (originally observed in bash).
254  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
255  - automated rebuild
256  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
257  - automated rebuild
258  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
259  - Use autoconf 2.53, not 2.52
260  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
261  - Rebuild
262  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
263  - removed the manual symlinking of .so, readline handles this by itself
264  - call only %%makeinstall, not %%makeinstall install install-shared as
265    this makes bogus .old files in the buildroot
266  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
267  - 4.2a
268  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
269  - Work around autoconf bug
270  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
271  - Don't use readline's internal re-implementation of strpbrk on systems
272    that have strpbrk - the system implementation is faster and better maintained.
273  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
274  - Make sure headers can be included from C++ applications (#51131)
275    (Patch based on Debian's with the bugs removed ;) )
276  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
277  - update to 4.2 and adapt patches
278  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
279  - change the paths listed for the header files in the man page to reflect
280    the location changes from previous versions (#35073)
281  - note that "on" is acceptable instead of "On" in the man page (#21327)
282  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
283  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
284  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
285  - mark the man page as currently out-of-date (#25294)
286
287* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
288- remove texi2dvi and texi2html from doc/
289
290* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
291- added doc and examples
292
293* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
294- 4.1-6vl3
295- rebuilt for VineSeed
296
297* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
298- 4.1-6vl2
299- Oops, spec was written in SJIS...
300
301* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
302- 4.1-6vl1
303- got i18n patch from Kondara
304
305* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
306- FHS packaging (64bit systems need to use libdir).
307
308* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
309- summaries from specspo.
310
311* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
312- use "rm -f" in specfile
313
314* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
315- automatic rebuild
316
317* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
318- FHS packaging.
319
320* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
321- 4.1
322
323* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
324- update to 4.0
325
326* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
327- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
328
329* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
330- auto rebuild in the new build environment (release 4)
331
332* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
333- updated to 2.2.1
334
335* Wed May 06 1998 Prospector System <bugs@redhat.com>
336- translations modified for de, fr, tr
337
338* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
339- don't package /usr/info/dir
340
341* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
342- devel package moved to Development/Libraries
343
344* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
345- updated to 2.2
346
347* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
348- spec file cleanups
349
350* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
351- added proper sonames
352
353* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
354- updated to readline 2.1
355
356* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
357- built against glibc
Note: See TracBrowser for help on using the repository browser.