source: projects/specs/trunk/r/readline/readline-vl.spec @ 9457

Revision 9457, 12.3 KB checked in by inagaki, 9 years ago (diff)

2015-03-22 Ryoichi INAGAKI <ryo1@…>

  • apt, bc, gnupg: rebuilt with new readline
  • readline: updated


Line 
1Summary: A library for editing typed in command lines.
2Summary(ja): Readline ライブラリ
3
4Name: readline
5Version: 6.3
6Release: 1%{?_dist_release}
7License: GPLv3+
8Group: System Environment/Libraries
9URL: http://tiswww.tis.case.edu/~chet/readline/rltop.html
10Source: ftp://ftp.gnu.org/gnu/readline/readline-%{version}.tar.gz
11
12# upstream patches
13Patch1: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-001
14Patch2: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-002
15Patch3: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-003
16Patch4: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-004
17Patch5: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-005
18Patch6: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-006
19Patch7: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-007
20Patch8: ftp://ftp.gnu.org/gnu/readline/readline-%{version}-patches/readline63-008
21
22# add workaround for problem in gdb
23# in new version of readline needs to be deleted
24# bz701131
25Patch9: readline-6.2-gdb.patch
26# fix file permissions, remove RPATH, use CFLAGS
27Patch10: readline-6.2-shlib.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
30BuildRequires: sed
31BuildRequires: ncurses-devel
32Requires(post): /sbin/install-info, /sbin/ldconfig
33Requires(preun): /sbin/install-info
34Requires(postun): /sbin/ldconfig
35
36Vendor: Project Vine
37Distribution: Vine Linux
38
39%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
40
41%description
42The Readline library provides a set of functions that allow users to
43edit command lines. Both Emacs and vi editing modes are available. The
44Readline library includes additional functions for maintaining a list
45of previously-entered command lines for recalling or editing those
46lines, and for performing csh-like history expansion on previous
47commands.
48
49%description -l ja
50Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
51Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
52これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
53
54%package devel
55Summary: Files needed to develop programs which use the readline library.
56Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
57Group: Development/Libraries
58Requires: readline = %{version}
59Requires: ncurses-devel
60
61%description devel
62The Readline library provides a set of functions that allow users to
63edit typed command lines. If you want to develop programs that will
64use the readline library, you need to have the readline-devel package
65installed. You also need to have the readline package installed.
66
67
68%package -n compat32-%{name}
69Summary: A library for editing typed in command lines.
70Summary(ja): Readline ライブラリ
71Group: System Environment/Libraries
72Requires: %{name} = %{version}-%{release}
73
74%description -n compat32-%{name}
75The Readline library provides a set of functions that allow users to
76edit command lines. Both Emacs and vi editing modes are available. The
77Readline library includes additional functions for maintaining a list
78of previously-entered command lines for recalling or editing those
79lines, and for performing csh-like history expansion on previous
80commands.
81
82%description -n compat32-%{name} -l ja
83Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
84Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
85これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
86
87%package -n compat32-%{name}-devel
88Summary: Files needed to develop programs which use the readline library.
89Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Requires: %{name}-devel = %{version}-%{release}
93Requires: compat32-ncurses-devel
94
95%description -n compat32-%{name}-devel
96The Readline library provides a set of functions that allow users to
97edit typed command lines. If you want to develop programs that will
98use the readline library, you need to have the readline-devel package
99installed. You also need to have the readline package installed.
100
101%prep
102%setup -q
103
104# upstream patches
105%patch1 -p0 -b .001
106%patch2 -p0 -b .002
107%patch3 -p0 -b .003
108%patch4 -p0 -b .004
109%patch5 -p0 -b .005
110%patch6 -p0 -b .006
111%patch7 -p0 -b .007
112%patch8 -p0 -b .008
113
114%patch9 -p1 -b .gdb
115%patch10 -p1 -b .shlib
116
117%build
118export CPPFLAGS="-I%{_includedir}/ncurses"
119%configure
120make %{?_smp_mflags}
121
122
123%install
124[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
125mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
126
127make DESTDIR=$RPM_BUILD_ROOT install
128
129mkdir $RPM_BUILD_ROOT/%{_lib}
130mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
131for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
132    ln -sf $(echo %{_libdir} | \
133     sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
134done
135
136rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
137rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
138rm -f $RPM_BUILD_ROOT%{_infodir}/dir
139
140%clean
141[ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
142
143%post
144/sbin/ldconfig
145/sbin/install-info %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
146/sbin/install-info %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
147:
148
149%postun -p /sbin/ldconfig
150
151%post -n compat32-%{name} -p /sbin/ldconfig
152
153%postun -n compat32-%{name} -p /sbin/ldconfig
154
155%preun
156if [ $1 = 0 ]; then
157   /sbin/install-info --delete %{_infodir}/history.info.gz %{_infodir}/dir &> /dev/null
158   /sbin/install-info --delete %{_infodir}/rluserman.info.gz %{_infodir}/dir &> /dev/null
159fi
160:
161
162%post devel
163/sbin/install-info %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
164:
165
166%preun devel
167if [ $1 = 0 ]; then
168   /sbin/install-info --delete %{_infodir}/readline.info.gz %{_infodir}/dir &> /dev/null
169fi
170:
171
172%files
173%defattr(-,root,root)
174%doc CHANGES COPYING NEWS README USAGE
175%doc doc/*.{html,pdf}
176/%{_lib}/libreadline*.so.*
177%{_libdir}/libhistory*.so.*
178%{_infodir}/history.info*
179%{_infodir}/rluserman.info*
180
181%files devel
182%defattr(-,root,root)
183%doc examples/*.c examples/*.h examples/rlfe
184%{_includedir}/readline
185%{_libdir}/lib*.a
186%{_libdir}/lib*.so
187%{_infodir}/readline.info*
188%{_mandir}/man*/*
189
190%if %{build_compat32}
191%files -n compat32-%{name}
192%defattr(-,root,root)
193/%{_lib}/libreadline*.so.*
194%{_libdir}/libhistory*.so.*
195
196%files -n compat32-%{name}-devel
197%defattr(-,root,root)
198%{_libdir}/lib*.a
199%{_libdir}/lib*.so
200%endif
201
202%changelog
203* Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
204- new upstream release
205- update upstream patches (patch1-8)
206
207* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
208- rebuild with VineSeed environment
209
210* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
211- add upstream patches 13,14 (Patch13,14)
212
213* Fri Mar  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
214- rebuilt with new toolchain
215- add Requires(post,pre): /sbin/ldconfig
216
217* Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
218- build with ncurses-devel
219- spec in utf8
220- move libncurses.so.* to %%_lib from %%_libdir
221
222* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
223- added upstream patches (patch8-12)
224
225* Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
226- new upstream release
227- update upstream patches (patch1-7)
228
229* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
230- new upstream release
231- update upstream patches (patch1-4)
232- add doc/*.{html,pdf} instead of doc/
233
234* Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
235- s/Copyright/License/
236- add URL
237- update source URL
238- add PreReq: ldconfig
239- move outdated.patch (patch1) to patch10
240- add upstream patches (patch1-5)
241- add no_rpath.patch (patch11)
242
243* Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
244- added compat32- packages for x86_64 architecture support
245- fixed %files section (TODO* has been removed)
246
247* Sat Mar  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
248- new upstream release 4.3
249- merged with rawhide package.
250  * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
251  - rebuild in current collinst
252  - BuildRequires autoconf only
253  * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
254  - Fixed Esc-O-M stack overflow bug.
255  * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
256  - Updated to latest readline release 4.3
257  * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
258  - Fixed problem with alpha build.
259  * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
260  - Fixed utf8 problem (originally observed in bash).
261  * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
262  - automated rebuild
263  * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
264  - automated rebuild
265  * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
266  - Use autoconf 2.53, not 2.52
267  * Mon Mar  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
268  - Rebuild
269  * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
270  - removed the manual symlinking of .so, readline handles this by itself
271  - call only %%makeinstall, not %%makeinstall install install-shared as
272    this makes bogus .old files in the buildroot
273  * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
274  - 4.2a
275  * Tue Oct  2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
276  - Work around autoconf bug
277  * Mon Oct  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
278  - Don't use readline's internal re-implementation of strpbrk on systems
279    that have strpbrk - the system implementation is faster and better maintained.
280  * Tue Aug  7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
281  - Make sure headers can be included from C++ applications (#51131)
282    (Patch based on Debian's with the bugs removed ;) )
283  * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
284  - update to 4.2 and adapt patches
285  * Fri Apr  6 2001 Nalin Dahyabhai <nalin@redhat.com>
286  - change the paths listed for the header files in the man page to reflect
287    the location changes from previous versions (#35073)
288  - note that "on" is acceptable instead of "On" in the man page (#21327)
289  * Thu Mar  8 2001 Preston Brown <pbrown@redhat.com>
290  - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
291  * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
292  - mark the man page as currently out-of-date (#25294)
293
294* Tue Sep  4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
295- remove texi2dvi and texi2html from doc/
296
297* Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
298- added doc and examples
299
300* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
301- 4.1-6vl3
302- rebuilt for VineSeed
303
304* Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
305- 4.1-6vl2
306- Oops, spec was written in SJIS...
307
308* Sat Dec  9 2000 Jun Nishii <jun@vinelinux.org>
309- 4.1-6vl1
310- got i18n patch from Kondara
311
312* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
313- FHS packaging (64bit systems need to use libdir).
314
315* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
316- summaries from specspo.
317
318* Wed Aug  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
319- use "rm -f" in specfile
320
321* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
322- automatic rebuild
323
324* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
325- FHS packaging.
326
327* Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
328- 4.1
329
330* Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
331- update to 4.0
332
333* Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
334- added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
335
336* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
337- auto rebuild in the new build environment (release 4)
338
339* Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
340- updated to 2.2.1
341
342* Wed May 06 1998 Prospector System <bugs@redhat.com>
343- translations modified for de, fr, tr
344
345* Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
346- don't package /usr/info/dir
347
348* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
349- devel package moved to Development/Libraries
350
351* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
352- updated to 2.2
353
354* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
355- spec file cleanups
356
357* Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
358- added proper sonames
359
360* Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
361- updated to readline 2.1
362
363* Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
364- built against glibc
Note: See TracBrowser for help on using the repository browser.