source: projects/specs/trunk/r/readahead/readahead-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        Read a preset list of files into memory.
2Summary(ja):    あらかじめ指定したファイル群をメモリに先読みするツール
3Name:           readahead
4Version:        1.5.4
5Release:        1%{?_dist_release}
6Group:          System Environment/Base
7License:        GPLv2+
8URL:            https://hosted.fedoraproject.org/readahead
9Source0:        readahead-%{version}.tar.bz2
10Source1:        readahead_early
11Source2:        default.early
12# default settings for Vine Linux
13Patch0:         readahead-1.5.0-default.patch
14# (mdv) create a temp file to detect if collector is running, autodelect collector enabling file at end of collection
15Patch1:         readahead-1.4.6-autocollector.patch
16# (mdv) don't generate later list
17Patch2:         readahead-1.4.6-nolater.patch
18Patch3:         better-cron.patch
19Patch4:         multiple-ignores.patch
20
21BuildRoot:      %{_tmppath}/%{name}-%{version}-root
22Requires(post): /sbin/chkconfig
23Requires(pre):  /sbin/chkconfig
24Requires(triggerpostun): /sbin/chkconfig
25Requires:       procps, gawk
26BuildRequires:  e2fsprogs-devel, audit-libs-devel, libblkid-devel
27BuildRequires:  pkgconfig
28
29%description
30readahead reads the contents of a list of files into memory,
31which causes them to be read from cache when they are actually
32needed. Its goal is to speed up the boot process.
33
34%description -l ja
35readahead はあらかじめ指定されたファイルをメモリに読み込んでおき、
36実際に必要になったときにキャッシュから読み込まれるようにします。
37このツールの目的は起動プロセスの高速化です。
38
39%prep
40%setup -q
41%patch0 -p1 -b .default
42%patch1 -p1 -b .autocollector
43%patch2 -p1 -b .nolater
44%patch3 -p1
45%patch4 -p1
46install -m644 %{SOURCE2} lists/
47
48
49%build
50%configure --sbindir=/sbin
51make %{?_smp_mflags} rpm-lists-rebuild FILES="default.early" CFLAGS="$RPM_OPT_FLAGS" RPM_LIB="%{_lib}" RPM_ARCH="%{_arch}"
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make DESTDIR=$RPM_BUILD_ROOT install
56%find_lang %{name}
57
58install -m755 %{SOURCE1} $RPM_BUILD_ROOT/sbin
59
60# file list dir
61mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
62
63
64%clean
65rm -rf ${RPM_BUILD_ROOT}
66
67%files -f %{name}.lang
68%defattr(-,root,root)
69%doc COPYING README
70#%attr(0644,root,root) %{_sysconfdir}/readahead.d/default.early
71/sbin/readahead
72/sbin/readahead-collector
73/sbin/readahead_early
74/etc/event.d/*
75/etc/cron.daily/readahead.cron
76/etc/cron.monthly/readahead-monthly.cron
77%config(noreplace) %{_sysconfdir}/sysconfig/readahead
78%config(noreplace) /etc/readahead.conf
79%dir %{_localstatedir}/lib/%{name}
80
81%pre
82if [ -f /etc/rc.d/init.d/readahead_early ]; then
83  /sbin/chkconfig --del readahead_early > /dev/null 2>&1 ||:
84  /sbin/chkconfig --del readahead_later > /dev/null 2>&1 ||:
85fi
86
87%preun
88if [ "$1" = "0" ] ; then
89 # for updating older packages with service files
90 /sbin/service readahead_later stop >/dev/null 2>&1
91 /sbin/chkconfig --del readahead_later  >/dev/null 2>&1
92 /sbin/service readahead_early stop >/dev/null 2>&1
93 /sbin/chkconfig --del readahead_early  >/dev/null 2>&1
94 :
95fi
96
97%post
98if [ "$1" = "1" ]; then
99 touch /.readahead_collect
100fi
101
102%changelog
103* Sun Oct 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.4-1
104- new upstream release
105- added %preun to delete old service
106- added configure option
107- added BuildRequires: libblkid-devel
108
109* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.3-1
110- new upstream release
111- dropt Pacth3,5
112- renumbered Patch
113- added Patch4 (multiple-ignores.patch) from Debian
114
115* Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-2
116- fixed Patch number in changelog Thu Sep 24 2009
117- added Patch4,5 from Debian
118
119* Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-1
120- new upstream release
121- added Patch3 from Fedora
122
123* Sun Sep 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
124- new upstream release
125- updated and renamed Patch0: readahead-1.5.0-default.patch
126
127* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-5
128- add /usr/share/anthy to exclude list
129
130* Sun Aug 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-4
131- /etc/readahead.d moved to /var/lib/readahead
132
133* Sat May  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-3
134- fix readahead_early (Source1) to check wheter /etc/readahead.d/*.early
135  do exist
136
137* Fri May  1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-2
138- include /etc/readahead.d directory (otherwise /sbin/readahead_early
139  will exit with non-zero exit status)
140
141* Sat Apr 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.9-1
142- new upstream release
143- updated and renamed Patch0: readahead-1.4.9-default.patch
144
145* Sat Dec 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-1
146- new upstream release
147- remove readahead_later, use preload for this.
148- add some patches from mdk
149- remove initscripts, will be handle in rc.sysinit
150
151* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-1
152- initial build for Vine Linux
153
154* Fri Feb  2 2007 Karel Zak <kzak@redhat.com> - 1:1.3-7
155- rebuild (update file lists)
156
157* Tue Jan 16 2007 Karel Zak <kzak@redhat.com> - 1:1.3-6
158- update file lists (215503)
159
160* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1:1.3-5
161- rebuilt for unwind info generation, broken in gcc-4.1.1-21
162
163* Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-4
164- fix #207631 - clean up package build system and use tarball instead
165                separated source files
166
167* Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-3
168- fix #207631 - readahead has no debuginfo
169
170* Mon Jul 20 2006 Karel Zak <kzak@redhat.com> 1:1.3-1
171- move lists of files to /etc/readahead.d
172- add readahead-check to docs
173- ignore duplicate files
174
175* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-3
176- fix release for upgrade path (by removing cvs generated release)
177
178* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.26
179- rebuild
180
181* Thu Mar 16 2006 Karel Zak <kzak@redhat.com>
182- update versions in *.in lists
183
184* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.24.2
185- bump again for double-long bug on ppc(64)
186
187* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.23.1
188- rebuilt for new gcc4.1 snapshot and glibc changes
189
190* Fri Jan 13 2006 Karel Zak <kzak@redhat.com>
191- check & cleanup list of files by readahead-gen script
192
193* Wed Dec 21 2005 Karel Zak <kzak@redhat.com>
194- removed double slashes in the directory names
195- removed or fixed the rest of X11R6 directories
196
197* Mon Dec 19 2005 Karel Zak <kzak@redhat.com>
198- sync versioned gcc, firefox, openoffice.org, evolution dirs with FC5
199
200* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
201- rebuilt
202
203* Thu Aug  4 2005 Dave Jones <davej@redhat.com>
204- Integrated changes from Ville Skytta (#164872)
205  - Fix inverted logic in readahead_early also.
206  - readahead_early looks useful in more runlevels than just 5.
207  - Sync versioned gcc, firefox and openoffice.org dirs with FC4 updates.
208
209* Tue Aug  2 2005 Dave Jones <davej@redhat.com>
210- Fix inverted free memory test in startup script. (#164872)
211
212* Wed May 18 2005 Bill Nottingham <notting@redhat.com>
213- new readahead.c from Ziga Mahkovec <ziga.mahkovec@klika.si>
214  - optimizes read access for more throughput
215- regenerate file lists (#128444)
216- fix lack of newlines (#146744)
217- fix lists so that they are architecture-neutral
218- move check for > 384MB into the init scripts, not the %%post
219
220* Tue Mar  1 2005 Dave Jones <davej@redhat.com>
221- Rebuild for gcc4
222
223* Thu Feb 10 2005 Dave Jones <davej@redhat.com>
224- Remove non-existent files from file lists.
225
226* Fri Jan 14 2005 Dave Jones <davej@redhat.com>
227- Don't do readahead if we have less than 256MB of memory.
228
229* Sat Dec 18 2004 Dave Jones <davej@redhat.com>
230- Initial packaging, based upon kernel-utils.
231
Note: See TracBrowser for help on using the repository browser.