source: projects/specs/trunk/r/readahead/readahead-vl.spec @ 2136

Revision 2136, 7.3 KB checked in by kudoh, 14 years ago (diff)
Line 
1Summary:        Read a preset list of files into memory.
2Summary(ja):    あらかじめ指定したファイル群をメモリに先読みするツール
3Name:           readahead
4Version:        1.5.7
5Release:        1%{?_dist_release}
6Group:          System Environment/Base
7License:        GPLv2+
8URL:            https://hosted.fedoraproject.org/readahead
9Source0:        readahead-%{version}.tar.bz2
10Patch0:         better-cron.patch
11Patch1:         readahead-1.5.6-autocollector.patch
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14Requires(post): /sbin/chkconfig
15Requires(pre):  /sbin/chkconfig
16Requires(triggerpostun): /sbin/chkconfig
17Requires:       procps, gawk
18Requires:       upstart /usr/bin/ionice
19BuildRequires:  e2fsprogs-devel, audit-libs-devel, libblkid-devel
20BuildRequires:  pkgconfig
21
22%description
23readahead reads the contents of a list of files into memory,
24which causes them to be read from cache when they are actually
25needed. Its goal is to speed up the boot process.
26
27%description -l ja
28readahead はあらかじめ指定されたファイルをメモリに読み込んでおき、
29実際に必要になったときにキャッシュから読み込まれるようにします。
30このツールの目的は起動プロセスの高速化です。
31
32%prep
33%setup -q
34%patch0 -p1 -b .cron
35%patch1 -p1 -b .collector
36
37%build
38%configure --sbindir=/sbin
39make %{?_smp_mflags}
40
41%install
42rm -rf $RPM_BUILD_ROOT
43make DESTDIR=$RPM_BUILD_ROOT install
44mkdir -p ${RPM_BUILD_ROOT}%{_localstatedir}/lib/readahead
45
46%find_lang %{name}
47
48# for delete systemd require file
49rm -rf %{buildroot}/lib/systemd/system/*
50
51%clean
52rm -rf ${RPM_BUILD_ROOT}
53
54%preun
55if [ "$1" = "0" ] ; then
56 # for updating older packages with service files
57 /sbin/service readahead_later stop >/dev/null 2>&1
58 /sbin/chkconfig --del readahead_later  >/dev/null 2>&1
59 /sbin/service readahead_early stop >/dev/null 2>&1
60 /sbin/chkconfig --del readahead_early  >/dev/null 2>&1
61 :
62fi
63
64%post
65%{_sysconfdir}/cron.monthly/readahead-monthly.cron
66:
67
68%files -f %{name}.lang
69%defattr(-,root,root,- )
70%doc COPYING README lists/README.lists NEWS
71%{_sysconfdir}/cron.daily/readahead.cron
72%{_sysconfdir}/cron.monthly/readahead-monthly.cron
73%dir %{_localstatedir}/lib/readahead
74%{_sysconfdir}/init/readahead-collector.conf
75%{_sysconfdir}/init/readahead-disable-services.conf
76%{_sysconfdir}/init/readahead.conf
77%config(noreplace) %{_sysconfdir}/sysconfig/readahead
78%config(noreplace) %{_sysconfdir}/readahead.conf
79/sbin/readahead
80/sbin/readahead-collector
81%dir /lib/readahead
82/lib/readahead/readahead-collect.sh
83/lib/readahead/readahead-replay.sh
84/lib/readahead/readahead-sort.sh
85
86%changelog
87* Tue Oct 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.7-1
88- new upstream release
89- cleaned up spec
90- renumberd patches
91- added patch1 from mandriva
92
93* Wed Jun 16 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.6-1
94- new upstream release
95- dropt patche0,1,2,4 and other sources
96- added Requires: upstart, /usr/bin/ionice
97- set up for upstart
98
99* Sun Oct 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.4-1
100- new upstream release
101- added %preun to delete old service
102- added configure option
103- added BuildRequires: libblkid-devel
104
105* Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.3-1
106- new upstream release
107- dropt Pacth3,5
108- renumbered Patch
109- added Patch4 (multiple-ignores.patch) from Debian
110
111* Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-2
112- fixed Patch number in changelog Thu Sep 24 2009
113- added Patch4,5 from Debian
114
115* Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-1
116- new upstream release
117- added Patch3 from Fedora
118
119* Sun Sep 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
120- new upstream release
121- updated and renamed Patch0: readahead-1.5.0-default.patch
122
123* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-5
124- add /usr/share/anthy to exclude list
125
126* Sun Aug 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-4
127- /etc/readahead.d moved to /var/lib/readahead
128
129* Sat May  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-3
130- fix readahead_early (Source1) to check wheter /etc/readahead.d/*.early
131  do exist
132
133* Fri May  1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-2
134- include /etc/readahead.d directory (otherwise /sbin/readahead_early
135  will exit with non-zero exit status)
136
137* Sat Apr 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.9-1
138- new upstream release
139- updated and renamed Patch0: readahead-1.4.9-default.patch
140
141* Sat Dec 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-1
142- new upstream release
143- remove readahead_later, use preload for this.
144- add some patches from mdk
145- remove initscripts, will be handle in rc.sysinit
146
147* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-1
148- initial build for Vine Linux
149
150* Fri Feb  2 2007 Karel Zak <kzak@redhat.com> - 1:1.3-7
151- rebuild (update file lists)
152
153* Tue Jan 16 2007 Karel Zak <kzak@redhat.com> - 1:1.3-6
154- update file lists (215503)
155
156* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1:1.3-5
157- rebuilt for unwind info generation, broken in gcc-4.1.1-21
158
159* Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-4
160- fix #207631 - clean up package build system and use tarball instead
161                separated source files
162
163* Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-3
164- fix #207631 - readahead has no debuginfo
165
166* Mon Jul 20 2006 Karel Zak <kzak@redhat.com> 1:1.3-1
167- move lists of files to /etc/readahead.d
168- add readahead-check to docs
169- ignore duplicate files
170
171* Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-3
172- fix release for upgrade path (by removing cvs generated release)
173
174* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.26
175- rebuild
176
177* Thu Mar 16 2006 Karel Zak <kzak@redhat.com>
178- update versions in *.in lists
179
180* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.24.2
181- bump again for double-long bug on ppc(64)
182
183* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.23.1
184- rebuilt for new gcc4.1 snapshot and glibc changes
185
186* Fri Jan 13 2006 Karel Zak <kzak@redhat.com>
187- check & cleanup list of files by readahead-gen script
188
189* Wed Dec 21 2005 Karel Zak <kzak@redhat.com>
190- removed double slashes in the directory names
191- removed or fixed the rest of X11R6 directories
192
193* Mon Dec 19 2005 Karel Zak <kzak@redhat.com>
194- sync versioned gcc, firefox, openoffice.org, evolution dirs with FC5
195
196* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
197- rebuilt
198
199* Thu Aug  4 2005 Dave Jones <davej@redhat.com>
200- Integrated changes from Ville Skytta (#164872)
201  - Fix inverted logic in readahead_early also.
202  - readahead_early looks useful in more runlevels than just 5.
203  - Sync versioned gcc, firefox and openoffice.org dirs with FC4 updates.
204
205* Tue Aug  2 2005 Dave Jones <davej@redhat.com>
206- Fix inverted free memory test in startup script. (#164872)
207
208* Wed May 18 2005 Bill Nottingham <notting@redhat.com>
209- new readahead.c from Ziga Mahkovec <ziga.mahkovec@klika.si>
210  - optimizes read access for more throughput
211- regenerate file lists (#128444)
212- fix lack of newlines (#146744)
213- fix lists so that they are architecture-neutral
214- move check for > 384MB into the init scripts, not the %%post
215
216* Tue Mar  1 2005 Dave Jones <davej@redhat.com>
217- Rebuild for gcc4
218
219* Thu Feb 10 2005 Dave Jones <davej@redhat.com>
220- Remove non-existent files from file lists.
221
222* Fri Jan 14 2005 Dave Jones <davej@redhat.com>
223- Don't do readahead if we have less than 256MB of memory.
224
225* Sat Dec 18 2004 Dave Jones <davej@redhat.com>
226- Initial packaging, based upon kernel-utils.
227
Note: See TracBrowser for help on using the repository browser.