source: projects/specs/trunk/q/qyoto/qyoto-vl.spec @ 9075

Revision 9075, 7.4 KB checked in by inagaki, 9 years ago (diff)

2014-11-09 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, kimono, korundum, qwt, qyoto, smokegen, smokekde, smokeqt: NEW
  • kdebindings: updated


Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2
3%global monodir /usr/lib/mono
4
5Name:    qyoto
6Summary: .NET/Mono bindings for the Qt libraries
7Summary(ja): Qt ライブラリの .NET/Mono バインディング
8Version: 4.14.2
9Release: 1%{?_dist_release}
10
11# libqyoto LGPLv2+, mono bindings GPLv2+
12License: LGPLv2+ and GPLv2+
13Group:   System Environment/Libraries
14URL:     http://techbase.kde.org/Development/Languages/Qyoto
15
16Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: cmake
20BuildRequires: mono-devel
21BuildRequires: phonon-devel
22BuildRequires: qimageblitz-devel
23BuildRequires: qt4-devel
24#BuildRequires: pkgconfig(QtWebKit)
25BuildRequires: qscintilla-devel
26BuildRequires: qwt-qt4-devel
27BuildRequires: smokeqt-devel >= %{version}
28BuildRequires: sqlite3-devel
29
30# common name some other distros use
31Provides: mono-qt = %{version}-%{release}
32
33Requires: qt4 >= %{_qt4_version}
34Requires: smokeqt >= %{version}
35
36%{?mono_arches:ExclusiveArch: %{mono_arches}}
37
38%description
39%{summary}.
40
41%package devel
42Summary: Development libraries for %{name}
43Summary(ja): %{name} の開発用ファイル
44Group:   Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Provides: mono-qt-devel = %{version}-%{release}
47
48%description devel
49This package contains development files for the .NET/Mono bindings
50for the Qt libraries.
51
52
53%prep
54%setup -q
55
56
57%build
58mkdir -p %{_target_platform}
59pushd %{_target_platform}
60%cmake \
61    -DCMAKE_BUILD_TYPE=release \
62    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
63    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
64    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
65    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
66    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
67    ..
68popd
69
70make %{?_smp_mflags} -C %{_target_platform}
71
72
73%install
74rm -rf $RPM_BUILD_ROOT
75make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
76
77
78%post -p /sbin/ldconfig
79%postun -p /sbin/ldconfig
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%files
85%doc AUTHORS COPYING README
86# LGPLv2+
87%{_libdir}/libqyoto.so.2*
88# bindings GPLv2+
89%{_libdir}/libqtscript-sharp.so
90%{_libdir}/libphonon-sharp.so
91%{_libdir}/libqttest-sharp.so
92%{_libdir}/libqtuitools-sharp.so
93%{_libdir}/libqtwebkit-sharp.so
94%{_libdir}/libqscintilla-sharp.so
95%{monodir}/gac/qt-dotnet/
96%{monodir}/gac/qtscript/
97%{monodir}/gac/qttest/
98%{monodir}/gac/qtuitools/
99%{monodir}/gac/qtwebkit/
100%{monodir}/gac/phonon/
101%{monodir}/gac/qscintilla/
102%{monodir}/qyoto/
103%dir %{_datadir}/qyoto/
104%{_datadir}/qyoto/key.snk
105
106%files devel
107%{_bindir}/csrcc
108%{_bindir}/uics
109%{_includedir}/qyoto/
110%{_libdir}/pkgconfig/qyoto.pc
111%{_libdir}/pkgconfig/qtwebkit-sharp.pc
112%{_libdir}/pkgconfig/qttest-sharp.pc
113%{_libdir}/pkgconfig/qtuitools-sharp.pc
114%{_libdir}/pkgconfig/qtscript-sharp.pc
115%{_libdir}/libqyoto.so
116%{_datadir}/qyoto/cmake/
117
118
119%changelog
120* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
121- splitted from kdebindings
122
123* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
124- new upstream release
125
126* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
127- updated to 4.6.1
128- added BR: kdesdk-devel
129- disabled attica plugins temporaly
130- rebuilt with mono-2.10.1
131
132* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
133- rebuilt with rpm-4.8.1 for pkg-config
134
135* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
136- new upstream release
137- added Patch50
138- added more japanese summaries
139
140* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
141- new upstream release
142
143* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
144- new upstream release
145
146* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
147- new upstream release
148
149* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
150- new upstream release
151
152* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
153- new upstream release
154- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
155  (see https://bugs.kde.org/show_bug.cgi?id=214824)
156- built with new toolchain
157
158* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
159- new upstream release
160
161* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
162- merged 4.3.1-2 %changelog
163- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
164
165* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
166- use %%{_prefix}/lib for mono-dll (for x86_64)
167
168* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
169- new upstream release
170- built with PyQt4-4.6
171
172* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
173- define %%{mono_dir} to specify mono library install path
174
175* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
176- new upstream release
177- fixed ruby modules installation path
178
179* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
180- new upstream release
181- spilt sub package based on Fedora
182
183* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
184- applied new versioning policy
185- added Patch1
186  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
187
188* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
189- added --with-qt-libraries option
190
191* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
192- rebuild for VineSeed
193
194* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
195- new upstream release
196
197* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
198- rebuild for VineSeed
199
200* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
201- new upstream release
202- update Patch0
203- drop Patch1
204
205* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
206- new upstream release
207- add Patch1
208- add --enable-libsuffix option
209
210* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
211- rebuild for VineSeed
212
213* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
214- new upstream release
215
216* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
217- rebuild for VineSeed
218
219* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
220- new upstream release
221
222* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
223- rebuild for VineSeed
224
225* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
226- new upstream release
227
228* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
229- rebuild for VineSeed
230
231* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
232- new upstream release
233
234* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
235- rebuild for VineSeed
236
237* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
238- new upstream release
239- renew BuildPrereq and build section
240- renew %%files
241- enable python
242- change spec to make main and devel package
243- add BuildPrereq: ruby ruby-devel
244- add Patch0 to install ruby-bindings under /usr/lib/ruby
245
246* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
247- build for VineSeed
248- disable python and mozilla
249- objprelink (i386 only)
250
251* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
252- 2.2.2
253- build kmozilla binding only on x86/alpha
254
255* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
256- Make sure %%{name}-kmozilla isn't built on ia64
257
258* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
259- Move python bindings to separate package
260- Add perl bindings
261- Shut up rpmlint
262
263* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
264- 2.1
265
266* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
267- initial RPM
Note: See TracBrowser for help on using the repository browser.