source: projects/specs/trunk/q/qyoto/qyoto-vl.spec @ 9248

Revision 9248, 7.2 KB checked in by inagaki, 9 years ago (diff)

2015-01-11 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, kimono, kio_gopher, korundum, qyoto: updated
  • hfsutils, kio-ftps, kio_sysinfo, kphotoalbum: rebuilt
  • jfsutils: added Patch


Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2
3%global monodir /usr/lib/mono
4
5Name:    qyoto
6Summary: .NET/Mono bindings for the Qt libraries
7Summary(ja): Qt ライブラリの .NET/Mono バインディング
8Version: 4.14.3
9Release: 1%{?_dist_release}
10
11# libqyoto LGPLv2+, mono bindings GPLv2+
12License: LGPLv2+ and GPLv2+
13Group:   System Environment/Libraries
14URL:     http://techbase.kde.org/Development/Languages/Qyoto
15
16Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: cmake
20BuildRequires: mono-devel
21BuildRequires: phonon-devel
22BuildRequires: qimageblitz-devel
23BuildRequires: qt4-devel
24BuildRequires: qscintilla-devel
25BuildRequires: qwt-qt4-devel
26BuildRequires: smokeqt-devel >= %{version}
27BuildRequires: sqlite3-devel
28
29# common name some other distros use
30Provides: mono-qt = %{version}-%{release}
31
32Requires: qt4 >= %{_qt4_version}
33Requires: smokeqt >= %{version}
34
35%{?mono_arches:ExclusiveArch: %{mono_arches}}
36
37%description
38%{summary}.
39
40%package devel
41Summary: Development libraries for %{name}
42Summary(ja): %{name} の開発用ファイル
43Group:   Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Provides: mono-qt-devel = %{version}-%{release}
46
47%description devel
48This package contains development files for the .NET/Mono bindings
49for the Qt libraries.
50
51
52%prep
53%setup -q
54
55
56%build
57mkdir -p %{_target_platform}
58pushd %{_target_platform}
59%cmake ..
60popd
61
62make %{?_smp_mflags} -C %{_target_platform}
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
68
69
70%post -p /sbin/ldconfig
71%postun -p /sbin/ldconfig
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%doc AUTHORS COPYING README
78# LGPLv2+
79%{_libdir}/libqyoto.so.2*
80# bindings GPLv2+
81%{_libdir}/libqtscript-sharp.so
82%{_libdir}/libphonon-sharp.so
83%{_libdir}/libqttest-sharp.so
84%{_libdir}/libqtuitools-sharp.so
85%{_libdir}/libqtwebkit-sharp.so
86%{_libdir}/libqscintilla-sharp.so
87%{monodir}/gac/qt-dotnet/
88%{monodir}/gac/qtscript/
89%{monodir}/gac/qttest/
90%{monodir}/gac/qtuitools/
91%{monodir}/gac/qtwebkit/
92%{monodir}/gac/phonon/
93%{monodir}/gac/qscintilla/
94%{monodir}/qyoto/
95%dir %{_datadir}/qyoto/
96%{_datadir}/qyoto/key.snk
97
98%files devel
99%{_bindir}/csrcc
100%{_bindir}/uics
101%{_includedir}/qyoto/
102%{_libdir}/pkgconfig/qyoto.pc
103%{_libdir}/pkgconfig/qtwebkit-sharp.pc
104%{_libdir}/pkgconfig/qttest-sharp.pc
105%{_libdir}/pkgconfig/qtuitools-sharp.pc
106%{_libdir}/pkgconfig/qtscript-sharp.pc
107%{_libdir}/libqyoto.so
108%{_datadir}/qyoto/cmake/
109
110
111%changelog
112* Sun Jan 11 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
113- updated to 4.14.3
114
115* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
116- splitted from kdebindings
117
118* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
119- new upstream release
120
121* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
122- updated to 4.6.1
123- added BR: kdesdk-devel
124- disabled attica plugins temporaly
125- rebuilt with mono-2.10.1
126
127* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
128- rebuilt with rpm-4.8.1 for pkg-config
129
130* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
131- new upstream release
132- added Patch50
133- added more japanese summaries
134
135* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
136- new upstream release
137
138* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
139- new upstream release
140
141* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
142- new upstream release
143
144* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
145- new upstream release
146
147* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
148- new upstream release
149- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
150  (see https://bugs.kde.org/show_bug.cgi?id=214824)
151- built with new toolchain
152
153* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
154- new upstream release
155
156* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
157- merged 4.3.1-2 %changelog
158- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
159
160* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
161- use %%{_prefix}/lib for mono-dll (for x86_64)
162
163* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
164- new upstream release
165- built with PyQt4-4.6
166
167* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
168- define %%{mono_dir} to specify mono library install path
169
170* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
171- new upstream release
172- fixed ruby modules installation path
173
174* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
175- new upstream release
176- spilt sub package based on Fedora
177
178* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
179- applied new versioning policy
180- added Patch1
181  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
182
183* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
184- added --with-qt-libraries option
185
186* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
187- rebuild for VineSeed
188
189* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
190- new upstream release
191
192* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
193- rebuild for VineSeed
194
195* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
196- new upstream release
197- update Patch0
198- drop Patch1
199
200* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
201- new upstream release
202- add Patch1
203- add --enable-libsuffix option
204
205* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
206- rebuild for VineSeed
207
208* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
209- new upstream release
210
211* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
212- rebuild for VineSeed
213
214* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
215- new upstream release
216
217* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
218- rebuild for VineSeed
219
220* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
221- new upstream release
222
223* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
224- rebuild for VineSeed
225
226* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
227- new upstream release
228
229* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
230- rebuild for VineSeed
231
232* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
233- new upstream release
234- renew BuildPrereq and build section
235- renew %%files
236- enable python
237- change spec to make main and devel package
238- add BuildPrereq: ruby ruby-devel
239- add Patch0 to install ruby-bindings under /usr/lib/ruby
240
241* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
242- build for VineSeed
243- disable python and mozilla
244- objprelink (i386 only)
245
246* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
247- 2.2.2
248- build kmozilla binding only on x86/alpha
249
250* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
251- Make sure %%{name}-kmozilla isn't built on ia64
252
253* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
254- Move python bindings to separate package
255- Add perl bindings
256- Shut up rpmlint
257
258* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
259- 2.1
260
261* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
262- initial RPM
Note: See TracBrowser for help on using the repository browser.