source: projects/specs/trunk/q/qtsoap/qtsoap-vl.spec @ 4445

Revision 4445, 2.5 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, shared-desktop-ontologies
NEW: herqq, qtsoap

Line 
1%define _qt4_ver 4.7.2
2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
4%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
5
6Name:           qtsoap
7Summary:        The Simple Object Access Protocol Qt-based client side library
8Version:        2.7
9Release:        3%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        LGPLv2 with exceptions or GPLv3
13URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
14
15Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
16Patch0:         qtsoap-2.7_1-opensource-install-pub-headers.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  qt4-devel
20
21%description
22The SOAP (Simple Object Access Protocol) library uses the XML standard
23for describing how to exchange messages. Its primary usage is to invoke web
24services and get responses from Qt-based applications.
25
26%package        devel
27Summary:        Development files for %{name}
28Group:          Development/Libraries
29Requires:       %{name} = %{version}-%{release}
30Requires:       qt4-devel = %{_qt4_version}
31
32%description    devel
33Development files for %{name}.
34
35%prep
36%setup -q -n qtsoap-%{version}_1-opensource
37
38# headers are not installed for shared library
39%patch0 -p1 -b .install-pub-headers
40
41sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
42
43%build
44# we want shared library
45echo "SOLUTIONS_LIBRARY = yes" > config.pri
46
47echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
48echo "VERSION=%{version}" >> common.pri
49
50qmake PREFIX=%{_prefix}
51make %{?_smp_mflags}
52
53
54%install
55rm -rf %{buildroot}
56make INSTALL_ROOT=%{buildroot} install
57
58
59%clean
60rm -rf %{buildroot}
61
62
63%post -p /sbin/ldconfig
64
65%postun -p /sbin/ldconfig
66
67
68%files
69%defattr(-,root,root,-)
70%doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
71%{_libdir}/libqtsoap.so.*
72
73%files devel
74%defattr(-,root,root,-)
75%doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
76%{_libdir}/libqtsoap.so
77%{_qt4_headerdir}/QtSoap/
78
79%changelog
80* Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
81- Initial build for Vine Linux
82
83* Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
84- libqtsoap library name
85
86* Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
87- fix version
88
89* Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
90- Initial spec file
Note: See TracBrowser for help on using the repository browser.