source: projects/specs/trunk/q/qtsoap/qtsoap-vl.spec @ 5383

Revision 5383, 2.7 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%define _qt4_ver 4.8.0
2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
4%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
5
6Name:           qtsoap
7Summary:        The Simple Object Access Protocol Qt-based client side library
8Version:        2.7
9Release:        4%{?_dist_release}
10
11Group:          System Environment/Libraries
12License:        LGPLv2 with exceptions or GPLv3
13URL:            http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
14
15Source0:        http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
16Patch0:         qtsoap-2.7_1-opensource-install-pub-headers.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  qt4-devel
20
21%description
22The SOAP (Simple Object Access Protocol) library uses the XML standard
23for describing how to exchange messages. Its primary usage is to invoke web
24services and get responses from Qt-based applications.
25
26%package        devel
27Summary:        Development files for %{name}
28Summary(ja):    %{name} の開発用ファイル
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31Requires:       qt4-devel >= %{_qt4_version}
32
33%description    devel
34Development files for %{name}.
35
36%prep
37%setup -q -n qtsoap-%{version}_1-opensource
38
39# headers are not installed for shared library
40%patch0 -p1 -b .install-pub-headers
41
42sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
43
44%build
45# we want shared library
46echo "SOLUTIONS_LIBRARY = yes" > config.pri
47
48echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
49echo "VERSION=%{version}" >> common.pri
50
51qmake PREFIX=%{_prefix}
52make %{?_smp_mflags}
53
54
55%install
56rm -rf %{buildroot}
57make INSTALL_ROOT=%{buildroot} install
58
59
60%clean
61rm -rf %{buildroot}
62
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68
69%files
70%defattr(-,root,root,-)
71%doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
72%{_libdir}/libqtsoap.so.*
73
74%files devel
75%defattr(-,root,root,-)
76%doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
77%{_libdir}/libqtsoap.so
78%{_qt4_headerdir}/QtSoap/
79
80%changelog
81* Sun Jan  8 2012 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> - 2.7-4
82- rebuilt with qt-4.8.0
83
84* Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
85- Initial build for Vine Linux
86
87* Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
88- libqtsoap library name
89
90* Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
91- fix version
92
93* Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
94- Initial spec file
Note: See TracBrowser for help on using the repository browser.