source: projects/specs/trunk/q/qt5-qtwebengine/qt5-qtwebengine-vl.spec @ 12287

Revision 12287, 29.0 KB checked in by tomop, 5 years ago (diff)

updated 26 packages

python-qt5-5.12.3-1

qt5-qt3d-5.12.5-1

qt5-qtbase-5.12.5-1

qt5-qtcanvas3d-5.12.5-1

qt5-qtconnectivity-5.12.5-1

qt5-qtdeclarative-5.12.5-1

qt5-qtdoc-5.12.5-1

qt5-qtgraphicaleffects-5.12.5-1

qt5-qtimageformats-5.12.5-1

qt5-qtlocation-5.12.5-1

qt5-qtmultimedia-5.12.5-1

qt5-qtquickcontrols-5.12.5-1

qt5-qtquickcontrols2-5.12.5-1

qt5-qtscript-5.12.5-1

qt5-qtsensors-5.12.5-1

qt5-qtserialport-5.12.5-1

qt5-qtsvg-5.12.5-1

qt5-qttools-5.12.5-1

qt5-qttranslations-5.12.5-1

qt5-qtwebchannel-5.12.5-1

qt5-qtwebengine-5.12.5-1

qt5-qtwebsockets-5.12.5-1

qt5-qtx11extras-5.12.5-1

qt5-qtxmlpatterns-5.12.5-1

qt5-5.12.5-2

sip-4.19.19-1

Line 
1
2%global qt_module qtwebengine
3
4%global _hardened_build 1
5
6# define to build docs, need to undef this for bootstrapping
7# where qt5-qttools builds are not yet available
8# only primary archs (for now), allow secondary to bootstrap
9%ifarch %{arm} %{ix86} x86_64
10#global docs 1
11%endif
12
13%if 0
14# need libvpx >= 1.8.0
15%global use_system_libvpx 1
16%endif
17%if 0
18# need libwebp >= 0.4.3
19%global use_system_libwebp 1
20%endif
21
22#global prerelease rc
23
24# spellchecking dictionary directory
25%global _qtwebengine_dictionaries_dir %{_qt5_datadir}/qtwebengine_dictionaries
26
27%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
28
29# exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
30# else)
31%global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
32# exclude libv8.so (i686, it's static everywhere else)
33%global __requires_exclude ^libv8\\.so$
34# and designer plugins
35%global __provides_exclude_from ^%{_qt5_plugindir}/.*\\.so$
36
37%global qt5_minorver 5.12
38%global qt5_version 5.12.5
39#global qt5_patchlevel 1
40
41Summary: Qt5 - QtWebEngine components
42Name:    qt5-qtwebengine
43Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
44Release: 1%{?_dist_release}
45
46# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
47# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
48# The other licenses are from Chromium and the code it bundles
49License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
50URL:     https://www.qt.io/
51
52Vendor: Project Vine
53Distribution: Vine Linux
54
55# cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
56# wget https://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-everywhere-src-5.6.1-1.tar.xz
57# ./clean_qtwebengine.sh 5.6.1-1
58Source0: %{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
59
60# cleanup scripts used above
61Source1: clean_qtwebengine.sh
62Source2: clean_ffmpeg.sh
63Source3: get_free_ffmpeg_source_files.py
64# macros
65Source10: macros.qt5-qtwebengine
66
67# pulseaudio headers
68Source20: pulseaudio-12.2-headers.tar.gz
69
70# some tweaks to linux.pri (system yasm, link libpci, run unbundling script)
71Patch0:  qtwebengine-everywhere-src-5.10.0-linux-pri.patch
72# quick hack to avoid checking for the nonexistent icudtl.dat and silence the
73# resulting warnings - not upstreamable as is because it removes the fallback
74# mechanism for the ICU data directory (which is not used in our builds because
75# we use the system ICU, which embeds the data statically) completely
76Patch1:  qtwebengine-everywhere-src-5.11.0-no-icudtl-dat.patch
77# fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
78# ARM flags with our %%qmake_qt5 macro, including for the next patch
79Patch2:  qtwebengine-opensource-src-5.12.4-fix-extractcflag.patch
80# disable NEON vector instructions on ARM where the NEON code FTBFS due to
81# GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
82Patch3:  qtwebengine-opensource-src-5.9.0-no-neon.patch
83# workaround FTBFS against kernel-headers-5.2.0+
84Patch4:  qtwebengine-SIOCGSTAMP.patch
85# remove Android dependencies from openmax_dl ARM NEON detection (detect.c)
86Patch10: qtwebengine-opensource-src-5.9.0-openmax-dl-neon.patch
87# Force verbose output from the GN bootstrap process
88Patch21: qtwebengine-everywhere-src-5.12.0-gn-bootstrap-verbose.patch
89# Fix/workaround FTBFS on aarch64 with newer glibc
90Patch24: qtwebengine-everywhere-src-5.11.3-aarch64-new-stat.patch
91
92
93# fix build error with libicu-65
94Patch1000: qtwebengine-icu65.patch
95
96# handled by qt5-srpm-macros, which defines %%qt5_qtwebengine_arches
97ExclusiveArch: %{qt5_qtwebengine_arches}
98
99BuildRequires: qt5-rpm-macros
100BuildRequires: qt5-srpm-macros
101BuildRequires: qt5-qtbase-devel
102BuildRequires: qt5-qtbase-private-devel
103# TODO: check of = is really needed or if >= would be good enough -- rex
104%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
105BuildRequires: qt5-qtdeclarative-devel
106BuildRequires: qt5-qtxmlpatterns-devel
107BuildRequires: qt5-qtlocation-devel
108BuildRequires: qt5-qtsensors-devel
109BuildRequires: qt5-qtwebchannel-devel
110BuildRequires: qt5-qttools-static
111# for examples?
112BuildRequires: qt5-qtquickcontrols2-devel
113BuildRequires: ninja
114BuildRequires: cmake
115BuildRequires: bison
116BuildRequires: flex
117BuildRequires: gcc-c++
118# gn links statically (for now)
119BuildRequires: libstdc++-static
120BuildRequires: git-core
121BuildRequires: gperf
122BuildRequires: krb5-devel
123BuildRequires: libicu-devel
124BuildRequires: libjpeg-turbo-devel
125#BuildRequires: re2-devel
126BuildRequires: snappy-devel
127%ifarch %{ix86} x86_64
128BuildRequires: yasm
129%endif
130BuildRequires: pkgconfig(expat)
131BuildRequires: pkgconfig(gobject-2.0)
132BuildRequires: pkgconfig(glib-2.0)
133BuildRequires: pkgconfig(fontconfig)
134BuildRequires: pkgconfig(freetype2)
135BuildRequires: pkgconfig(gl)
136BuildRequires: pkgconfig(egl)
137BuildRequires: pkgconfig(jsoncpp)
138BuildRequires: pkgconfig(libpng)
139BuildRequires: pkgconfig(libudev)
140%if 0%{?use_system_libwebp}
141BuildRequires: pkgconfig(libwebp) >= 0.6.0
142%endif
143BuildRequires: pkgconfig(harfbuzz)
144BuildRequires: pkgconfig(libdrm)
145BuildRequires: opus-devel
146BuildRequires: pkgconfig(protobuf)
147BuildRequires: pkgconfig(libevent)
148BuildRequires: zlib-devel
149#BuildRequires: pkgconfig(minizip)
150BuildRequires: pkgconfig(x11)
151BuildRequires: pkgconfig(xi)
152BuildRequires: libXcursor-devel
153BuildRequires: pkgconfig(xext)
154BuildRequires: pkgconfig(xfixes)
155BuildRequires: pkgconfig(xrender)
156BuildRequires: pkgconfig(xdamage)
157BuildRequires: pkgconfig(xcomposite)
158BuildRequires: pkgconfig(xtst)
159BuildRequires: pkgconfig(xrandr)
160BuildRequires: pkgconfig(xscrnsaver)
161BuildRequires: pkgconfig(libcap)
162BuildRequires: pkgconfig(libpulse)
163BuildRequires: pkgconfig(alsa)
164BuildRequires: pciutils-devel
165BuildRequires: pkgconfig(dbus-1)
166BuildRequires: pkgconfig(nss)
167BuildRequires: pkgconfig(lcms2)
168BuildRequires: perl
169BuildRequires: python
170BuildRequires: python-rpm-macros
171%if 0%{?use_system_libvpx}
172BuildRequires: pkgconfig(vpx) >= 1.7.0
173%endif
174
175# extra (non-upstream) functions needed, see
176# src/3rdparty/chromium/third_party/sqlite/README.chromium for details
177#BuildRequires: pkgconfig(sqlite3)
178
179## Various bundled libraries that Chromium does not support unbundling :-(
180## Only the parts actually built are listed.
181## Query for candidates:
182## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
183## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
184## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
185## some false positives where only shim headers are generated for some reason
186## some false positives with dummy placeholder dirs (swiftshader, widevine)
187## some false negatives where a header-only library is bundled (e.g. x86inc)
188## Spot's chromium.spec also has a list that I checked.
189
190# Of course, Chromium itself is bundled. It cannot be unbundled because it is
191# not a library, but forked (modified) application code.
192# Some security fixes are backported, see:
193# http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
194Provides: bundled(chromium) = 61.0.3163.140
195
196# Bundled in src/3rdparty/chromium/third_party:
197# Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
198# except where specified otherwise.
199Provides: bundled(angle) = 2422
200# Google's fork of OpenSSL
201# We cannot build against NSS instead because it no longer works with NSS 3.21:
202# HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
203# completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
204# http://kaosx.us/phpBB3/viewtopic.php?t=1235
205# https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
206# So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
207# use the BoringSSL code and the system NSS certificates.
208Provides: bundled(boringssl)
209Provides: bundled(brotli)
210# Don't get too excited. MPEG and other legally problematic stuff is stripped
211# out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
212# see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
213Provides: bundled(ffmpeg) = 3.3
214Provides: bundled(hunspell) = 1.6.0
215Provides: bundled(iccjpeg)
216# bundled as "khronos", headers only
217Provides: bundled(khronos_headers)
218# bundled as "leveldatabase"
219Provides: bundled(leveldb) = 1.20
220# bundled as "libjingle_xmpp"
221Provides: bundled(libjingle)
222# see src/3rdparty/chromium/third_party/libsrtp/CHANGES for the version number
223Provides: bundled(libsrtp) = 2.1.0
224%if !0%{?use_system_libvpx}
225# claims "Version: 1.6.0", but according to the fine print, this is actually a
226# snapshot from master from after the 1.6.1 release
227Provides: bundled(libvpx) = 1.6.1
228%endif
229%if !0%{?use_system_libwebp}
230Provides: bundled(libwebp) = 0.6.0
231%endif
232# bundled as "libxml"
233# see src/3rdparty/chromium/third_party/libxml/linux/include/libxml/xmlversion.h
234
235Provides: bundled(libxml2) = 2.9.4
236# see src/3rdparty/chromium/third_party/libxslt/linux/config.h for version
237Provides: bundled(libxslt) = 1.1.29
238Provides: bundled(libXNVCtrl) = 302.17
239Provides: bundled(libyuv) = 1658
240Provides: bundled(modp_b64)
241Provides: bundled(openmax_dl) = 1.0.2
242Provides: bundled(ots)
243# see src/3rdparty/chromium/third_party/protobuf/CHANGES.txt for the version
244#Provides: bundled(protobuf) = 3.0.0-0.1.beta3
245Provides: bundled(qcms) = 4
246Provides: bundled(sfntly)
247Provides: bundled(skia)
248# bundled as "smhasher"
249Provides: bundled(SMHasher) = 0-0.1.svn147
250Provides: bundled(sqlite) = 3.20
251Provides: bundled(usrsctp)
252Provides: bundled(webrtc) = 90
253
254%ifarch %{ix86} x86_64
255# bundled by ffmpeg and libvpx:
256# header (for assembly) only
257Provides: bundled(x86inc)
258%endif
259
260# Bundled in src/3rdparty/chromium/base/third_party:
261# Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
262# numbers, except where specified otherwise.
263Provides: bundled(dmg_fp)
264Provides: bundled(dynamic_annotations) = 4384
265Provides: bundled(superfasthash) = 0
266Provides: bundled(symbolize)
267# bundled as "valgrind", headers only
268Provides: bundled(valgrind.h)
269# bundled as "xdg_mime"
270Provides: bundled(xdg-mime)
271# bundled as "xdg_user_dirs"
272Provides: bundled(xdg-user-dirs) = 0.10
273
274# Bundled in src/3rdparty/chromium/net/third_party:
275# Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
276# numbers, except where specified otherwise.
277Provides: bundled(mozilla_security_manager) = 1.9.2
278
279# Bundled in src/3rdparty/chromium/url/third_party:
280# Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
281# numbers, except where specified otherwise.
282# bundled as "mozilla", file renamed and modified
283Provides: bundled(nsURLParsers)
284
285# Bundled outside of third_party, apparently not considered as such by Chromium:
286
287Provides: bundled(mojo)
288# see src/3rdparty/chromium/v8/include/v8_version.h for the version number
289Provides: bundled(v8) = 6.1.534.44
290# bundled by v8 (src/3rdparty/chromium/v8/src/base/ieee754.cc)
291# The version number is 5.3, the last version that upstream released, years ago:
292
293# http://www.netlib.org/fdlibm/readme
294Provides: bundled(fdlibm) = 5.3
295
296%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
297
298
299%description
300%{summary}.
301
302%package devel
303Summary: Development files for %{name}
304Requires: %{name}%{?_isa} = %{version}-%{release}
305Requires: qt5-qtbase-devel%{?_isa}
306Requires: qt5-qtdeclarative-devel%{?_isa}
307# not arch'd for now, see if can get away with avoiding multilib'ing -- rex
308Requires: %{name}-devtools = %{version}-%{release}
309%description devel
310%{summary}.
311
312%package devtools
313Summary: WebEngine devtools_resources
314Requires: %{name}%{?_isa} = %{version}-%{release}
315%description devtools
316Support for remote debugging.
317
318%package examples
319Summary: Example files for %{name}
320
321%description examples
322%{summary}.
323
324
325%if 0%{?docs}
326%package doc
327Summary: API documentation for %{name}
328BuildRequires: qt5-qhelpgenerator
329BuildRequires: qt5-qdoc
330BuildArch: noarch
331%description doc
332%{summary}.
333%endif
334
335
336%prep
337%setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
338
339%if 0
340tar xvf %{SOURCE20}
341mv pulse src/3rdparty/chromium/
342%endif
343
344%patch0 -p1 -b .linux-pri
345%patch1 -p1 -b .no-icudtl-dat
346%patch2 -p1 -b .fix-extractcflag
347%if !0%{?arm_neon}
348%patch3 -p1 -b .no-neon
349%endif
350%patch4 -p1 -b .SIOCGSTAMP
351
352## upstream patches
353
354%patch10 -p1 -b .openmax-dl-neon
355## NEEDSWORK
356#patch21 -p1 -b .gn-bootstrap-verbose
357%patch24 -p1 -b .aarch64-new-stat
358
359# enable to build with libicu-65
360%patch1000 -p1 -b .icu65
361
362
363# fix // in #include in content/renderer/gpu to avoid debugedit failure
364#sed -i -e 's!gpu//!gpu/!g' \
365#  src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
366# and another one in 2 files in WebRTC
367sed -i -e 's!audio_processing//!audio_processing/!g' \
368  src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft.cc \
369  src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft_sse2.cc
370# remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
371sed -i -e 's!\./!!g' \
372  src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
373  src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
374# delete all "toolprefix = " lines from build/toolchain/linux/BUILD.gn, as we
375# never cross-compile in native Fedora RPMs, fixes ARM and aarch64 FTBFS
376sed -i -e '/toolprefix = /d' -e 's/\${toolprefix}//g' \
377  src/3rdparty/chromium/build/toolchain/linux/BUILD.gn
378
379# http://bugzilla.redhat.com/1337585
380# can't just delete, but we'll overwrite with system headers to be on the safe side
381#cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/src/re2/
382
383%if 0
384#ifarch x86_64
385# enable this to force -g2 on x86_64 (most arches run out of memory with -g2)
386# DISABLED BECAUSE OF:
387# /usr/lib/rpm/find-debuginfo.sh: line 188:  3619 Segmentation fault
388# (core dumped) eu-strip --remove-comment $r $g -f "$1" "$2"
389sed -i -e 's/symbol_level=1/symbol_level=2/g' src/core/config/common.pri
390%endif
391
392# generate qtwebengine-3rdparty.qdoc, it is missing from the tarball
393pushd src/3rdparty
394%{__python} chromium/tools/licenses.py \
395  --file-template ../../tools/about_credits.tmpl \
396  --entry-template ../../tools/about_credits_entry.tmpl \
397  credits >../webengine/doc/src/qtwebengine-3rdparty.qdoc
398popd
399
400# copy the Chromium license so it is installed with the appropriate name
401cp -p src/3rdparty/chromium/LICENSE LICENSE.Chromium
402
403
404%build
405export STRIP=strip
406export NINJAFLAGS="%{?__ninja_common_opts}"
407export NINJA_PATH=%{_bindir}/ninja-build
408export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
409
410export CFLAGS="%{optflags}"
411#ifnarch x86_64
412# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
413export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
414#endif
415export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
416#ifnarch x86_64
417# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
418export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
419#endif
420
421mkdir %{_target_platform}
422pushd %{_target_platform}
423
424%{qmake_qt5} \
425  %{?debug_config:CONFIG+="%{debug_config}"} \
426  CONFIG+="link_pulseaudio" \
427  QMAKE_EXTRA_ARGS+="-system-webengine-icu" \
428  QMAKE_EXTRA_ARGS+="-webengine-kerberos" \
429  ..
430
431# if we keep these set here, gyp picks up duplicate flags
432unset CFLAGS
433export CFLAGS
434unset CXXFLAGS
435export CXXFLAGS
436
437# workaround, disable parallel compilation as it fails to compile in brew
438make %{?_smp_mflags}
439
440%if 0%{?docs}
441make %{?_smp_mflags} docs
442%endif
443popd
444
445%install
446rm -rf %{buildroot}
447make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
448
449%if 0%{?docs}
450make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
451%endif
452
453# rpm macros
454install -p -m644 -D %{SOURCE10} \
455  %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
456sed -i \
457  -e "s|@@NAME@@|%{name}|g" \
458  -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
459  -e "s|@@VERSION@@|%{version}|g" \
460  -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
461  %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
462
463# hardlink files to {_bindir}
464mkdir -p %{buildroot}%{_bindir}
465pushd %{buildroot}%{_qt5_bindir}
466for i in * ; do
467  ln -v  ${i} %{buildroot}%{_bindir}/${i}
468done
469popd
470
471## .prl/.la file love
472# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
473pushd %{buildroot}%{_qt5_libdir}
474for prl_file in libQt5*.prl ; do
475  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
476  if [ -f "$(basename ${prl_file} .prl).so" ]; then
477    rm -fv "$(basename ${prl_file} .prl).la"
478    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
479  fi
480done
481popd
482
483# explicitly omit, at least until there's a real library installed associated with it -- rex
484rm -fv %{buildroot}%{_libdir}/Qt5WebEngineCore.la
485
486mkdir -p %{buildroot}%{_qtwebengine_dictionaries_dir}
487
488# adjust cmake dep(s) to allow for using the same Qt5 that was used to build it
489# using the lesser of %%version, %%_qt5_version
490%global lesser_version $(echo -e "%{version}\\n%{_qt5_version}" | sort -V | head -1)
491sed -i -e "s|%{version} \${_Qt5WebEngine|%{lesser_version} \${_Qt5WebEngine|" \
492  %{buildroot}%{_qt5_libdir}/cmake/Qt5WebEngine*/Qt5WebEngine*Config.cmake
493
494
495%post -p /sbin/ldconfig
496%postun -p /sbin/ldconfig
497
498%files
499%license LICENSE.* src/webengine/doc/src/qtwebengine-3rdparty.qdoc
500%{_qt5_libdir}/libQt5*.so.*
501%{_bindir}/qwebengine_convert_dict
502%{_qt5_bindir}/qwebengine_convert_dict
503%{_qt5_libdir}/qt5/qml/*
504%{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
505#ifarch %{ix86}
506%if 0%{?sse2}
507# shared V8 library and its SSE2 version
508%{_qt5_libdir}/qtwebengine/
509%endif
510%{_qt5_plugindir}/designer/libqwebengineview.so
511%dir %{_qt5_datadir}/resources/
512%{_qt5_datadir}/resources/qtwebengine_resources_100p.pak
513%{_qt5_datadir}/resources/qtwebengine_resources_200p.pak
514%{_qt5_datadir}/resources/qtwebengine_resources.pak
515%dir %{_qtwebengine_dictionaries_dir}
516%dir %{_qt5_translationdir}/qtwebengine_locales
517%lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
518%lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
519%lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
520%lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
521%lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
522%lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
523%lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
524%lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
525%lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
526%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
527%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
528%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
529%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
530%lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
531%lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
532%lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
533%lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
534%lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
535%lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
536%lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
537%lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
538%lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
539%lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
540%lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
541%lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
542%lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
543%lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
544%lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
545%lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
546%lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
547%lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
548%lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
549%lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
550%lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
551%lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
552%lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
553%lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
554%lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
555%lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
556%lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
557%lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
558%lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
559%lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
560%lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
561%lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
562%lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
563%lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
564%lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
565%lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
566%lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
567%lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
568%lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
569%lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
570
571%files devel
572%{rpm_macros_dir}/macros.qt5-qtwebengine
573%{_qt5_headerdir}/Qt*/
574%{_qt5_libdir}/libQt5*.so
575%{_qt5_libdir}/libQt5*.prl
576#{_qt5_libdir}/Qt5WebEngineCore.la
577%{_qt5_libdir}/cmake/Qt5*/
578%{_qt5_libdir}/pkgconfig/Qt5*.pc
579%{_qt5_archdatadir}/mkspecs/modules/*.pri
580
581%files devtools
582%{_qt5_datadir}/resources/qtwebengine_devtools_resources.pak
583
584%files examples
585%{_qt5_examplesdir}/
586
587%if 0%{?docs}
588%files doc
589%{_qt5_docdir}/*
590%endif
591
592
593%changelog
594* Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
595- new upstream release.
596
597* Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-2
598- rebuild with libevent-2.1.8
599
600* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
601- new upstream release.
602
603* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
604- new upstream release.
605- initial build for Vine Linux.
606- updated Source1.
607
608* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
609- rebuild (glibc)
610
611* Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
612- add versioned qt5-qtbase runtime dep
613
614* Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
615- Update to 5.6.1
616- Rebase linux-pri patch (drop the parts already fixed upstream)
617- Drop backported chimera-nss-init patch, already applied upstream
618- Rebase no-sse2 patch (the core_module.pro change)
619- Add the new designer/libqwebengineview.so plugin to the file list
620
621* Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
622- workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
623
624* Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
625- rebuild (pciutuils)
626
627* Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
628- BR: git-core
629
630* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
631- rebuild for ICU 57.1
632
633* Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
634- drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
635
636* Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
637- Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
638- Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
639- Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
640- Work around debugedit failure by removing "./" from #line commands and
641  changing "//" to "/" in an #include command
642
643* Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
644- Avoid checking for the nonexistent icudtl.dat and silence the warnings
645
646* Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
647- Update to 5.6.0 (final)
648- Drop system-icu54 patch, fixed upstream
649
650* Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
651- Update to 5.6.0 RC
652- Rebase linux-pri and no-sse2 patches
653- Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
654- Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
655- Tag translations with correct %%lang tags
656
657* Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
658- no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
659
660* Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
661- Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
662
663* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
664- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
665
666* Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
667- Build V8 as a shared library on i686 to allow for swappable backends
668- Build both the x87 version and the SSE2 version of V8 on i686
669- Add the private library directory to the file list on i686
670- Add Provides/Requires filtering for libv8.so (i686) and for plugins
671
672* Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
673- Do not require SSE2 on i686
674
675* Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
676- Drop nss321 backport (and the related nss-headers patch), it did not help
677- Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
678- Update License accordingly (add "OpenSSL")
679- Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
680
681* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
682- Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
683
684* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
685- Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
686
687* Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
688- Unbundle prtime.cc, use the system NSPR instead (which is already required)
689- Unbundle icu_utf.cc, use the system ICU instead (which is already required)
690
691* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
692- linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
693
694* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
695- Build against the system libvpx also on F23 (1.4.0), worked in Copr
696
697* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
698- Use the system libvpx on F24+ (1.5.0)
699- Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
700
701* Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
702- Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
703- Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
704
705* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
706- Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
707- Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
708
709* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
710- Use more specific BuildRequires for docs (thanks to rdieter)
711- Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
712
713* Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
714- Fix License tag
715- Use %%_qt5_examplesdir macro
716- Add Provides: bundled(*) for all the bundled libraries that I found
717
718* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
719- linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
720
721* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
722- linux-pri patch: Add missing newline at the end of the log line
723- Use export for NINJA_PATH (fixes system ninja-build use)
724
725* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
726- Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
727- BR yasm only on x86 (i686, x86_64)
728- Add dot at the end of %%description
729- Rebase no-format patch
730- Replace unbundle-gyp.patch with new linux-pri.patch
731- Use system ninja-build instead of the bundled one
732- Run the unbundling script replace_gyp_files.py in linux.pri rather than here
733- Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
734
735* Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
736- Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
737  pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
738  pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
739  pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
740  perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
741- Add missing explicit BRs on pkgconfig(x11),  pkgconfig(xext),
742  pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
743- Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
744- Fix BR python-devel to python
745- Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
746- Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
747
748* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
749- Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
750
751* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
752- Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
753- Remove unused BR v8-devel (cannot currently be unbundled)
754
755* Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
756- Update to 5.5.1
757- Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
758
759* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
760- Update with unbundle flags. Adapted from original 5.4 Suse package
761- Disable vpx and sqlite as unbundle due some compilation issues
762- Enable verbose build
763
764* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
765- Initial spec
766
767* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
768- Update for official RC1 released packages
Note: See TracBrowser for help on using the repository browser.