source: projects/specs/trunk/q/qt5-qtwebengine/qt5-qtwebengine-vl.spec @ 12348

Revision 12348, 29.0 KB checked in by tomop, 4 years ago (diff)

updated 25 packages

python-qt5-5.12.3-2

qt5-qt3d-5.12.7-1

qt5-qtbase-5.12.7-1

qt5-qtcanvas3d-5.12.7-1

qt5-qtconnectivity-5.12.7-1

qt5-qtdeclarative-5.12.7-1

qt5-qtdoc-5.12.7-1

qt5-qtgraphicaleffects-5.12.7-1

qt5-qtimageformats-5.12.7-1

qt5-qtlocation-5.12.7-1

qt5-qtmultimedia-5.12.7-1

qt5-qtquickcontrols-5.12.7-1

qt5-qtquickcontrols2-5.12.7-1

qt5-qtscript-5.12.7-1

qt5-qtsensors-5.12.7-1

qt5-qtserialport-5.12.7-1

qt5-qtsvg-5.12.7-1

qt5-qttools-5.12.7-1

qt5-qttranslations-5.12.7-1

qt5-qtwebchannel-5.12.7-1

qt5-qtwebengine-5.12.7-1

qt5-qtwebsockets-5.12.7-1

qt5-qtx11extras-5.12.7-1

qt5-qtxmlpatterns-5.12.7-1

qt5-5.12.7-1

Line 
1
2%global qt_module qtwebengine
3
4%global _hardened_build 1
5
6# define to build docs, need to undef this for bootstrapping
7# where qt5-qttools builds are not yet available
8# only primary archs (for now), allow secondary to bootstrap
9%ifarch %{arm} %{ix86} x86_64
10#global docs 1
11%endif
12
13%if 0
14# need libvpx >= 1.8.0
15%global use_system_libvpx 1
16%endif
17%if 0
18# need libwebp >= 0.4.3
19%global use_system_libwebp 1
20%endif
21
22#global prerelease rc
23
24# spellchecking dictionary directory
25%global _qtwebengine_dictionaries_dir %{_qt5_datadir}/qtwebengine_dictionaries
26
27%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
28
29# exclude plugins (all architectures) and libv8.so (i686, it's static everywhere
30# else)
31%global __provides_exclude ^lib.*plugin\\.so.*|libv8\\.so$
32# exclude libv8.so (i686, it's static everywhere else)
33%global __requires_exclude ^libv8\\.so$
34# and designer plugins
35%global __provides_exclude_from ^%{_qt5_plugindir}/.*\\.so$
36
37%global qt5_minorver 5.12
38%global qt5_version 5.12.7
39#global qt5_patchlevel 1
40
41Summary: Qt5 - QtWebEngine components
42Name:    qt5-qtwebengine
43Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
44Release: 1%{?_dist_release}
45
46# See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
47# See also http://qt-project.org/doc/qt-5.0/qtdoc/licensing.html
48# The other licenses are from Chromium and the code it bundles
49License: (LGPLv2 with exceptions or GPLv3 with exceptions) and BSD and LGPLv2+ and ASL 2.0 and IJG and MIT and GPLv2+ and ISC and OpenSSL and (MPLv1.1 or GPLv2 or LGPLv2)
50URL:     https://www.qt.io/
51
52Vendor: Project Vine
53Distribution: Vine Linux
54
55# cleaned tarball with patent-encumbered codecs removed from the bundled FFmpeg
56# wget https://download.qt.io/official_releases/qt/5.6/5.6.1-1/submodules/qtwebengine-everywhere-src-5.6.1-1.tar.xz
57# ./clean_qtwebengine.sh 5.6.1-1
58Source0: %{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}-clean.tar.xz
59
60# cleanup scripts used above
61Source1: clean_qtwebengine.sh
62Source2: clean_ffmpeg.sh
63Source3: get_free_ffmpeg_source_files.py
64# macros
65Source10: macros.qt5-qtwebengine
66
67# pulseaudio headers
68Source20: pulseaudio-12.2-headers.tar.gz
69
70# some tweaks to linux.pri (system yasm, link libpci, run unbundling script)
71Patch0:  qtwebengine-everywhere-src-5.10.0-linux-pri.patch
72# quick hack to avoid checking for the nonexistent icudtl.dat and silence the
73# resulting warnings - not upstreamable as is because it removes the fallback
74# mechanism for the ICU data directory (which is not used in our builds because
75# we use the system ICU, which embeds the data statically) completely
76Patch1:  qtwebengine-everywhere-src-5.11.0-no-icudtl-dat.patch
77# fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE, needed to detect the
78# ARM flags with our %%qmake_qt5 macro, including for the next patch
79Patch2:  qtwebengine-opensource-src-5.12.4-fix-extractcflag.patch
80# disable NEON vector instructions on ARM where the NEON code FTBFS due to
81# GCC bug https://bugzilla.redhat.com/show_bug.cgi?id=1282495
82Patch3:  qtwebengine-opensource-src-5.9.0-no-neon.patch
83# workaround FTBFS against kernel-headers-5.2.0+
84Patch4:  qtwebengine-SIOCGSTAMP.patch
85# remove Android dependencies from openmax_dl ARM NEON detection (detect.c)
86Patch10: qtwebengine-opensource-src-5.9.0-openmax-dl-neon.patch
87# Force verbose output from the GN bootstrap process
88Patch21: qtwebengine-everywhere-src-5.12.0-gn-bootstrap-verbose.patch
89# Fix/workaround FTBFS on aarch64 with newer glibc
90Patch24: qtwebengine-everywhere-src-5.11.3-aarch64-new-stat.patch
91
92
93# handled by qt5-srpm-macros, which defines %%qt5_qtwebengine_arches
94ExclusiveArch: %{qt5_qtwebengine_arches}
95
96BuildRequires: qt5-rpm-macros
97BuildRequires: qt5-srpm-macros
98BuildRequires: qt5-qtbase-devel
99BuildRequires: qt5-qtbase-private-devel
100# TODO: check of = is really needed or if >= would be good enough -- rex
101%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
102BuildRequires: qt5-qtdeclarative-devel
103BuildRequires: qt5-qtxmlpatterns-devel
104BuildRequires: qt5-qtlocation-devel
105BuildRequires: qt5-qtsensors-devel
106BuildRequires: qt5-qtwebchannel-devel
107BuildRequires: qt5-qttools-static
108# for examples?
109BuildRequires: qt5-qtquickcontrols2-devel
110BuildRequires: ninja
111BuildRequires: cmake
112BuildRequires: bison
113BuildRequires: flex
114BuildRequires: gcc-c++
115# gn links statically (for now)
116BuildRequires: libstdc++-static
117BuildRequires: git-core
118BuildRequires: gperf
119BuildRequires: krb5-devel
120BuildRequires: libicu-devel
121BuildRequires: libjpeg-turbo-devel
122#BuildRequires: re2-devel
123BuildRequires: snappy-devel
124%ifarch %{ix86} x86_64
125BuildRequires: yasm
126%endif
127BuildRequires: pkgconfig(expat)
128BuildRequires: pkgconfig(gobject-2.0)
129BuildRequires: pkgconfig(glib-2.0)
130BuildRequires: pkgconfig(fontconfig)
131BuildRequires: pkgconfig(freetype2)
132BuildRequires: pkgconfig(gl)
133BuildRequires: pkgconfig(egl)
134BuildRequires: pkgconfig(jsoncpp)
135BuildRequires: pkgconfig(libpng)
136BuildRequires: pkgconfig(libudev)
137%if 0%{?use_system_libwebp}
138BuildRequires: pkgconfig(libwebp) >= 0.6.0
139%endif
140BuildRequires: pkgconfig(harfbuzz)
141BuildRequires: pkgconfig(libdrm)
142BuildRequires: opus-devel
143BuildRequires: pkgconfig(protobuf)
144BuildRequires: pkgconfig(libevent)
145BuildRequires: zlib-devel
146#BuildRequires: pkgconfig(minizip)
147BuildRequires: pkgconfig(x11)
148BuildRequires: pkgconfig(xi)
149BuildRequires: libXcursor-devel
150BuildRequires: pkgconfig(xext)
151BuildRequires: pkgconfig(xfixes)
152BuildRequires: pkgconfig(xrender)
153BuildRequires: pkgconfig(xdamage)
154BuildRequires: pkgconfig(xcomposite)
155BuildRequires: pkgconfig(xtst)
156BuildRequires: pkgconfig(xrandr)
157BuildRequires: pkgconfig(xscrnsaver)
158BuildRequires: pkgconfig(libcap)
159BuildRequires: pkgconfig(libpulse)
160BuildRequires: pkgconfig(alsa)
161BuildRequires: pciutils-devel
162BuildRequires: pkgconfig(dbus-1)
163BuildRequires: pkgconfig(nss)
164BuildRequires: pkgconfig(lcms2)
165BuildRequires: perl
166BuildRequires: python
167BuildRequires: python-rpm-macros
168%if 0%{?use_system_libvpx}
169BuildRequires: pkgconfig(vpx) >= 1.7.0
170%endif
171
172# extra (non-upstream) functions needed, see
173# src/3rdparty/chromium/third_party/sqlite/README.chromium for details
174#BuildRequires: pkgconfig(sqlite3)
175
176## Various bundled libraries that Chromium does not support unbundling :-(
177## Only the parts actually built are listed.
178## Query for candidates:
179## grep third_party/ build.log | sed 's!third_party/!\nthird_party/!g' | \
180## grep third_party/ | sed 's!^third_party/!!g' | sed 's!/.*$!!g' | \
181## sed 's/\;.*$//g' | sed 's/ .*$//g' | sort | uniq | less
182## some false positives where only shim headers are generated for some reason
183## some false positives with dummy placeholder dirs (swiftshader, widevine)
184## some false negatives where a header-only library is bundled (e.g. x86inc)
185## Spot's chromium.spec also has a list that I checked.
186
187# Of course, Chromium itself is bundled. It cannot be unbundled because it is
188# not a library, but forked (modified) application code.
189# Some security fixes are backported, see:
190# http://code.qt.io/cgit/qt/qtwebengine-chromium.git/log/?h=45-based
191Provides: bundled(chromium) = 61.0.3163.140
192
193# Bundled in src/3rdparty/chromium/third_party:
194# Check src/3rdparty/chromium/third_party/*/README.chromium for version numbers,
195# except where specified otherwise.
196Provides: bundled(angle) = 2422
197# Google's fork of OpenSSL
198# We cannot build against NSS instead because it no longer works with NSS 3.21:
199# HTTPS on, ironically, Google's sites (Google, YouTube, etc.) stops working
200# completely and produces only ERR_SSL_PROTOCOL_ERROR errors:
201# http://kaosx.us/phpBB3/viewtopic.php?t=1235
202# https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1520568
203# So we have to do what Chromium 47 now defaults to: a "chimera build", i.e.,
204# use the BoringSSL code and the system NSS certificates.
205Provides: bundled(boringssl)
206Provides: bundled(brotli)
207# Don't get too excited. MPEG and other legally problematic stuff is stripped
208# out. See clean_qtwebengine.sh, clean_ffmpeg.sh, and process_ffmpeg_gyp.py.
209# see src/3rdparty/chromium/third_party/ffmpeg/Changelog for the version number
210Provides: bundled(ffmpeg) = 3.3
211Provides: bundled(hunspell) = 1.6.0
212Provides: bundled(iccjpeg)
213# bundled as "khronos", headers only
214Provides: bundled(khronos_headers)
215# bundled as "leveldatabase"
216Provides: bundled(leveldb) = 1.20
217# bundled as "libjingle_xmpp"
218Provides: bundled(libjingle)
219# see src/3rdparty/chromium/third_party/libsrtp/CHANGES for the version number
220Provides: bundled(libsrtp) = 2.1.0
221%if !0%{?use_system_libvpx}
222# claims "Version: 1.6.0", but according to the fine print, this is actually a
223# snapshot from master from after the 1.6.1 release
224Provides: bundled(libvpx) = 1.6.1
225%endif
226%if !0%{?use_system_libwebp}
227Provides: bundled(libwebp) = 0.6.0
228%endif
229# bundled as "libxml"
230# see src/3rdparty/chromium/third_party/libxml/linux/include/libxml/xmlversion.h
231
232Provides: bundled(libxml2) = 2.9.4
233# see src/3rdparty/chromium/third_party/libxslt/linux/config.h for version
234Provides: bundled(libxslt) = 1.1.29
235Provides: bundled(libXNVCtrl) = 302.17
236Provides: bundled(libyuv) = 1658
237Provides: bundled(modp_b64)
238Provides: bundled(openmax_dl) = 1.0.2
239Provides: bundled(ots)
240# see src/3rdparty/chromium/third_party/protobuf/CHANGES.txt for the version
241#Provides: bundled(protobuf) = 3.0.0-0.1.beta3
242Provides: bundled(qcms) = 4
243Provides: bundled(sfntly)
244Provides: bundled(skia)
245# bundled as "smhasher"
246Provides: bundled(SMHasher) = 0-0.1.svn147
247Provides: bundled(sqlite) = 3.20
248Provides: bundled(usrsctp)
249Provides: bundled(webrtc) = 90
250
251%ifarch %{ix86} x86_64
252# bundled by ffmpeg and libvpx:
253# header (for assembly) only
254Provides: bundled(x86inc)
255%endif
256
257# Bundled in src/3rdparty/chromium/base/third_party:
258# Check src/3rdparty/chromium/third_party/base/*/README.chromium for version
259# numbers, except where specified otherwise.
260Provides: bundled(dmg_fp)
261Provides: bundled(dynamic_annotations) = 4384
262Provides: bundled(superfasthash) = 0
263Provides: bundled(symbolize)
264# bundled as "valgrind", headers only
265Provides: bundled(valgrind.h)
266# bundled as "xdg_mime"
267Provides: bundled(xdg-mime)
268# bundled as "xdg_user_dirs"
269Provides: bundled(xdg-user-dirs) = 0.10
270
271# Bundled in src/3rdparty/chromium/net/third_party:
272# Check src/3rdparty/chromium/third_party/net/*/README.chromium for version
273# numbers, except where specified otherwise.
274Provides: bundled(mozilla_security_manager) = 1.9.2
275
276# Bundled in src/3rdparty/chromium/url/third_party:
277# Check src/3rdparty/chromium/third_party/url/*/README.chromium for version
278# numbers, except where specified otherwise.
279# bundled as "mozilla", file renamed and modified
280Provides: bundled(nsURLParsers)
281
282# Bundled outside of third_party, apparently not considered as such by Chromium:
283
284Provides: bundled(mojo)
285# see src/3rdparty/chromium/v8/include/v8_version.h for the version number
286Provides: bundled(v8) = 6.1.534.44
287# bundled by v8 (src/3rdparty/chromium/v8/src/base/ieee754.cc)
288# The version number is 5.3, the last version that upstream released, years ago:
289
290# http://www.netlib.org/fdlibm/readme
291Provides: bundled(fdlibm) = 5.3
292
293%{?_qt5_version:Requires: qt5-qtbase%{?_isa} >= %{_qt5_version}}
294
295
296%description
297%{summary}.
298
299%package devel
300Summary: Development files for %{name}
301Requires: %{name}%{?_isa} = %{version}-%{release}
302Requires: qt5-qtbase-devel%{?_isa}
303Requires: qt5-qtdeclarative-devel%{?_isa}
304# not arch'd for now, see if can get away with avoiding multilib'ing -- rex
305Requires: %{name}-devtools = %{version}-%{release}
306%description devel
307%{summary}.
308
309%package devtools
310Summary: WebEngine devtools_resources
311Requires: %{name}%{?_isa} = %{version}-%{release}
312%description devtools
313Support for remote debugging.
314
315%package examples
316Summary: Example files for %{name}
317
318%description examples
319%{summary}.
320
321
322%if 0%{?docs}
323%package doc
324Summary: API documentation for %{name}
325BuildRequires: qt5-qhelpgenerator
326BuildRequires: qt5-qdoc
327BuildArch: noarch
328%description doc
329%{summary}.
330%endif
331
332
333%prep
334%setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
335
336%if 0
337tar xvf %{SOURCE20}
338mv pulse src/3rdparty/chromium/
339%endif
340
341%patch0 -p1 -b .linux-pri
342%patch1 -p1 -b .no-icudtl-dat
343%patch2 -p1 -b .fix-extractcflag
344%if !0%{?arm_neon}
345%patch3 -p1 -b .no-neon
346%endif
347%patch4 -p1 -b .SIOCGSTAMP
348
349## upstream patches
350
351%patch10 -p1 -b .openmax-dl-neon
352## NEEDSWORK
353#patch21 -p1 -b .gn-bootstrap-verbose
354%patch24 -p1 -b .aarch64-new-stat
355
356
357# fix // in #include in content/renderer/gpu to avoid debugedit failure
358#sed -i -e 's!gpu//!gpu/!g' \
359#  src/3rdparty/chromium/content/renderer/gpu/compositor_forwarding_message_filter.cc
360# and another one in 2 files in WebRTC
361sed -i -e 's!audio_processing//!audio_processing/!g' \
362  src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft.cc \
363  src/3rdparty/chromium/third_party/webrtc/modules/audio_processing/utility/ooura_fft_sse2.cc
364# remove ./ from #line commands in ANGLE to avoid debugedit failure (?)
365sed -i -e 's!\./!!g' \
366  src/3rdparty/chromium/third_party/angle/src/compiler/preprocessor/Tokenizer.cpp \
367  src/3rdparty/chromium/third_party/angle/src/compiler/translator/glslang_lex.cpp
368# delete all "toolprefix = " lines from build/toolchain/linux/BUILD.gn, as we
369# never cross-compile in native Fedora RPMs, fixes ARM and aarch64 FTBFS
370sed -i -e '/toolprefix = /d' -e 's/\${toolprefix}//g' \
371  src/3rdparty/chromium/build/toolchain/linux/BUILD.gn
372
373# http://bugzilla.redhat.com/1337585
374# can't just delete, but we'll overwrite with system headers to be on the safe side
375#cp -bv /usr/include/re2/*.h src/3rdparty/chromium/third_party/re2/src/re2/
376
377%if 0
378#ifarch x86_64
379# enable this to force -g2 on x86_64 (most arches run out of memory with -g2)
380# DISABLED BECAUSE OF:
381# /usr/lib/rpm/find-debuginfo.sh: line 188:  3619 Segmentation fault
382# (core dumped) eu-strip --remove-comment $r $g -f "$1" "$2"
383sed -i -e 's/symbol_level=1/symbol_level=2/g' src/core/config/common.pri
384%endif
385
386# generate qtwebengine-3rdparty.qdoc, it is missing from the tarball
387pushd src/3rdparty
388%{__python} chromium/tools/licenses.py \
389  --file-template ../../tools/about_credits.tmpl \
390  --entry-template ../../tools/about_credits_entry.tmpl \
391  credits >../webengine/doc/src/qtwebengine-3rdparty.qdoc
392popd
393
394# copy the Chromium license so it is installed with the appropriate name
395cp -p src/3rdparty/chromium/LICENSE LICENSE.Chromium
396
397
398%build
399export STRIP=strip
400export NINJAFLAGS="%{?__ninja_common_opts}"
401export NINJA_PATH=%{_bindir}/ninja-build
402export RE2_INCLUDE=$(pwd)/src/3rdparty/chromium/third_party/re2
403
404export CFLAGS="%{optflags}"
405#ifnarch x86_64
406# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
407export CFLAGS=`echo "$CFLAGS" | sed -e 's/ -g / -g1 /g'`
408#endif
409export CXXFLAGS="%{optflags} -fno-delete-null-pointer-checks"
410#ifnarch x86_64
411# most arches run out of memory with full debuginfo, so use -g1 on non-x86_64
412export CXXFLAGS=`echo "$CXXFLAGS" | sed -e 's/ -g / -g1 /g'`
413#endif
414
415mkdir %{_target_platform}
416pushd %{_target_platform}
417
418%{qmake_qt5} \
419  %{?debug_config:CONFIG+="%{debug_config}"} \
420  CONFIG+="link_pulseaudio" \
421  QMAKE_EXTRA_ARGS+="-system-webengine-icu" \
422  QMAKE_EXTRA_ARGS+="-webengine-kerberos" \
423  ..
424
425# if we keep these set here, gyp picks up duplicate flags
426unset CFLAGS
427export CFLAGS
428unset CXXFLAGS
429export CXXFLAGS
430
431# workaround, disable parallel compilation as it fails to compile in brew
432make %{?_smp_mflags}
433
434%if 0%{?docs}
435make %{?_smp_mflags} docs
436%endif
437popd
438
439%install
440rm -rf %{buildroot}
441make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
442
443%if 0%{?docs}
444make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
445%endif
446
447# rpm macros
448install -p -m644 -D %{SOURCE10} \
449  %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
450sed -i \
451  -e "s|@@NAME@@|%{name}|g" \
452  -e "s|@@EPOCH@@|%{?epoch}%{!?epoch:0}|g" \
453  -e "s|@@VERSION@@|%{version}|g" \
454  -e "s|@@EVR@@|%{?epoch:%{epoch:}}%{version}-%{release}|g" \
455  %{buildroot}%{rpm_macros_dir}/macros.qt5-qtwebengine
456
457# hardlink files to {_bindir}
458mkdir -p %{buildroot}%{_bindir}
459pushd %{buildroot}%{_qt5_bindir}
460for i in * ; do
461  ln -v  ${i} %{buildroot}%{_bindir}/${i}
462done
463popd
464
465## .prl/.la file love
466# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
467pushd %{buildroot}%{_qt5_libdir}
468for prl_file in libQt5*.prl ; do
469  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
470  if [ -f "$(basename ${prl_file} .prl).so" ]; then
471    rm -fv "$(basename ${prl_file} .prl).la"
472    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
473  fi
474done
475popd
476
477# explicitly omit, at least until there's a real library installed associated with it -- rex
478rm -fv %{buildroot}%{_libdir}/Qt5WebEngineCore.la
479
480mkdir -p %{buildroot}%{_qtwebengine_dictionaries_dir}
481
482# adjust cmake dep(s) to allow for using the same Qt5 that was used to build it
483# using the lesser of %%version, %%_qt5_version
484%global lesser_version $(echo -e "%{version}\\n%{_qt5_version}" | sort -V | head -1)
485sed -i -e "s|%{version} \${_Qt5WebEngine|%{lesser_version} \${_Qt5WebEngine|" \
486  %{buildroot}%{_qt5_libdir}/cmake/Qt5WebEngine*/Qt5WebEngine*Config.cmake
487
488
489%post -p /sbin/ldconfig
490%postun -p /sbin/ldconfig
491
492%files
493%license LICENSE.* src/webengine/doc/src/qtwebengine-3rdparty.qdoc
494%{_qt5_libdir}/libQt5*.so.*
495%{_bindir}/qwebengine_convert_dict
496%{_qt5_bindir}/qwebengine_convert_dict
497%{_qt5_libdir}/qt5/qml/*
498%{_qt5_libdir}/qt5/libexec/QtWebEngineProcess
499#ifarch %{ix86}
500%if 0%{?sse2}
501# shared V8 library and its SSE2 version
502%{_qt5_libdir}/qtwebengine/
503%endif
504%{_qt5_plugindir}/designer/libqwebengineview.so
505%dir %{_qt5_datadir}/resources/
506%{_qt5_datadir}/resources/qtwebengine_resources_100p.pak
507%{_qt5_datadir}/resources/qtwebengine_resources_200p.pak
508%{_qt5_datadir}/resources/qtwebengine_resources.pak
509%dir %{_qtwebengine_dictionaries_dir}
510%dir %{_qt5_translationdir}/qtwebengine_locales
511%lang(am) %{_qt5_translationdir}/qtwebengine_locales/am.pak
512%lang(ar) %{_qt5_translationdir}/qtwebengine_locales/ar.pak
513%lang(bg) %{_qt5_translationdir}/qtwebengine_locales/bg.pak
514%lang(bn) %{_qt5_translationdir}/qtwebengine_locales/bn.pak
515%lang(ca) %{_qt5_translationdir}/qtwebengine_locales/ca.pak
516%lang(cs) %{_qt5_translationdir}/qtwebengine_locales/cs.pak
517%lang(da) %{_qt5_translationdir}/qtwebengine_locales/da.pak
518%lang(de) %{_qt5_translationdir}/qtwebengine_locales/de.pak
519%lang(el) %{_qt5_translationdir}/qtwebengine_locales/el.pak
520%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-GB.pak
521%lang(en) %{_qt5_translationdir}/qtwebengine_locales/en-US.pak
522%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es-419.pak
523%lang(es) %{_qt5_translationdir}/qtwebengine_locales/es.pak
524%lang(et) %{_qt5_translationdir}/qtwebengine_locales/et.pak
525%lang(fa) %{_qt5_translationdir}/qtwebengine_locales/fa.pak
526%lang(fi) %{_qt5_translationdir}/qtwebengine_locales/fi.pak
527%lang(fil) %{_qt5_translationdir}/qtwebengine_locales/fil.pak
528%lang(fr) %{_qt5_translationdir}/qtwebengine_locales/fr.pak
529%lang(gu) %{_qt5_translationdir}/qtwebengine_locales/gu.pak
530%lang(he) %{_qt5_translationdir}/qtwebengine_locales/he.pak
531%lang(hi) %{_qt5_translationdir}/qtwebengine_locales/hi.pak
532%lang(hr) %{_qt5_translationdir}/qtwebengine_locales/hr.pak
533%lang(hu) %{_qt5_translationdir}/qtwebengine_locales/hu.pak
534%lang(id) %{_qt5_translationdir}/qtwebengine_locales/id.pak
535%lang(it) %{_qt5_translationdir}/qtwebengine_locales/it.pak
536%lang(ja) %{_qt5_translationdir}/qtwebengine_locales/ja.pak
537%lang(kn) %{_qt5_translationdir}/qtwebengine_locales/kn.pak
538%lang(ko) %{_qt5_translationdir}/qtwebengine_locales/ko.pak
539%lang(lt) %{_qt5_translationdir}/qtwebengine_locales/lt.pak
540%lang(lv) %{_qt5_translationdir}/qtwebengine_locales/lv.pak
541%lang(ml) %{_qt5_translationdir}/qtwebengine_locales/ml.pak
542%lang(mr) %{_qt5_translationdir}/qtwebengine_locales/mr.pak
543%lang(ms) %{_qt5_translationdir}/qtwebengine_locales/ms.pak
544%lang(nb) %{_qt5_translationdir}/qtwebengine_locales/nb.pak
545%lang(nl) %{_qt5_translationdir}/qtwebengine_locales/nl.pak
546%lang(pl) %{_qt5_translationdir}/qtwebengine_locales/pl.pak
547%lang(pt_BR) %{_qt5_translationdir}/qtwebengine_locales/pt-BR.pak
548%lang(pt_PT) %{_qt5_translationdir}/qtwebengine_locales/pt-PT.pak
549%lang(ro) %{_qt5_translationdir}/qtwebengine_locales/ro.pak
550%lang(ru) %{_qt5_translationdir}/qtwebengine_locales/ru.pak
551%lang(sk) %{_qt5_translationdir}/qtwebengine_locales/sk.pak
552%lang(sl) %{_qt5_translationdir}/qtwebengine_locales/sl.pak
553%lang(sr) %{_qt5_translationdir}/qtwebengine_locales/sr.pak
554%lang(sv) %{_qt5_translationdir}/qtwebengine_locales/sv.pak
555%lang(sw) %{_qt5_translationdir}/qtwebengine_locales/sw.pak
556%lang(ta) %{_qt5_translationdir}/qtwebengine_locales/ta.pak
557%lang(te) %{_qt5_translationdir}/qtwebengine_locales/te.pak
558%lang(th) %{_qt5_translationdir}/qtwebengine_locales/th.pak
559%lang(tr) %{_qt5_translationdir}/qtwebengine_locales/tr.pak
560%lang(uk) %{_qt5_translationdir}/qtwebengine_locales/uk.pak
561%lang(vi) %{_qt5_translationdir}/qtwebengine_locales/vi.pak
562%lang(zh_CN) %{_qt5_translationdir}/qtwebengine_locales/zh-CN.pak
563%lang(zh_TW) %{_qt5_translationdir}/qtwebengine_locales/zh-TW.pak
564
565%files devel
566%{rpm_macros_dir}/macros.qt5-qtwebengine
567%{_qt5_headerdir}/Qt*/
568%{_qt5_libdir}/libQt5*.so
569%{_qt5_libdir}/libQt5*.prl
570#{_qt5_libdir}/Qt5WebEngineCore.la
571%{_qt5_libdir}/cmake/Qt5*/
572%{_qt5_libdir}/pkgconfig/Qt5*.pc
573%{_qt5_archdatadir}/mkspecs/modules/*.pri
574
575%files devtools
576%{_qt5_datadir}/resources/qtwebengine_devtools_resources.pak
577
578%files examples
579%{_qt5_examplesdir}/
580
581%if 0%{?docs}
582%files doc
583%{_qt5_docdir}/*
584%endif
585
586
587%changelog
588* Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
589- new upstream release.
590- dropped Patch1000: fixed in upstream.
591
592* Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
593- new upstream release.
594
595* Fri Nov 16 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-2
596- rebuild with libevent-2.1.8
597
598* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
599- new upstream release.
600
601* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
602- new upstream release.
603- initial build for Vine Linux.
604- updated Source1.
605
606* Tue Jun 14 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-3
607- rebuild (glibc)
608
609* Sun Jun 12 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
610- add versioned qt5-qtbase runtime dep
611
612* Sat Jun 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.1-1
613- Update to 5.6.1
614- Rebase linux-pri patch (drop the parts already fixed upstream)
615- Drop backported chimera-nss-init patch, already applied upstream
616- Rebase no-sse2 patch (the core_module.pro change)
617- Add the new designer/libqwebengineview.so plugin to the file list
618
619* Mon Jun 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-8
620- workaround stackmashing runtime errors in re2-related bundled headers (#1337585)
621
622* Sat May 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-7
623- rebuild (pciutuils)
624
625* Wed May 18 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-6
626- BR: git-core
627
628* Fri Apr 15 2016 David Tardon <dtardon@redhat.com> - 5.6.0-5
629- rebuild for ICU 57.1
630
631* Fri Apr 08 2016 Than Ngo <than@redhat.com> - 5.6.0-4
632- drop ppc ppc64 ppc64le from ExclusiveArch, it's not supported yet
633
634* Thu Mar 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-3
635- Build with CONFIG+="webcore_debug v8base_debug force_debug_info"
636- Force -fno-delete-null-pointer-checks through CXXFLAGS, Qt flags not used here
637- Use -g1 instead of -g on non-x86_64 to avoid memory exhaustion
638- Work around debugedit failure by removing "./" from #line commands and
639  changing "//" to "/" in an #include command
640
641* Fri Mar 18 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-2
642- Avoid checking for the nonexistent icudtl.dat and silence the warnings
643
644* Thu Mar 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-1
645- Update to 5.6.0 (final)
646- Drop system-icu54 patch, fixed upstream
647
648* Thu Feb 25 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.19.rc
649- Update to 5.6.0 RC
650- Rebase linux-pri and no-sse2 patches
651- Remove BuildRequires pkgconfig(flac), pkgconfig(speex), no longer needed
652- Update file list for 5.6.0 RC (resources now in resources/ subdirectory)
653- Tag translations with correct %%lang tags
654
655* Wed Feb 24 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.18.beta
656- no-sse2 patch: Fix FFT (RealFourier) in webrtc on non-SSE2 x86
657
658* Tue Feb 23 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.17.beta
659- Fix FTBFS on aarch64: Respin tarball with fixed clean_ffmpeg.sh (#1310753).
660
661* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.16.beta
662- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
663
664* Tue Jan 19 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.15.beta
665- Build V8 as a shared library on i686 to allow for swappable backends
666- Build both the x87 version and the SSE2 version of V8 on i686
667- Add the private library directory to the file list on i686
668- Add Provides/Requires filtering for libv8.so (i686) and for plugins
669
670* Sun Jan 17 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.14.beta
671- Do not require SSE2 on i686
672
673* Thu Jan 14 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.13.beta
674- Drop nss321 backport (and the related nss-headers patch), it did not help
675- Do an NSS/BoringSSL "chimera build" as will be the default in Chromium 47
676- Update License accordingly (add "OpenSSL")
677- Fix the "chimera build" to call EnsureNSSHttpIOInit (backport from Chromium)
678
679* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.12.beta
680- Update forked NSS SSL code to 3.21, match system NSS (backport from Chromium)
681
682* Wed Jan 13 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.11.beta
683- Add an (optimistic) ExclusiveArch list because of V8 (tracking bug: #1298011)
684
685* Tue Jan 12 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.10.beta
686- Unbundle prtime.cc, use the system NSPR instead (which is already required)
687- Unbundle icu_utf.cc, use the system ICU instead (which is already required)
688
689* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.9.beta
690- linux-pri.patch: Set icu_use_data_file_flag=0 for system ICU
691
692* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.8.beta
693- Build against the system libvpx also on F23 (1.4.0), worked in Copr
694
695* Mon Jan 11 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.7.beta
696- Use the system libvpx on F24+ (1.5.0)
697- Fixes to Provides: bundled(*): libwebp if bundled, x86inc only on x86
698
699* Sun Jan 10 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.6.beta
700- Fix extractCFlag to also look in QMAKE_CFLAGS_RELEASE (needed for ARM)
701- Fix FTBFS on ARM: Disable NEON due to #1282495 (GCC bug)
702
703* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.5.beta
704- Fix FTBFS on ARM: linux-pri patch: Set use_system_yasm only on x86_64 and i386
705- Fix FTBFS on ARM: Respin tarball with: clean_ffmpeg.sh: Add missing ARM files
706
707* Sat Jan 09 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta.1
708- Use more specific BuildRequires for docs (thanks to rdieter)
709- Fix FTBFS against ICU 54 (F22/F23), thanks to spot for the Chromium fix
710
711* Fri Jan 08 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.4.beta
712- Fix License tag
713- Use %%_qt5_examplesdir macro
714- Add Provides: bundled(*) for all the bundled libraries that I found
715
716* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.3.beta
717- linux-pri patch: Add use_system_protobuf, went missing in the 5.6 rebase
718
719* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.2.beta
720- linux-pri patch: Add missing newline at the end of the log line
721- Use export for NINJA_PATH (fixes system ninja-build use)
722
723* Wed Jan 06 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.6.0-0.1.beta
724- Readd BR pkgconfig(jsoncpp) because linux.pri now checks for it
725- BR yasm only on x86 (i686, x86_64)
726- Add dot at the end of %%description
727- Rebase no-format patch
728- Replace unbundle-gyp.patch with new linux-pri.patch
729- Use system ninja-build instead of the bundled one
730- Run the unbundling script replace_gyp_files.py in linux.pri rather than here
731- Update file list for 5.6.0-beta (no more libffmpegsumo since Chromium 45)
732
733* Tue Jan 05 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-4
734- Remove unused BRs flex, libgcrypt-devel, bzip2-devel, pkgconfig(gio-2.0),
735  pkgconfig(hunspell), pkgconfig(libpcre), pkgconfig(libssl),
736  pkgconfig(libcrypto), pkgconfig(jsoncpp), pkgconfig(libmtp),
737  pkgconfig(libexif), pkgconfig(liblzma), pkgconfig(cairo), pkgconfig(libusb),
738  perl(version), perl(Digest::MD5), perl(Text::ParseWords), ruby
739- Add missing explicit BRs on pkgconfig(x11),  pkgconfig(xext),
740  pkgconfig(xfixes), pkgconfig(xdamage), pkgconfig(egl)
741- Fix BR pkgconfig(flac++) to pkgconfig(flac) (libFLAC++ not used, only libFLAC)
742- Fix BR python-devel to python
743- Remove unused -Duse_system_openssl=1 flag (QtWebEngine uses NSS instead)
744- Remove unused -Duse_system_jsoncpp=1 and -Duse_system_libusb=1 flags
745
746* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-3
747- Update file list for 5.5.1 (add qtwebengine_resources_[12]00p.pak)
748
749* Mon Jan 04 2016 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-2
750- Add missing explicit BRs on pkgconfig(expat) and pkgconfig(libxml-2.0)
751- Remove unused BR v8-devel (cannot currently be unbundled)
752
753* Thu Dec 24 2015 Kevin Kofler <Kevin@tigcc.ticalc.org> - 5.5.1-1
754- Update to 5.5.1
755- Remove patent-encumbered codecs in the bundled FFmpeg from the tarball
756
757* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-2
758- Update with unbundle flags. Adapted from original 5.4 Suse package
759- Disable vpx and sqlite as unbundle due some compilation issues
760- Enable verbose build
761
762* Fri Jul 17 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-1
763- Initial spec
764
765* Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
766- Update for official RC1 released packages
Note: See TracBrowser for help on using the repository browser.