source: projects/specs/trunk/q/qt5-qtlocation/qt5-qtlocation-vl.spec @ 11435

Revision 11435, 8.6 KB checked in by tomop, 6 years ago (diff)

updated Qt5

Line 
1
2%global qt_module qtlocation
3
4# define to build docs, need to undef this for bootstrapping
5# where qt5-qttools builds are not yet available
6# only primary archs (for now), allow secondary to bootstrap
7#global bootstrap 1
8
9%if ! 0%{?bootstrap}
10%ifarch %{arm} %{ix86} x86_64
11%define docs 1
12%endif
13%endif
14
15#define prerelease
16
17%global qt5_minorver 5.6
18%global qt5_version 5.6.3
19#global qt5_patchlevel 1
20
21Summary: Qt5 - Location component
22Name:    qt5-%{qt_module}
23Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
24Release: 1%{?_dist_release}
25
26# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
27License: LGPLv2 with exceptions or GPLv3 with exceptions
28Url:     http://www.qt.io
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
34
35## upstreamable patches
36# try to support older glib2 (like el6)
37Patch50: qtlocation-opensource-src-5.6.0-G_VALUE_INIT.patch
38
39BuildRequires: cmake
40BuildRequires: qt5-qtbase-devel >= %{version}
41BuildRequires: qt5-qtdeclarative-devel >= %{version}
42
43# QtPositioning core-private
44BuildRequires:  qt5-qtbase-private-devel
45%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
46
47%description
48The Qt Location and Qt Positioning APIs gives developers the ability to
49determine a position by using a variety of possible sources, including
50satellite, or wifi, or text file, and so on.
51
52%package devel
53Summary: Development files for %{name}
54Requires: %{name}%{?_isa} = %{version}-%{release}
55Requires: qt5-qtbase-devel%{?_isa}
56%description devel
57%{summary}.
58
59%if 0%{?docs}
60%package doc
61Summary: API documentation for %{name}
62Requires: %{name} = %{version}-%{release}
63BuildRequires: qt5-qdoc
64BuildRequires: qt5-qhelpgenerator
65BuildArch: noarch
66%description doc
67%{summary}.
68%endif
69
70%package examples
71Summary: Programming examples for %{name}
72Requires: %{name}%{?_isa} = %{version}-%{release}
73%description examples
74%{summary}.
75
76
77%prep
78%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
79## G_VALUE_INIT is new in glib-2.30+ only
80%patch50 -p1 -b .G_VALUE_INIT
81
82
83%build
84mkdir %{_target_platform}
85pushd %{_target_platform}
86%{qmake_qt5} ..
87
88make %{?_smp_mflags}
89
90%if 0%{?docs}
91make %{?_smp_mflags} docs
92%endif
93popd
94
95
96%install
97make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
98
99%if 0%{?docs}
100make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
101%endif
102
103## .prl/.la file love
104# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
105pushd %{buildroot}%{_qt5_libdir}
106for prl_file in libQt5*.prl ; do
107  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
108  if [ -f "$(basename ${prl_file} .prl).so" ]; then
109    rm -fv "$(basename ${prl_file} .prl).la"
110    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
111  fi
112done
113popd
114
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%license LGPL_EXCEPTION.txt LICENSE.GPL* LICENSE.LGPL*
121%{_qt5_libdir}/libQt5Location.so.5*
122%{_qt5_archdatadir}/qml/QtLocation/
123%{_qt5_plugindir}/geoservices/
124%{_qt5_libdir}/libQt5Positioning.so.5*
125%{_qt5_archdatadir}/qml/QtPositioning/
126%{_qt5_plugindir}/position/
127%dir %{_qt5_libdir}/cmake/
128%dir %{_qt5_libdir}/cmake/Qt5Location
129%dir %{_qt5_libdir}/cmake/Qt5Positioning
130%{_qt5_libdir}/cmake/Qt5Location/Qt5Location_QGeoServiceProviderFactory*.cmake
131%{_qt5_libdir}/cmake/Qt5Positioning/Qt5Positioning_QGeoPositionInfoSourceFactory*.cmake
132
133%files devel
134%{_qt5_headerdir}/QtLocation/
135%{_qt5_libdir}/libQt5Location.so
136%{_qt5_libdir}/libQt5Location.prl
137%{_qt5_libdir}/pkgconfig/Qt5Location.pc
138%{_qt5_archdatadir}/mkspecs/modules/qt_lib_location*.pri
139%{_qt5_libdir}/cmake/Qt5Location/Qt5LocationConfig*.cmake
140%{_qt5_headerdir}/QtPositioning/
141%{_qt5_libdir}/libQt5Positioning.so
142%{_qt5_libdir}/libQt5Positioning.prl
143%{_qt5_libdir}/cmake/Qt5Positioning/Qt5PositioningConfig*.cmake
144%{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
145%{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
146
147%if 0%{?docs}
148%files doc
149%license LICENSE.FDL
150%{_qt5_docdir}/qtlocation.qch
151%{_qt5_docdir}/qtlocation/
152%{_qt5_docdir}/qtpositioning.qch
153%{_qt5_docdir}/qtpositioning/
154%endif
155
156%if 0%{?_qt5_examplesdir:1}
157%files examples
158%{_qt5_examplesdir}/
159%endif
160
161
162%changelog
163* Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
164- new upstream release.
165
166* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
167- initial build for Vine Linux.
168- new upstream release.
169
170* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
171- drop pkgconfig-style Qt5 deps
172
173* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
174- Update to 5.6.1
175
176* Thu Apr 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
177- BR: qt5-qtbase-private-devel
178
179* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
180- rebuild
181
182* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
183- rebuild
184
185* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
186- 5.6.0 final release
187
188* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
189- Update to final RC
190
191* Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.9.rc
192- rebuild
193
194* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
195- Update RC release
196
197* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
199
200* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
201- update source URL, use %%license, BR: cmake
202
203* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
204- Update to final beta release
205
206* Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
207- (re) add bootstrap macro support
208- drop geoclue(1) dep (unused at build time anyway (#1286886)
209- drop (deprecated) gypsy support (#1069225)
210
211* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
212- Official beta release
213
214* Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
215- (re)add bootstrap macro support
216
217* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
218- Start to implement 5.6.0 beta
219
220* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
221- Update to final release 5.5.1
222
223* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
224- Update to Qt 5.5.1 RC1
225
226* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
227- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
228
229* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
230- tighten qtbase dep (#1233829), .spec cosmetics, (re)enable docs
231
232* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
233- New final upstream release Qt 5.5.0
234
235* Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
236- Update for official RC1 released packages
237
238* Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
239- Qt 5.5.0 RC1
240
241* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
242- 5.4.2
243
244* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
245- Rebuilt for GCC 5 C++11 ABI change
246
247* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
248- rebuild (gcc5)
249
250* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
251- 5.4.1
252
253* Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
254- rebuild (gcc5)
255
256* Wed Dec 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-2
257- BR: pkgconfig(Qt5Qml) > 5.4.0 (#1177986)
258
259* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
260- 5.4.0 (final)
261
262* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
263- 5.4.0-rc
264
265* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
266- out-of-tree build, use %%qmake_qt5
267
268* Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
269- 5.4.0-beta
270
271* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
272- 5.3.2
273
274* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
275- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
276
277* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
278- 5.3.1
279
280* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
281- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
282
283* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
284- 5.3.0
285
286* Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
287- sanitize .prl file(s)
288
289* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
290- 5.2.1
291
292* Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
293- build -examples only when supported
294
295* Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
296- -examples subpkg
297
298* Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
299- first try
Note: See TracBrowser for help on using the repository browser.