source: projects/specs/trunk/q/qt5-qtlocation/qt5-qtlocation-vl.spec @ 10586

Revision 10586, 8.5 KB checked in by tomop, 8 years ago (diff)

new: qt5-5.6.1.1-1

Line 
1
2%global qt_module qtlocation
3
4# define to build docs, need to undef this for bootstrapping
5# where qt5-qttools builds are not yet available
6# only primary archs (for now), allow secondary to bootstrap
7#global bootstrap 1
8
9%if ! 0%{?bootstrap}
10%ifarch %{arm} %{ix86} x86_64
11%define docs 1
12%endif
13%endif
14
15#define prerelease
16
17%global qt5_minorver 5.6
18%global qt5_version 5.6.1
19%global qt5_patchlevel 1
20
21Summary: Qt5 - Location component
22Name:    qt5-%{qt_module}
23Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
24Release: 1%{?_dist_release}
25
26# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
27License: LGPLv2 with exceptions or GPLv3 with exceptions
28Url:     http://www.qt.io
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33Source0: http://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-opensource-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
34
35## upstreamable patches
36# try to support older glib2 (like el6)
37Patch50: qtlocation-opensource-src-5.6.0-G_VALUE_INIT.patch
38
39BuildRequires: cmake
40BuildRequires: qt5-qtbase-devel >= %{version}
41BuildRequires: qt5-qtdeclarative-devel >= %{version}
42
43# QtPositioning core-private
44BuildRequires:  qt5-qtbase-private-devel
45%{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
46
47%description
48The Qt Location and Qt Positioning APIs gives developers the ability to
49determine a position by using a variety of possible sources, including
50satellite, or wifi, or text file, and so on.
51
52%package devel
53Summary: Development files for %{name}
54Requires: %{name}%{?_isa} = %{version}-%{release}
55Requires: qt5-qtbase-devel%{?_isa}
56%description devel
57%{summary}.
58
59%if 0%{?docs}
60%package doc
61Summary: API documentation for %{name}
62Requires: %{name} = %{version}-%{release}
63BuildRequires: qt5-qdoc
64BuildRequires: qt5-qhelpgenerator
65BuildArch: noarch
66%description doc
67%{summary}.
68%endif
69
70%package examples
71Summary: Programming examples for %{name}
72Requires: %{name}%{?_isa} = %{version}-%{release}
73%description examples
74%{summary}.
75
76
77%prep
78%setup -q -n %{qt_module}-opensource-src-%{qt5_version}
79## G_VALUE_INIT is new in glib-2.30+ only
80%patch50 -p1 -b .G_VALUE_INIT
81
82
83%build
84mkdir %{_target_platform}
85pushd %{_target_platform}
86%{qmake_qt5} ..
87
88make %{?_smp_mflags}
89
90%if 0%{?docs}
91make %{?_smp_mflags} docs
92%endif
93popd
94
95
96%install
97make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
98
99%if 0%{?docs}
100make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
101%endif
102
103## .prl/.la file love
104# nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
105pushd %{buildroot}%{_qt5_libdir}
106for prl_file in libQt5*.prl ; do
107  sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
108  if [ -f "$(basename ${prl_file} .prl).so" ]; then
109    rm -fv "$(basename ${prl_file} .prl).la"
110    sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
111  fi
112done
113popd
114
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%license LGPL_EXCEPTION.txt LICENSE.GPL* LICENSE.LGPL*
121%{_qt5_libdir}/libQt5Location.so.5*
122%{_qt5_archdatadir}/qml/QtLocation/
123%{_qt5_plugindir}/geoservices/
124%{_qt5_libdir}/libQt5Positioning.so.5*
125%{_qt5_archdatadir}/qml/QtPositioning/
126%{_qt5_plugindir}/position/
127%dir %{_qt5_libdir}/cmake/
128%dir %{_qt5_libdir}/cmake/Qt5Location
129%dir %{_qt5_libdir}/cmake/Qt5Positioning
130%{_qt5_libdir}/cmake/Qt5Location/Qt5Location_QGeoServiceProviderFactory*.cmake
131%{_qt5_libdir}/cmake/Qt5Positioning/Qt5Positioning_QGeoPositionInfoSourceFactory*.cmake
132
133%files devel
134%{_qt5_headerdir}/QtLocation/
135%{_qt5_libdir}/libQt5Location.so
136%{_qt5_libdir}/libQt5Location.prl
137%{_qt5_libdir}/pkgconfig/Qt5Location.pc
138%{_qt5_archdatadir}/mkspecs/modules/qt_lib_location*.pri
139%{_qt5_libdir}/cmake/Qt5Location/Qt5LocationConfig*.cmake
140%{_qt5_headerdir}/QtPositioning/
141%{_qt5_libdir}/libQt5Positioning.so
142%{_qt5_libdir}/libQt5Positioning.prl
143%{_qt5_libdir}/cmake/Qt5Positioning/Qt5PositioningConfig*.cmake
144%{_qt5_libdir}/pkgconfig/Qt5Positioning.pc
145%{_qt5_archdatadir}/mkspecs/modules/qt_lib_positioning*.pri
146
147%if 0%{?docs}
148%files doc
149%license LICENSE.FDL
150%{_qt5_docdir}/qtlocation.qch
151%{_qt5_docdir}/qtlocation/
152%{_qt5_docdir}/qtpositioning.qch
153%{_qt5_docdir}/qtpositioning/
154%endif
155
156%if 0%{?_qt5_examplesdir:1}
157%files examples
158%{_qt5_examplesdir}/
159%endif
160
161
162%changelog
163* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
164- initial build for Vine Linux.
165- new upstream release.
166
167* Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
168- drop pkgconfig-style Qt5 deps
169
170* Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
171- Update to 5.6.1
172
173* Thu Apr 21 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
174- BR: qt5-qtbase-private-devel
175
176* Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
177- rebuild
178
179* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
180- rebuild
181
182* Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
183- 5.6.0 final release
184
185* Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10.rc
186- Update to final RC
187
188* Sun Feb 21 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.9.rc
189- rebuild
190
191* Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8
192- Update RC release
193
194* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.7.beta
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
196
197* Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.6.beta
198- update source URL, use %%license, BR: cmake
199
200* Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.5
201- Update to final beta release
202
203* Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.4
204- (re) add bootstrap macro support
205- drop geoclue(1) dep (unused at build time anyway (#1286886)
206- drop (deprecated) gypsy support (#1069225)
207
208* Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
209- Official beta release
210
211* Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
212- (re)add bootstrap macro support
213
214* Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
215- Start to implement 5.6.0 beta
216
217* Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
218- Update to final release 5.5.1
219
220* Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
221- Update to Qt 5.5.1 RC1
222
223* Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
224- -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
225
226* Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
227- tighten qtbase dep (#1233829), .spec cosmetics, (re)enable docs
228
229* Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
230- New final upstream release Qt 5.5.0
231
232* Wed Jun 24 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
233- Update for official RC1 released packages
234
235* Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
236- Qt 5.5.0 RC1
237
238* Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
239- 5.4.2
240
241* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 5.4.1-3
242- Rebuilt for GCC 5 C++11 ABI change
243
244* Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
245- rebuild (gcc5)
246
247* Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
248- 5.4.1
249
250* Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-3
251- rebuild (gcc5)
252
253* Wed Dec 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-2
254- BR: pkgconfig(Qt5Qml) > 5.4.0 (#1177986)
255
256* Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
257- 5.4.0 (final)
258
259* Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.3.rc
260- 5.4.0-rc
261
262* Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.2.beta
263- out-of-tree build, use %%qmake_qt5
264
265* Sun Oct 19 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.beta
266- 5.4.0-beta
267
268* Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
269- 5.3.2
270
271* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
273
274* Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
275- 5.3.1
276
277* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-2
278- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
279
280* Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
281- 5.3.0
282
283* Mon May 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-2
284- sanitize .prl file(s)
285
286* Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
287- 5.2.1
288
289* Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
290- build -examples only when supported
291
292* Sun Jan 26 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
293- -examples subpkg
294
295* Thu Jan 02 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
296- first try
Note: See TracBrowser for help on using the repository browser.