source: projects/specs/trunk/q/qt-assistant-adp/qt-assistant-adp-vl.spec @ 5383

Revision 5383, 5.1 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1Name:    qt-assistant-adp
2Summary: Compatibility version of Qt Assistant
3Version: 4.6.3
4Release: 5%{?_dist_release}
5
6Group: System Environment/Libraries
7# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
8License: LGPLv2 with exceptions or GPLv3 with exceptions
9URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
10
11Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
12# missing header files from Debian (Fathi Boudra)
13Source1: QAssistantClient
14Source2: QtAssistant
15# build fixes from Debian (Fathi Boudra)
16Patch1: 01_build_system.diff
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
21
22%description
23The old version of Qt Assistant, based on Assistant Document Profile (.adp)
24files, and the associated QtAssistantClient library, for compatibility with
25applications providing help in that format.
26
27New applications should use the new version of Qt Assistant introduced in Qt
284.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
29
30%package devel
31Summary: Development files for the compatibility QAssistantClient
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: qt4-devel
35
36%description devel
37This package contains the files necessary to build applications using the
38deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
39which is used together with the legacy Assistant Document Profile (.adp) version
40of Qt Assistant.
41
42This class is obsolete. It is provided to keep old source code working. We
43strongly advise against using it in new code. New code should use the Qt Help
44Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
45(also introduced in Qt 4.4) instead.
46
47
48%prep
49%setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
50%patch1 -p1 -b .build_system
51mkdir include
52cp -p %{SOURCE1} %{SOURCE2} include/
53
54
55%build
56# build assistant_adp
57qmake QT_PRODUCT=OpenSource
58make %{?_smp_mflags}
59
60# build libQtAssistantClient
61cd lib
62qmake CONFIG=create_prl
63make %{?_smp_mflags}
64
65# build assistant_adp translations
66cd ../translations
67lrelease assistant_adp_*.ts
68cd ..
69
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74# install assistant_adp
75make install INSTALL_ROOT=$RPM_BUILD_ROOT
76
77# install libQtAssistantClient
78make install INSTALL_ROOT=$RPM_BUILD_ROOT -C lib
79
80# install assistant_adp translations
81mkdir -p $RPM_BUILD_ROOT%{_qt4_translationdir}
82install -p -m644 translations/assistant_adp_*.qm \
83                 $RPM_BUILD_ROOT%{_qt4_translationdir}/
84
85# install assistant.prf mkspec
86install -D -p -m644 features/assistant.prf \
87                    $RPM_BUILD_ROOT%{_qt4_datadir}/mkspecs/features/assistant.prf
88
89# install missing headers (thanks to Fathi Boudra from Debian)
90install -p -m644 include/Q* $RPM_BUILD_ROOT%{_qt4_headerdir}/QtAssistant/
91
92# nuke dangling reference(s) to the buildroot
93sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" $RPM_BUILD_ROOT%{_qt4_libdir}/*.prl
94
95# let rpm handle binaries conflicts
96mkdir $RPM_BUILD_ROOT%{_bindir}
97pushd $RPM_BUILD_ROOT%{_qt4_bindir}
98mv assistant_adp ../../../bin/
99ln -s ../../../bin/assistant_adp .
100popd
101
102# _debug target (see bug #196513)
103pushd $RPM_BUILD_ROOT%{_qt4_libdir}
104echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
105popd
106
107# Note that we intentionally DO NOT install a .desktop file for assistant_adp
108# because it makes no sense to invoke it without a specific .adp file to open.
109# By default, it views the Qt documentation, for which we already have a menu
110# entry using the current version of the Qt Assistant, and there is no UI for
111# viewing anything different. The .adp file needs to be passed on the command
112# line, which is usually done by the application.
113
114%find_lang assistant_adp --with-qt --without-mo
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%files -f assistant_adp.lang
125%defattr(-,root,root,-)
126%doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
127%{_bindir}/assistant_adp
128%{_qt4_bindir}/assistant_adp
129%{_qt4_libdir}/libQtAssistantClient.so.4*
130
131%files devel
132%defattr(-,root,root,-)
133%{_qt4_headerdir}/QtAssistant/
134%{_qt4_libdir}/libQtAssistantClient.so
135%{_qt4_libdir}/libQtAssistantClient_debug.so
136%{_qt4_libdir}/libQtAssistantClient.prl
137%{_libdir}/pkgconfig/QtAssistantClient.pc
138%{_qt4_datadir}/mkspecs/features/assistant.prf
139
140
141%changelog
142* Sat Jan 07 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-5
143- rebuilt with qt-4.8.0
144
145* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
146- fixed BR
147
148* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
149- Initial build for Vine Linux
150
151* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
153
154* Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
155- new upstream tarball with only the compat assistant_adp and QAssistantClient
156- build fixes from Debian (Fathi Boudra)
157- use find_lang to package the qm files (#609749)
158
159* Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
160- use versioned BR/Requires to avoid Conflicts
161
162* Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
163- first Fedora package
Note: See TracBrowser for help on using the repository browser.