source: projects/specs/trunk/q/qt-assistant-adp/qt-assistant-adp-vl.spec @ 3377

Revision 3377, 5.2 KB checked in by inagaki, 13 years ago (diff)

update: qt-assistant-adp

Line 
1Name:    qt-assistant-adp
2Summary: Compatibility version of Qt Assistant
3Version: 4.6.3
4Release: 4%{?_dist_release}
5
6Group: System Environment/Libraries
7# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
8License: LGPLv2 with exceptions or GPLv3 with exceptions
9URL: http://qt.nokia.com/doc/4.6/qassistantclient.html
10
11Source: ftp://ftp.qt.nokia.com/qt/source/qt-assistant-qassistantclient-library-compat-src-%{version}.tar.gz
12# missing header files from Debian (Fathi Boudra)
13Source1: QAssistantClient
14Source2: QtAssistant
15# build fixes from Debian (Fathi Boudra)
16Patch1: 01_build_system.diff
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires: qt4-devel >= 4.7.2-2%{?_dist_release}
21Requires: qt4 = %{_qt4_version}
22
23%description
24The old version of Qt Assistant, based on Assistant Document Profile (.adp)
25files, and the associated QtAssistantClient library, for compatibility with
26applications providing help in that format.
27
28New applications should use the new version of Qt Assistant introduced in Qt
294.4, based on the Qt Help Framework also introduced in Qt 4.4, instead.
30
31
32%package devel
33Summary: Development files for the compatibility QAssistantClient
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: qt4-devel = %{_qt4_version}
37
38%description devel
39This package contains the files necessary to build applications using the
40deprecated QAssistantClient class (in the deprecated QtAssistantClient library),
41which is used together with the legacy Assistant Document Profile (.adp) version
42of Qt Assistant.
43
44This class is obsolete. It is provided to keep old source code working. We
45strongly advise against using it in new code. New code should use the Qt Help
46Framework introduced in Qt 4.4 and/or the version of Qt Assistant based on it
47(also introduced in Qt 4.4) instead.
48
49
50%prep
51%setup -q -n qt-assistant-qassistantclient-library-compat-version-%{version}
52%patch1 -p1 -b .build_system
53mkdir include
54cp -p %{SOURCE1} %{SOURCE2} include/
55
56
57%build
58# build assistant_adp
59qmake QT_PRODUCT=OpenSource
60make %{?_smp_mflags}
61
62# build libQtAssistantClient
63cd lib
64qmake CONFIG=create_prl
65make %{?_smp_mflags}
66
67# build assistant_adp translations
68cd ../translations
69lrelease assistant_adp_*.ts
70cd ..
71
72
73%install
74rm -rf %{buildroot}
75
76# install assistant_adp
77make install INSTALL_ROOT=%{buildroot}
78
79# install libQtAssistantClient
80make install INSTALL_ROOT=%{buildroot} -C lib
81
82# install assistant_adp translations
83mkdir -p %{buildroot}%{_qt4_translationdir}
84install -p -m644 translations/assistant_adp_*.qm \
85                 %{buildroot}%{_qt4_translationdir}/
86
87# install assistant.prf mkspec
88install -D -p -m644 features/assistant.prf \
89                    %{buildroot}%{_qt4_datadir}/mkspecs/features/assistant.prf
90
91# install missing headers (thanks to Fathi Boudra from Debian)
92install -p -m644 include/Q* %{buildroot}%{_qt4_headerdir}/QtAssistant/
93
94# nuke dangling reference(s) to the buildroot
95sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" %{buildroot}%{_qt4_libdir}/*.prl
96
97# let rpm handle binaries conflicts
98mkdir %{buildroot}%{_bindir}
99pushd %{buildroot}%{_qt4_bindir}
100mv assistant_adp ../../../bin/
101ln -s ../../../bin/assistant_adp .
102popd
103
104# _debug target (see bug #196513)
105pushd %{buildroot}%{_qt4_libdir}
106echo "INPUT(-lQtAssistantClient)" >libQtAssistantClient_debug.so
107popd
108
109# Note that we intentionally DO NOT install a .desktop file for assistant_adp
110# because it makes no sense to invoke it without a specific .adp file to open.
111# By default, it views the Qt documentation, for which we already have a menu
112# entry using the current version of the Qt Assistant, and there is no UI for
113# viewing anything different. The .adp file needs to be passed on the command
114# line, which is usually done by the application.
115
116%find_lang assistant_adp --with-qt --without-mo
117
118mkdir -p $RPM_BUILD_ROOT%{_libdir}
119mv $RPM_BUILD_ROOT%{_qt4_libdir}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
120
121%clean
122rm -rf %{buildroot}
123
124
125%post -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129%files -f assistant_adp.lang
130%defattr(-,root,root,-)
131%doc LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
132%{_bindir}/assistant_adp
133%{_qt4_bindir}/assistant_adp
134%{_qt4_libdir}/libQtAssistantClient.so.4*
135
136%files devel
137%defattr(-,root,root,-)
138%{_qt4_headerdir}/QtAssistant/
139%{_qt4_libdir}/libQtAssistantClient.so
140%{_qt4_libdir}/libQtAssistantClient_debug.so
141%{_qt4_libdir}/libQtAssistantClient.prl
142%{_libdir}/pkgconfig/QtAssistantClient.pc
143%{_qt4_datadir}/mkspecs/features/assistant.prf
144
145
146%changelog
147* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-4
148- fixed BR
149
150* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.6.3-3
151- Initial build for Vine Linux
152
153* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.6.3-2
154- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
155
156* Mon Jul 05 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.3-1
157- new upstream tarball with only the compat assistant_adp and QAssistantClient
158- build fixes from Debian (Fathi Boudra)
159- use find_lang to package the qm files (#609749)
160
161* Tue Mar 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6.2-2
162- use versioned BR/Requires to avoid Conflicts
163
164* Sat Mar 13 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.6.2-1
165- first Fedora package
Note: See TracBrowser for help on using the repository browser.