source: projects/specs/trunk/q/qscintilla/qscintilla-vl.spec @ 5383

Revision 5383, 5.4 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%global pyqt4_version 4.9
3
4%define ver 2.29
5
6%define _qt4_version 4.8.0
7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
8%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_libdir})
9%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_includedir})
10%define _qt4_translationdir %(pkg-config --variable translationdir --silence-errors Qt 2>/dev/null || echo %{_datadir}/qt4/translations)
11
12Summary:        A Scintilla port to Qt
13Name:           qscintilla
14Version:        2.6
15Release:        1%{?_dist_release}
16
17# matches up (pretty much) with qt4
18License:        GPLv3 or GPLv2 with exceptions
19Group:          Development/Tools
20URL:            http://www.riverbankcomputing.co.uk/qscintilla
21
22Source:         QScintilla-gpl-%{version}.tar.gz
23# TODO: upstream this
24Patch1:         QScintilla-2-gpl-Qt4-incpath.patch
25
26BuildRoot:      %{_tmppath}/%{name}-%{version}-root
27BuildRequires:  qt4-devel
28BuildRequires:  PyQt4-devel >= %{pyqt4_version}
29Requires:       qt4 >= %{_qt4_version}
30
31%description
32QScintilla is a port of Scintilla to the Qt GUI toolkit.
33
34This version of QScintilla is based on Scintilla v%{ver}.
35
36%package designer
37Summary:  QScintilla designer plugin
38Group:    Development/Tools
39Requires: %{name} = %{version}-%{release}
40Requires: qt4-designer
41
42%description designer
43%{summary}.
44
45%package devel
46Summary: QScintilla Development Files
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: qt4-devel >= %{_qt4_version}
50
51%description  devel
52This packages contains the libraries, include and other files
53you can use to develop applications with QScintilla.
54
55%package python
56Summary:  QScintilla PyQt4 bindings
57Group:    Development/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires: PyQt4 >= %{pyqt4_version}
60
61%description python
62%{summary}.
63
64%package python-devel
65Summary:  Development files for QScintilla PyQt4 bindings
66Group:    Development/Libraries
67Requires: %{name}-python = %{version}-%{release}
68Requires: PyQt4-devel >= %{pyqt4_version}
69
70%description python-devel
71%{summary}.
72
73%prep
74%setup -q -n QScintilla-gpl-%{version}
75%patch1 -p1 -b .designer-incpath-qt4
76
77# fix permissions on doc files
78find doc example-Qt4  -type f -exec chmod 0644 {} ';'
79find src include -type f -exec chmod 0644 {} ';'
80
81# fix line endings in license file(s)
82sed -i 's/\r//' LICENSE.GPL2 GPL_EXCEPTION_ADDENDUM.TXT
83
84%build
85export QTDIR=%{_qt4_prefix}
86%ifarch x86_64
87export QMAKESPEC=$QTDIR/mkspecs/linux-g++-64/
88%else
89export QMAKESPEC=$QTDIR/mkspecs/linux-g++/
90%endif
91
92pushd Qt4
93$QTDIR/bin/qmake -o Makefile qscintilla.pro
94make %{?_smp_mflags}
95popd
96
97pushd designer-Qt4
98$QTDIR/bin/qmake -o Makefile designer.pro
99make %{?_smp_mflags}
100popd
101
102pushd Python
103%{__python} configure.py \
104            -c -j 3 \
105            -n ../Qt4 \
106            -o ../Qt4
107make %{?_smp_mflags}
108popd
109
110%install
111rm -rf $RPM_BUILD_ROOT
112
113make install INSTALL_ROOT=$RPM_BUILD_ROOT -C Qt4
114make install INSTALL_ROOT=$RPM_BUILD_ROOT -C designer-Qt4
115make install DESTDIR=$RPM_BUILD_ROOT -C Python
116
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%post  -p /sbin/ldconfig
122
123%postun -p /sbin/ldconfig
124
125%files
126%defattr(-, root, root, 755)
127%doc NEWS README
128%doc LICENSE.GPL3 LICENSE.GPL2 GPL_EXCEPTION.TXT GPL_EXCEPTION_ADDENDUM.TXT
129%{_qt4_libdir}/libqscintilla2.so.*
130%{_qt4_prefix}/qsci/*
131%{_qt4_translationdir}/*
132
133%files designer
134%defattr(-,root,root,-)
135%{_qt4_prefix}/plugins/designer/libqscintillaplugin.so
136
137%files devel
138%defattr(-, root, root, -)
139%{_qt4_headerdir}/*
140%{_qt4_libdir}/libqscintilla2.so
141
142%files python
143%defattr(-,root,root,-)
144%{python_sitearch}/PyQt4/Qsci.so
145
146%files python-devel
147%defattr(-,root,root,-)
148%{_datadir}/sip/PyQt4/Qsci
149
150%changelog
151* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-1
152- new upstream release
153- built with qt-4.8.0, PyQt4-4.9
154
155* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-2
156- rebuilt with qt-4.7.2
157
158* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-1
159- new upstream release
160- fix qt4_ver from 4.6.3 to 4.7.1
161
162* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.4-2
163- rebuild with qt4-4.6.3
164- fix qt4_ver from 4.6.1 to 4.6.3
165- fix BuildRequires: qt4-devel = %{qt4_ver} (add version)
166
167* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
168- new upstream release
169- updated qt4 macros
170
171* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-1
172- new upstream release
173
174* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
175- rebuilt with qt4-4.6.1, python-2.6
176- installed translation to %%{_datadir}/qt4/translations now
177
178* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
179- updated macro pyqt4_version to 4.6
180- fixed changelog year below (2008 -> 2009)
181
182* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
183- new upstream release
184- added designer, python and python-devel sub-packages
185
186* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
187- appiled new versioning policy
188
189* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.7.1-0vl2
190- updated macro QMAKESPEC to linux-g++-64 (if x86_64)
191
192* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-0vl1
193- new upstream release (1.71)
194
195* Mon Jun  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6-0vl1
196- new upstream release (1.65)
197- changed Group to System Environment/Libraries
198
199* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 1.4-0vl1
200- initial built for VineLinux
201
Note: See TracBrowser for help on using the repository browser.