source: projects/specs/trunk/q/qscintilla/qscintilla-vl.spec @ 3001

Revision 3001, 5.5 KB checked in by inagaki, 13 years ago (diff)

update: kdebase3, kuftp, qtscriptgenerator, gscintilla

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%global pyqt4_version 4.8
3
4%define ver 1.78
5
6%define _qt4_version 4.7.2
7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{_qt4_version})
8%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
9%define _qt4_includedir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
10%define _qt4_translationdir %(pkg-config --variable translationdir --silence-errors Qt 2>/dev/null || echo %{_datadir}/qt4/translations)
11
12%global qtdir %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
13%global qtinc   %{qtdir}/include
14%global qtlib   %{qtdir}/lib
15
16Summary:        A Scintilla port to Qt
17Name:           qscintilla
18Version:        2.4.6
19Release:        2%{?_dist_release}
20
21# matches up (pretty much) with qt4
22License:        GPLv3 or GPLv2 with exceptions
23Group:          Development/Tools
24URL:            http://www.riverbankcomputing.co.uk/qscintilla
25
26Source:         QScintilla-gpl-%{version}.tar.gz
27# TODO: upstream this
28Patch1:         QScintilla-2-gpl-Qt4-incpath.patch
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31BuildRequires:  qt4-devel
32BuildRequires:  PyQt4-devel >= %{pyqt4_version}
33Requires:       qt4 = %{_qt4_version}
34
35%description
36QScintilla is a port of Scintilla to the Qt GUI toolkit.
37
38This version of QScintilla is based on Scintilla v%{ver}.
39
40%package designer
41Summary:  QScintilla designer plugin
42Group:    Development/Tools
43Requires: %{name} = %{version}-%{release}
44Requires: qt4-designer
45
46%description designer
47%{summary}.
48
49%package devel
50Summary: QScintilla Development Files
51Group: Development/Libraries
52Requires: %{name} = %{version}
53Requires: qt4-devel = %{_qt4_version}
54
55%description  devel
56This packages contains the libraries, include and other files
57you can use to develop applications with QScintilla.
58
59%package python
60Summary:  QScintilla PyQt4 bindings
61Group:    Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: PyQt4 >= %{pyqt4_version}
64
65%description python
66%{summary}.
67
68%package python-devel
69Summary:  Development files for QScintilla PyQt4 bindings
70Group:    Development/Libraries
71Requires: %{name}-python = %{version}-%{release}
72Requires: PyQt4-devel
73
74%description python-devel
75%{summary}.
76
77%prep
78%setup -q -n QScintilla-gpl-%{version}
79%patch1 -p1 -b .designer-incpath-qt4
80
81# fix permissions on doc files
82find doc example-Qt4  -type f -exec chmod 0644 {} ';'
83find src include -type f -exec chmod 0644 {} ';'
84
85# fix line endings in license file(s)
86sed -i 's/\r//' LICENSE.GPL2 GPL_EXCEPTION_ADDENDUM.TXT
87
88%build
89export QTDIR=%{_qt4_prefix}
90%ifarch x86_64
91export QMAKESPEC=$QTDIR/mkspecs/linux-g++-64/
92%else
93export QMAKESPEC=$QTDIR/mkspecs/linux-g++/
94%endif
95
96pushd Qt4
97$QTDIR/bin/qmake -o Makefile qscintilla.pro
98make %{?_smp_mflags}
99popd
100
101pushd designer-Qt4
102$QTDIR/bin/qmake -o Makefile designer.pro
103make %{?_smp_mflags}
104popd
105
106pushd Python
107%{__python} configure.py \
108            -c -j 3 \
109            -n ../Qt4 \
110            -o ../Qt4
111make %{?_smp_mflags}
112popd
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117make install INSTALL_ROOT=$RPM_BUILD_ROOT -C Qt4
118make install INSTALL_ROOT=$RPM_BUILD_ROOT -C designer-Qt4
119make install DESTDIR=$RPM_BUILD_ROOT -C Python
120
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post  -p /sbin/ldconfig
126
127%postun -p /sbin/ldconfig
128
129%files
130%defattr(-, root, root, 755)
131%doc NEWS README
132%doc LICENSE.GPL3 LICENSE.GPL2 GPL_EXCEPTION.TXT GPL_EXCEPTION_ADDENDUM.TXT
133%{_qt4_libdir}/libqscintilla2.so.*
134%{_qt4_prefix}/qsci/*
135%{_qt4_translationdir}/*
136
137%files designer
138%defattr(-,root,root,-)
139%{_qt4_prefix}/plugins/designer/libqscintillaplugin.so
140
141%files devel
142%defattr(-, root, root, -)
143%{_qt4_includedir}/*
144%{_qt4_libdir}/libqscintilla2.so
145
146%files python
147%defattr(-,root,root,-)
148%{python_sitearch}/PyQt4/Qsci.so
149
150%files python-devel
151%defattr(-,root,root,-)
152%{_datadir}/sip/PyQt4/Qsci
153
154%changelog
155* Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-2
156- rebuilt with qt-4.7.2
157
158* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-1
159- new upstream release
160- fix qt4_ver from 4.6.3 to 4.7.1
161
162* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.4-2
163- rebuild with qt4-4.6.3
164- fix qt4_ver from 4.6.1 to 4.6.3
165- fix BuildRequires: qt4-devel = %{qt4_ver} (add version)
166
167* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
168- new upstream release
169- updated qt4 macros
170
171* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-1
172- new upstream release
173
174* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
175- rebuilt with qt4-4.6.1, python-2.6
176- installed translation to %%{_datadir}/qt4/translations now
177
178* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
179- updated macro pyqt4_version to 4.6
180- fixed changelog year below (2008 -> 2009)
181
182* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
183- new upstream release
184- added designer, python and python-devel sub-packages
185
186* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
187- appiled new versioning policy
188
189* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.7.1-0vl2
190- updated macro QMAKESPEC to linux-g++-64 (if x86_64)
191
192* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-0vl1
193- new upstream release (1.71)
194
195* Mon Jun  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6-0vl1
196- new upstream release (1.65)
197- changed Group to System Environment/Libraries
198
199* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 1.4-0vl1
200- initial built for VineLinux
201
Note: See TracBrowser for help on using the repository browser.