source: projects/specs/trunk/q/qscintilla/qscintilla-vl.spec @ 2725

Revision 2725, 5.3 KB checked in by inagaki, 13 years ago (diff)

update: qscintilla, libktorrent

Line 
1%{!?python_sitearch:%global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2%global pyqt4_version 4.8
3
4%define ver 1.78
5
6%define qt4_ver 4.7.1
7%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
8%define _qt4_libdir %(pkg-config --variable libdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/lib)
9%define _qt4_includedir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
10%define _qt4_translationdir %(pkg-config --variable translationdir --silence-errors Qt 2>/dev/null || echo %{_datadir}/qt4/translations)
11
12%global qtdir %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
13%global qtinc   %{qtdir}/include
14%global qtlib   %{qtdir}/lib
15
16Summary:        A Scintilla port to Qt
17Name:           qscintilla
18Version:        2.4.6
19Release:        1%{?_dist_release}
20
21# matches up (pretty much) with qt4
22License:        GPLv3 or GPLv2 with exceptions
23Group:          Development/Tools
24URL:            http://www.riverbankcomputing.co.uk/qscintilla
25
26Source:         QScintilla-gpl-%{version}.tar.gz
27# TODO: upstream this
28Patch1:         QScintilla-2-gpl-Qt4-incpath.patch
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-root
31BuildRequires:  qt4-devel = %{qt4_ver}
32BuildRequires:  PyQt4-devel >= %{pyqt4_version}
33
34%description
35QScintilla is a port of Scintilla to the Qt GUI toolkit.
36
37This version of QScintilla is based on Scintilla v%{ver}.
38
39%package designer
40Summary:  QScintilla designer plugin
41Group:    Development/Tools
42Requires: %{name} = %{version}-%{release}
43Requires: qt4-designer
44
45%description designer
46%{summary}.
47
48%package devel
49Summary: QScintilla Development Files
50Group: Development/Libraries
51Requires: %{name} = %{version}
52Requires: qt4-devel
53
54%description  devel
55This packages contains the libraries, include and other files
56you can use to develop applications with QScintilla.
57
58%package python
59Summary:  QScintilla PyQt4 bindings
60Group:    Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: PyQt4 >= %{pyqt4_version}
63
64%description python
65%{summary}.
66
67%package python-devel
68Summary:  Development files for QScintilla PyQt4 bindings
69Group:    Development/Libraries
70Requires: %{name}-python = %{version}-%{release}
71Requires: PyQt4-devel
72
73%description python-devel
74%{summary}.
75
76%prep
77%setup -q -n QScintilla-gpl-%{version}
78%patch1 -p1 -b .designer-incpath-qt4
79
80# fix permissions on doc files
81find doc example-Qt4  -type f -exec chmod 0644 {} ';'
82find src include -type f -exec chmod 0644 {} ';'
83
84# fix line endings in license file(s)
85sed -i 's/\r//' LICENSE.GPL2 GPL_EXCEPTION_ADDENDUM.TXT
86
87%build
88export QTDIR=%{_qt4_prefix}
89%ifarch x86_64
90export QMAKESPEC=$QTDIR/mkspecs/linux-g++-64/
91%else
92export QMAKESPEC=$QTDIR/mkspecs/linux-g++/
93%endif
94
95pushd Qt4
96$QTDIR/bin/qmake -o Makefile qscintilla.pro
97make %{?_smp_mflags}
98popd
99
100pushd designer-Qt4
101$QTDIR/bin/qmake -o Makefile designer.pro
102make %{?_smp_mflags}
103popd
104
105pushd Python
106%{__python} configure.py \
107            -c -j 3 \
108            -n ../Qt4 \
109            -o ../Qt4
110make %{?_smp_mflags}
111popd
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116make install INSTALL_ROOT=$RPM_BUILD_ROOT -C Qt4
117make install INSTALL_ROOT=$RPM_BUILD_ROOT -C designer-Qt4
118make install DESTDIR=$RPM_BUILD_ROOT -C Python
119
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post  -p /sbin/ldconfig
125
126%postun -p /sbin/ldconfig
127
128%files
129%defattr(-, root, root, 755)
130%doc NEWS README
131%doc LICENSE.GPL3 LICENSE.GPL2 GPL_EXCEPTION.TXT GPL_EXCEPTION_ADDENDUM.TXT
132%{_qt4_libdir}/libqscintilla2.so.*
133%{_qt4_prefix}/qsci/*
134%{_qt4_translationdir}/*
135
136%files designer
137%defattr(-,root,root,-)
138%{_qt4_prefix}/plugins/designer/libqscintillaplugin.so
139
140%files devel
141%defattr(-, root, root, -)
142%{_qt4_includedir}/*
143%{_qt4_libdir}/libqscintilla2.so
144
145%files python
146%defattr(-,root,root,-)
147%{python_sitearch}/PyQt4/Qsci.so
148
149%files python-devel
150%defattr(-,root,root,-)
151%{_datadir}/sip/PyQt4/Qsci
152
153%changelog
154* Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.6-1
155- new upstream release
156- fix qt4_ver from 4.6.3 to 4.7.1
157
158* Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.4-2
159- rebuild with qt4-4.6.3
160- fix qt4_ver from 4.6.1 to 4.6.3
161- fix BuildRequires: qt4-devel = %{qt4_ver} (add version)
162
163* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-1
164- new upstream release
165- updated qt4 macros
166
167* Sat Feb 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-1
168- new upstream release
169
170* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.4-3
171- rebuilt with qt4-4.6.1, python-2.6
172- installed translation to %%{_datadir}/qt4/translations now
173
174* Thu Oct 22 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
175- updated macro pyqt4_version to 4.6
176- fixed changelog year below (2008 -> 2009)
177
178* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
179- new upstream release
180- added designer, python and python-devel sub-packages
181
182* Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-1
183- appiled new versioning policy
184
185* Fri Nov 30 2007 Shu KONNO <owa@bg.wakwak.com> 1.7.1-0vl2
186- updated macro QMAKESPEC to linux-g++-64 (if x86_64)
187
188* Thu Sep 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.7.1-0vl1
189- new upstream release (1.71)
190
191* Mon Jun  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6-0vl1
192- new upstream release (1.65)
193- changed Group to System Environment/Libraries
194
195* Sat Jan 15 2005 Satoshi MACHINO <machino@vinelinux.org> 1.4-0vl1
196- initial built for VineLinux
197
Note: See TracBrowser for help on using the repository browser.