source: projects/specs/trunk/q/qpdf/qpdf-vl.spec @ 11455

Revision 11455, 4.9 KB checked in by ara_t, 6 years ago (diff)

qpdf: update to 7.1.0

Line 
1Summary: Command-line tools and library for transforming PDF files
2Name:    qpdf
3Version: 7.1.0
4Release: 1%{?_dist_release}
5
6# MIT: e.g. libqpdf/sha2.c
7License: Apache License Version 2.0 or Artistic 2.0
8Group:   System Environment/Base
9URL:     http://qpdf.sourceforge.net/
10Source0: http://downloads.sourceforge.net/sourceforge/qpdf/qpdf-%{version}.tar.gz
11
12Patch0:  qpdf-doc.patch
13
14BuildRequires: zlib-devel
15BuildRequires: pcre-devel
16BuildRequires: libjpeg-turbo-devel libtiff-devel
17
18# for fix-qdf and test suite
19BuildRequires: perl
20BuildRequires: perl(Digest::MD5)
21
22# # for autoreconf
23# BuildRequires: autoconf
24# BuildRequires: automake
25# BuildRequires: libtool
26
27Requires: qpdf-libs%{?_isa} = %{version}-%{release}
28
29Vendor: Project Vine
30Distribution: Vine Linux
31Packager: tomopl, ara_t
32
33
34%package libs
35Summary: QPDF library for transforming PDF files
36Group:   System Environment/Libraries
37
38%package devel
39Summary: Development files for QPDF library
40Group:   Development/Libraries
41Requires: qpdf-libs%{?_isa} = %{version}-%{release}
42
43%package doc
44Summary: QPDF Manual
45Group:   Documentation
46BuildArch: noarch
47Requires: qpdf-libs = %{version}-%{release}
48
49
50%description
51QPDF is a command-line program that does structural, content-preserving
52transformations on PDF files. It could have been called something
53like pdf-to-pdf. It includes support for merging and splitting PDFs
54and to manipulate the list of pages in a PDF file. It is not a PDF viewer
55or a program capable of converting PDF into other formats.
56
57%description libs
58QPDF is a C++ library that inspect and manipulate the structure of PDF files.
59It can encrypt and linearize files, expose the internals of a PDF file,
60and do many other operations useful to PDF developers.
61
62%description devel
63Header files and libraries necessary
64for developing programs using the QPDF library.
65
66%description doc
67QPDF Manual
68
69
70%prep
71%setup -q
72
73# fix 'complete manual location' note in man pages
74%patch0 -p1 -b .doc
75
76sed -i -e '1s,^#!/usr/bin/env perl,#!/usr/bin/perl,' qpdf/fix-qdf
77
78%build
79# work-around check-rpaths errors
80# autoreconf --verbose --force --install
81
82%configure --disable-static \
83           --enable-show-failed-test-output
84
85make %{?_smp_mflags}
86
87%install
88make install DESTDIR=%{buildroot}
89
90# https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
91mkdir __doc
92mv  %{buildroot}%{_datadir}/doc/qpdf/* __doc
93rm -rf %{buildroot}%{_datadir}/doc/qpdf
94
95rm -f %{buildroot}%{_libdir}/libqpdf.la
96
97%check
98make check
99
100%post libs -p /sbin/ldconfig
101
102%postun libs -p /sbin/ldconfig
103
104
105%files
106%{_bindir}/fix-qdf
107%{_bindir}/qpdf
108%{_bindir}/zlib-flate
109%{_mandir}/man1/*
110
111%files libs
112%doc README.md  NOTICE.md TODO ChangeLog Artistic-2.0 LICENSE.txt
113%{_libdir}/libqpdf*.so.*
114
115%files devel
116%doc examples/*.cc examples/*.c
117%{_includedir}/*
118%{_libdir}/libqpdf*.so
119%{_libdir}/pkgconfig/libqpdf.pc
120
121%files doc
122%doc __doc/*
123
124
125%changelog
126* Tue Jan 30 2018 Toshiaki Ara <ara_t@384.jp> - 7.1.0-1
127- new upstream release.
128- add BuildRequires: libjpeg-turbo-devel libtiff-devel
129- drop BuildRequires: autoconf automake libtool
130
131* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.0.0-1
132- new upstream release.
133
134* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.1.0-2
135- initial build for Vine Linux.
136
137* Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 5.1.0-1
138- 5.1.0
139
140* Mon Oct 21 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.1-1
141- 5.0.1
142
143* Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-4
144- Perl 5.18 rebuild
145
146* Mon Jul 22 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-3
147- change shebang to absolute path (#987040)
148
149* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-2
150- Perl 5.18 rebuild
151
152* Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-1
153- 5.0.0
154
155* Mon Jul 08 2013 Jiri Popelka <jpopelka@redhat.com> - 4.2.0-1
156- 4.2.0
157
158* Thu May 23 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-3
159- fix 'complete manual location' note in man pages (#966534)
160
161* Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-2
162- some source files are under MIT license
163
164* Mon Apr 15 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-1
165- 4.1.0
166
167* Tue Mar 05 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0.1-3
168- work around gcc 4.8.0 issue on ppc64 (#915321)
169- properly handle overridden compressed objects
170
171* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-2
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
173
174* Fri Jan 18 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.1-1
175- 4.0.1
176
177* Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.0-1
178- 4.0.0
179
180* Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.2-1
181- 3.0.2
182
183* Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-3
184- the previously added requirement doesn't need to be arch-specific
185
186* Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-2
187- doc subpackage requires libs subpackage due to license file (#848466)
188
189* Wed Aug 15 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-1
190- initial spec file
Note: See TracBrowser for help on using the repository browser.