source: projects/specs/trunk/q/qpdf/qpdf-vl.spec @ 11791

Revision 11791, 5.0 KB checked in by ara_t, 6 years ago (diff)

qpdf: update to 8.1.0

Line 
1Summary: Command-line tools and library for transforming PDF files
2Name:    qpdf
3Version: 8.1.0
4Release: 1%{?_dist_release}
5
6# MIT: e.g. libqpdf/sha2.c
7# upstream uses ASL 2.0 now, but he allowed other to distribute qpdf under
8# old license (see README)
9License: Artistic 2.0
10Group:   System Environment/Base
11URL:     http://qpdf.sourceforge.net/
12Source0: http://downloads.sourceforge.net/sourceforge/qpdf/qpdf-%{version}.tar.gz
13
14Patch0:  qpdf-doc.patch
15
16BuildRequires: zlib-devel
17BuildRequires: pcre-devel
18BuildRequires: libjpeg-turbo-devel libtiff-devel
19
20# for fix-qdf and test suite
21BuildRequires: perl
22BuildRequires: perl(Digest::MD5)
23
24# # for autoreconf
25# BuildRequires: autoconf
26# BuildRequires: automake
27# BuildRequires: libtool
28
29Requires: qpdf-libs%{?_isa} = %{version}-%{release}
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: tomop, ara_t
34
35
36%package libs
37Summary: QPDF library for transforming PDF files
38Group:   System Environment/Libraries
39
40%package devel
41Summary: Development files for QPDF library
42Group:   Development/Libraries
43Requires: qpdf-libs%{?_isa} = %{version}-%{release}
44
45%package doc
46Summary: QPDF Manual
47Group:   Documentation
48BuildArch: noarch
49Requires: qpdf-libs = %{version}-%{release}
50
51
52%description
53QPDF is a command-line program that does structural, content-preserving
54transformations on PDF files. It could have been called something
55like pdf-to-pdf. It includes support for merging and splitting PDFs
56and to manipulate the list of pages in a PDF file. It is not a PDF viewer
57or a program capable of converting PDF into other formats.
58
59%description libs
60QPDF is a C++ library that inspect and manipulate the structure of PDF files.
61It can encrypt and linearize files, expose the internals of a PDF file,
62and do many other operations useful to PDF developers.
63
64%description devel
65Header files and libraries necessary
66for developing programs using the QPDF library.
67
68%description doc
69QPDF Manual
70
71
72%prep
73%setup -q
74
75# fix 'complete manual location' note in man pages
76%patch0 -p1 -b .doc
77
78sed -i -e '1s,^#!/usr/bin/env perl,#!/usr/bin/perl,' qpdf/fix-qdf
79
80%build
81# work-around check-rpaths errors
82# autoreconf --verbose --force --install
83
84%configure --disable-static \
85           --enable-show-failed-test-output
86
87make %{?_smp_mflags}
88
89%install
90make install DESTDIR=%{buildroot}
91
92# https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
93mkdir __doc
94mv  %{buildroot}%{_datadir}/doc/qpdf/* __doc
95rm -rf %{buildroot}%{_datadir}/doc/qpdf
96
97rm -f %{buildroot}%{_libdir}/libqpdf.la
98
99%check
100make check
101
102%post libs -p /sbin/ldconfig
103
104%postun libs -p /sbin/ldconfig
105
106
107%files
108%{_bindir}/fix-qdf
109%{_bindir}/qpdf
110%{_bindir}/zlib-flate
111%{_mandir}/man1/*
112
113%files libs
114%doc README.md  NOTICE.md TODO ChangeLog Artistic-2.0 LICENSE.txt
115%{_libdir}/libqpdf*.so.*
116
117%files devel
118%doc examples/*.cc examples/*.c
119%{_includedir}/*
120%{_libdir}/libqpdf*.so
121%{_libdir}/pkgconfig/libqpdf.pc
122
123%files doc
124%doc __doc/*
125
126
127%changelog
128* Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> - 8.1.0-1
129- update to 8.1.0
130
131* Tue Jan 30 2018 Toshiaki Ara <ara_t@384.jp> - 7.1.0-1
132- new upstream release.
133- add BuildRequires: libjpeg-turbo-devel libtiff-devel
134- drop BuildRequires: autoconf automake libtool
135
136* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.0.0-1
137- new upstream release.
138
139* Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.1.0-2
140- initial build for Vine Linux.
141
142* Wed Dec 18 2013 Jiri Popelka <jpopelka@redhat.com> - 5.1.0-1
143- 5.1.0
144
145* Mon Oct 21 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.1-1
146- 5.0.1
147
148* Sat Aug 03 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-4
149- Perl 5.18 rebuild
150
151* Mon Jul 22 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-3
152- change shebang to absolute path (#987040)
153
154* Wed Jul 17 2013 Petr Pisar <ppisar@redhat.com> - 5.0.0-2
155- Perl 5.18 rebuild
156
157* Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 5.0.0-1
158- 5.0.0
159
160* Mon Jul 08 2013 Jiri Popelka <jpopelka@redhat.com> - 4.2.0-1
161- 4.2.0
162
163* Thu May 23 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-3
164- fix 'complete manual location' note in man pages (#966534)
165
166* Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-2
167- some source files are under MIT license
168
169* Mon Apr 15 2013 Jiri Popelka <jpopelka@redhat.com> - 4.1.0-1
170- 4.1.0
171
172* Tue Mar 05 2013 Jiri Popelka <jpopelka@redhat.com> - 4.0.1-3
173- work around gcc 4.8.0 issue on ppc64 (#915321)
174- properly handle overridden compressed objects
175
176* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.0.1-2
177- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
178
179* Fri Jan 18 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.1-1
180- 4.0.1
181
182* Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 4.0.0-1
183- 4.0.0
184
185* Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.2-1
186- 3.0.2
187
188* Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-3
189- the previously added requirement doesn't need to be arch-specific
190
191* Thu Aug 16 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-2
192- doc subpackage requires libs subpackage due to license file (#848466)
193
194* Wed Aug 15 2012 Jiri Popelka <jpopelka@redhat.com> 3.0.1-1
195- initial spec file
Note: See TracBrowser for help on using the repository browser.