source: projects/specs/trunk/q/qjson/qjson-vl.spec @ 1594

Revision 1594, 3.6 KB checked in by inagaki, 14 years ago (diff)

update: akonadi, gpgme, polkit-qt, shared-desktop-ontologies, soprano
NEW: cagibi, dbusmenu-qt, qjson

Line 
1Name:           qjson
2Summary:        A qt-based library that maps JSON data to QVariant objects
3Version:        0.7.1
4Release:        2%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8URL:            http://sourceforge.net/projects/qjson/
9Source0:        http://downloads.sourceforge.net/project/qjson/qjson/0.7.1/%{name}-%{version}.tar.bz2
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  qt4-devel
13BuildRequires:  cmake >= 2.6
14BuildRequires:  doxygen
15
16%description
17JSON is a lightweight data-interchange format. It can represents integer, real
18number, string, an ordered sequence of value, and a collection of
19name/value pairs.QJson is a qt-based library that maps JSON data to
20QVariant objects.
21
22%package devel
23Summary:  Development files for qjson
24Group:    Development/Libraries
25Requires: %{name} = %{version}-%{release}
26Requires: qt4-devel
27Requires: pkgconfig
28Requires: cmake
29
30%description devel
31The %{name}-devel package contains the libraries and header files required for
32developing applications that use %{name}.
33
34%prep
35%setup -qn qjson
36
37%build
38mkdir -p %{_target_platform}
39pushd %{_target_platform}
40%cmake -DQJSON_BUILD_TESTS=1 \
41    -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/cmake/Modules/ \
42    ..
43cd %{_builddir}/%{buildsubdir}/doc
44doxygen
45popd
46
47sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
48-e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
49-e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
50
51make %{?_smp_mflags} -C %{_target_platform}
52
53%install
54rm -rf %{buildroot}
55make install DESTDIR=%{buildroot} -C %{_target_platform}
56
57%check
58LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
59           %{_target_platform}/tests/testparser
60LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
61           %{_target_platform}/tests/testserializer
62
63%clean
64rm -rf %{buildroot}
65
66%post -p /sbin/ldconfig
67
68%postun -p /sbin/ldconfig
69
70%files
71%defattr(-,root,root,-)
72%doc COPYING
73%{_libdir}/*.so.*
74
75%files devel
76%defattr(-,root,root,-)
77%doc doc/html
78%{_includedir}/qjson/
79%{_libdir}/pkgconfig/*.pc
80%{_datadir}/cmake/Modules/FindQJSON.cmake
81%{_libdir}/*.so
82
83%changelog
84* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
85- initial build for Vine Linux
86
87* Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
88-0.7.1
89- Version upgrade
90- Fixed doxygen documentation (Thanks again Orcan)
91
92* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
93-0.6.3
94- Fixed capitalization of the summary
95
96* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
97-0.6.3
98- Moved Doxygen docs to the development package.
99- Corrected placement of the cmake project file (Thanks Orcan)
100- Fixed the running of the build tests
101- Corrected column length of the descriptions
102- Changed description of the devlepment package
103
104* Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
105-0.6.3
106- Additional placment of library files fix
107
108* Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
109-0.6.3
110- Fixed placment of library files
111- Activated build tests
112- Corrected ownership of include directory
113- Corrected dependacies
114- Added doxygen documentation
115- Fixed reported version in the changelogs
116
117* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
118-0.6.3
119- Split off development libraries to its own package
120- Modified licensing in spec file to reflect GPL2 code though docs state that qjson
121-   licensed under LPGL
122- Uncommeted and corrected sed line in this spec file
123
124* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
125-0.6.3
126- Initial Build
Note: See TracBrowser for help on using the repository browser.