source: projects/specs/trunk/q/qjson/qjson-vl.spec @ 1597

Revision 1597, 3.6 KB checked in by inagaki, 14 years ago (diff)

updated: libgadu, libindi, ortp, qjson, qimageblitz, shared-desktop-ontologies

Line 
1Name:           qjson
2Summary:        A qt-based library that maps JSON data to QVariant objects
3Version:        0.7.1
4Release:        3%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8URL:            http://sourceforge.net/projects/qjson/
9
10Source0:        http://downloads.sourceforge.net/project/qjson/qjson/0.7.1/%{name}-%{version}.tar.bz2
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  qt4-devel
14BuildRequires:  cmake >= 2.6
15BuildRequires:  doxygen
16
17%description
18JSON is a lightweight data-interchange format. It can represents integer, real
19number, string, an ordered sequence of value, and a collection of
20name/value pairs.QJson is a qt-based library that maps JSON data to
21QVariant objects.
22
23%package devel
24Summary:  Development files for qjson
25Group:    Development/Libraries
26Requires: %{name} = %{version}-%{release}
27Requires: qt4-devel
28Requires: pkgconfig
29Requires: cmake
30
31%description devel
32The %{name}-devel package contains the libraries and header files required for
33developing applications that use %{name}.
34
35%prep
36%setup -qn qjson
37
38%build
39mkdir -p %{_target_platform}
40pushd %{_target_platform}
41%cmake -DQJSON_BUILD_TESTS=1 \
42    -DCMAKE_MODULES_INSTALL_DIR=%{_datadir}/CMake/Modules/ \
43    ..
44cd %{_builddir}/%{buildsubdir}/doc
45doxygen
46popd
47
48sed -i -e 's/-fno-exceptions -fno-check-new -fno-common//' \
49-e 's/-fno-threadsafe-statics -fvisibility=hidden -fvisibility-inlines-hidden//' \
50-e 's/-ansi//' %{_target_platform}/src/CMakeFiles/qjson.dir/flags.make
51
52make %{?_smp_mflags} -C %{_target_platform}
53
54%install
55rm -rf %{buildroot}
56make install DESTDIR=%{buildroot} -C %{_target_platform}
57
58%check
59LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
60           %{_target_platform}/tests/testparser
61LD_PRELOAD=%{_target_platform}/%{_lib}/libqjson.so \
62           %{_target_platform}/tests/testserializer
63
64%clean
65rm -rf %{buildroot}
66
67%post -p /sbin/ldconfig
68
69%postun -p /sbin/ldconfig
70
71%files
72%defattr(-,root,root,-)
73%doc COPYING
74%{_libdir}/*.so.*
75
76%files devel
77%defattr(-,root,root,-)
78%doc doc/html
79%{_includedir}/qjson/
80%{_libdir}/pkgconfig/*.pc
81%{_datadir}/CMake/Modules/FindQJSON.cmake
82%{_libdir}/*.so
83
84%changelog
85* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-3
86- fixed CMAKE_MODULES_INSTALL_DIR
87
88* Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.1-2
89- initial build for Vine Linux
90
91* Sat Dec 12 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.7.1-1
92-0.7.1
93- Version upgrade
94- Fixed doxygen documentation (Thanks again Orcan)
95
96* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-6
97-0.6.3
98- Fixed capitalization of the summary
99
100* Tue Dec 8 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-5
101-0.6.3
102- Moved Doxygen docs to the development package.
103- Corrected placement of the cmake project file (Thanks Orcan)
104- Fixed the running of the build tests
105- Corrected column length of the descriptions
106- Changed description of the devlepment package
107
108* Sun Dec 6 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-4
109-0.6.3
110- Additional placment of library files fix
111
112* Fri Dec 4 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-3
113-0.6.3
114- Fixed placment of library files
115- Activated build tests
116- Corrected ownership of include directory
117- Corrected dependacies
118- Added doxygen documentation
119- Fixed reported version in the changelogs
120
121* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-2
122-0.6.3
123- Split off development libraries to its own package
124- Modified licensing in spec file to reflect GPL2 code though docs state that qjson
125-   licensed under LPGL
126- Uncommeted and corrected sed line in this spec file
127
128* Sun Nov 22 2009 Eli Wapniarski <eli@orbsky.homelinux.org> 0.6.3-1
129-0.6.3
130- Initial Build
Note: See TracBrowser for help on using the repository browser.