source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 5383

Revision 5383, 4.2 KB checked in by inagaki, 12 years ago (diff)

update: akonadi, automoc4, herqq, ibus-qt, kdebase-runtime, libqzeitgeist, phonon, PyQt4, qca2, qca-ossl, qt4, qt-assistant-adp, qscintilla, qtsoap, uim

Line 
1%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
2
3Name:           qca2
4Summary:        Qt Cryptographic Architecture
5Version:        2.0.3
6Release:        3%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://delta.affinix.com/qca
11Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  qt4-devel >= 4.2
15BuildRequires:  pkgconfig
16
17%description
18Taking a hint from the similarly-named Java Cryptography Architecture,
19QCA aims to provide a straightforward and cross-platform crypto API,
20using Qt datatypes and conventions. QCA separates the API from the
21implementation, using plugins known as Providers. The advantage of this
22model is to allow applications to avoid linking to or explicitly depending
23on any particular cryptographic library. This allows one to easily change
24or upgrade crypto implementations without even needing to recompile the
25application!
26
27%package        devel
28Summary:        Qt Cryptographic Architecture development files
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31Requires:       qt4-devel >= %{_qt4_version}
32
33%description    devel
34This packages contains the development files for QCA
35
36%prep
37%setup -q -n qca-%{version}
38
39%build
40MAKE=%{_bindir}/make \
41./configure \
42  --prefix=%{_prefix} \
43  --includedir=%{_includedir} \
44  --libdir=%{_libdir} \
45  --datadir=%{_datadir} \
46  --no-separate-debug-info \
47  --verbose
48
49sed -i -e /strip/d Makefile
50make %{?_smp_mflags}
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make install INSTALL_ROOT=$RPM_BUILD_ROOT
56
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%post -p /sbin/ldconfig
62
63%postun -p /sbin/ldconfig
64
65
66%files
67%defattr(-,root,root,-)
68%doc COPYING README TODO
69%{_bindir}/qcatool2
70%{_libdir}/*.so.*
71%{_mandir}/*/*
72
73%files devel
74%defattr(-,root,root,-)
75%{_includedir}/QtCrypto
76%{_libdir}/*.so
77%{_libdir}/pkgconfig/qca2.pc
78%{_libdir}/libqca.prl
79%{_qt4_datadir}/mkspecs/features/crypto.prf
80
81
82%changelog
83* Sun Jan  8 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-3
84- rebuilt with qt-4.8.0
85
86* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-2
87- rebuilt with qt-4.7.2
88
89* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-1
90- new upstream release
91- built with qt-4.7.1
92
93* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
94- rebuilt with rpm-4.8.1
95
96* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
97- rebuilt with qt-4.6.3 again
98- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
99
100* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
101- rebuilt with qt-4.6.3
102
103* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
104- rebuilt with new toolchain, qt4-4.6.1
105
106* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
107- rebuilt with qt-4.5.3
108
109* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
110- Initial build for Vine Linux
111
112* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
114
115* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
116- new upstream release - qt 4.5-compat-fixes
117
118* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
119- new upstream release
120- removed 64bit patch - now upstream
121
122* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
124
125* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
126- crypto.prf is in libdir not datadir
127
128* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
129- Autorebuild for GCC 4.3
130
131* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
132- version 2.0.0 final
133
134* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
135- fix build on x86_64
136
137* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
138- missing BR: openssl
139
140* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
141- review from bug 289681 (thanks Rex)
142
143* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
144- initial package
Note: See TracBrowser for help on using the repository browser.