source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 2981

Revision 2981, 4.3 KB checked in by inagaki, 13 years ago (diff)

updated: qt, qt4, PyQt4, avogadro, phonon, qca-ossl, qca2, qoauth, scim-bridge and uim

Line 
1%define qt4_ver 4.7.2
2%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
3%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
4
5Name:           qca2
6Summary:        Qt Cryptographic Architecture
7Version:        2.0.3
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://delta.affinix.com/qca
13Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  qt4-devel >= 4.2
17BuildRequires:  pkgconfig
18
19%description
20Taking a hint from the similarly-named Java Cryptography Architecture,
21QCA aims to provide a straightforward and cross-platform crypto API,
22using Qt datatypes and conventions. QCA separates the API from the
23implementation, using plugins known as Providers. The advantage of this
24model is to allow applications to avoid linking to or explicitly depending
25on any particular cryptographic library. This allows one to easily change
26or upgrade crypto implementations without even needing to recompile the
27application!
28
29%package        devel
30Summary:        Qt Cryptographic Architecture development files
31Group:          Development/Libraries
32Requires:       %{name} = %{version}-%{release}
33Requires:       qt4-devel = %{_qt4_version}
34
35%description    devel
36This packages contains the development files for QCA
37
38%prep
39%setup -q -n qca-%{version}
40
41%build
42unset QTDIR || : ; . /etc/profile.d/qt4.sh
43MAKE=%{_bindir}/make \
44./configure \
45  --prefix=%{_prefix} \
46  --includedir=%{_includedir} \
47  --libdir=%{_libdir} \
48  --datadir=%{_datadir} \
49  --no-separate-debug-info \
50  --verbose
51
52sed -i -e /strip/d Makefile
53make %{?_smp_mflags}
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install INSTALL_ROOT=$RPM_BUILD_ROOT
59
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68
69%files
70%defattr(-,root,root,-)
71%doc COPYING README TODO
72%{_bindir}/qcatool2
73%{_libdir}/*.so.*
74%{_mandir}/*/*
75
76%files devel
77%defattr(-,root,root,-)
78%{_includedir}/QtCrypto
79%{_libdir}/*.so
80%{_libdir}/pkgconfig/qca2.pc
81%{_libdir}/libqca.prl
82%{_qt4_prefix}/mkspecs/features/crypto.prf
83
84
85%changelog
86* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-2
87- rebuilt with qt-4.7.2
88
89* Sun Jan 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.3-1
90- new upstream release
91- built with qt-4.7.1
92
93* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-8
94- rebuilt with rpm-4.8.1
95
96* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.2-7
97- rebuilt with qt-4.6.3 again
98- change BuildRequires: qt4-devel = %{qt4_ver} (add version)
99
100* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
101- rebuilt with qt-4.6.3
102
103* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
104- rebuilt with new toolchain, qt4-4.6.1
105
106* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
107- rebuilt with qt-4.5.3
108
109* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
110- Initial build for Vine Linux
111
112* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
114
115* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
116- new upstream release - qt 4.5-compat-fixes
117
118* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
119- new upstream release
120- removed 64bit patch - now upstream
121
122* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
123- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
124
125* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
126- crypto.prf is in libdir not datadir
127
128* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
129- Autorebuild for GCC 4.3
130
131* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
132- version 2.0.0 final
133
134* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
135- fix build on x86_64
136
137* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
138- missing BR: openssl
139
140* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
141- review from bug 289681 (thanks Rex)
142
143* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
144- initial package
Note: See TracBrowser for help on using the repository browser.