source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 1442

Revision 1442, 3.7 KB checked in by inagaki, 14 years ago (diff)

updated: Qt4, cmake, qca2, uim

Line 
1Name:           qca2
2Summary:        Qt Cryptographic Architecture
3Version:        2.0.2
4Release:        6%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://delta.affinix.com/qca
9Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  qt4-devel
13BuildRequires:  pkgconfig
14
15%define qt4_ver 4.6.3
16%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
17
18%description
19Taking a hint from the similarly-named Java Cryptography Architecture,
20QCA aims to provide a straightforward and cross-platform crypto API,
21using Qt datatypes and conventions. QCA separates the API from the
22implementation, using plugins known as Providers. The advantage of this
23model is to allow applications to avoid linking to or explicitly depending
24on any particular cryptographic library. This allows one to easily change
25or upgrade crypto implementations without even needing to recompile the
26application!
27
28%package        devel
29Summary:        Qt Cryptographic Architecture development files
30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
32Requires:       qt4-devel = %{_qt4_version}
33Requires:       pkgconfig
34
35%description    devel
36This packages contains the development files for QCA
37
38%prep
39%setup -q -n qca-%{version}
40
41%build
42unset QTDIR || : ; . /etc/profile.d/qt4.sh
43MAKE=%{_bindir}/make \
44./configure \
45  --prefix=%{_prefix} \
46  --includedir=%{_includedir} \
47  --libdir=%{_libdir} \
48  --datadir=%{_datadir} \
49  --no-separate-debug-info \
50  --verbose
51
52sed -i -e /strip/d Makefile
53make %{?_smp_mflags}
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make install INSTALL_ROOT=$RPM_BUILD_ROOT
59
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post -p /sbin/ldconfig
65
66%postun -p /sbin/ldconfig
67
68
69%files
70%defattr(-,root,root,-)
71%doc COPYING README TODO
72%{_bindir}/qcatool2
73%{_libdir}/*.so.*
74%{_mandir}/*/*
75
76%files devel
77%defattr(-,root,root,-)
78%{_includedir}/QtCrypto
79%{_libdir}/*.so
80%{_libdir}/pkgconfig/qca2.pc
81%{_libdir}/libqca.prl
82%{_libdir}/qt-%{_qt4_version}/mkspecs/features/crypto.prf
83
84
85%changelog
86* Sat Jul 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-6
87- rebuilt with qt-4.6.3
88
89* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
90- rebuilt with new toolchain, qt4-4.6.1
91
92* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
93- rebuilt with qt-4.5.3
94
95* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
96- Initial build for Vine Linux
97
98* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
100
101* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
102- new upstream release - qt 4.5-compat-fixes
103
104* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
105- new upstream release
106- removed 64bit patch - now upstream
107
108* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
110
111* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
112- crypto.prf is in libdir not datadir
113
114* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
115- Autorebuild for GCC 4.3
116
117* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
118- version 2.0.0 final
119
120* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
121- fix build on x86_64
122
123* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
124- missing BR: openssl
125
126* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
127- review from bug 289681 (thanks Rex)
128
129* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
130- initial package
Note: See TracBrowser for help on using the repository browser.