source: projects/specs/trunk/q/qca2/qca2-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           qca2
2Version:        2.0.2
3Release:        5%{?_dist_release}
4Summary:        Qt Cryptographic Architecture
5
6Group:          System Environment/Libraries
7License:        LGPLv2+
8URL:            http://delta.affinix.com/qca
9Source0:        http://delta.affinix.com/download/qca/2.0/qca-%{version}.tar.bz2
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  qt4-devel
13BuildRequires:  pkgconfig
14
15%define         qtver %(pkg-config --modversion %{_libdir}/pkgconfig/QtCore.pc)
16
17%description
18Taking a hint from the similarly-named Java Cryptography Architecture,
19QCA aims to provide a straightforward and cross-platform crypto API,
20using Qt datatypes and conventions. QCA separates the API from the
21implementation, using plugins known as Providers. The advantage of this
22model is to allow applications to avoid linking to or explicitly depending
23on any particular cryptographic library. This allows one to easily change
24or upgrade crypto implementations without even needing to recompile the
25application!
26
27%package        devel
28Summary:        Qt Cryptographic Architecture development files
29Group:          Development/Libraries
30Requires:       %{name} = %{version}-%{release}
31Requires:       qt4-devel = %{qtver}
32Requires:       pkgconfig
33
34%description    devel
35This packages contains the development files for QCA
36
37%prep
38%setup -q -n qca-%{version}
39
40%build
41unset QTDIR || : ; . /etc/profile.d/qt4.sh
42MAKE=%{_bindir}/make \
43./configure \
44  --prefix=%{_prefix} \
45  --includedir=%{_includedir} \
46  --libdir=%{_libdir} \
47  --datadir=%{_datadir} \
48  --no-separate-debug-info \
49  --verbose
50
51sed -i -e /strip/d Makefile
52make %{?_smp_mflags}
53
54
55%install
56rm -rf $RPM_BUILD_ROOT
57make install INSTALL_ROOT=$RPM_BUILD_ROOT
58
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%post -p /sbin/ldconfig
64
65%postun -p /sbin/ldconfig
66
67
68%files
69%defattr(-,root,root,-)
70%doc COPYING README TODO
71%{_bindir}/qcatool2
72%{_libdir}/*.so.*
73%{_mandir}/*/*
74
75%files devel
76%defattr(-,root,root,-)
77%{_includedir}/QtCrypto
78%{_libdir}/*.so
79%{_libdir}/pkgconfig/qca2.pc
80%{_libdir}/libqca.prl
81%{_libdir}/qt-%{qtver}/mkspecs/features/crypto.prf
82
83
84%changelog
85* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.2-5
86- rebuilt with new toolchain, qt4-4.6.1
87
88* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-4
89- rebuilt with qt-4.5.3
90
91* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.0.2-3
92- Initial build for Vine Linux
93
94* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
96
97* Tue May 05 2009 Sven Lankes <sven@lank.es> - 2.0.2-1
98- new upstream release - qt 4.5-compat-fixes
99
100* Wed Apr 08 2009 Sven Lankes <sven@lank.es> - 2.0.1-1
101- new upstream release
102- removed 64bit patch - now upstream
103
104* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-4
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
106
107* Fri May 30 2008 Dennis Gilmore <dennis@ausil.us> - 2.0.0-3
108- crypto.prf is in libdir not datadir
109
110* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-2
111- Autorebuild for GCC 4.3
112
113* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-1
114- version 2.0.0 final
115
116* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.4.beta7
117- fix build on x86_64
118
119* Sun Oct 21 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.3.beta7
120- missing BR: openssl
121
122* Thu Sep 13 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.2.beta7
123- review from bug 289681 (thanks Rex)
124
125* Sun Sep 09 2007 Aurelien Bompard <abompard@fedoraproject.org> 2.0.0-0.1.beta7
126- initial package
Note: See TracBrowser for help on using the repository browser.