source: projects/specs/trunk/p/pytz/pytz-vl.spec @ 12469

Revision 12469, 6.1 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%bcond_with check
2
3%define pathfix %{_libdir}/python%{python3_version}/Tools/scripts/pathfix.py
4
5Name: pytz
6Version: 2020.1
7Release: 1%{?_dist_release}
8Summary: World Timezone Definitions for Python
9Summary(ja): Python 用の世界タイムゾーン定義
10Group: programming
11Vendor: Project Vine
12Distribution: Vine Linux
13
14License: MIT
15URL: https://pytz.sourceforge.net/
16
17Source0: https://pypi.python.org/packages/source/p/%{name}/%{name}-%{version}.tar.gz
18# Patch to use the system supplied zoneinfo files
19Patch0: pytz-zoneinfo.patch
20# https://bugzilla.redhat.com/1497572
21Patch1: remove_tzinfo_test.patch
22
23BuildArch: noarch
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: python-rpm-macros
26
27%description
28pytz brings the Olson tz database into Python. This library allows accurate
29and cross platform timezone calculations using Python 2.3 or higher. It
30also solves the issue of ambiguous times at the end of daylight savings,
31which you can read more about in the Python Library Reference
32(datetime.tzinfo).
33
34Amost all (over 540) of the Olson timezones are supported.
35
36%package -n python-%{name}
37Summary:        World Timezone Definitions for Python
38Summary(ja):    Python 用の世界タイムゾーン定義
39Group:          programming
40%{?python_provide:%python_provide python2-%{name}}
41BuildRequires:  python-devel, python2-rpm-macros
42%if %{with check}
43BuildRequires:  python-pytest
44%endif
45Requires:       tzdata
46# Remove before vl7
47Provides: pytz = %{version}-%{release}
48Obsoletes: pytz < %{version}-%{release}
49
50%description -n python-%{name}
51pytz brings the Olson tz database into Python. This library allows accurate
52and cross platform timezone calculations using Python 2.3 or higher. It
53also solves the issue of ambiguous times at the end of daylight savings,
54which you can read more about in the Python Library Reference
55(datetime.tzinfo).
56
57Amost all (over 540) of the Olson timezones are supported.
58
59
60%package -n python3-%{name}
61Summary:        World Timezone Definitions for Python
62Summary(ja):    Python 用の世界タイムゾーン定義
63Group:          programming
64%{?python_provide:%python_provide python3-%{name}}
65BuildRequires:  python3-devel, python3-rpm-macros
66%if %{with check}
67BuildRequires:  python3-pytest
68%endif
69Requires:       tzdata
70
71%description -n python3-%{name}
72pytz brings the Olson tz database into Python. This library allows accurate
73and cross platform timezone calculations using Python 2.3 or higher. It
74also solves the issue of ambiguous times at the end of daylight savings,
75which you can read more about in the Python Library Reference
76(datetime.tzinfo).
77
78Amost all (over 540) of the Olson timezones are supported.
79
80
81%prep
82%autosetup -p1
83
84
85%build
86%py2_build
87%py3_build
88
89
90%install
91rm -rf $RPM_BUILD_ROOT
92%py2_install
93rm -r %{buildroot}%{python2_sitelib}/pytz/zoneinfo
94%{pathfix} -p -i %{__python2} %{buildroot}%{python2_sitelib}
95
96%py3_install
97rm -r %{buildroot}%{python3_sitelib}/pytz/zoneinfo
98%{pathfix} -p -i %{__python3} %{buildroot}%{python3_sitelib}
99
100
101%if %{with check}
102%check
103PYTHONPATH=%{buildroot}%{python2_sitelib} %{__python2} -m pytest -v
104PYTHONPATH=%{buildroot}%{python3_sitelib} %{__python3} -m pytest -v
105%endif
106
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111
112%files -n python-%{name}
113%defattr(-,root,root,-)
114%license LICENSE.txt
115%doc README.txt
116%{python2_sitelib}/pytz/
117%{python2_sitelib}/*.egg-info
118
119%files -n python3-pytz
120%license LICENSE.txt
121%doc README.txt
122%{python3_sitelib}/pytz/
123%{python3_sitelib}/*.egg-info
124
125
126%changelog
127* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2020.1-1
128- new upstream release.
129
130* Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2018.7-1
131- new upstream release.
132- added python3 support.
133
134* Sat Aug 09 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2014.4-1
135- initial build for VineSeed
136
137* Tue Jun 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2012c-1
138- initial build for VineSeed
139
140* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2010h-5
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
142
143* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2010h-4
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
145
146* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2010h-3
147- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
148
149* Mon Jun 28 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2010h-2
150- Define => global
151
152* Tue Apr 27 2010 Jon Ciesla <limb@jcomserv.net> - 2010h-1
153- Update to current version, BZ 573252.
154
155* Mon Feb 01 2010 Jon Ciesla <limb@jcomserv.net> - 2009i-7
156- Corrected Source0 URL, BZ 560168.
157
158* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2008i-6
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
160
161* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2008i-5
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
163
164* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2008i-4
165- Rebuild for Python 2.6
166
167* Tue Nov 18 2008 Jef Spaleta <jspaleta at fedoraproject dot org> 2008i-3
168- Apply patch correctly.
169
170* Thu Nov 13 2008 Jef Spaleta <jspaleta at fedoraproject dot org> 2008i-2
171- Updated tzdata patch from Petr Machata bug 471014
172
173* Tue Nov 11 2008 Jef Spaleta <jspaleta at fedoraproject dot org> 2008i-1
174- Update to latest, now using timezone files provided by tzdata package
175
176* Fri Jan 04 2008 Jef Spaleta <jspaleta@gmail.com> 2006p-3
177- Fix for egg-info file creation
178
179* Mon Dec 11 2006 Jef Spaleta <jspaleta@gmail.com> 2006p-2
180- Bump for rebuild against python 2.5 and change BR to python-devel accordingly
181
182* Fri Dec  8 2006 Orion Poplawski <orion@cora.nwra.com> 2006p-1
183- Update to 2006p
184
185* Thu Sep  7 2006 Orion Poplawski <orion@cora.nwra.com> 2006g-1
186- Update to 2006g
187
188* Mon Feb 13 2006 Orion Poplawski <orion@cora.nwra.com> 2005r-2
189- Rebuild for gcc/glibc changes
190
191* Tue Jan  3 2006 Orion Poplawski <orion@cora.nwra.com> 2005r-1
192- Update to 2005r
193
194* Thu Dec 22 2005 Orion Poplawski <orion@cora.nwra.com> 2005m-1
195- Update to 2005m
196
197* Fri Jul 22 2005 Orion Poplawski <orion@cora.nwra.com> 2005i-2
198- Remove -O1 from install command
199
200* Tue Jul 05 2005 Orion Poplawski <orion@cora.nwra.com> 2005i-1
201- Initial Fedora Extras package
Note: See TracBrowser for help on using the repository browser.