source: projects/specs/trunk/p/python3/python3-vl.spec @ 12522

Revision 12522, 16.7 KB checked in by tomop, 3 years ago (diff)

updated 16 packages

SDL2-2.0.14-1

gmp-6.2.1-1

gnupg2-2.2.27-1

gnutls-3.7.0-1

golang-1.15.7-1

iputils-20210202-1

libassuan-2.5.4-1

libgcrypt-1.9.1-1

libgpg-error-1.41-1

libksba-1.5.0-1

libusb1-1.0.24-1

nettle-3.7-1

npth-1.6-2

pcsc-lite-1.9.0-1

python3-3.8.7-1

tcpdump-4.9.3-2

RevLine 
[12469]1%bcond_with run_test
2
3%define libvers 3.8
4%define binsuffix 3.8
[3491]5%define python_lib %{_libdir}/python%{libvers}
6%define config_htmldir /var/www/html/python
[1216]7Summary: An interpreted, interactive, object-oriented programming language.
[1222]8Summary(ja): オブジェクト指向 Python3 インタプリタ
[1216]9Name: python3
[12522]10Version: 3.8.7
11Release: 1%{?_dist_release}
[12469]12Group: programming
[12376]13Vendor: Project Vine
14Distribution: Vine Linux
15
[12469]16License: Python
[1216]17URL: http://www.python.org/download/releases/%{version}
[12376]18Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
19Source1: https://docs.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
[12469]20# (Patches taken from github.com/fedora-python/cpython)
[10025]21
[12469]22# 00001 # d06a8853cf4bae9e115f45e1d531d2dc152c5cc8
23# Fixup distutils/unixccompiler.py to remove standard library path from rpath
24# Was Patch0 in ivazquez' python3000 specfile
25Patch1: 00001-rpath.patch
26
27# 00102 # ec4353c0f646eb567cc0d63e1e41eb5e29cc3e81
28# Change the various install paths to use /usr/lib64/ instead or /usr/lib/
29#
30# Only used when "%%{_lib}" == "lib64".
31Patch102: 00102-lib64.patch
32
33# 00111 # 03918d404a40a50c9f5f93dc748b52e613d70d31
34# Don't try to build a libpythonMAJOR.MINOR.a
35#
36# Downstream only: not appropriate for upstream.
37#
38# See https://bugzilla.redhat.com/show_bug.cgi?id=556092
39Patch111: 00111-no-static-lib.patch
40
41# 00189 # adf51ed04ac74fd6fc39c642af35b87680c71dab
42# Instead of bundled wheels, use our RPM packaged wheels
43#
44# We keep them in /usr/share/python-wheels
45#
46# Downstream only: upstream bundles
47# We might eventually pursuit upstream support, but it's low prio
48Patch189: 00189-use-rpm-wheels.patch
49# The following versions of setuptools/pip are bundled when this patch is not applied.
50# The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
51# When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
52# In such cases, the patch needs to be amended and the versions updated here:
53%global pip_version 20.1.1
54%global setuptools_version 47.1.0
55
56# 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
57# Change user install location
58#
59# Set values of prefix and exec_prefix in distutils install command
60# to /usr/local if executable is /usr/bin/python* and RPM build
61# is not detected to make pip and distutils install into separate location.
62#
63# Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
64# Downstream only: Awaiting resources to work on upstream PEP
65Patch251: 00251-change-user-install-location.patch
66
67# 00274 # 1e9258f6e8f70e86d5130113d3eed22993cf3da9
68# Upstream uses Debian-style architecture naming, change to match Fedora
69Patch274: 00274-fix-arch-names.patch
70
71# 00328 # 367fdcb5a075f083aea83ac174999272a8faf75c
72# Restore pyc to TIMESTAMP invalidation mode as default in rpmbuild
73#
74# Since Fedora 31, the $SOURCE_DATE_EPOCH is set in rpmbuild to the latest
75# %%changelog date. This makes Python default to the CHECKED_HASH pyc
76# invalidation mode, bringing more reproducible builds traded for an import
77# performance decrease. To avoid that, we don't default to CHECKED_HASH
78# when $RPM_BUILD_ROOT is set (i.e. when we are building RPM packages).
79#
80# See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/57#comment-27426
81# Downstream only: only used when building RPM packages
82# Ideally, we should talk to upstream and explain why we don't want this
83Patch328: 00328-pyc-timestamp-invalidation-mode.patch
84
[12507]85# security
[12522]86Patch1000: CVE-2021-3177.patch
[12507]87
[1216]88BuildRoot: %{_tmppath}/%{name}-%{version}-root
[12469]89BuildRequires: autoconf
[12028]90BuildRequires: bzip2-devel
[3491]91BuildRequires: expat-devel
[12469]92BuildRequires: findutils
93BuildRequires: gcc-c++
[3491]94BuildRequires: gdbm-devel
[1221]95BuildRequires: glibc-devel
[12028]96BuildRequires: libdb-devel
97BuildRequires: libffi-devel
[12056]98BuildRequires: libnsl2-devel
99BuildRequires: libtirpc-devel
100BuildRequires: libxcrypt-devel
[1221]101BuildRequires: ncurses-devel
102BuildRequires: openssl-devel
[12469]103BuildRequires: pkgconfig
[1221]104BuildRequires: readline-devel
[12028]105BuildRequires: sqlite3-devel
[12469]106BuildRequires: tar
[12028]107BuildRequires: valgrind-devel
[12469]108BuildRequires: xz-devel
[1221]109BuildRequires: zlib-devel
[7938]110
[1216]111%description
112Python is an interpreted, interactive, object-oriented programming
[3491]113language.  It incorporates modules, exceptions, dynamic typing, very high
114level dynamic data types, and classes. Python combines remarkable power
115with very clear syntax. It has interfaces to many system calls and
116libraries, as well as to various window systems, and is extensible in C or
117C++. It is also usable as an extension language for applications that need
118a programmable interface.  Finally, Python is portable: it runs on many
119brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
120Mac.
[1216]121
[12469]122
[1216]123%package devel
124Summary: The libraries and header files needed for Python development.
[12469]125Group: programming
[7938]126Requires: %{name} = %{version}-%{release}
[12098]127Requires: libtirpc-devel
[1216]128
129%description devel
130The Python programming language's interpreter can be extended with
131dynamically loaded extensions and can be embedded in other programs.
132This package contains the header files and libraries needed to do
133these types of tasks.
134
135Install python-devel if you want to develop Python extensions.  The
136python package will also need to be installed.  You'll probably also
137want to install the python-docs package, which contains Python
138documentation.
139
140%package tkinter
141Summary: A graphical user interface for the Python scripting language.
[12469]142Group: programming
[7938]143Requires: %{name} = %{version}-%{release}
[1221]144Requires: tcl, tk, tix
145Requires: libX11, libxcb, libXau, libXdmcp
[9461]146BuildRequires: tcl-devel, tk-devel, tix
[1221]147BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
[1216]148
149%description tkinter
150The Tkinter (Tk interface) program is an graphical user interface for
151the Python scripting language.
152
153You should install the tkinter package if you'd like to use a graphical
154user interface for Python programming.
155
[12469]156
[1216]157%package tools
158Summary: A collection of development tools included with Python.
[12469]159Group: programming
[7938]160Requires: %{name} = %{version}-%{release}
[1216]161Requires: %{name}-tkinter = %{version}
162
163%description tools
164The Python package includes several development tools that are used
165to build python programs.
166
[12469]167
[1216]168%package docs
169Summary: Documentation for the Python programming language.
[9461]170Summary(ja): Python プログラミング言語のドキュメント
[12469]171Group: documentation
[1216]172
173%description docs
174The python-docs package contains documentation on the Python
175programming language and interpreter.  The documentation is provided
176in ASCII text files and in LaTeX source files.
177
178Install the python-docs package if you'd like to use the documentation
179for the Python language.
180
181
[12469]182%debug_package
183
184
[1216]185%prep
186%setup -q -n Python-%{version}
[12469]187# Remove all exe files to ensure we are not shipping prebuilt binaries
188# note that those are only used to create Microsoft Windows installers
189# and that functionality is broken on Linux anyway
190find -name '*.exe' -print -delete
191
192# Remove bundled libraries to ensure that we're using the system copy.
193rm -r Modules/expat
194
195#
196# Apply patches:
197#
198%patch1 -p1
199
200%if "%{_lib}" == "lib64"
201%patch102 -p1
[1216]202%endif
[12469]203%patch111 -p1
[1216]204
[12469]205%if %{with rpmwheels}
206%patch189 -p1
207rm Lib/ensurepip/_bundled/*.whl
208%endif
[1216]209
[12469]210%patch251 -p1
211%patch274 -p1
212%patch328 -p1
213
[12507]214# security
215%patch1000 -p1
216
[12469]217# Remove files that should be generated by the build
218# (This is after patching, so that we can use patches directly from upstream)
219rm configure pyconfig.h.in
220
221# Regenerate the configure script and pyconfig.h.in
222autoconf
223autoheader
224
225
[1216]226%build
[12469]227export CFLAGS="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
228export CFLAGS_NODIST="%{?build_cflags} -D_GNU_SOURCE -fPIC -fwrapv%{?with_no_semantic_interposition: -fno-semantic-interposition}"
229export CXXFLAGS="%{?extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
230export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
231export OPT="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
232export LINKCC="gcc"
233export CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
234export LDFLAGS="%{?extension_ldflags} -g $(pkg-config --libs-only-L openssl)"
235export LDFLAGS_NODIST="%{?build_ldflags}%{?with_no_semantic_interposition: -fno-semantic-interposition} -g $(pkg-config --libs-only-L openssl)"
236
[3491]237./configure \
238        --prefix=%{_prefix} \
239        --libdir=%{_libdir} \
[12469]240        --enable-ipv6 \
[1216]241        --enable-shared \
[12469]242        --with-computed-gotos=yes \
243        --with-dbmliborder=gdbm:ndbm:bdb \
244        --with-system-expat \
[3491]245        --with-system-ffi \
[12469]246        --enable-loadable-sqlite-extensions \
247        --with-lto \
248        --with-ssl-default-suites=openssl \
[3491]249        --with-valgrind \
[9249]250        --without-ensurepip \
[12469]251        --enable-optimizations \
252        %{nil}
[1216]253
[12469]254make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST" \
255        regen-all PYTHON_FOR_REGEN="python%{binsuffix}"
[11920]256
[12469]257make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST"
[1216]258
[2238]259
[1216]260%install
[3491]261[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
262make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
[1216]263
[3491]264# replace path in pydoc
265if [ ! -z "%{binsuffix}" ]
266then
267   (
268      cd $RPM_BUILD_ROOT%{_bindir}
269      mv pydoc%{libvers} pydoc.old
270      sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
271            pydoc.old > pydoc%{libvers}
272      chmod 755 pydoc%{libvers}
273      rm -f pydoc.old
274   )
275fi
[1216]276
[3491]277#  Tools
278echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
279echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
280echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python_lib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
281echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
282echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
283chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
284cp -a Tools $RPM_BUILD_ROOT%{python_lib}
285
286# make file lists
287rm -f mainpkg.files
288find "$RPM_BUILD_ROOT"%{python_lib} -type f |
289        sed "s|^${RPM_BUILD_ROOT}|/|" |
[12286]290        grep -v \
291                -e '/python%{libvers}/config$' \
292                -e '_tkinter.so$' \
293                -e '_tkinter.cpython-' \
294                >> mainpkg.files
[3491]295
296rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
297find "$RPM_BUILD_ROOT""%{_prefix}"/bin -type f -o -type l |
298        sed "s|^${RPM_BUILD_ROOT}|/|" |
299        grep -v -e '/bin/2to3%{binsuffix}$' |
300        grep -v -e '/bin/pydoc%{binsuffix}$' |
301        grep -v -e '/bin/smtpd.py%{binsuffix}$' |
302        grep -v -e '/bin/idle%{binsuffix}$' >> mainpkg.files
303
304
305rm -f tools.files
306find "$RPM_BUILD_ROOT"%{python_lib}/idlelib \
307      "$RPM_BUILD_ROOT"%{python_lib}/Tools -type f |
308      sed "s|^${RPM_BUILD_ROOT}|/|" > tools.files
309echo %{_bindir}/2to3-%{binsuffix} >> tools.files
310echo %{_bindir}/pydoc%{binsuffix} >> tools.files
311##echo %{_bindir}/smtpd.py%{binsuffix} >> tools.files
312echo %{_bindir}/idle%{binsuffix} >> tools.files
313
314# docs
315mkdir -p "$RPM_BUILD_ROOT"%{config_htmldir}
316(
317   cd "$RPM_BUILD_ROOT"%{config_htmldir}
318   bunzip2 < %{SOURCE1} | tar x
319)
320
321#  fix the #! line in installed files
322find "$RPM_BUILD_ROOT" -type f -print0 |
323      xargs -0 grep -l /usr/local/bin/python | while read file
324do
325   FIXFILE="$file"
326   sed 's|^#!.*python|#!%{_bindir}/env python'"%{binsuffix}"'|' \
327         "$FIXFILE" >/tmp/fix-python-path.$$
328   cat /tmp/fix-python-path.$$ > "$FIXFILE"
329   rm -f /tmp/fix-python-path.$$
330done
331
332#  check to see if there are any straggling #! lines
333find "$RPM_BUILD_ROOT" -type f | xargs egrep -n '^#! */usr/local/bin/python' \
334      | grep ':1:#!' >/tmp/python-rpm-files.$$ || true
335if [ -s /tmp/python-rpm-files.$$ ]
336then
337   echo '*****************************************************'
338   cat /tmp/python-rpm-files.$$
339   cat <<@EOF
340   *****************************************************
341     There are still files referencing /usr/local/bin/python in the
342     install directory.  They are listed above.  Please fix the .spec
343     file and try again.  If you are an end-user, you probably want
344     to report this to jafo-rpms@tummy.com as well.
345   *****************************************************
346@EOF
347   rm -f /tmp/python-rpm-files.$$
348   exit 1
[1216]349fi
[3491]350rm -f /tmp/python-rpm-files.$$
[1216]351
352
[12469]353%if %{with run_test}
354%check
355make test
356%endif
357
358
[1216]359%clean
360rm -fr $RPM_BUILD_ROOT
361
[12469]362
363%post -p /sbin/ldconfig
364%postun -p /sbin/ldconfig
365
366
[3491]367%files -f mainpkg.files
[1216]368%defattr(-, root, root)
[12028]369%license LICENSE
[3491]370%doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
371%attr(755,root,root) %dir %{python_lib}/
372%{_libdir}/libpython*
373%{_mandir}/man1/python%{libvers}.1*
[7938]374%{_mandir}/man1/%{name}.1*
[1216]375
376%files devel
377%defattr(-,root,root)
[12469]378%dir %{_includedir}/python%{libvers}
379%dir %{_includedir}/python%{libvers}/cpython
380%dir %{_includedir}/python%{libvers}/internal
381%{_includedir}/python%{libvers}/*.h
382%{_includedir}/python%{libvers}/cpython/*.h
383%{_includedir}/python%{libvers}/internal/*.h
[3491]384%{_libdir}/pkgconfig/*.pc
[1216]385
[3491]386%files -f tools.files tools
[1216]387%defattr(-,root,root)
388
389%files tkinter
390%defattr(-,root,root)
391%{python_lib}/tkinter
[3491]392%{python_lib}/lib-dynload/_tkinter.*.so*
[1216]393
394%files docs
395%defattr(-,root,root)
[3491]396%{config_htmldir}/*
[1216]397
398
399%changelog
[12522]400* Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.7-1
401- new upstream release.
402- dropped Patch1000: fixed in upstream.
403- added Patch1000 to fix CVE-2021-3177.
404
[12507]405* Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-2
406- added Patch1000 to fix CVE-2020-27619.
407
[12505]408* Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-1
409- new upstream release.
410
[12469]411* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.5-1
412- new upstream release.
413
[12376]414* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
415- new upstream release.
416
[12286]417* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
418- fixed %%files.
419
[12277]420* Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-4
421- rebuilt with tix-8.4.3-5.
422
[12236]423* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-3
424- rebuilt with tcl/tk-8.6.9.
425
[12140]426* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.5.7-2
427- rebuild with readline-8.0 and ncurses-6.1
428
[12098]429* Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-1
430- new upstream release.
431- rebuilt with gdbm-1.18.1.
432- added R:libtirpc-devel to python3-devel.
433
[12056]434* Thu Feb 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-3
435- added BR:libxcrypt-devel.
436- added BR:libtirpc-devel.
437- added BR:libnsl2-devel.
438
[12028]439* Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
440- rebuilt with new toolchain.
441
[11920]442* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
443- new upstream release.
444- really rebuilt with openssl-1.1.1.
445
[11827]446* Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
447- rebuild with openssl-1.1.1
448
[10405]449* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
450- new upstream release
451- update Patch1 (python-3.5.2-lib64.patch)
452
[10101]453* Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
454- rebuild with openssl-1.0.2g
455
[10025]456* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
457- new upstream release
458- add Patch2 (python3-3.4.4-revert-makefile.patch)
459
[9502]460* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
461- new upstream release
462
[9461]463* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
464- rebuilt with readline 6.3
465- changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
466- changed BuildRequires: libdb-devel instead of db4-devel
467
[9249]468* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
469- new upstream release
470- update Patch1 (python-3.4.2-lib64.patch)
471
[8940]472* Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
473- remove configure option "--enable-profiling"
474
[8758]475* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
476- rebuild with libffi-3.0.13
477
[8011]478* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
479- new upstream release
480
[7938]481* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
482- updated python to 3.3.2
483
[7297]484* Sun Jan  6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
485- build with Tcl/Tk 8.5.7-1
486
[6985]487* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
488- updated python to 3.3.0
489- update Patch1 (python-3.3.0-lib64.patch)
490- add BuildRequires: valgrind-devel
491
[3491]492* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
493- updated python to 3.2
494- updated python-*-docs-html to 3.2
495- dropt all patchs
496- added python-3.2b2-lib64.patch
497- referred to the review Python-3.2/Misc/RPM/python-3.2.spec
498
[2500]499* Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
500- rebuilt with openssl-1.0.0c
501
[2238]502* Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
503- updated python to 3.1.3
504- added python-3.1.3-locale.patch
505- dropt python-3.1.2-lib64.patch
506- added python-3.1.3-lib64-*.patchs
507  python-3.1.3-lib64-Makefile.patch
508  python-3.1.3-lib64-setup.patch
509  python-3.1.3-lib64-site.patch
510  python-3.1.3-lib64-install.patch
511  python-3.1.3-lib64-sysconfig.patch
512  python-3.1.3-lib64-getpath.patch
513  python-3.1.3-lib64-test_install.patch
514- added run_test macro to run unit test
515- added BR: libffi
516
[1902]517* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
518- rebuilt with rpm-4.8.1 for pkg-config
519
[1222]520* Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
521- spec in utf-8
522
[1221]523* Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
524- added missings in BuildRequires, Requires
525
[1216]526* Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
527- initial build for VineSeed
528
Note: See TracBrowser for help on using the repository browser.