source: projects/specs/trunk/p/python3/python3-vl.spec @ 12554

Revision 12554, 17.8 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

bind-9.11.28-1

jasper-2.0.25-1

python3-3.8.8-2

Line 
1%bcond_with run_test
2
3%define config_htmldir /var/www/html/python
4Summary: An interpreted, interactive, object-oriented programming language.
5Summary(ja): オブジェクト指向 Python3 インタプリタ
6Name: python3
7Version: 3.8.8
8Release: 2%{?_dist_release}
9Group: programming
10Vendor: Project Vine
11Distribution: Vine Linux
12
13License: Python
14URL: http://www.python.org/download/releases/%{version}
15
16%define majorver %(echo %{version} | cut -d . -f 1)
17%define libvers %(echo %{version} | cut -d . -f 1-2)
18%define binsuffix %{libvers}
19%define python_lib %{_libdir}/python%{libvers}
20%global py_SOVERSION 1.0
21%global py_INSTSONAME libpython%{libvers}.so.%{py_SOVERSION}
22
23Source0: https://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
24Source1: https://docs.python.org/ftp/python/doc/%{version}/python-%{version}-docs-html.tar.bz2
25# (Patches taken from github.com/fedora-python/cpython)
26
27# 00001 # d06a8853cf4bae9e115f45e1d531d2dc152c5cc8
28# Fixup distutils/unixccompiler.py to remove standard library path from rpath
29# Was Patch0 in ivazquez' python3000 specfile
30Patch1: 00001-rpath.patch
31
32# 00102 # ec4353c0f646eb567cc0d63e1e41eb5e29cc3e81
33# Change the various install paths to use /usr/lib64/ instead or /usr/lib/
34#
35# Only used when "%%{_lib}" == "lib64".
36Patch102: 00102-lib64.patch
37
38# 00111 # 03918d404a40a50c9f5f93dc748b52e613d70d31
39# Don't try to build a libpythonMAJOR.MINOR.a
40#
41# Downstream only: not appropriate for upstream.
42#
43# See https://bugzilla.redhat.com/show_bug.cgi?id=556092
44Patch111: 00111-no-static-lib.patch
45
46# 00189 # adf51ed04ac74fd6fc39c642af35b87680c71dab
47# Instead of bundled wheels, use our RPM packaged wheels
48#
49# We keep them in /usr/share/python-wheels
50#
51# Downstream only: upstream bundles
52# We might eventually pursuit upstream support, but it's low prio
53Patch189: 00189-use-rpm-wheels.patch
54# The following versions of setuptools/pip are bundled when this patch is not applied.
55# The versions are written in Lib/ensurepip/__init__.py, this patch removes them.
56# When the bundled setuptools/pip wheel is updated, the patch no longer applies cleanly.
57# In such cases, the patch needs to be amended and the versions updated here:
58%global pip_version 20.1.1
59%global setuptools_version 47.1.0
60
61# 00251 # 2eabd04356402d488060bc8fe316ad13fc8a3356
62# Change user install location
63#
64# Set values of prefix and exec_prefix in distutils install command
65# to /usr/local if executable is /usr/bin/python* and RPM build
66# is not detected to make pip and distutils install into separate location.
67#
68# Fedora Change: https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
69# Downstream only: Awaiting resources to work on upstream PEP
70Patch251: 00251-change-user-install-location.patch
71
72# 00274 # 1e9258f6e8f70e86d5130113d3eed22993cf3da9
73# Upstream uses Debian-style architecture naming, change to match Fedora
74Patch274: 00274-fix-arch-names.patch
75
76# 00328 # 367fdcb5a075f083aea83ac174999272a8faf75c
77# Restore pyc to TIMESTAMP invalidation mode as default in rpmbuild
78#
79# Since Fedora 31, the $SOURCE_DATE_EPOCH is set in rpmbuild to the latest
80# %%changelog date. This makes Python default to the CHECKED_HASH pyc
81# invalidation mode, bringing more reproducible builds traded for an import
82# performance decrease. To avoid that, we don't default to CHECKED_HASH
83# when $RPM_BUILD_ROOT is set (i.e. when we are building RPM packages).
84#
85# See https://src.fedoraproject.org/rpms/redhat-rpm-config/pull-request/57#comment-27426
86# Downstream only: only used when building RPM packages
87# Ideally, we should talk to upstream and explain why we don't want this
88Patch328: 00328-pyc-timestamp-invalidation-mode.patch
89
90# security
91# (none)
92
93BuildRoot: %{_tmppath}/%{name}-%{version}-root
94BuildRequires: autoconf
95BuildRequires: bzip2-devel
96BuildRequires: expat-devel
97BuildRequires: findutils
98BuildRequires: gcc-c++
99BuildRequires: gdbm-devel
100BuildRequires: glibc-devel
101BuildRequires: libdb-devel
102BuildRequires: libffi-devel
103BuildRequires: libnsl2-devel
104BuildRequires: libtirpc-devel
105BuildRequires: libxcrypt-devel
106BuildRequires: ncurses-devel
107BuildRequires: openssl-devel
108BuildRequires: pkgconfig
109BuildRequires: readline-devel
110BuildRequires: sqlite3-devel
111BuildRequires: tar
112BuildRequires: valgrind-devel
113BuildRequires: xz-devel
114BuildRequires: zlib-devel
115
116%description
117Python is an interpreted, interactive, object-oriented programming
118language.  It incorporates modules, exceptions, dynamic typing, very high
119level dynamic data types, and classes. Python combines remarkable power
120with very clear syntax. It has interfaces to many system calls and
121libraries, as well as to various window systems, and is extensible in C or
122C++. It is also usable as an extension language for applications that need
123a programmable interface.  Finally, Python is portable: it runs on many
124brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
125Mac.
126
127
128%package devel
129Summary: The libraries and header files needed for Python development.
130Group: programming
131Requires: %{name} = %{version}-%{release}
132Requires: libtirpc-devel
133
134%description devel
135The Python programming language's interpreter can be extended with
136dynamically loaded extensions and can be embedded in other programs.
137This package contains the header files and libraries needed to do
138these types of tasks.
139
140Install python-devel if you want to develop Python extensions.  The
141python package will also need to be installed.  You'll probably also
142want to install the python-docs package, which contains Python
143documentation.
144
145%package tkinter
146Summary: A graphical user interface for the Python scripting language.
147Group: programming
148Requires: %{name} = %{version}-%{release}
149Requires: tcl, tk, tix
150Requires: libX11, libxcb, libXau, libXdmcp
151BuildRequires: tcl-devel, tk-devel, tix
152BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
153
154%description tkinter
155The Tkinter (Tk interface) program is an graphical user interface for
156the Python scripting language.
157
158You should install the tkinter package if you'd like to use a graphical
159user interface for Python programming.
160
161
162%package tools
163Summary: A collection of development tools included with Python.
164Group: programming
165Requires: %{name} = %{version}-%{release}
166Requires: %{name}-tkinter = %{version}
167
168%description tools
169The Python package includes several development tools that are used
170to build python programs.
171
172
173%package docs
174Summary: Documentation for the Python programming language.
175Summary(ja): Python プログラミング言語のドキュメント
176Group: documentation
177
178%description docs
179The python-docs package contains documentation on the Python
180programming language and interpreter.  The documentation is provided
181in ASCII text files and in LaTeX source files.
182
183Install the python-docs package if you'd like to use the documentation
184for the Python language.
185
186
187%debug_package
188
189
190%prep
191%setup -q -n Python-%{version}
192# Remove all exe files to ensure we are not shipping prebuilt binaries
193# note that those are only used to create Microsoft Windows installers
194# and that functionality is broken on Linux anyway
195find -name '*.exe' -print -delete
196
197# Remove bundled libraries to ensure that we're using the system copy.
198rm -r Modules/expat
199
200#
201# Apply patches:
202#
203%patch1 -p1
204
205%if "%{_lib}" == "lib64"
206%patch102 -p1
207%endif
208%patch111 -p1
209
210%if %{with rpmwheels}
211%patch189 -p1
212rm Lib/ensurepip/_bundled/*.whl
213%endif
214
215%patch251 -p1
216%patch274 -p1
217%patch328 -p1
218
219# security
220# (none)
221
222# Remove files that should be generated by the build
223# (This is after patching, so that we can use patches directly from upstream)
224rm configure pyconfig.h.in
225
226# Regenerate the configure script and pyconfig.h.in
227autoconf
228autoheader
229
230
231%build
232export CFLAGS="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
233export CFLAGS_NODIST="%{?build_cflags} -D_GNU_SOURCE -fPIC -fwrapv%{?with_no_semantic_interposition: -fno-semantic-interposition}"
234export CXXFLAGS="%{?extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"
235export CPPFLAGS="$(pkg-config --cflags-only-I libffi)"
236export OPT="%{?extension_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
237export LINKCC="gcc"
238export CFLAGS="$CFLAGS $(pkg-config --cflags openssl)"
239export LDFLAGS="%{?extension_ldflags} -g $(pkg-config --libs-only-L openssl)"
240export LDFLAGS_NODIST="%{?build_ldflags}%{?with_no_semantic_interposition: -fno-semantic-interposition} -g $(pkg-config --libs-only-L openssl)"
241
242./configure \
243        --prefix=%{_prefix} \
244        --libdir=%{_libdir} \
245        --enable-ipv6 \
246        --enable-shared \
247        --with-computed-gotos=yes \
248        --with-dbmliborder=gdbm:ndbm:bdb \
249        --with-system-expat \
250        --with-system-ffi \
251        --enable-loadable-sqlite-extensions \
252        --with-lto \
253        --with-ssl-default-suites=openssl \
254        --with-valgrind \
255        --without-ensurepip \
256        --enable-optimizations \
257        %{nil}
258
259make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST" \
260        regen-all PYTHON_FOR_REGEN="python%{binsuffix}"
261
262make %{?_smp_mflags} CFLAGS_NODIST="$CFLAGS_NODIST"
263
264
265%install
266[ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
267make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
268
269# replace path in pydoc
270if [ ! -z "%{binsuffix}" ]
271then
272   (
273      cd $RPM_BUILD_ROOT%{_bindir}
274      mv pydoc%{libvers} pydoc.old
275      sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
276            pydoc.old > pydoc%{libvers}
277      chmod 755 pydoc%{libvers}
278      rm -f pydoc.old
279   )
280fi
281
282#  Tools
283echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
284echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
285echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python_lib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
286echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
287echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
288chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
289#cp -a Tools $RPM_BUILD_ROOT%{python_lib}
290mkdir -p %{buildroot}%{_prefix}/lib/debug%{_libdir}
291cp -f Tools/gdb/libpython.py %{buildroot}%{_prefix}/lib/debug%{_libdir}/%{py_INSTSONAME}-%{version}-%{release}.%{_arch}.debug-gdb.py
292
293# Install pathfix.py to bindir
294# See https://github.com/fedora-python/python-rpm-porting/issues/24
295cp -p Tools/scripts/pathfix.py %{buildroot}%{_bindir}/pathfix%{binsuffix}.py
296
297# Install i18n tools to bindir
298# They are also in python2, so we version them
299# https://bugzilla.redhat.com/show_bug.cgi?id=1571474
300for tool in pygettext msgfmt; do
301  cp -p Tools/i18n/${tool}.py %{buildroot}%{_bindir}/${tool}%{binsuffix}.py
302  ln -s ${tool}%{binsuffix}.py %{buildroot}%{_bindir}/${tool}3.py
303done
304
305# Switch all shebangs to refer to the specific Python version.
306# This currently only covers files matching ^[a-zA-Z0-9_]+\.py$,
307# so handle files named using other naming scheme separately.
308LD_LIBRARY_PATH=./ ./python \
309        Tools/scripts/pathfix.py \
310        -i "%{_bindir}/python%{binsuffix}" -pn \
311        %{buildroot} \
312        %{buildroot}%{_bindir}/{2to3-,idle,pydoc}%{binsuffix} \
313        %{buildroot}%{_bindir}/*%{binsuffix}.py \
314        %{buildroot}%{_libdir}/python%{binsuffix}/cgi.py \
315        %{buildroot}%{_prefix}/lib/debug%{_libdir}/*.py
316
317# Remove shebang lines from .py files that aren't executable, and
318# remove executability from .py files that don't have a shebang line:
319find %{buildroot} -name \*.py \
320  \( \( \! -perm /u+x,g+x,o+x -exec sed -e '/^#!/Q 0' -e 'Q 1' {} \; \
321  -print -exec sed -i '1d' {} \; \) -o \( \
322  -perm /u+x,g+x,o+x ! -exec grep -m 1 -q '^#!' {} \; \
323  -exec chmod a-x {} \; \) \)
324
325# make file lists
326rm -f mainpkg.files
327find "$RPM_BUILD_ROOT"%{python_lib} -type f |
328        sed "s|^${RPM_BUILD_ROOT}|/|" |
329        grep -v \
330                -e '/python%{libvers}/config$' \
331                -e '_tkinter.so$' \
332                -e '_tkinter.cpython-' \
333                -e '/tkinter/' \
334                -e '/turtledemo/' \
335                -e '/idlelib/' \
336                >> mainpkg.files
337
338rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
339find "$RPM_BUILD_ROOT""%{_prefix}"/bin -type f -o -type l |
340        sed "s|^${RPM_BUILD_ROOT}|/|" |
341        grep -v \
342                -e '/idlelib/' \
343                -e '/bin/2to3-%{binsuffix}$' \
344                -e '/bin/msgfmt%{binsuffix}.py' \
345                -e '/bin/pathfix%{binsuffix}.py' \
346                -e '/bin/pygettext%{binsuffix}.py' \
347                -e '/bin/pydoc%{binsuffix}$' \
348                -e '/bin/pydoc%{majorver}$' \
349                -e '/bin/idle%{binsuffix}$' \
350                -e '/bin/idle%{majorver}$' \
351                >> mainpkg.files
352
353rm -f tools.files
354find "$RPM_BUILD_ROOT"%{python_lib}/idlelib \
355      -type f |
356      sed "s|^${RPM_BUILD_ROOT}|/|" > tools.files
357echo %{_bindir}/pydoc%{binsuffix} >> tools.files
358echo %{_bindir}/pydoc%{majorver} >> tools.files
359echo %{_bindir}/idle%{binsuffix} >> tools.files
360echo %{_bindir}/idle%{majorver} >> tools.files
361
362# docs
363mkdir -p "$RPM_BUILD_ROOT"%{config_htmldir}
364(
365   cd "$RPM_BUILD_ROOT"%{config_htmldir}
366   bunzip2 < %{SOURCE1} | tar x
367)
368
369
370%if %{with run_test}
371%check
372make test
373%endif
374
375
376%clean
377rm -fr $RPM_BUILD_ROOT
378
379
380%post -p /sbin/ldconfig
381%postun -p /sbin/ldconfig
382
383
384%files -f mainpkg.files
385%defattr(-, root, root)
386%license LICENSE
387%doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
388%attr(755,root,root) %dir %{python_lib}/
389%{_libdir}/libpython*
390%{_mandir}/man1/python%{libvers}.1*
391%{_mandir}/man1/%{name}.1*
392
393%files devel
394%defattr(-,root,root)
395%{_bindir}/2to3-%{binsuffix}
396%{_bindir}/msgfmt%{binsuffix}.py
397%{_bindir}/pathfix%{binsuffix}.py
398%{_bindir}/pygettext%{binsuffix}.py
399%dir %{_includedir}/python%{libvers}
400%dir %{_includedir}/python%{libvers}/cpython
401%dir %{_includedir}/python%{libvers}/internal
402%{_includedir}/python%{libvers}/*.h
403%{_includedir}/python%{libvers}/cpython/*.h
404%{_includedir}/python%{libvers}/internal/*.h
405%{_libdir}/pkgconfig/*.pc
406%{_prefix}/lib/debug%{_libdir}/*.py
407
408%files -f tools.files tools
409%defattr(-,root,root)
410
411%files tkinter
412%defattr(-,root,root)
413%{python_lib}/__pycache__/turtle.*
414%{python_lib}/tkinter
415%{python_lib}/turtledemo
416%{python_lib}/lib-dynload/_tkinter.*.so*
417
418%files docs
419%defattr(-,root,root)
420%{config_htmldir}/*
421
422
423%changelog
424* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-2
425- fixed %%files.
426
427* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.8-1
428- new upstream release.
429- dropped Patch1000: fixed in upstream.
430
431* Wed Feb 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.7-1
432- new upstream release.
433- dropped Patch1000: fixed in upstream.
434- added Patch1000 to fix CVE-2021-3177.
435
436* Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-2
437- added Patch1000 to fix CVE-2020-27619.
438
439* Fri Oct 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.6-1
440- new upstream release.
441
442* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.5-1
443- new upstream release.
444
445* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.9-1
446- new upstream release.
447
448* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-5
449- fixed %%files.
450
451* Tue Oct 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-4
452- rebuilt with tix-8.4.3-5.
453
454* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-3
455- rebuilt with tcl/tk-8.6.9.
456
457* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.5.7-2
458- rebuild with readline-8.0 and ncurses-6.1
459
460* Sun May 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.7-1
461- new upstream release.
462- rebuilt with gdbm-1.18.1.
463- added R:libtirpc-devel to python3-devel.
464
465* Thu Feb 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-3
466- added BR:libxcrypt-devel.
467- added BR:libtirpc-devel.
468- added BR:libnsl2-devel.
469
470* Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
471- rebuilt with new toolchain.
472
473* Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
474- new upstream release.
475- really rebuilt with openssl-1.1.1.
476
477* Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
478- rebuild with openssl-1.1.1
479
480* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
481- new upstream release
482- update Patch1 (python-3.5.2-lib64.patch)
483
484* Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
485- rebuild with openssl-1.0.2g
486
487* Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
488- new upstream release
489- add Patch2 (python3-3.4.4-revert-makefile.patch)
490
491* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
492- new upstream release
493
494* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
495- rebuilt with readline 6.3
496- changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
497- changed BuildRequires: libdb-devel instead of db4-devel
498
499* Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
500- new upstream release
501- update Patch1 (python-3.4.2-lib64.patch)
502
503* Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
504- remove configure option "--enable-profiling"
505
506* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
507- rebuild with libffi-3.0.13
508
509* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
510- new upstream release
511
512* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
513- updated python to 3.3.2
514
515* Sun Jan  6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
516- build with Tcl/Tk 8.5.7-1
517
518* Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
519- updated python to 3.3.0
520- update Patch1 (python-3.3.0-lib64.patch)
521- add BuildRequires: valgrind-devel
522
523* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
524- updated python to 3.2
525- updated python-*-docs-html to 3.2
526- dropt all patchs
527- added python-3.2b2-lib64.patch
528- referred to the review Python-3.2/Misc/RPM/python-3.2.spec
529
530* Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
531- rebuilt with openssl-1.0.0c
532
533* Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
534- updated python to 3.1.3
535- added python-3.1.3-locale.patch
536- dropt python-3.1.2-lib64.patch
537- added python-3.1.3-lib64-*.patchs
538  python-3.1.3-lib64-Makefile.patch
539  python-3.1.3-lib64-setup.patch
540  python-3.1.3-lib64-site.patch
541  python-3.1.3-lib64-install.patch
542  python-3.1.3-lib64-sysconfig.patch
543  python-3.1.3-lib64-getpath.patch
544  python-3.1.3-lib64-test_install.patch
545- added run_test macro to run unit test
546- added BR: libffi
547
548* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
549- rebuilt with rpm-4.8.1 for pkg-config
550
551* Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
552- spec in utf-8
553
554* Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
555- added missings in BuildRequires, Requires
556
557* Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
558- initial build for VineSeed
559
Note: See TracBrowser for help on using the repository browser.