source: projects/specs/trunk/p/python25/python25-vl.spec @ 1994

Revision 1994, 30.5 KB checked in by owa, 14 years ago (diff)

change python24,25 docs to noarch

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2# If you want to get document, add "--with doc" to rpm option
3%define run_test %{?_run_test:1}%{!?_run_test:0}
4%define with_doc %{?_with_doc:1}%{!?_with_doc:0}
5%define unicode  ucs4
6%define tcl_major 8.4
7%define tk_major 8.4
8%define tix_major 8.4
9%define pybasever 2.5
10%define python_lib %{_libdir}/python%{pybasever}
11Packager: owa
12
13Summary: An interpreted, interactive, object-oriented programming language.
14Summary(ja): オブジェクト指向言語 Python インタプリタ
15Name: python25
16Version: %{pybasever}.5
17Release: 4%{?_dist_release}
18License: PSF - see LICENSE
19Group: Development/Languages
20URL: http://www.python.org/%{pybasever}/
21Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
22Source1: db46_headers.tar.gz
23Source6: shmmodule.c
24# For TEST
25Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
26Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
27Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
28Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
29Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
30Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
31Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
32Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
33Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
34Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
35Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
36Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
37Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
38Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
39
40#Patch0: python-2.5.2-config.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch4: Python-2.3.3-nowhatsnew.patch
43Patch5: Python-2.3.3-distutilrpm.patch
44Patch8: python-2.5.2-lib64.patch
45#Patch9: python-2.5.2-config64.patch
46#Patch10: python-2.5.4-libcrypt.patch
47
48# new Setup patchs include patch-{0, 9, 10}
49Patch11: Python-2.5.4-Setup.patch
50Patch12: Python-2.5.4-Setup64.patch
51
52# Security fixes
53#Patch100: python-2.4.4_CVE-2007-4965.patch
54#Patch110: python-2.4.4_CVE-2008-1721.patch
55#Patch120: python-2.4.4-CVE-2008-1679.patch
56#Patch130: python-2.4.4_CVE-2008-1887.patch
57#Patch140: python-2.4.4_CVE-2007-2052.patch
58
59Conflicts: python = 2.5
60Obsoletes: python2
61Obsoletes: Distutils
62Obsoletes: python-base
63Provides: Distutils
64
65BuildRequires: db4-devel
66BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
67BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
68BuildRequires: tk tix gcc-c++ glibc-devel
69BuildRequires: xorg-x11-devel mesa-libGL-devel
70BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
71BuildRequires: nkf
72BuildRoot: %{_tmppath}/%{name}-%{version}-root
73
74
75%description
76Python is an interpreted, interactive, object-oriented programming
77language often compared to Tcl, Perl, Scheme or Java. Python includes
78modules, classes, exceptions, very high level dynamic data types and
79dynamic typing. Python supports interfaces to many system calls and
80libraries, as well as to various windowing systems (X11, Motif, Tk,
81Mac and MFC).
82
83Programmers can write new built-in modules for Python in C or C++.
84Python can be used as an extension language for applications that need
85a programmable interface. This package contains most of the standard
86Python modules, as well as modules for interfacing to the Tix widget
87set for Tk and RPM.
88
89Note that documentation for Python is provided in the python-docs
90package.
91
92%package devel
93Summary: The libraries and header files needed for Python development.
94Summary(ja): Python での開発に必要なライブラリやヘッダファイル
95Group: Development/Libraries
96Obsoletes: python2-devel
97
98%description devel
99The Python programming language's interpreter can be extended with
100dynamically loaded extensions and can be embedded in other programs.
101This package contains the header files and libraries needed to do
102these types of tasks.
103
104Install python-devel if you want to develop Python extensions.  The
105python package will also need to be installed.  You'll probably also
106want to install the python-docs package, which contains Python
107documentation.
108
109%package tools
110Summary: A collection of development tools included with Python.
111Summary(ja): Python に含まれる開発ツール一式
112Group: Development/Tools
113Requires: %{name} = %{version}
114Requires: %{name}-tkinter = %{version}
115Obsoletes: python2-tools
116
117%description tools
118The Python package includes several development tools that are used
119to build python programs.
120
121%if %{with_doc}
122%package docs
123Summary: Documentation for the Python programming language.
124Summary(ja): Python プログラミング言語のドキュメント
125Group: Applications/Documentation
126BuildArch: noarch
127BuildRequires: latex2html
128Obsoletes: python2-docs
129
130%description docs
131The python-docs package contains documentation on the Python
132programming language and interpreter.  The documentation is provided
133in ASCII text files and in LaTeX source files.
134
135Install the python-docs package if you'd like to use the documentation
136for the Python language.
137%endif
138
139%package tkinter
140Summary: A graphical user interface for the Python scripting language.
141Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
142Group: Development/Languages
143Obsoletes: tkinter2
144BuildRequires: tcl, tk
145Requires: %{name} = %{version}
146Requires: tix
147
148%description tkinter
149The Tkinter (Tk interface) program is an graphical user interface for
150the Python scripting language.
151
152You should install the tkinter package if you'd like to use a graphical
153user interface for Python programming.
154
155%prep
156%setup -q -n Python-%{version} -a 1
157%patch3 -p1 -b .no_gui
158%patch4 -p1 -b .nowhatsnew
159%patch5 -p1
160
161%if %{_lib} == lib64
162%patch8 -p2 -b .lib64
163#%patch9 -p1 -b .config64
164%patch12 -p1 -b .Setup64
165%else
166#%patch0 -p1 -b .config
167%patch11 -p1 -b .Setup
168%endif
169
170#%patch10 -p1 -b .libcrypt
171
172# security fixes
173#%patch100 -p1 -b .CVE-2007-4965
174#%patch110 -p1 -b .CVE-2008-1721
175#%patch120 -p1 -b .CVE-2008-1679
176#%patch130 -p0 -b .CVE-2008-1887
177#%patch140 -p0 -b .CVE-2007-2052
178
179# remove unneeded files
180rm -vf Lib/test/test_*.py.CVE*
181rm -vf Lib/test/test_*.py.orig
182rm -vf Lib/test/test_*.py.org
183
184# Temporary workaround to avoid confusing find-requires: don't ship the tests
185# as executable files
186chmod 0644 Lib/test/test_*.py
187
188# shm module
189cp %{SOURCE6} Modules
190cat >> Modules/Setup.dist << EOF
191
192# Shared memory module
193shm shmmodule.c
194EOF
195
196# Fix library flags
197pushd Modules
198mv Setup.dist Setup.dist.in
199sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
200sed "s|-ltk|-ltk%{tk_major}|" |\
201sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
202rm -f Setup.dist.in
203popd
204
205
206%build
207topdir=`pwd`
208export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
209export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
211export LINKCC="gcc"
212if pkg-config openssl ; then
213        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
214        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
215fi
216%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
217make OPT="$CFLAGS" %{?_smp_mflags}
218
219export LD_LIBRARY_PATH=$topdir
220export PATH="$topdir:$PATH"
221cp $topdir/python $topdir/python%{pybasever}
222$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
223make OPT="$CFLAGS" %{?_smp_mflags}
224
225# Doc
226%if %{with_doc}
227make %{?_smp_mflags} -C Doc
228rm Doc/html/index.html.in
229%endif
230
231# Test
232%if %{run_test}
233cp %{SOURCE7} ./
234cp %{SOURCE8} ./
235cp %{SOURCE9} ./
236cp %{SOURCE10} ./
237cp %{SOURCE11} ./
238cp %{SOURCE12} ./
239cp %{SOURCE13} ./
240cp %{SOURCE14} ./
241cp %{SOURCE15} ./
242cp %{SOURCE16} ./
243cp %{SOURCE17} ./
244cp %{SOURCE18} ./
245cp %{SOURCE19} ./
246cp %{SOURCE20} ./
247# This runs the test set twice (once with no compiled files, once with
248# the compiled files left by the previous test run).
249export LD_LIBRARY_PATH=$topdir
250export PYTHONHOME=$topdir
251export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
252
253find ./Lib -name '*.py[co]' -print | xargs rm -f
254./python -tt ./Lib/test/regrtest.py -l
255./python -tt ./Lib/test/regrtest.py -l
256#./python -tt ./Lib/test/test_bsddb.py -l
257#./python -tt ./Lib/test/test_bsddb.py -l
258%endif
259
260
261%install
262rm -fr $RPM_BUILD_ROOT
263mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
264
265# Clean up patched .py files that are saved as .lib64
266for f in distutils/command/install distutils/sysconfig; do
267    rm -f Lib/$f.py.lib64
268done
269
270make DESTDIR=$RPM_BUILD_ROOT install
271
272# Fix the interpreter path in binaries installed by distutils
273# (which changes them by itself)
274# Make sure we preserve the file permissions
275for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
276    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
277        && cat $fixed- > $fixed && rm -f $fixed-
278done
279
280# tools
281mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
282
283echo "#!/bin/bash
284exec %{python_lib}/site-packages/pynche/pynche" \
285        > $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
286chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche%{pybasever}
287
288echo "#!/bin/bash
289exec %{python_lib}/site-packages/modulator/modulator.py" \
290        > $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
291chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator%{pybasever}
292
293# idle
294mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
295install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
296
297sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/usr/bin/idle > $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
298chmod 755 $RPM_BUILD_ROOT/usr/bin/idle%{pybasever}
299
300install -m755 $RPM_BUILD_ROOT%{_bindir}/pydoc $RPM_BUILD_ROOT%{_bindir}/pydoc%{pybasever}
301install -m755 $RPM_BUILD_ROOT%{_bindir}/smtpd.py $RPM_BUILD_ROOT%{_bindir}/smtpd%{pybasever}.py
302
303#modulator
304cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
305
306#pynche
307rm -f Tools/pynche/*.pyw
308cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
309
310(mv Tools/modulator/README Tools/modulator/README.modulator)
311(mv Tools/pynche/README Tools/pynche/README.pynche)
312
313#gettext
314install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/pygettext%{pybasever}.py
315install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/msgfmt%{pybasever}.py
316
317# Get rid of crap
318find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
319find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
320find . -name "*~"|xargs rm -f
321find . -name ".cvsignore"|xargs rm -f
322#zero length
323rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
324
325# Clean up the testsuite - we don't need compiled files for it
326find $RPM_BUILD_ROOT%{python_lib}/test \
327    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
328rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
329
330find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
331
332# Fix the file permissions
333chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
334chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
335find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
336
337## remove unuse files
338rm -f $RPM_BUILD_ROOT%{_mandir}/man1/python*
339rm -f $RPM_BUILD_ROOT%{_bindir}/idle
340rm -f $RPM_BUILD_ROOT%{_bindir}/pydoc
341rm -f $RPM_BUILD_ROOT%{_bindir}/python
342rm -f $RPM_BUILD_ROOT%{_bindir}/python-config
343rm -f $RPM_BUILD_ROOT%{_bindir}/smtpd.py
344
345%clean
346rm -fr $RPM_BUILD_ROOT
347
348%files -f dynfiles
349%defattr(-, root, root)
350%doc LICENSE README
351%{_bindir}/python%{pybasever}
352%{_bindir}/python%{pybasever}-config
353%{_libdir}/libpython%{pybasever}.so*
354%dir %{python_lib}
355%dir %{python_lib}/lib-dynload
356%dir %{python_lib}/site-packages
357%{python_lib}/*.py*
358%{python_lib}/*.doc
359%{python_lib}/bsddb
360%{python_lib}/compiler
361%{python_lib}/ctypes
362%{python_lib}/curses
363%{python_lib}/distutils
364%{python_lib}/email
365%{python_lib}/encodings
366%{python_lib}/hotshot
367%{python_lib}/idlelib
368%{python_lib}/logging
369%{python_lib}/plat-linux2
370%{python_lib}/sqlite3
371%{python_lib}/wsgiref
372%{python_lib}/wsgiref.egg-info
373%{python_lib}/xml
374
375%files devel
376%defattr(-,root,root)
377%{_includedir}/*
378%{python_lib}/config
379%{python_lib}/test
380
381%files tools
382%defattr(-,root,root,755)
383%doc Tools/modulator/README.modulator
384%doc Tools/pynche/README.pynche
385%{python_lib}/site-packages
386%{_bindir}/idle%{pybasever}
387%{_bindir}/modulator%{pybasever}
388%{_bindir}/msgfmt%{pybasever}.py
389%{_bindir}/pydoc%{pybasever}
390%{_bindir}/pygettext%{pybasever}.py
391%{_bindir}/pynche%{pybasever}
392%{_bindir}/smtpd%{pybasever}.py
393
394%if %{with_doc}
395%files docs
396%defattr(-,root,root,755)
397%doc Misc/NEWS  Misc/README Misc/cheatsheet
398%doc Misc/HISTORY Doc/html
399%endif
400
401%files tkinter
402%defattr(-,root,root,755)
403%{python_lib}/lib-tk
404%{python_lib}/lib-dynload/_tkinter.so
405
406%changelog
407* Tue Oct 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-4
408- changed %{name}-docs to noarch
409
410* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-3
411- rebuilt with rpm-4.8.1 for pkg-config
412
413* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-2
414- added db46_headers.tar.gz
415- update Setup.dist{32,64}.patch
416- s/BuildPreReq/BuildRequires/
417
418* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
419- forked python to python25
420- renamed tkinter to python25-tkinter
421
422* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
423- updated python to 2.5.5
424
425* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
426- added Python-2.5.4-{Setup,Setup64}.patch
427  - added _bsddb module
428  - dropt patch{0,9,10}
429
430* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
431- updated Patch0 for building with db-4.6.21
432
433* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
434- add patch10
435  - add -lcrypt for cryptmodule
436
437* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
438- new upstream release
439- changed typo of summary(ja)
440
441* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
442- new upstream release
443- dropt python-2.4.4_CVE-2007-4965.patch
444- dropt python-2.4.4_CVE-2008-1721.patch
445- dropt python-2.4.4-CVE-2008-1679.patch
446
447* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
448- updated python to 2.5.2
449- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
450- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
451- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
452- added modules ctypes, sqlite3, and wsgiref
453- dropt modules lib-old
454- dropt python-2.4.4_CVE-2008-1887.patch
455- dropt python-2.4.4_CVE-2007-2052.patch
456- fixed the file permissions
457
458* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
459- applied new versioning policy and spec in utf-8
460- added BuildPrereq: xorg-x11-devel
461- imported updates from Vine4.2
462        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
463        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
464        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
465        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
466        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
467        - add patch110 CVE-2008-1721 (zlib module)
468        - add remove unneeded files in Lib/test/
469        #- new versioning policy
470
471* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
472- updated python to 2.4.5
473
474* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
475- rebuild with expat-2.0.1
476
477* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
478- fix typo on Patch0 (s/db-4.2/db-4.3/)
479
480* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
481- rebuild with tcl/tk-8.4.18
482
483* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
484- imported updates from Vine4.2 Plus
485        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
486        - add BuildPrereq: nkf
487        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
488        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
489
490* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
491- rebuilt with openssl-0.9.8e and tix-8.4.2
492- fixed spec file encoding
493
494* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
495- rebuilt with new toolchain and db4-4.3.x
496- modified Patch0 (s/db-4.2/db-4.3/)
497
498* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
499- updated python to 2.4.4 (included security fix PSF-2006-001)
500- added japanese summary
501- updated patch8 (python-2.4.2-lib64.patch)
502- added patch9 (python-2.4.4c1-setup.lib64.patch)
503
504* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
505- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
506
507* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
508- rebuild with readline-5.1 (x86_64)
509
510* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
511- fixed python-2.4.3-config.patch cause undefined symbol: crypt
512
513* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
514- updated python to 2.4.3
515- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
516
517* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
518- set permition of lib-dynload/*.so to 755
519- added without_doc option
520- rebuilt with x86_64
521
522* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
523- add run_test option
524
525* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
526- add BuildPrereq: bzip2-devel
527- arrange testing script
528
529* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
530- back to %%configure macro
531- change testing script
532
533* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
534- update Patch8 (VineSeed:10306)
535- use ./configure instead of %%configure script
536- add forgotten popd
537
538* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
539- add --enable-shared to confiugre option
540- add %%{_libdir}/libpython2.4.so* to python package
541- add LD_LIBRARY_PATH=$topdir to use pathfix.py
542- change build method of Doc
543- add files for make test
544- change install method
545
546* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
547- update python to 2.4.2 (final)
548
549* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
550- update python to 2.4.1 (final)
551
552* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
553- update python to 2.4.1c2
554- moved all site-packages files to python-tools package
555
556* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
557- update python to 2.4.1c1
558- droped aspython2 macros
559- droped japanese-codecs module
560- droped Source2 idle, now it's provided from original source
561- droped Source3 modulator, now it's generated in a spec file
562- droped Source4 pynche, now it's generated in a spec file
563- droped Python-2.3.3-buildroot-bytecode.patch
564- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
565
566* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
567- update python to 2.3.5
568
569* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
570- add PSF-2005-001.patch
571
572* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
573- rebuilt
574
575* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
576- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
577
578* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
579- rebuilt with db4-4.2.25
580
581* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
582- updated python to 2.3.4
583- fixed patch10, patch11
584
585* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
586- rebuild
587
588* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
589- updated python-2.3.3-config2.patch
590
591* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
592- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
593
594* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
595- updated python to 2.3.3
596- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
597- updated config2.patch for 2.3.3
598- updated nowhatsnew.patch for 2.3.3
599- updated distutilrpm.patch in which tabstops have made indent error
600- updated buildroot-bytecode.patch for 2.3.3
601- deleted buildroot.patch which fixed in 2.3.3
602- changed Tools/idle with Lib/idlelib
603
604* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
605- rebuild with openssl-0.9.7d
606
607* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
608- updated JapaneseCodecs to 1.4.10
609
610* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
611- synced with RawHide 2.2.3-3 (substantially source ver up)
612
613* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
614- rebuild with tcltk-8.4.2
615- synced with RawHide 2.2.2-26
616  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
617  - rebuilt
618
619  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
620  - Fixed bug #84886: pydoc dies when run w/o arguments
621  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
622  - Fixed bug #84966: path in byte-compiled code still wrong
623
624  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
625  - ftp uri's should be able to specify being rooted at the root instead of
626    where you login via ftp (#84692)
627
628  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
629  - Using newer Japanese codecs (1.4.9). Thanks to
630    Peter Bowen <pzb@datastacks.com> for pointing this out.
631
632  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
633  - Rebuild
634
635  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
636  - Release number bumped really high: turning on UCS4 (ABI compatibility
637    breakage)
638
639  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
640  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
641    some work on python-2.2.2-lib64.patch
642
643  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
644  - Rebuild to incorporate the removal of .lib64 and - files.
645
646  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
647  - Fixed bug #82544: Errata removes most tools
648  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
649  - Removed .lib64 and - files that get installed after we fix the multilib
650    .py files.
651
652  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
653  - rebuilt
654
655  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
656  - rebuild to update tkinter's tcltk deps
657  - convert changelog to utf-8
658
659
660* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
661- rebuilt for Vine Linux against db4
662- obsolete python-base (which comes with python-2.2.1 of TestPkg)
663
664* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
665- rebuild
666
667* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
668- pick up OpenSSL cflags and ldflags from pkgconfig if available
669
670* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
671- urllib2 didn't support non-anonymous ftp.  add support based on how
672  urllib did it (#80676, #78168)
673
674* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
675- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
676- Added a bunch of missing BuildRequires found while fixing the
677  above-mentioned bug
678
679* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
680- rebuild to fix broken tcltk deps for tkinter
681
682* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6832.2.2-3.7.3
684- Recompiled for 7.3 (to fix the -lcrypt bug)
685- Fix for the spurious error message at the end of the build (build-requires
686  gets confused by executable files starting with """"): make the tests
687  non-executable.
688
689* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6902.2.2-5
691- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
692
6932.2.2-4
694- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
695  with the C++ compiler.
696
697* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6982.2.2-3.*
699- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
700  use %%{_libdir}
701- Added XFree86-libs as BuildRequires (because of tkinter)
702- Fixed duplicate listing of plat-linux2
703- Fixed exclusion of lib-dynload/japanese
704- Added lib64 patch for the japanese codecs
705- Use setup magic instead of using tar directly on JapaneseCodecs
706
707* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7082.2.2-2
709- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
710  requirement of tkinter from python-tools).
711- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
712
713* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
714- builds as python2 require a different libdb
715- changed the buildroot name of python to match python2 builds
716
717* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
718- updated python to 2.2.2 and adjusted the patches accordingly
719
720* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
721- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
722- Added BuildPrereq dependency on gcc-c++
723
724* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
725- security fix for _execvpe
726
727* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
728- Fix  #71011,#71134, #58157
729
730* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
731- Resurrect tkinter
732- Fix for distutils (#67671)
733- Fix #69962
734
735* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
736- Obsolete tkinter/tkinter2 (#69838)
737
738* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
739- Doc fixes (#53951) - not on alpha at the momemt
740
741* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
742- fix pydoc (#68082)
743
744* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
745- Add db4-devel as a BuildPrereq
746
747* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
748- automated rebuild
749
750* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
751- Add Japanese codecs (#66352)
752
753* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
754- No more tkinter...
755
756* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
757- Rebuild
758
759* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
760- Add the email subcomponent (#65301)
761
762* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
763- Rebuild
764
765* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
766- rebuild i new enviroment
767
768* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
769- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
770
771* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
772- Make it use db4
773
774* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
775- 2.2.1 - a bugfix-only release
776
777* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
778- the same, but in builddirs - this will remove them from the
779  docs package, which doesn't look in the buildroot for files.
780
781* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
782- Get rid of temporary files and .cvsignores included
783  in the tarball and make install
784
785* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
786- Don't own lib-tk in main package, only in tkinter (#62753)
787
788* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
789- rebuild
790
791* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
792- rebuild
793
794* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
795- Add a not to the Distutils obsoletes test (doh!)
796
797* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
798- Rebuild
799
800* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
801- Only obsolete Distutils when built as python
802
803* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
804- Make files in /usr/bin install side by side with python 1.5 when
805- Drop explicit requirement of db4
806  built as python2
807
808* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
809- Use version and pybasever macros to make updating easy
810- Use _smp_mflags macro
811
812* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
813- Add db4-devel to BuildPrereq
814
815* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
816- disable ndbm support, which is db2 in disguise (really interesting things
817  can happen when you mix db2 and db4 in a single application)
818
819* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
820- Obsolete subpackages if necesarry
821- provide versioned python2
822- build with db4
823
824* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
825- Alpha toolchain broken. Disable build on alpha.
826- New openssl
827
828* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
829- 2.2 final
830
831* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
832- 2.2 RC 1
833- Don't include the _tkinter module in the main package - it's
834  already in the tkiter packace
835- Turn off the mpzmodule, something broke in the buildroot
836
837* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
838- Use -fPIC for OPT as well, in lack of a proper libpython.so
839
840* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
841- changed DESTDIR to point to / so that distutils will install dynload
842  modules properly in the installroot
843
844* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
845- 2.2b2
846
847* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
848- python2ify
849
850* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
851- 2.2b1
852
853* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
854- 2.2a4
855- Enable UCS4 support
856- Enable IPv6
857- Provide distutils
858- Include msgfmt.py and pygettext.py
859
860* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
861- Obsolete Distutils, which is now part of the main package
862- Obsolete python2
863
864* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
865- Add docs, tools and tkinter subpackages, to match the 1.5 layout
866
867* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
868- 2.2a3
869- don't build tix and blt extensions
870
871* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
872- Add tk and tix to build dependencies
873
874* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
875- 2.1.1 bugfix release - with a GPL compatible license
876
877* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
878- Add new build dependencies (#49753)
879
880* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
881- build with -fPIC
882
883* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
884- 2.1
885- reorganization of file includes
886
887* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
888- fix the "requires" clause, it lacked a space causing problems
889- use %%{_tmppath}
890- don't define name, version etc
891- add the available patches from the Python home page
892
893* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
894- added devel subpackage
895
896* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
897- modify all files to use "python2.0" as the intrepter
898- don't build the Expat bindings
899- build against db1
900
901* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
902- updated for 2.0 final
903
904* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
905- updated for 2.0c1
906- build audioop, imageop, and rgbimg extension modules
907- include xml.parsers subpackage
908- add test.xml.out to files list
909
910* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
911- added bin/python2.0 to files list (suggested by Martin v. Loewis)
912
913* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
914- updated for release 1 of 2.0b2
915- use .bz2 version of Python source
916
917* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
918- Version 2 of 2.0b1
919- Make the package relocatable.  Thanks to Suchandra Thapa.
920- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
921  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.