source: projects/specs/trunk/p/python24/python24-vl.spec @ 1994

Revision 1994, 29.1 KB checked in by owa, 14 years ago (diff)

change python24,25 docs to noarch

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2# If you want to get document, add "--with doc" to rpm option
3%define run_test %{?_run_test:1}%{!?_run_test:0}
4%define with_doc %{?_with_doc:1}%{!?_with_doc:0}
5%define unicode  ucs4
6%define tcl_major 8.4
7%define tk_major 8.4
8%define tix_major 8.4
9%define pybasever 2.4
10%define python_lib %{_libdir}/python%{pybasever}
11Packager: owa
12
13Summary: An interpreted, interactive, object-oriented programming language.
14Summary(ja): オブジェクト指向言語 Python2.4 インタプリタ
15Name: python24
16Version: 2.4.6
17Release: 5%{?_dist_release}
18License: PSF - see LICENSE
19Group: Development/Languages
20URL: http://www.python.org/2.4/
21Source0: Python-%{version}.tar.bz2
22Source1: db46_headers.tar.gz
23#Source6: http://gigue.peabody.jhu.edu/~mdboom/omi/source/shm_source/shmmodule.c
24Source6: shmmodule.c
25# For TEST
26Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
27Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
28Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
29Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
30Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
31Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
32Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
33Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
34Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
35Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
36Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
37Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
38Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
39Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
40
41
42#Patch0: python-2.4.6-config.patch
43Patch3: Python-2.2.1-pydocnogui.patch
44Patch4: Python-2.3.3-nowhatsnew.patch
45Patch5: Python-2.3.3-distutilrpm.patch
46
47#Patch8: python-2.4.2-lib64.patch
48#Patch9: python-2.4.4c1-setup.lib64.patch
49Patch10: python-2.4.6-Setup.patch
50Patch11: python-2.4.6-Setup64.patch
51Patch12: python-2.4.6-lib64.patch
52Patch13: python-2.4.6-bsddb.patch
53
54# Security fixes
55Patch100: python-2.4.4_CVE-2007-4965.patch
56Patch110: python-2.4.4_CVE-2008-1721.patch
57Patch120: python-2.4.4-CVE-2008-1679.patch
58Patch130: python-2.4.4_CVE-2008-1887.patch
59Patch140: python-2.4.4_CVE-2007-2052.patch
60
61Obsoletes: python2
62Obsoletes: Distutils
63Obsoletes: python-base
64Provides: Distutils
65Provides: python2.4
66
67BuildRequires: db4-devel
68BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
69BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel
70BuildRequires: tk tix gcc-c++ glibc-devel
71BuildRequires: xorg-x11-devel mesa-libGL-devel
72BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
73BuildRequires: nkf
74BuildRoot: %{_tmppath}/%{name}-%{version}-root
75
76%description
77Python is an interpreted, interactive, object-oriented programming
78language often compared to Tcl, Perl, Scheme or Java. Python includes
79modules, classes, exceptions, very high level dynamic data types and
80dynamic typing. Python supports interfaces to many system calls and
81libraries, as well as to various windowing systems (X11, Motif, Tk,
82Mac and MFC).
83
84Programmers can write new built-in modules for Python in C or C++.
85Python can be used as an extension language for applications that need
86a programmable interface. This package contains most of the standard
87Python modules, as well as modules for interfacing to the Tix widget
88set for Tk and RPM.
89
90Note that documentation for Python is provided in the python-docs
91package.
92
93%package devel
94Summary: The libraries and header files needed for Python development.
95Summary(ja): Python での開発に必要なライブラリやヘッダファイル
96Group: Development/Libraries
97Obsoletes: python2-devel
98
99%description devel
100The Python programming language's interpreter can be extended with
101dynamically loaded extensions and can be embedded in other programs.
102This package contains the header files and libraries needed to do
103these types of tasks.
104
105Install python-devel if you want to develop Python extensions.  The
106python package will also need to be installed.  You'll probably also
107want to install the python-docs package, which contains Python
108documentation.
109
110%package tools
111Summary: A collection of development tools included with Python.
112Summary(ja): Python に含まれる開発ツール一式
113Group: Development/Tools
114Requires: %{name} = %{version}
115Requires: %{name}-tkinter = %{version}
116Obsoletes: python2-tools
117
118%description tools
119The Python package includes several development tools that are used
120to build python programs.
121
122%if %{with_doc}
123%package docs
124Summary: Documentation for the Python programming language.
125Summary(ja): Python プログラミング言語のドキュメント
126Group: Applications/Documentation
127BuildArch: noarch
128BuildRequires: latex2html
129Obsoletes: python2-docs
130
131%description docs
132The python-docs package contains documentation on the Python
133programming language and interpreter.  The documentation is provided
134in ASCII text files and in LaTeX source files.
135
136Install the python-docs package if you'd like to use the documentation
137for the Python language.
138%endif
139
140%package tkinter
141Summary: A graphical user interface for the Python scripting language.
142Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
143Group: Development/Languages
144Obsoletes: tkinter2
145BuildRequires:  tcl, tk
146Requires: %{name} = %{version}
147Requires: tix
148
149%description tkinter
150The Tkinter (Tk interface) program is an graphical user interface for
151the Python scripting language.
152
153You should install the tkinter package if you'd like to use a graphical
154user interface for Python programming.
155
156%prep
157%setup -q -n Python-%{version} -a 1
158
159#%patch0 -p1 -b .Setup
160%patch3 -p1 -b .no_gui
161%patch4 -p1 -b .nowhatsnew
162%patch5 -p1
163
164%if %{_lib} == lib64
165%patch11 -p1 -b .Setup64
166%patch12 -p1 -b .lib64
167%else
168%patch10 -p1 -b .Setup
169%endif
170%patch13 -p1 -b .bsddb
171
172
173# security fixes
174#%patch100 -p1 -b .CVE-2007-4965
175#%patch110 -p1 -b .CVE-2008-1721
176#%patch120 -p1 -b .CVE-2008-1679
177#%patch130 -p0 -b .CVE-2008-1887
178%patch140 -p0 -b .CVE-2007-2052
179
180# remove unneeded files
181rm -vf Lib/test/test_*.py.CVE*
182rm -vf Lib/test/test_*.py.orig
183rm -vf Lib/test/test_*.py.org
184
185# Temporary workaround to avoid confusing find-requires: don't ship the tests
186# as executable files
187chmod 0644 Lib/test/test_*.py
188
189# shm module
190cp %{SOURCE6} Modules
191cat >> Modules/Setup.dist << EOF
192
193# Shared memory module
194shm shmmodule.c
195EOF
196
197# Fix library flags
198pushd Modules
199mv Setup.dist Setup.dist.in
200sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
201sed "s|-ltk|-ltk%{tk_major}|" |\
202sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
203rm -f Setup.dist.in
204popd
205
206
207%build
208topdir=`pwd`
209export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
210export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
211export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
212export LINKCC="gcc"
213if pkg-config openssl ; then
214        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
215        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
216fi
217%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
218
219make OPT="$CFLAGS" %{?_smp_mflags}
220LD_LIBRARY_PATH=$topdir $topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
221make OPT="$CFLAGS" %{?_smp_mflags}
222
223# Doc
224%if %{with_doc}
225make %{?_smp_mflags} -C Doc
226rm Doc/html/index.html.in
227%endif
228
229# Test
230%if %{run_test}
231cp %{SOURCE7} ./
232cp %{SOURCE8} ./
233cp %{SOURCE9} ./
234cp %{SOURCE10} ./
235cp %{SOURCE11} ./
236cp %{SOURCE12} ./
237cp %{SOURCE13} ./
238cp %{SOURCE14} ./
239cp %{SOURCE15} ./
240cp %{SOURCE16} ./
241cp %{SOURCE17} ./
242cp %{SOURCE18} ./
243cp %{SOURCE19} ./
244cp %{SOURCE20} ./
245# This runs the test set twice (once with no compiled files, once with
246# the compiled files left by the previous test run).
247export LD_LIBRARY_PATH=$topdir
248export PYTHONHOME=$topdir
249export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
250
251find ./Lib -name '*.py[co]' -print | xargs rm -f
252./python -tt ./Lib/test/regrtest.py -l
253./python -tt ./Lib/test/regrtest.py -l
254#./python -tt ./Lib/test/test_bsddb.py -l
255#./python -tt ./Lib/test/test_bsddb.py -l
256%endif
257
258
259%install
260rm -fr $RPM_BUILD_ROOT
261mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
262
263# Clean up patched .py files that are saved as .lib64
264for f in distutils/command/install distutils/sysconfig; do
265    rm -f Lib/$f.py.lib64
266done
267
268make DESTDIR=$RPM_BUILD_ROOT install
269
270# Fix the interpreter path in binaries installed by distutils
271# (which changes them by itself)
272# Make sure we preserve the file permissions
273for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
274    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
275        && cat $fixed- > $fixed && rm -f $fixed-
276done
277
278# tools
279mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
280
281echo "#!/bin/bash
282exec %{python_lib}/site-packages/pynche/pynche" \
283        > $RPM_BUILD_ROOT/usr/bin/pynche
284chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
285
286echo "#!/bin/bash
287exec %{python_lib}/site-packages/modulator/modulator.py" \
288        > $RPM_BUILD_ROOT/usr/bin/modulator
289chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
290
291# idle
292mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
293install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
294mv $RPM_BUILD_ROOT/usr/bin/idle $RPM_BUILD_ROOT/idle
295sed "s/python/&%{pybasever}/" $RPM_BUILD_ROOT/idle > $RPM_BUILD_ROOT/usr/bin/idle
296chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
297rm $RPM_BUILD_ROOT/idle
298
299#modulator
300cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
301
302#pynche
303rm -f Tools/pynche/*.pyw
304cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
305
306(mv Tools/modulator/README Tools/modulator/README.modulator)
307(mv Tools/pynche/README Tools/pynche/README.pynche)
308
309#gettext
310install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
311install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
312
313# Get rid of crap
314find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
315find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
316find . -name "*~"|xargs rm -f
317find . -name ".cvsignore"|xargs rm -f
318#zero length
319rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
320
321# Clean up the testsuite - we don't need compiled files for it
322find $RPM_BUILD_ROOT%{python_lib}/test \
323    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
324rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
325
326find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
327
328chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
329chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
330
331## move conflict files
332mkdir -p $RPM_BUILD_ROOT%{python_lib}/bin
333mv $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{python_lib}/bin
334mv $RPM_BUILD_ROOT%{python_lib}/bin/python%{pybasever} $RPM_BUILD_ROOT%{_bindir}/
335rm -rf $RPM_BUILD_ROOT%{_mandir}
336
337%clean
338rm -fr $RPM_BUILD_ROOT
339
340
341%files -f dynfiles
342%defattr(-, root, root)
343%doc LICENSE README
344%{_bindir}/python%{pybasever}
345%{_libdir}/libpython%{pybasever}.so*
346%dir %{python_lib}
347%dir %{python_lib}/bin
348%dir %{python_lib}/lib-dynload
349%dir %{python_lib}/site-packages
350%{python_lib}/bin/python
351%{python_lib}/*.py*
352%{python_lib}/*.doc
353%{python_lib}/bsddb
354%{python_lib}/compiler
355%{python_lib}/curses
356%{python_lib}/distutils
357%{python_lib}/email
358%{python_lib}/encodings
359%{python_lib}/hotshot
360%{python_lib}/idlelib
361%{python_lib}/lib-old
362%{python_lib}/logging
363%{python_lib}/plat-linux2
364%{python_lib}/xml
365#%{_mandir}/*/*
366
367%files devel
368%defattr(-,root,root)
369%{_includedir}/*
370%{python_lib}/config
371%{python_lib}/test
372
373%files tools
374%defattr(-,root,root,755)
375%doc Tools/modulator/README.modulator
376%doc Tools/pynche/README.pynche
377%exclude %{python_lib}/bin/python
378%{python_lib}/bin/*
379%{python_lib}/site-packages
380
381%if %{with_doc}
382%files docs
383%defattr(-,root,root,755)
384%doc Misc/NEWS  Misc/README Misc/cheatsheet
385%doc Misc/HISTORY Doc/html
386%endif
387
388%files tkinter
389%defattr(-,root,root,755)
390%{python_lib}/lib-tk
391%{python_lib}/lib-dynload/_tkinter.so
392
393%changelog
394* Tue Oct 05 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-5
395- changed %{name}-docs to noarch
396
397* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-4
398- rebuilt with rpm-4.8.1 for pkg-config
399
400* Tue Apr 20 2010 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-3
401- added db46_headers.tar.gz
402- update Setup.dist{32,64}.patch
403- changed default to '--without doc'
404- s/BuildPreReq/BuildRequires/
405
406* Thu May 07 2009 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-2vl5
407- added python-2.4.6-{Setup,Setup64,lib64}.patch
408  - added _bsddb module
409  - dropt Patch{0,8,9}
410- added python-2.4.6-bsddb.patch
411
412* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.6-1vl5
413- new upstream release
414- dropt python-2.4.4_CVE-2007-4965.patch
415- dropt python-2.4.4_CVE-2008-1721.patch
416- dropt python-2.4.4-CVE-2008-1679.patch
417- dropt python-2.4.4_CVE-2008-1887.patch
418
419* Wed Oct 22 2008 Shu KONNO <owa@bg.wakwak.com> python2.4-2.4.5-1vl5
420- new package name is %{name}
421- new sub-package name is %{name}-*
422
423* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
424- applied new versioning policy and spec in utf-8
425- added BuildPrereq: xorg-x11-devel
426- imported updates from Vine4.2
427        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
428        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
429        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
430        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
431        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
432        - add patch110 CVE-2008-1721 (zlib module)
433        - add remove unneeded files in Lib/test/
434        #- new versioning policy
435
436* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
437- updated python to 2.4.5
438
439* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
440- rebuild with expat-2.0.1
441
442* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
443- fix typo on Patch0 (s/db-4.2/db-4.3/)
444
445* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
446- rebuild with tcl/tk-8.4.18
447
448* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
449- imported updates from Vine4.2 Plus
450        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
451        - add BuildPrereq: nkf
452        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
453        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
454
455* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
456- rebuilt with openssl-0.9.8e and tix-8.4.2
457- fixed spec file encoding
458
459* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
460- rebuilt with new toolchain and db4-4.3.x
461- modified Patch0 (s/db-4.2/db-4.3/)
462
463* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
464- updated python to 2.4.4 (included security fix PSF-2006-001)
465- added japanese summary
466- updated patch8 (python-2.4.2-lib64.patch)
467- added patch9 (python-2.4.4c1-setup.lib64.patch)
468
469* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
470- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
471
472* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
473- rebuild with readline-5.1 (x86_64)
474
475* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
476- fixed python-2.4.3-config.patch cause undefined symbol: crypt
477
478* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
479- updated python to 2.4.3
480- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
481
482* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
483- set permition of lib-dynload/*.so to 755
484- added without_doc option
485- rebuilt with x86_64
486
487* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
488- add run_test option
489
490* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
491- add BuildPrereq: bzip2-devel
492- arrange testing script
493
494* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
495- back to %%configure macro
496- change testing script
497
498* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
499- update Patch8 (VineSeed:10306)
500- use ./configure instead of %%configure script
501- add forgotten popd
502
503* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
504- add --enable-shared to confiugre option
505- add %%{_libdir}/libpython2.4.so* to python package
506- add LD_LIBRARY_PATH=$topdir to use pathfix.py
507- change build method of Doc
508- add files for make test
509- change install method
510
511* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
512- update python to 2.4.2 (final)
513
514* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
515- update python to 2.4.1 (final)
516
517* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
518- update python to 2.4.1c2
519- moved all site-packages files to python-tools package
520
521* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
522- update python to 2.4.1c1
523- droped aspython2 macros
524- droped japanese-codecs module
525- droped Source2 idle, now it's provided from original source
526- droped Source3 modulator, now it's generated in a spec file
527- droped Source4 pynche, now it's generated in a spec file
528- droped Python-2.3.3-buildroot-bytecode.patch
529- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
530
531* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
532- update python to 2.3.5
533
534* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
535- add PSF-2005-001.patch
536
537* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
538- rebuilt
539
540* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
541- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
542
543* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
544- rebuilt with db4-4.2.25
545
546* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
547- updated python to 2.3.4
548- fixed patch10, patch11
549
550* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
551- rebuild
552
553* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
554- updated python-2.3.3-config2.patch
555
556* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
557- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
558
559* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
560- updated python to 2.3.3
561- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
562- updated config2.patch for 2.3.3
563- updated nowhatsnew.patch for 2.3.3
564- updated distutilrpm.patch in which tabstops have made indent error
565- updated buildroot-bytecode.patch for 2.3.3
566- deleted buildroot.patch which fixed in 2.3.3
567- changed Tools/idle with Lib/idlelib
568
569* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
570- rebuild with openssl-0.9.7d
571
572* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
573- updated JapaneseCodecs to 1.4.10
574
575* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
576- synced with RawHide 2.2.3-3 (substantially source ver up)
577
578* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
579- rebuild with tcltk-8.4.2
580- synced with RawHide 2.2.2-26
581  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
582  - rebuilt
583
584  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
585  - Fixed bug #84886: pydoc dies when run w/o arguments
586  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
587  - Fixed bug #84966: path in byte-compiled code still wrong
588
589  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
590  - ftp uri's should be able to specify being rooted at the root instead of
591    where you login via ftp (#84692)
592
593  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
594  - Using newer Japanese codecs (1.4.9). Thanks to
595    Peter Bowen <pzb@datastacks.com> for pointing this out.
596
597  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
598  - Rebuild
599
600  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
601  - Release number bumped really high: turning on UCS4 (ABI compatibility
602    breakage)
603
604  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
605  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
606    some work on python-2.2.2-lib64.patch
607
608  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
609  - Rebuild to incorporate the removal of .lib64 and - files.
610
611  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
612  - Fixed bug #82544: Errata removes most tools
613  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
614  - Removed .lib64 and - files that get installed after we fix the multilib
615    .py files.
616
617  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
618  - rebuilt
619
620  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
621  - rebuild to update tkinter's tcltk deps
622  - convert changelog to utf-8
623
624
625* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
626- rebuilt for Vine Linux against db4
627- obsolete python-base (which comes with python-2.2.1 of TestPkg)
628
629* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
630- rebuild
631
632* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
633- pick up OpenSSL cflags and ldflags from pkgconfig if available
634
635* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
636- urllib2 didn't support non-anonymous ftp.  add support based on how
637  urllib did it (#80676, #78168)
638
639* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
640- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
641- Added a bunch of missing BuildRequires found while fixing the
642  above-mentioned bug
643
644* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
645- rebuild to fix broken tcltk deps for tkinter
646
647* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6482.2.2-3.7.3
649- Recompiled for 7.3 (to fix the -lcrypt bug)
650- Fix for the spurious error message at the end of the build (build-requires
651  gets confused by executable files starting with """"): make the tests
652  non-executable.
653
654* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6552.2.2-5
656- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
657
6582.2.2-4
659- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
660  with the C++ compiler.
661
662* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6632.2.2-3.*
664- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
665  use %%{_libdir}
666- Added XFree86-libs as BuildRequires (because of tkinter)
667- Fixed duplicate listing of plat-linux2
668- Fixed exclusion of lib-dynload/japanese
669- Added lib64 patch for the japanese codecs
670- Use setup magic instead of using tar directly on JapaneseCodecs
671
672* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6732.2.2-2
674- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
675  requirement of tkinter from python-tools).
676- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
677
678* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
679- builds as python2 require a different libdb
680- changed the buildroot name of python to match python2 builds
681
682* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
683- updated python to 2.2.2 and adjusted the patches accordingly
684
685* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
686- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
687- Added BuildPrereq dependency on gcc-c++
688
689* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
690- security fix for _execvpe
691
692* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
693- Fix  #71011,#71134, #58157
694
695* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
696- Resurrect tkinter
697- Fix for distutils (#67671)
698- Fix #69962
699
700* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
701- Obsolete tkinter/tkinter2 (#69838)
702
703* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
704- Doc fixes (#53951) - not on alpha at the momemt
705
706* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
707- fix pydoc (#68082)
708
709* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
710- Add db4-devel as a BuildPrereq
711
712* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
713- automated rebuild
714
715* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
716- Add Japanese codecs (#66352)
717
718* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
719- No more tkinter...
720
721* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
722- Rebuild
723
724* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
725- Add the email subcomponent (#65301)
726
727* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
728- Rebuild
729
730* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
731- rebuild i new enviroment
732
733* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
734- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
735
736* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
737- Make it use db4
738
739* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
740- 2.2.1 - a bugfix-only release
741
742* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
743- the same, but in builddirs - this will remove them from the
744  docs package, which doesn't look in the buildroot for files.
745
746* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
747- Get rid of temporary files and .cvsignores included
748  in the tarball and make install
749
750* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
751- Don't own lib-tk in main package, only in tkinter (#62753)
752
753* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
754- rebuild
755
756* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
757- rebuild
758
759* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
760- Add a not to the Distutils obsoletes test (doh!)
761
762* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
763- Rebuild
764
765* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
766- Only obsolete Distutils when built as python
767
768* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
769- Make files in /usr/bin install side by side with python 1.5 when
770- Drop explicit requirement of db4
771  built as python2
772
773* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
774- Use version and pybasever macros to make updating easy
775- Use _smp_mflags macro
776
777* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
778- Add db4-devel to BuildPrereq
779
780* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
781- disable ndbm support, which is db2 in disguise (really interesting things
782  can happen when you mix db2 and db4 in a single application)
783
784* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
785- Obsolete subpackages if necesarry
786- provide versioned python2
787- build with db4
788
789* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
790- Alpha toolchain broken. Disable build on alpha.
791- New openssl
792
793* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
794- 2.2 final
795
796* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
797- 2.2 RC 1
798- Don't include the _tkinter module in the main package - it's
799  already in the tkiter packace
800- Turn off the mpzmodule, something broke in the buildroot
801
802* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
803- Use -fPIC for OPT as well, in lack of a proper libpython.so
804
805* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
806- changed DESTDIR to point to / so that distutils will install dynload
807  modules properly in the installroot
808
809* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
810- 2.2b2
811
812* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
813- python2ify
814
815* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
816- 2.2b1
817
818* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
819- 2.2a4
820- Enable UCS4 support
821- Enable IPv6
822- Provide distutils
823- Include msgfmt.py and pygettext.py
824
825* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
826- Obsolete Distutils, which is now part of the main package
827- Obsolete python2
828
829* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
830- Add docs, tools and tkinter subpackages, to match the 1.5 layout
831
832* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
833- 2.2a3
834- don't build tix and blt extensions
835
836* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
837- Add tk and tix to build dependencies
838
839* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
840- 2.1.1 bugfix release - with a GPL compatible license
841
842* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
843- Add new build dependencies (#49753)
844
845* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
846- build with -fPIC
847
848* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
849- 2.1
850- reorganization of file includes
851
852* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
853- fix the "requires" clause, it lacked a space causing problems
854- use %%{_tmppath}
855- don't define name, version etc
856- add the available patches from the Python home page
857
858* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
859- added devel subpackage
860
861* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
862- modify all files to use "python2.0" as the intrepter
863- don't build the Expat bindings
864- build against db1
865
866* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
867- updated for 2.0 final
868
869* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
870- updated for 2.0c1
871- build audioop, imageop, and rgbimg extension modules
872- include xml.parsers subpackage
873- add test.xml.out to files list
874
875* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
876- added bin/python2.0 to files list (suggested by Martin v. Loewis)
877
878* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
879- updated for release 1 of 2.0b2
880- use .bz2 version of Python source
881
882* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
883- Version 2 of 2.0b1
884- Make the package relocatable.  Thanks to Suchandra Thapa.
885- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
886  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.