source: projects/specs/trunk/p/python2-dns/python2-dns-vl.spec @ 12469

Revision 12469, 9.6 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1Name:           python2-dns
2Version:        1.16.0
3Release:        2%{?_dist_release}
4Summary:        DNS toolkit for Python
5Summary(ja):    Python 用 DNS ツールキット
6Group:          programming
7Vendor:         Project Vine
8Distribution:   Vine Linux
9
10License:        MIT
11URL:            http://www.dnspython.org/
12Source0:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
13Source1:        http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildArch:      noarch
17BuildRequires: python-setuptools
18BuildRequires: python-devel
19BuildRequires: python-rpm-macros
20BuildRequires: python-crypto
21Obsoletes:     python-dns < %{version}-2
22Provides:      python-dns = %{version}-%{release}
23
24%description
25dnspython is a DNS toolkit for Python. It supports almost all record
26types. It can be used for queries, zone transfers, and dynamic
27updates. It supports TSIG authenticated messages and EDNS0.
28
29dnspython provides both high and low level access to DNS. The high
30level classes perform queries for data of a given name, type, and
31class, and return an answer set. The low level classes allow direct
32manipulation of DNS zones, messages, names, and records.
33
34
35%prep
36%setup0 -q -n dnspython-%{version}
37
38# strip executable permissions so that we don't pick up dependencies
39# from documentation
40find examples -type f | xargs chmod a-x
41
42
43%build
44%py_build
45
46
47%install
48rm -rf %{buildroot}
49%py_install
50
51
52#%check
53#%{__python} setup.py test
54
55
56%clean
57rm -rf %{buildroot}
58
59
60%files
61%defattr(-,root,root,-)
62%license LICENSE
63%doc README* examples
64%{python_sitelib}/*egg-info
65%{python_sitelib}/dns
66
67
68%changelog
69* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-2
70- changed %%name.
71- build with python2 only.
72
73* Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
74- new upstream release.
75- added python3 support.
76
77* Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
78- rebuild with VineSeed environment
79
80* Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
81- add BR: python-devel, python
82
83* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
84- new upstream release
85
86* Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
87- initial build for Vine Linux
88
89* Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
90-
91- dnspython 1.9.4 has been released and is available at
92- http://www.dnspython.org/kits/1.9.4/
93-
94- There is no new functionality in this release; just a few bug fixes
95- in RRSIG and SIG code.
96-
97- I will be eliminating legacy code for earlier versions of DNSSEC in a
98- future release of dnspython.
99
100* Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
101-
102- New since 1.9.2:
103-
104-     A boolean parameter, 'raise_on_no_answer', has been added to
105- the query() methods.  In no-error, no-data situations, this
106- parameter determines whether NoAnswer should be raised or not.
107- If True, NoAnswer is raised.  If False, then an Answer()
108- object with a None rrset will be returned.
109-
110- Resolver Answer() objects now have a canonical_name field.
111-
112- Rdata now have a __hash__ method.
113-
114- Bugs fixed since 1.9.2:
115-
116-        Dnspython was erroneously doing case-insensitive comparisons
117- of the names in NSEC and RRSIG RRs.
118-
119- We now use "is" and not "==" when testing what section an RR
120- is in.
121-
122- The resolver now disallows metaqueries.
123
124* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
126
127* Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
128- It's brown paper bag time :) The fix for the import problems was
129- actually bad, but didn't show up in testing because the test suite's
130- conditional importing code hid the problem.
131-
132- Any, 1.9.2 is out.
133-
134- Sorry for the churn!
135
136* Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
137- New since 1.9.0:
138-
139-        Nothing.
140-
141- Bugs fixed since 1.9.0
142-
143-        The dns.dnssec module didn't work with DSA due to namespace
144-        contamination from a "from"-style import.
145-
146- New since 1.8.0:
147-
148-        dnspython now uses poll() instead of select() when available.
149-
150-        Basic DNSSEC validation can be done using dns.dnsec.validate()
151-        and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
152-        later installed.  Complete secure resolution is not yet
153-        available.
154-
155-        Added key_id() to the DNSSEC module, which computes the DNSSEC
156-        key id of a DNSKEY rdata.
157-
158-        Added make_ds() to the DNSSEC module, which returns the DS RR
159-        for a given DNSKEY rdata.
160-
161-        dnspython now raises an exception if HMAC-SHA284 or
162-        HMAC-SHA512 are used with a Python older than 2.5.2.  (Older
163-        Pythons do not compute the correct value.)
164-
165-        Symbolic constants are now available for TSIG algorithm names.
166-
167- Bugs fixed since 1.8.0
168-
169-        dns.resolver.zone_for_name() didn't handle a query response
170-        with a CNAME or DNAME correctly in some cases.
171-
172-        When specifying rdata types and classes as text, Unicode
173-        strings may now be used.
174-
175-        Hashlib compatibility issues have been fixed.
176-
177-        dns.message now imports dns.edns.
178-
179-        The TSIG algorithm value was passed incorrectly to use_tsig()
180-        in some cases.
181
182* Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
183- Add a patch from upstream to fix a Python 2.7 issue.
184
185* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
186- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
187
188* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
189- Fix error
190
191* Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
192- New since 1.7.1:
193-
194-  Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
195-  hmac-sha512 has been contributed by Kevin Chen.
196-
197-  The tokenizer's tokens are now Token objects instead of (type,
198-  value) tuples.
199-
200- Bugs fixed since 1.7.1:
201-
202-  Escapes in masterfiles now work correctly.  Previously they were
203-  only working correctly when the text involved was part of a domain
204-  name.
205-
206-  When constructing a DDNS update, if the present() method was used
207-  with a single rdata, a zero TTL was not added.
208-
209-  The entropy pool needed locking to be thread safe.
210-
211-  The entropy pool's reading of /dev/random could cause dnspython to
212-  block.
213-
214-  The entropy pool did buffered reads, potentially consuming more
215-  randomness than we needed.
216-
217-  The entropy pool did not seed with high quality randomness on
218-  Windows.
219-
220-  SRV records were compared incorrectly.
221-
222-  In the e164 query function, the resolver parameter was not used.
223
224* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
226
227* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
228- New since 1.7.0:
229-
230-        Nothing
231-
232- Bugs fixed since 1.7.0:
233-
234-        The 1.7.0 kitting process inadventently omitted the code for the
235-        DLV RR.
236-
237-        Negative DDNS prerequisites are now handled correctly.
238
239* Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
240- New since 1.6.0:
241-
242-        Rdatas now have a to_digestable() method, which returns the
243-        DNSSEC canonical form of the rdata, suitable for use in
244-        signature computations.
245-
246-        The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
247-
248-        An entropy module has been added and is used to randomize query ids.
249-
250-        EDNS0 options are now supported.
251-
252-        UDP IXFR is now supported.
253-
254-        The wire format parser now has a 'one_rr_per_rrset' mode, which
255-        suppresses the usual coalescing of all RRs of a given type into a
256-        single RRset.
257-
258-        Various helpful DNSSEC-related constants are now defined.
259-
260-        The resolver's query() method now has an optional 'source' parameter,
261-        allowing the source IP address to be specified.
262-
263- Bugs fixed since 1.6.0:
264-
265-        On Windows, the resolver set the domain incorrectly.
266-
267-        DS RR parsing only allowed one Base64 chunk.
268-
269-        TSIG validation didn't always use absolute names.
270-
271-        NSEC.to_text() only printed the last window.
272-
273-        We did not canonicalize IPv6 addresses before comparing them; we
274-        would thus treat equivalent but different textual forms, e.g.
275-        "1:00::1" and "1::1" as being non-equivalent.
276-
277-        If the peer set a TSIG error, we didn't raise an exception.
278-
279-        Some EDNS bugs in the message code have been fixed (see the ChangeLog
280-        for details).
281
282* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
283- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
284
285* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
286- Rebuild for Python 2.6
287
288* Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
289- fix license tag
290
291* Tue Dec  4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
292- Update to 1.6.0
293
294* Tue Oct  9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
295- Follow new Python egg packaging specs
296
297* Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
298- Update to 1.5.0
299
300* Fri Dec  8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
301- Bump release for rebuild with Python 2.5
302
303* Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
304- No longer ghost *.pyo files, thus further simplifying the files section.
305
306* Sat Aug  5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
307- Update to 1.4.0
308- Remove unneeded python-abi requires
309- Remove unneeded python_sitearch macro
310
311* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
312- First version for Fedora Extras
313
Note: See TracBrowser for help on using the repository browser.