source: projects/specs/trunk/p/python/python-vl.spec @ 521

Revision 521, 29.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:0}%{!?_without_doc:1}
4%define unicode  ucs4
5%define tcl_major 8.4
6%define tk_major 8.4
7%define tix_major 8.4
8%define pybasever 2.6
9%define python_lib %{_libdir}/python%{pybasever}
10
11Summary: An interpreted, interactive, object-oriented programming language.
12Summary(ja): オブジェクト指向言語 Python インタプリタ
13Name: python
14Version: %{pybasever}.4
15Release: 5%{?_dist_release}
16License: PSF - see LICENSE
17Group: Development/Languages
18URL: http://www.python.org/%{pybasever}/
19Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
20Source1: Python-2.6.4-Doc.78718.tgz
21Source6: shmmodule.c
22
23# For TEST
24Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
25Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
26Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
27Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
28Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
29Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
30Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
31Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
32Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
33Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
34Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
35Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
36Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
37Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
38
39Patch0: Python-2.6.4-Setup.dist.patch
40Patch1: python-2.6.3-lib64.patch
41Patch3: Python-2.2.1-pydocnogui.patch
42Patch5: Python-2.3.3-distutilrpm.patch
43
44Patch10: python-2.6-db48.patch
45
46Obsoletes: python2
47Obsoletes: Distutils
48Obsoletes: python-base
49Provides: Distutils
50
51BuildRequires: db4-devel >= 4.8
52BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
53BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
54BuildRequires: tk tix gcc-c++ glibc-devel
55BuildRequires: xorg-x11-devel mesa-libGL-devel
56BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
57BuildRequires: nkf
58BuildRequires: sqlite3-devel
59%if %{with_doc}
60BuildRequires: latex2html
61%endif
62BuildRoot: %{_tmppath}/%{name}-%{version}-root
63
64
65%description
66Python is an interpreted, interactive, object-oriented programming
67language often compared to Tcl, Perl, Scheme or Java. Python includes
68modules, classes, exceptions, very high level dynamic data types and
69dynamic typing. Python supports interfaces to many system calls and
70libraries, as well as to various windowing systems (X11, Motif, Tk,
71Mac and MFC).
72
73Programmers can write new built-in modules for Python in C or C++.
74Python can be used as an extension language for applications that need
75a programmable interface. This package contains most of the standard
76Python modules, as well as modules for interfacing to the Tix widget
77set for Tk and RPM.
78
79Note that documentation for Python is provided in the python-docs
80package.
81
82%package devel
83Summary: The libraries and header files needed for Python development.
84Summary(ja): Python での開発に必要なライブラリやヘッダファイル
85Group: Development/Libraries
86Obsoletes: python2-devel
87
88%description devel
89The Python programming language's interpreter can be extended with
90dynamically loaded extensions and can be embedded in other programs.
91This package contains the header files and libraries needed to do
92these types of tasks.
93
94Install python-devel if you want to develop Python extensions.  The
95python package will also need to be installed.  You'll probably also
96want to install the python-docs package, which contains Python
97documentation.
98
99%package tools
100Summary: A collection of development tools included with Python.
101Summary(ja): Python に含まれる開発ツール一式
102Group: Development/Tools
103Requires: %{name} = %{version}
104Requires: tkinter = %{version}
105Obsoletes: python2-tools
106
107%description tools
108The Python package includes several development tools that are used
109to build python programs.
110
111%package docs
112Summary: Documentation for the Python programming language.
113Summary(ja): Python プログラミング言語のドキュメント
114Group: Applications/Documentation
115Obsoletes: python2-docs
116
117%description docs
118The python-docs package contains documentation on the Python
119programming language and interpreter.  The documentation is provided
120in ASCII text files and in LaTeX source files.
121
122Install the python-docs package if you'd like to use the documentation
123for the Python language.
124
125%package -n tkinter
126Summary: A graphical user interface for the Python scripting language.
127Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
128Group: Development/Languages
129Obsoletes: tkinter2
130BuildRequires: tcl, tk
131Requires: %{name} = %{version}
132Requires: tix
133
134%description -n tkinter
135The Tkinter (Tk interface) program is an graphical user interface for
136the Python scripting language.
137
138You should install the tkinter package if you'd like to use a graphical
139user interface for Python programming.
140
141%prep
142%setup -q -a 1 -n Python-%{version}
143%patch0 -p1 -b .Setup
144%if %{_lib} == lib64
145%patch1 -p2 -b .lib64
146%endif
147%patch3 -p1 -b .no_gui
148%patch5 -p1 -b .distutilrpm
149
150%patch10 -p1 -b .db48
151
152
153# remove unneeded files
154rm -vf Lib/test/test_*.py.CVE*
155rm -vf Lib/test/test_*.py.orig
156rm -vf Lib/test/test_*.py.org
157
158# Temporary workaround to avoid confusing find-requires: don't ship the tests
159# as executable files
160chmod 0644 Lib/test/test_*.py
161
162# shm module
163cp %{SOURCE6} Modules
164cat >> Modules/Setup.dist << EOF
165
166# Shared memory module
167shm shmmodule.c
168EOF
169
170# Fix library flags
171pushd Modules
172mv Setup.dist Setup.dist.in
173sed "s|-ltcl|-ltcl%{tcl_major}|" < Setup.dist.in |\
174sed "s|-ltk|-ltk%{tk_major}|" |\
175sed "s|-ltix|-ltix%{tix_major}|"  > Setup.dist
176rm -f Setup.dist.in
177popd
178
179
180%build
181topdir=`pwd`
182export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
183export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
184export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
185export LINKCC="gcc"
186if pkg-config openssl ; then
187        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
188        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
189fi
190%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
191make OPT="$CFLAGS" %{?_smp_mflags}
192
193export LD_LIBRARY_PATH=$topdir
194export PATH="$topdir:$PATH"
195cp $topdir/python $topdir/python%{pybasever}
196$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
197make OPT="$CFLAGS" %{?_smp_mflags}
198
199## # Doc
200## %if %{with_doc}
201## make %{?_smp_mflags} -C Doc html
202## rm Doc/html/index.html.in
203## %endif
204
205
206# Test
207%if %{run_test}
208cp %{SOURCE7} ./
209cp %{SOURCE8} ./
210cp %{SOURCE9} ./
211cp %{SOURCE10} ./
212cp %{SOURCE11} ./
213cp %{SOURCE12} ./
214cp %{SOURCE13} ./
215cp %{SOURCE14} ./
216cp %{SOURCE15} ./
217cp %{SOURCE16} ./
218cp %{SOURCE17} ./
219cp %{SOURCE18} ./
220cp %{SOURCE19} ./
221cp %{SOURCE20} ./
222# This runs the test set twice (once with no compiled files, once with
223# the compiled files left by the previous test run).
224export LD_LIBRARY_PATH=$topdir
225export PYTHONHOME=$topdir
226export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
227
228find ./Lib -name '*.py[co]' -print | xargs rm -f
229./python -tt ./Lib/test/regrtest.py -l
230./python -tt ./Lib/test/regrtest.py -l
231#./python -tt ./Lib/test/test_bsddb.py -l
232#./python -tt ./Lib/test/test_bsddb.py -l
233%endif
234
235
236%install
237rm -fr $RPM_BUILD_ROOT
238mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
239
240# Clean up patched .py files that are saved as .lib64
241for f in distutils/command/install distutils/sysconfig; do
242    rm -f Lib/$f.py.lib64
243done
244
245make DESTDIR=$RPM_BUILD_ROOT install
246
247# Fix the interpreter path in binaries installed by distutils
248# (which changes them by itself)
249# Make sure we preserve the file permissions
250for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
251    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
252        && cat $fixed- > $fixed && rm -f $fixed-
253done
254
255
256## docs
257%if %{with_doc}
258%endif
259
260
261## tools
262mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
263
264echo "#!/bin/bash
265exec %{python_lib}/site-packages/pynche/pynche" \
266        > $RPM_BUILD_ROOT/usr/bin/pynche
267chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
268
269echo "#!/bin/bash
270exec %{python_lib}/site-packages/modulator/modulator.py" \
271        > $RPM_BUILD_ROOT/usr/bin/modulator
272chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
273
274# idle
275mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
276install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
277chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
278
279#modulator
280cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
281
282#pynche
283rm -f Tools/pynche/*.pyw
284cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
285
286(mv Tools/modulator/README Tools/modulator/README.modulator)
287(mv Tools/pynche/README Tools/pynche/README.pynche)
288
289#gettext
290install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
291install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
292
293# Get rid of crap
294find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
295find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
296find . -name "*~"|xargs rm -f
297find . -name ".cvsignore"|xargs rm -f
298#zero length
299rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
300
301# Clean up the testsuite - we don't need compiled files for it
302find $RPM_BUILD_ROOT%{python_lib}/test \
303    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
304rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
305
306find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
307
308## Fix the file permissions
309chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
310chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
311find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
312
313
314%clean
315rm -fr $RPM_BUILD_ROOT
316
317
318%files -f dynfiles
319%defattr(-, root, root)
320%doc LICENSE README
321%{_bindir}/%{name}*
322%{_mandir}/*/*
323%{_libdir}/libpython%{pybasever}.so*
324%dir %{python_lib}
325%dir %{python_lib}/lib-dynload
326%dir %{python_lib}/site-packages
327%{python_lib}/*.py*
328%{python_lib}/*.doc
329%{python_lib}/bsddb
330%{python_lib}/compiler
331%{python_lib}/ctypes
332%{python_lib}/curses
333%{python_lib}/distutils
334%{python_lib}/email
335%{python_lib}/encodings
336%{python_lib}/hotshot
337%{python_lib}/idlelib
338%{python_lib}/json
339%{python_lib}/lib2to3
340%{python_lib}/logging
341%{python_lib}/multiprocessing
342%{python_lib}/plat-linux2
343%{python_lib}/sqlite3
344%{python_lib}/wsgiref
345%{python_lib}/wsgiref.egg-info
346%{python_lib}/xml
347
348%files devel
349%defattr(-,root,root)
350%{_includedir}/*
351%{python_lib}/config
352%{python_lib}/test
353
354%files tools
355%defattr(-,root,root,755)
356%doc Tools/modulator/README.modulator
357%doc Tools/pynche/README.pynche
358%{python_lib}/site-packages
359%{_bindir}/2to3
360%{_bindir}/idle
361%{_bindir}/modulator
362%{_bindir}/msgfmt.py
363%{_bindir}/pydoc
364%{_bindir}/pygettext.py
365%{_bindir}/pynche
366%{_bindir}/smtpd.py
367
368%if %{with_doc}
369%files docs
370%defattr(-,root,root,755)
371%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
372%doc Doc/build/html
373%endif
374
375%files -n tkinter
376%defattr(-,root,root,755)
377%{python_lib}/lib-tk
378%{python_lib}/lib-dynload/_tkinter.so
379
380
381%changelog
382* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
383- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
384- changed default to '--with doc' again
385
386* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
387- rebuilt with gcc-4.4.3-3 on ppc
388- s/BuildPreReq/BuildRequires/
389
390* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
391- replaced Python-%%{version}-Setup.dist.patch
392- added BR: sqlite3-devel
393
394* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
395- add Patch10 to build with db-4.8
396
397* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
398- updated python to 2.6.4
399- changed default to '--without doc'
400- added Setup.dist.patch instead of Setup.dist{32,64}.patch
401- updated python-*-lib64.patch to 2.6.3
402
403* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
404- updated python to 2.5.5
405
406* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
407- added Python-2.5.4-{Setup,Setup64}.patch
408  - added _bsddb module
409  - dropt patch{0,9,10}
410
411* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
412- updated Patch0 for building with db-4.6.21
413
414* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
415- add patch10
416  - add -lcrypt for cryptmodule
417
418* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
419- new upstream release
420- changed typo of summary(ja)
421
422* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
423- new upstream release
424- dropt python-2.4.4_CVE-2007-4965.patch
425- dropt python-2.4.4_CVE-2008-1721.patch
426- dropt python-2.4.4-CVE-2008-1679.patch
427
428* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
429- updated python to 2.5.2
430- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
431- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
432- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
433- added modules ctypes, sqlite3, and wsgiref
434- dropt modules lib-old
435- dropt python-2.4.4_CVE-2008-1887.patch
436- dropt python-2.4.4_CVE-2007-2052.patch
437- fixed the file permissions
438
439* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
440- applied new versioning policy and spec in utf-8
441- added BuildPrereq: xorg-x11-devel
442- imported updates from Vine4.2
443        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
444        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
445        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
446        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
447        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
448        - add patch110 CVE-2008-1721 (zlib module)
449        - add remove unneeded files in Lib/test/
450        #- new versioning policy
451
452* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
453- updated python to 2.4.5
454
455* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
456- rebuild with expat-2.0.1
457
458* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
459- fix typo on Patch0 (s/db-4.2/db-4.3/)
460
461* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
462- rebuild with tcl/tk-8.4.18
463
464* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
465- imported updates from Vine4.2 Plus
466        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
467        - add BuildPrereq: nkf
468        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
469        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
470
471* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
472- rebuilt with openssl-0.9.8e and tix-8.4.2
473- fixed spec file encoding
474
475* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
476- rebuilt with new toolchain and db4-4.3.x
477- modified Patch0 (s/db-4.2/db-4.3/)
478
479* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
480- updated python to 2.4.4 (included security fix PSF-2006-001)
481- added japanese summary
482- updated patch8 (python-2.4.2-lib64.patch)
483- added patch9 (python-2.4.4c1-setup.lib64.patch)
484
485* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
486- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
487
488* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
489- rebuild with readline-5.1 (x86_64)
490
491* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
492- fixed python-2.4.3-config.patch cause undefined symbol: crypt
493
494* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
495- updated python to 2.4.3
496- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
497
498* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
499- set permition of lib-dynload/*.so to 755
500- added without_doc option
501- rebuilt with x86_64
502
503* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
504- add run_test option
505
506* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
507- add BuildPrereq: bzip2-devel
508- arrange testing script
509
510* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
511- back to %%configure macro
512- change testing script
513
514* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
515- update Patch8 (VineSeed:10306)
516- use ./configure instead of %%configure script
517- add forgotten popd
518
519* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
520- add --enable-shared to confiugre option
521- add %%{_libdir}/libpython2.4.so* to python package
522- add LD_LIBRARY_PATH=$topdir to use pathfix.py
523- change build method of Doc
524- add files for make test
525- change install method
526
527* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
528- update python to 2.4.2 (final)
529
530* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
531- update python to 2.4.1 (final)
532
533* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
534- update python to 2.4.1c2
535- moved all site-packages files to python-tools package
536
537* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
538- update python to 2.4.1c1
539- droped aspython2 macros
540- droped japanese-codecs module
541- droped Source2 idle, now it's provided from original source
542- droped Source3 modulator, now it's generated in a spec file
543- droped Source4 pynche, now it's generated in a spec file
544- droped Python-2.3.3-buildroot-bytecode.patch
545- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
546
547* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
548- update python to 2.3.5
549
550* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
551- add PSF-2005-001.patch
552
553* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
554- rebuilt
555
556* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
557- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
558
559* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
560- rebuilt with db4-4.2.25
561
562* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
563- updated python to 2.3.4
564- fixed patch10, patch11
565
566* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
567- rebuild
568
569* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
570- updated python-2.3.3-config2.patch
571
572* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
573- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
574
575* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
576- updated python to 2.3.3
577- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
578- updated config2.patch for 2.3.3
579- updated nowhatsnew.patch for 2.3.3
580- updated distutilrpm.patch in which tabstops have made indent error
581- updated buildroot-bytecode.patch for 2.3.3
582- deleted buildroot.patch which fixed in 2.3.3
583- changed Tools/idle with Lib/idlelib
584
585* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
586- rebuild with openssl-0.9.7d
587
588* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
589- updated JapaneseCodecs to 1.4.10
590
591* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
592- synced with RawHide 2.2.3-3 (substantially source ver up)
593
594* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
595- rebuild with tcltk-8.4.2
596- synced with RawHide 2.2.2-26
597  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
598  - rebuilt
599
600  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
601  - Fixed bug #84886: pydoc dies when run w/o arguments
602  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
603  - Fixed bug #84966: path in byte-compiled code still wrong
604
605  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
606  - ftp uri's should be able to specify being rooted at the root instead of
607    where you login via ftp (#84692)
608
609  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
610  - Using newer Japanese codecs (1.4.9). Thanks to
611    Peter Bowen <pzb@datastacks.com> for pointing this out.
612
613  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
614  - Rebuild
615
616  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
617  - Release number bumped really high: turning on UCS4 (ABI compatibility
618    breakage)
619
620  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
621  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
622    some work on python-2.2.2-lib64.patch
623
624  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
625  - Rebuild to incorporate the removal of .lib64 and - files.
626
627  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
628  - Fixed bug #82544: Errata removes most tools
629  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
630  - Removed .lib64 and - files that get installed after we fix the multilib
631    .py files.
632
633  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
634  - rebuilt
635
636  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
637  - rebuild to update tkinter's tcltk deps
638  - convert changelog to utf-8
639
640
641* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
642- rebuilt for Vine Linux against db4
643- obsolete python-base (which comes with python-2.2.1 of TestPkg)
644
645* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
646- rebuild
647
648* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
649- pick up OpenSSL cflags and ldflags from pkgconfig if available
650
651* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
652- urllib2 didn't support non-anonymous ftp.  add support based on how
653  urllib did it (#80676, #78168)
654
655* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
656- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
657- Added a bunch of missing BuildRequires found while fixing the
658  above-mentioned bug
659
660* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
661- rebuild to fix broken tcltk deps for tkinter
662
663* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6642.2.2-3.7.3
665- Recompiled for 7.3 (to fix the -lcrypt bug)
666- Fix for the spurious error message at the end of the build (build-requires
667  gets confused by executable files starting with """"): make the tests
668  non-executable.
669
670* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6712.2.2-5
672- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
673
6742.2.2-4
675- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
676  with the C++ compiler.
677
678* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6792.2.2-3.*
680- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
681  use %%{_libdir}
682- Added XFree86-libs as BuildRequires (because of tkinter)
683- Fixed duplicate listing of plat-linux2
684- Fixed exclusion of lib-dynload/japanese
685- Added lib64 patch for the japanese codecs
686- Use setup magic instead of using tar directly on JapaneseCodecs
687
688* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
6892.2.2-2
690- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
691  requirement of tkinter from python-tools).
692- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
693
694* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
695- builds as python2 require a different libdb
696- changed the buildroot name of python to match python2 builds
697
698* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
699- updated python to 2.2.2 and adjusted the patches accordingly
700
701* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
702- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
703- Added BuildPrereq dependency on gcc-c++
704
705* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
706- security fix for _execvpe
707
708* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
709- Fix  #71011,#71134, #58157
710
711* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
712- Resurrect tkinter
713- Fix for distutils (#67671)
714- Fix #69962
715
716* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
717- Obsolete tkinter/tkinter2 (#69838)
718
719* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
720- Doc fixes (#53951) - not on alpha at the momemt
721
722* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
723- fix pydoc (#68082)
724
725* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
726- Add db4-devel as a BuildPrereq
727
728* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
729- automated rebuild
730
731* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
732- Add Japanese codecs (#66352)
733
734* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
735- No more tkinter...
736
737* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
738- Rebuild
739
740* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
741- Add the email subcomponent (#65301)
742
743* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
744- Rebuild
745
746* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
747- rebuild i new enviroment
748
749* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
750- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
751
752* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
753- Make it use db4
754
755* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
756- 2.2.1 - a bugfix-only release
757
758* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
759- the same, but in builddirs - this will remove them from the
760  docs package, which doesn't look in the buildroot for files.
761
762* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
763- Get rid of temporary files and .cvsignores included
764  in the tarball and make install
765
766* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
767- Don't own lib-tk in main package, only in tkinter (#62753)
768
769* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
770- rebuild
771
772* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
773- rebuild
774
775* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
776- Add a not to the Distutils obsoletes test (doh!)
777
778* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
779- Rebuild
780
781* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
782- Only obsolete Distutils when built as python
783
784* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
785- Make files in /usr/bin install side by side with python 1.5 when
786- Drop explicit requirement of db4
787  built as python2
788
789* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
790- Use version and pybasever macros to make updating easy
791- Use _smp_mflags macro
792
793* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
794- Add db4-devel to BuildPrereq
795
796* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
797- disable ndbm support, which is db2 in disguise (really interesting things
798  can happen when you mix db2 and db4 in a single application)
799
800* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
801- Obsolete subpackages if necesarry
802- provide versioned python2
803- build with db4
804
805* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
806- Alpha toolchain broken. Disable build on alpha.
807- New openssl
808
809* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
810- 2.2 final
811
812* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
813- 2.2 RC 1
814- Don't include the _tkinter module in the main package - it's
815  already in the tkiter packace
816- Turn off the mpzmodule, something broke in the buildroot
817
818* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
819- Use -fPIC for OPT as well, in lack of a proper libpython.so
820
821* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
822- changed DESTDIR to point to / so that distutils will install dynload
823  modules properly in the installroot
824
825* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
826- 2.2b2
827
828* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
829- python2ify
830
831* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
832- 2.2b1
833
834* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
835- 2.2a4
836- Enable UCS4 support
837- Enable IPv6
838- Provide distutils
839- Include msgfmt.py and pygettext.py
840
841* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
842- Obsolete Distutils, which is now part of the main package
843- Obsolete python2
844
845* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
846- Add docs, tools and tkinter subpackages, to match the 1.5 layout
847
848* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
849- 2.2a3
850- don't build tix and blt extensions
851
852* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
853- Add tk and tix to build dependencies
854
855* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
856- 2.1.1 bugfix release - with a GPL compatible license
857
858* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
859- Add new build dependencies (#49753)
860
861* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
862- build with -fPIC
863
864* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
865- 2.1
866- reorganization of file includes
867
868* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
869- fix the "requires" clause, it lacked a space causing problems
870- use %%{_tmppath}
871- don't define name, version etc
872- add the available patches from the Python home page
873
874* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
875- added devel subpackage
876
877* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
878- modify all files to use "python2.0" as the intrepter
879- don't build the Expat bindings
880- build against db1
881
882* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
883- updated for 2.0 final
884
885* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
886- updated for 2.0c1
887- build audioop, imageop, and rgbimg extension modules
888- include xml.parsers subpackage
889- add test.xml.out to files list
890
891* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
892- added bin/python2.0 to files list (suggested by Martin v. Loewis)
893
894* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
895- updated for release 1 of 2.0b2
896- use .bz2 version of Python source
897
898* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
899- Version 2 of 2.0b1
900- Make the package relocatable.  Thanks to Suchandra Thapa.
901- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
902  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.