source: projects/specs/trunk/p/python/python-vl.spec @ 619

Revision 619, 29.9 KB checked in by owa, 14 years ago (diff)

updated: python to 2.6.5

Line 
1# If you want to run test, add "--define '_run_test 1'" to rpm option
2%define run_test %{?_run_test:1}%{!?_run_test:0}
3%define with_doc %{?_without_doc:0}%{!?_without_doc:1}
4%define unicode  ucs4
5%define bsddb_ver 4.8
6%define tcl_major 8.4
7%define tk_major 8.4
8%define tix_major 8.4
9%define pybasever 2.6
10%define python_lib %{_libdir}/python%{pybasever}
11
12Summary: An interpreted, interactive, object-oriented programming language.
13Summary(ja): オブジェクト指向言語 Python インタプリタ
14Name: python
15Version: %{pybasever}.5
16Release: 1%{?_dist_release}
17License: PSF - see LICENSE
18Group: Development/Languages
19URL: http://www.python.org/%{pybasever}/
20Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.bz2
21Source1: Python-2.6.4-Doc.78718.tgz
22Source6: shmmodule.c
23
24# For TEST
25Source7: http://people.freebsd.org/~perky/i18n/EUC-CN.TXT
26Source8: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP936.TXT
27Source9: http://people.freebsd.org/~perky/i18n/BIG5HKSCS.TXT
28Source10: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP932.TXT
29Source11: http://people.freebsd.org/~perky/i18n/EUC-JP.TXT
30Source12: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/JIS/SHIFTJIS.TXT
31Source13: http://people.freebsd.org/~perky/i18n/EUC-JISX0213.TXT
32Source14: http://people.freebsd.org/~perky/i18n/SHIFT_JISX0213.TXT
33Source15: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP949.TXT
34Source16: http://people.freebsd.org/~perky/i18n/EUC-KR.TXT
35Source17: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/KSC/JOHAB.TXT
36Source18: http://www.unicode.org/Public/MAPPINGS/OBSOLETE/EASTASIA/OTHER/BIG5.TXT
37Source19: http://www.unicode.org/Public/MAPPINGS/VENDORS/MICSFT/WINDOWS/CP950.TXT
38Source20: http://www.unicode.org/Public/3.2-Update/NormalizationTest-3.2.0.txt
39
40Patch0: Python-2.6.4-Setup.dist.patch
41Patch1: python-2.6.3-lib64.patch
42Patch3: Python-2.2.1-pydocnogui.patch
43Patch5: Python-2.3.3-distutilrpm.patch
44
45Patch10: python-2.6-db48.patch
46Patch11: http://bugs.python.org/file16549/python-support_bdb-4.8-v2.patch
47
48Obsoletes: python2
49Obsoletes: Distutils
50Obsoletes: python-base
51Provides: Distutils
52
53BuildRequires: db4-devel >= 4.8
54BuildRequires: readline-devel, libtermcap-devel, openssl-devel, gmp-devel
55BuildRequires: ncurses-devel, gdbm-devel, zlib-devel, expat-devel, tetex-latex
56BuildRequires: tk tix gcc-c++ glibc-devel
57BuildRequires: xorg-x11-devel mesa-libGL-devel
58BuildRequires: gzip tar /usr/bin/find pkgconfig bzip2-devel
59BuildRequires: nkf
60BuildRequires: sqlite3-devel
61%if %{with_doc}
62BuildRequires: latex2html
63%endif
64BuildRoot: %{_tmppath}/%{name}-%{version}-root
65
66
67%description
68Python is an interpreted, interactive, object-oriented programming
69language often compared to Tcl, Perl, Scheme or Java. Python includes
70modules, classes, exceptions, very high level dynamic data types and
71dynamic typing. Python supports interfaces to many system calls and
72libraries, as well as to various windowing systems (X11, Motif, Tk,
73Mac and MFC).
74
75Programmers can write new built-in modules for Python in C or C++.
76Python can be used as an extension language for applications that need
77a programmable interface. This package contains most of the standard
78Python modules, as well as modules for interfacing to the Tix widget
79set for Tk and RPM.
80
81Note that documentation for Python is provided in the python-docs
82package.
83
84%package devel
85Summary: The libraries and header files needed for Python development.
86Summary(ja): Python での開発に必要なライブラリやヘッダファイル
87Group: Development/Libraries
88Obsoletes: python2-devel
89
90%description devel
91The Python programming language's interpreter can be extended with
92dynamically loaded extensions and can be embedded in other programs.
93This package contains the header files and libraries needed to do
94these types of tasks.
95
96Install python-devel if you want to develop Python extensions.  The
97python package will also need to be installed.  You'll probably also
98want to install the python-docs package, which contains Python
99documentation.
100
101%package tools
102Summary: A collection of development tools included with Python.
103Summary(ja): Python に含まれる開発ツール一式
104Group: Development/Tools
105Requires: %{name} = %{version}
106Requires: tkinter = %{version}
107Obsoletes: python2-tools
108
109%description tools
110The Python package includes several development tools that are used
111to build python programs.
112
113%package docs
114Summary: Documentation for the Python programming language.
115Summary(ja): Python プログラミング言語のドキュメント
116Group: Applications/Documentation
117Obsoletes: python2-docs
118
119%description docs
120The python-docs package contains documentation on the Python
121programming language and interpreter.  The documentation is provided
122in ASCII text files and in LaTeX source files.
123
124Install the python-docs package if you'd like to use the documentation
125for the Python language.
126
127%package -n tkinter
128Summary: A graphical user interface for the Python scripting language.
129Summary(ja): Python スクリプト言語のグラフィカルインターフェイス
130Group: Development/Languages
131Obsoletes: tkinter2
132BuildRequires: tcl, tk
133Requires: %{name} = %{version}
134Requires: tix
135
136%description -n tkinter
137The Tkinter (Tk interface) program is an graphical user interface for
138the Python scripting language.
139
140You should install the tkinter package if you'd like to use a graphical
141user interface for Python programming.
142
143%prep
144%setup -q -a 1 -n Python-%{version}
145%patch0 -p1 -b .Setup
146%if %{_lib} == lib64
147%patch1 -p2 -b .lib64
148%endif
149%patch3 -p1 -b .no_gui
150%patch5 -p1 -b .distutilrpm
151
152## for bsddb-4.8
153# %patch10 -p1 -b .db48
154%patch11 -p0 -b .db48-v2
155
156
157# remove unneeded files
158rm -vf Lib/test/test_*.py.CVE*
159rm -vf Lib/test/test_*.py.orig
160rm -vf Lib/test/test_*.py.org
161
162# Temporary workaround to avoid confusing find-requires: don't ship the tests
163# as executable files
164chmod 0644 Lib/test/test_*.py
165
166# shm module
167cp %{SOURCE6} Modules
168cat >> Modules/Setup.dist << EOF
169
170# Shared memory module
171shm shmmodule.c
172EOF
173
174# Fix library flags
175pushd Modules
176mv Setup.dist Setup.dist.in
177cat Setup.dist.in | \
178        sed "s^-ldb-^-ldb-%{bsddb_ver}^"| \
179        sed "s^-ltcl^-ltcl%{tcl_major}^"| \
180        sed "s^-ltk^-ltk%{tk_major}^" | \
181        sed "s^-ltix^-ltix%{tix_major}^" \
182> Setup.dist
183rm -f Setup.dist.in
184popd
185
186
187%build
188topdir=`pwd`
189export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
190export CXXFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
191export OPT="$RPM_OPT_FLAGS -D_GNU_SOURCE -fPIC"
192export LINKCC="gcc"
193if pkg-config openssl ; then
194        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
195        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
196fi
197%configure --enable-ipv6 --enable-unicode=%{unicode} --enable-shared
198make OPT="$CFLAGS" %{?_smp_mflags}
199
200export LD_LIBRARY_PATH=$topdir
201export PATH="$topdir:$PATH"
202cp $topdir/python $topdir/python%{pybasever}
203$topdir/python Tools/scripts/pathfix.py -i "/usr/bin/env python%{pybasever}" .
204make OPT="$CFLAGS" %{?_smp_mflags}
205
206## # Doc
207## %if %{with_doc}
208## make %{?_smp_mflags} -C Doc html
209## rm Doc/html/index.html.in
210## %endif
211
212
213# Test
214%if %{run_test}
215cp %{SOURCE7} ./
216cp %{SOURCE8} ./
217cp %{SOURCE9} ./
218cp %{SOURCE10} ./
219cp %{SOURCE11} ./
220cp %{SOURCE12} ./
221cp %{SOURCE13} ./
222cp %{SOURCE14} ./
223cp %{SOURCE15} ./
224cp %{SOURCE16} ./
225cp %{SOURCE17} ./
226cp %{SOURCE18} ./
227cp %{SOURCE19} ./
228cp %{SOURCE20} ./
229# This runs the test set twice (once with no compiled files, once with
230# the compiled files left by the previous test run).
231export LD_LIBRARY_PATH=$topdir
232export PYTHONHOME=$topdir
233export PYTHONPATH=$topdir/Lib:$topdir/Lib/test:$topdir/Lib/lib-tk:$topdir/Lib/site-packages:$topdir/Modules:$topdir/build/lib.linux-%{_host_cpu}-%{pybasever}
234
235find ./Lib -name '*.py[co]' -print | xargs rm -f
236./python -tt ./Lib/test/regrtest.py -l
237./python -tt ./Lib/test/regrtest.py -l
238#./python -tt ./Lib/test/test_bsddb.py -l
239#./python -tt ./Lib/test/test_bsddb.py -l
240%endif
241
242
243%install
244rm -fr $RPM_BUILD_ROOT
245mkdir -p $RPM_BUILD_ROOT/usr $RPM_BUILD_ROOT%{_mandir}
246
247# Clean up patched .py files that are saved as .lib64
248for f in distutils/command/install distutils/sysconfig; do
249    rm -f Lib/$f.py.lib64
250done
251
252make DESTDIR=$RPM_BUILD_ROOT install
253
254# Fix the interpreter path in binaries installed by distutils
255# (which changes them by itself)
256# Make sure we preserve the file permissions
257for fixed in $RPM_BUILD_ROOT/usr/bin/pydoc; do
258    sed 's,#!.*/python$,#!/usr/bin/env python%{pybasever},' $fixed > $fixed- \
259        && cat $fixed- > $fixed && rm -f $fixed-
260done
261
262
263## docs
264%if %{with_doc}
265%endif
266
267
268## tools
269mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages
270
271echo "#!/bin/bash
272exec %{python_lib}/site-packages/pynche/pynche" \
273        > $RPM_BUILD_ROOT/usr/bin/pynche
274chmod 755 $RPM_BUILD_ROOT/usr/bin/pynche
275
276echo "#!/bin/bash
277exec %{python_lib}/site-packages/modulator/modulator.py" \
278        > $RPM_BUILD_ROOT/usr/bin/modulator
279chmod 755 $RPM_BUILD_ROOT/usr/bin/modulator
280
281# idle
282mkdir -p $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
283install -m 755 ./Lib/idlelib/idle.py $RPM_BUILD_ROOT%{python_lib}/site-packages/idle
284chmod 755 $RPM_BUILD_ROOT/usr/bin/idle
285
286#modulator
287cp -r Tools/modulator ${RPM_BUILD_ROOT}%{python_lib}/site-packages/
288
289#pynche
290rm -f Tools/pynche/*.pyw
291cp -r Tools/pynche $RPM_BUILD_ROOT%{python_lib}/site-packages/
292
293(mv Tools/modulator/README Tools/modulator/README.modulator)
294(mv Tools/pynche/README Tools/pynche/README.pynche)
295
296#gettext
297install -m755  Tools/i18n/pygettext.py $RPM_BUILD_ROOT/usr/bin/
298install -m755  Tools/i18n/msgfmt.py $RPM_BUILD_ROOT/usr/bin/
299
300# Get rid of crap
301find $RPM_BUILD_ROOT/ -name "*~"|xargs rm -f
302find $RPM_BUILD_ROOT/ -name ".cvsignore"|xargs rm -f
303find . -name "*~"|xargs rm -f
304find . -name ".cvsignore"|xargs rm -f
305#zero length
306rm -f $RPM_BUILD_ROOT%{python_lib}/site-packages/modulator/Templates/copyright
307
308# Clean up the testsuite - we don't need compiled files for it
309find $RPM_BUILD_ROOT%{python_lib}/test \
310    -name "*.pyc" -o -name "*.pyo" | xargs rm -f
311rm -f $RPM_BUILD_ROOT%{python_lib}/LICENSE.txt
312
313find $RPM_BUILD_ROOT%{python_lib}/lib-dynload -type f | grep -v _tkinter.so | sed "s|$RPM_BUILD_ROOT||" > dynfiles
314
315## Fix the file permissions
316chmod 755 $RPM_BUILD_ROOT%{python_lib}/lib-dynload/*.so
317chmod 755 $RPM_BUILD_ROOT%{_libdir}/libpython*.so.*
318find $RPM_BUILD_ROOT%{python_lib} -type f -name '*.py' | xargs chmod -x
319
320
321%clean
322rm -fr $RPM_BUILD_ROOT
323
324
325%files -f dynfiles
326%defattr(-, root, root)
327%doc LICENSE README
328%{_bindir}/%{name}*
329%{_mandir}/*/*
330%{_libdir}/libpython%{pybasever}.so*
331%dir %{python_lib}
332%dir %{python_lib}/lib-dynload
333%dir %{python_lib}/site-packages
334%{python_lib}/*.py*
335%{python_lib}/*.doc
336%{python_lib}/bsddb
337%{python_lib}/compiler
338%{python_lib}/ctypes
339%{python_lib}/curses
340%{python_lib}/distutils
341%{python_lib}/email
342%{python_lib}/encodings
343%{python_lib}/hotshot
344%{python_lib}/idlelib
345%{python_lib}/json
346%{python_lib}/lib2to3
347%{python_lib}/logging
348%{python_lib}/multiprocessing
349%{python_lib}/plat-linux2
350%{python_lib}/sqlite3
351%{python_lib}/wsgiref
352%{python_lib}/wsgiref.egg-info
353%{python_lib}/xml
354
355%files devel
356%defattr(-,root,root)
357%{_includedir}/*
358%{python_lib}/config
359%{python_lib}/test
360
361%files tools
362%defattr(-,root,root,755)
363%doc Tools/modulator/README.modulator
364%doc Tools/pynche/README.pynche
365%{python_lib}/site-packages
366%{_bindir}/2to3
367%{_bindir}/idle
368%{_bindir}/modulator
369%{_bindir}/msgfmt.py
370%{_bindir}/pydoc
371%{_bindir}/pygettext.py
372%{_bindir}/pynche
373%{_bindir}/smtpd.py
374
375%if %{with_doc}
376%files docs
377%defattr(-,root,root,755)
378%doc Misc/HISTORY Misc/NEWS  Misc/README Misc/cheatsheet Misc/developers.txt
379%doc Doc/build/html
380%endif
381
382%files -n tkinter
383%defattr(-,root,root,755)
384%{python_lib}/lib-tk
385%{python_lib}/lib-dynload/_tkinter.so
386
387
388%changelog
389* Sat Mar 20 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
390- updated python to 2.6.5
391- updated Patch0: Python-2.6.4-Setup.dist.patch
392- added macro bsddb_ver
393- added Patch11: python-support_bdb-4.8-v2.patch (instead of Patch10: python-2.6-db48.patch)
394
395* Sat Mar 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-5
396- added Python-2.6.4-Doc.78718.tgz (documents from http://svn.python.org/projects)
397- changed default to '--with doc' again
398
399* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.4-4
400- rebuilt with gcc-4.4.3-3 on ppc
401- s/BuildPreReq/BuildRequires/
402
403* Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
404- replaced Python-%%{version}-Setup.dist.patch
405- added BR: sqlite3-devel
406
407* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-2
408- add Patch10 to build with db-4.8
409
410* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
411- updated python to 2.6.4
412- changed default to '--without doc'
413- added Setup.dist.patch instead of Setup.dist{32,64}.patch
414- updated python-*-lib64.patch to 2.6.3
415
416* Mon Feb 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.5-1
417- updated python to 2.5.5
418
419* Wed May 06 2009 Shu KONNO <owa@bg.wakwak.com> 2.5.4-4vl5
420- added Python-2.5.4-{Setup,Setup64}.patch
421  - added _bsddb module
422  - dropt patch{0,9,10}
423
424* Sun May  3 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4-3vl5
425- updated Patch0 for building with db-4.6.21
426
427* Thu Feb 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.4-2vl5
428- add patch10
429  - add -lcrypt for cryptmodule
430
431* Wed Dec 24 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.4-1vl5
432- new upstream release
433- changed typo of summary(ja)
434
435* Sat Dec 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.3-1vl5
436- new upstream release
437- dropt python-2.4.4_CVE-2007-4965.patch
438- dropt python-2.4.4_CVE-2008-1721.patch
439- dropt python-2.4.4-CVE-2008-1679.patch
440
441* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.2-1vl5
442- updated python to 2.5.2
443- added python-2.5.2-config.patch instead of python-2.5c1-config.patch
444- added python-2.5.2-config64.patch instead of python-2.4.3-config.lib64.patch
445- added python-2.5.2-lib64.patch instead of python-2.4.2-lib64.patch
446- added modules ctypes, sqlite3, and wsgiref
447- dropt modules lib-old
448- dropt python-2.4.4_CVE-2008-1887.patch
449- dropt python-2.4.4_CVE-2007-2052.patch
450- fixed the file permissions
451
452* Sun Jun 08 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-1vl5
453- applied new versioning policy and spec in utf-8
454- added BuildPrereq: xorg-x11-devel
455- imported updates from Vine4.2
456        * Fri Apr 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.4vl4
457        - add patch120 for fix CVE-2008-1679 (added fix of CVE-2007-4965)
458        - add patch130 for fix CVE-2008-1887 (PyString_FromStringAndSize)
459        - add patch140 for fix CVE-2007-2052 (_localemodule.c off-by-one err)
460        * Mon Apr 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-1.3vl4
461        - add patch110 CVE-2008-1721 (zlib module)
462        - add remove unneeded files in Lib/test/
463        #- new versioning policy
464
465* Wed Mar 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.5-0vl1
466- updated python to 2.4.5
467
468* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.4-0vl7
469- rebuild with expat-2.0.1
470
471* Mon Feb 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl6
472- fix typo on Patch0 (s/db-4.2/db-4.3/)
473
474* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl5
475- rebuild with tcl/tk-8.4.18
476
477* Sat Dec 01 2007 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl4
478- imported updates from Vine4.2 Plus
479        * Thu Nov 01 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.2
480        - add BuildPrereq: nkf
481        * Wed Oct 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.4-0vl1.1
482        - add patch100 for fix CVE-2007-4965 (imageop Module integer OF)
483
484* Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.4-0vl3
485- rebuilt with openssl-0.9.8e and tix-8.4.2
486- fixed spec file encoding
487
488* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.4-0vl2
489- rebuilt with new toolchain and db4-4.3.x
490- modified Patch0 (s/db-4.2/db-4.3/)
491
492* Thu Oct 19 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.4-0vl1
493- updated python to 2.4.4 (included security fix PSF-2006-001)
494- added japanese summary
495- updated patch8 (python-2.4.2-lib64.patch)
496- added patch9 (python-2.4.4c1-setup.lib64.patch)
497
498* Wed Sep 13 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.3-0vl4
499- change docs Group to Applications/Documentation. <BTS:VineLinux:163>
500
501* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.4.3-0vl3
502- rebuild with readline-5.1 (x86_64)
503
504* Fri Apr 14 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl2
505- fixed python-2.4.3-config.patch cause undefined symbol: crypt
506
507* Thu Mar 30 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.3-0vl1
508- updated python to 2.4.3
509- added python-2.4.3-config.patch instead of python-2.4.1c1-config.patch
510
511* Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl5
512- set permition of lib-dynload/*.so to 755
513- added without_doc option
514- rebuilt with x86_64
515
516* Thu Nov 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl4
517- add run_test option
518
519* Fri Nov  4 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3.2
520- add BuildPrereq: bzip2-devel
521- arrange testing script
522
523* Wed Nov 02 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl3.1
524- back to %%configure macro
525- change testing script
526
527* Mon Oct 31 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl3
528- update Patch8 (VineSeed:10306)
529- use ./configure instead of %%configure script
530- add forgotten popd
531
532* Fri Oct 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.2-0vl2
533- add --enable-shared to confiugre option
534- add %%{_libdir}/libpython2.4.so* to python package
535- add LD_LIBRARY_PATH=$topdir to use pathfix.py
536- change build method of Doc
537- add files for make test
538- change install method
539
540* Wed Sep 28 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.2-0vl1
541- update python to 2.4.2 (final)
542
543* Wed Mar 30 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl1
544- update python to 2.4.1 (final)
545
546* Sat Mar 19 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c2
547- update python to 2.4.1c2
548- moved all site-packages files to python-tools package
549
550* Sat Mar 12 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl0.c1
551- update python to 2.4.1c1
552- droped aspython2 macros
553- droped japanese-codecs module
554- droped Source2 idle, now it's provided from original source
555- droped Source3 modulator, now it's generated in a spec file
556- droped Source4 pynche, now it's generated in a spec file
557- droped Python-2.3.3-buildroot-bytecode.patch
558- changed python-2.3.3-config2.patch to python-2.4.1c1-config.patch
559
560* Wed Feb 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.5-0vl1
561- update python to 2.3.5
562
563* Fri Feb 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl6
564- add PSF-2005-001.patch
565
566* Wed Nov 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl4
567- rebuilt
568
569* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl3
570- modified Patch0 and Patch8 (-ldb-4.0 -> -ldb-4.2)
571
572* Wed Oct 13 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.3.4-0vl2
573- rebuilt with db4-4.2.25
574
575* Thu May 27 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.4-0vl1
576- updated python to 2.3.4
577- fixed patch10, patch11
578
579* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl1
580- rebuild
581
582* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.3
583- updated python-2.3.3-config2.patch
584
585* Thu Apr 08 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.2
586- added librarys 'logging, bsddb, idlelib' to /usr/lib/python2.3
587
588* Wed Apr 07 2004 Shu KONNO <owa@bg.wakwak.com> 2.3.3-0vl0.1
589- updated python to 2.3.3
590- changed version code 2.2.3 to 2.3.3 in source{2,3,4}
591- updated config2.patch for 2.3.3
592- updated nowhatsnew.patch for 2.3.3
593- updated distutilrpm.patch in which tabstops have made indent error
594- updated buildroot-bytecode.patch for 2.3.3
595- deleted buildroot.patch which fixed in 2.3.3
596- changed Tools/idle with Lib/idlelib
597
598* Wed Mar 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-3vl3
599- rebuild with openssl-0.9.7d
600
601* Wed Mar 03 2004 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3vl2
602- updated JapaneseCodecs to 1.4.10
603
604* Wed Jul 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.3-3vl1
605- synced with RawHide 2.2.3-3 (substantially source ver up)
606
607* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2.2-26vl1
608- rebuild with tcltk-8.4.2
609- synced with RawHide 2.2.2-26
610  * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
611  - rebuilt
612
613  * Mon Feb 24 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-25
614  - Fixed bug #84886: pydoc dies when run w/o arguments
615  - Fixed bug #84205: add python shm module back (used to be shipped with 1.5.2)
616  - Fixed bug #84966: path in byte-compiled code still wrong
617
618  * Thu Feb 20 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-23
619  - ftp uri's should be able to specify being rooted at the root instead of
620    where you login via ftp (#84692)
621
622  * Mon Feb 10 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-22
623  - Using newer Japanese codecs (1.4.9). Thanks to
624    Peter Bowen <pzb@datastacks.com> for pointing this out.
625
626  * Thu Feb  6 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-21
627  - Rebuild
628
629  * Wed Feb  5 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-20
630  - Release number bumped really high: turning on UCS4 (ABI compatibility
631    breakage)
632
633  * Fri Jan 31 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-13
634  - Attempt to look both in /usr/lib64 and /usr/lib/python2.2/site-packages/:
635    some work on python-2.2.2-lib64.patch
636
637  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-12
638  - Rebuild to incorporate the removal of .lib64 and - files.
639
640  * Thu Jan 30 2003 Mihai Ibanescu <misa@redhat.com> 2.2.2-11.7.3
641  - Fixed bug #82544: Errata removes most tools
642  - Fixed bug #82435: Python 2.2.2 errata breaks redhat-config-users
643  - Removed .lib64 and - files that get installed after we fix the multilib
644    .py files.
645
646  * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
647  - rebuilt
648
649  * Wed Jan 15 2003 Jens Petersen <petersen@redhat.com> 2.2.2-10
650  - rebuild to update tkinter's tcltk deps
651  - convert changelog to utf-8
652
653
654* Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.2-9vl0
655- rebuilt for Vine Linux against db4
656- obsolete python-base (which comes with python-2.2.1 of TestPkg)
657
658* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 2.2.2-9
659- rebuild
660
661* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
662- pick up OpenSSL cflags and ldflags from pkgconfig if available
663
664* Thu Jan  2 2003 Jeremy Katz <katzj@redhat.com> 2.2.2-8
665- urllib2 didn't support non-anonymous ftp.  add support based on how
666  urllib did it (#80676, #78168)
667
668* Mon Dec 16 2002 Mihai Ibanescu <misa@redhat.com> 2.2.2-7
669- Fix bug #79647 (Rebuild of SRPM fails if python isn't installed)
670- Added a bunch of missing BuildRequires found while fixing the
671  above-mentioned bug
672
673* Tue Dec 10 2002 Tim Powers <timp@redhat.com> 2.2.2-6
674- rebuild to fix broken tcltk deps for tkinter
675
676* Fri Nov 22 2002 Mihai Ibanescu <misa@redhat.com>
6772.2.2-3.7.3
678- Recompiled for 7.3 (to fix the -lcrypt bug)
679- Fix for the spurious error message at the end of the build (build-requires
680  gets confused by executable files starting with """"): make the tests
681  non-executable.
682
683* Wed Nov 20 2002 Mihai Ibanescu <misa@redhat.com>
6842.2.2-5
685- Fixed configuration patch to add -lcrypt when compiling cryptmodule.c
686
6872.2.2-4
688- Spec file change from Matt Wilson <msw@redhat.com> to disable linking
689  with the C++ compiler.
690
691* Mon Nov 11 2002 Mihai Ibanescu <misa@redhat.com>
6922.2.2-3.*
693- Merged patch from Karsten Hopp <karsten@redhat.de> from 2.2.1-17hammer to
694  use %%{_libdir}
695- Added XFree86-libs as BuildRequires (because of tkinter)
696- Fixed duplicate listing of plat-linux2
697- Fixed exclusion of lib-dynload/japanese
698- Added lib64 patch for the japanese codecs
699- Use setup magic instead of using tar directly on JapaneseCodecs
700
701* Tue Nov  5 2002 Mihai Ibanescu <misa@redhat.com>
7022.2.2-2
703- Fix #76912 (python-tools contains idle, which uses tkinter, but there is no
704  requirement of tkinter from python-tools).
705- Fix #74013 (rpm is missing the /usr/lib/python2.2/test directory)
706
707* Mon Nov  4 2002 Mihai Ibanescu <misa@redhat.com>
708- builds as python2 require a different libdb
709- changed the buildroot name of python to match python2 builds
710
711* Fri Nov  1 2002 Mihai Ibanescu <misa@redhat.com>
712- updated python to 2.2.2 and adjusted the patches accordingly
713
714* Mon Oct 21 2002 Mihai Ibanescu <misa@redhat.com>
715- Fix #53930 (Python-2.2.1-buildroot-bytecode.patch)
716- Added BuildPrereq dependency on gcc-c++
717
718* Fri Aug 30 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-17
719- security fix for _execvpe
720
721* Tue Aug 13 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-16
722- Fix  #71011,#71134, #58157
723
724* Wed Aug  7 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-15
725- Resurrect tkinter
726- Fix for distutils (#67671)
727- Fix #69962
728
729* Thu Jul 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-14
730- Obsolete tkinter/tkinter2 (#69838)
731
732* Tue Jul 23 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-13
733- Doc fixes (#53951) - not on alpha at the momemt
734
735* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-12
736- fix pydoc (#68082)
737
738* Mon Jul  8 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-11
739- Add db4-devel as a BuildPrereq
740
741* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.2.1-10
742- automated rebuild
743
744* Mon Jun 17 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-9
745- Add Japanese codecs (#66352)
746
747* Tue Jun 11 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-8
748- No more tkinter...
749
750* Wed May 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-7
751- Rebuild
752
753* Tue May 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-6
754- Add the email subcomponent (#65301)
755
756* Fri May 10 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-5
757- Rebuild
758
759* Thu May 02 2002 Than Ngo <than@redhat.com> 2.2.1-4
760- rebuild i new enviroment
761
762* Tue Apr 23 2002 Trond Eivind Glomsroed <teg@redhat.com>
763- Use ucs2, not ucs4, to avoid breaking tkinter (#63965)
764
765* Mon Apr 22 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-2
766- Make it use db4
767
768* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2.1-1
769- 2.2.1 - a bugfix-only release
770
771* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-16
772- the same, but in builddirs - this will remove them from the
773  docs package, which doesn't look in the buildroot for files.
774
775* Fri Apr 12 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-15
776- Get rid of temporary files and .cvsignores included
777  in the tarball and make install
778
779* Fri Apr  5 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-14
780- Don't own lib-tk in main package, only in tkinter (#62753)
781
782* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-13
783- rebuild
784
785* Mon Mar 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-12
786- rebuild
787
788* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-11
789- Add a not to the Distutils obsoletes test (doh!)
790
791* Fri Mar  1 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-10
792- Rebuild
793
794* Mon Feb 25 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-9
795- Only obsolete Distutils when built as python
796
797* Thu Feb 21 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-8
798- Make files in /usr/bin install side by side with python 1.5 when
799- Drop explicit requirement of db4
800  built as python2
801
802* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 2.2-7
803- Use version and pybasever macros to make updating easy
804- Use _smp_mflags macro
805
806* Tue Jan 29 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-6
807- Add db4-devel to BuildPrereq
808
809* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 2.2-5
810- disable ndbm support, which is db2 in disguise (really interesting things
811  can happen when you mix db2 and db4 in a single application)
812
813* Thu Jan 24 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-4
814- Obsolete subpackages if necesarry
815- provide versioned python2
816- build with db4
817
818* Wed Jan 16 2002 Trond Eivind Glomsroed <teg@redhat.com> 2.2-3
819- Alpha toolchain broken. Disable build on alpha.
820- New openssl
821
822* Wed Dec 26 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-1
823- 2.2 final
824
825* Fri Dec 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.11c1
826- 2.2 RC 1
827- Don't include the _tkinter module in the main package - it's
828  already in the tkiter packace
829- Turn off the mpzmodule, something broke in the buildroot
830
831* Wed Nov 28 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.10b2
832- Use -fPIC for OPT as well, in lack of a proper libpython.so
833
834* Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.9b2
835- changed DESTDIR to point to / so that distutils will install dynload
836  modules properly in the installroot
837
838* Fri Nov 16 2001 Matt Wilson <msw@redhat.com> 2.2-0.8b2
839- 2.2b2
840
841* Fri Oct 26 2001 Matt Wilson <msw@redhat.com> 2.2-0.7b1
842- python2ify
843
844* Fri Oct 19 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.5b1
845- 2.2b1
846
847* Sun Sep 30 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.4a4
848- 2.2a4
849- Enable UCS4 support
850- Enable IPv6
851- Provide distutils
852- Include msgfmt.py and pygettext.py
853
854* Fri Sep 14 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.3a3
855- Obsolete Distutils, which is now part of the main package
856- Obsolete python2
857
858* Thu Sep 13 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.2a3
859- Add docs, tools and tkinter subpackages, to match the 1.5 layout
860
861* Wed Sep 12 2001 Trond Eivind Glomsroed <teg@redhat.com> 2.2-0.1a3
862- 2.2a3
863- don't build tix and blt extensions
864
865* Mon Aug 13 2001 Trond Eivind Glomsroed <teg@redhat.com>
866- Add tk and tix to build dependencies
867
868* Sat Jul 21 2001 Trond Eivind Glomsroed <teg@redhat.com>
869- 2.1.1 bugfix release - with a GPL compatible license
870
871* Fri Jul 20 2001 Trond Eivind Glomsroed <teg@redhat.com>
872- Add new build dependencies (#49753)
873
874* Tue Jun 26 2001 Nalin Dahyabhai <nalin@redhat.com>
875- build with -fPIC
876
877* Fri Jun  1 2001 Trond Eivind Glomsroed <teg@redhat.com>
878- 2.1
879- reorganization of file includes
880
881* Wed Dec 20 2000 Trond Eivind Glomsroed <teg@redhat.com>
882- fix the "requires" clause, it lacked a space causing problems
883- use %%{_tmppath}
884- don't define name, version etc
885- add the available patches from the Python home page
886
887* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
888- added devel subpackage
889
890* Fri Dec 15 2000 Matt Wilson <msw@redhat.com>
891- modify all files to use "python2.0" as the intrepter
892- don't build the Expat bindings
893- build against db1
894
895* Mon Oct 16 2000 Jeremy Hylton <jeremy@beopen.com>
896- updated for 2.0 final
897
898* Mon Oct  9 2000 Jeremy Hylton <jeremy@beopen.com>
899- updated for 2.0c1
900- build audioop, imageop, and rgbimg extension modules
901- include xml.parsers subpackage
902- add test.xml.out to files list
903
904* Thu Oct  5 2000 Jeremy Hylton <jeremy@beopen.com>
905- added bin/python2.0 to files list (suggested by Martin v. Loewis)
906
907* Tue Sep 26 2000 Jeremy Hylton <jeremy@beopen.com>
908- updated for release 1 of 2.0b2
909- use .bz2 version of Python source
910
911* Tue Sep 12 2000 Jeremy Hylton <jeremy@beopen.com>
912- Version 2 of 2.0b1
913- Make the package relocatable.  Thanks to Suchandra Thapa.
914- Exclude Tkinter from main RPM.  If it is in a separate RPM, it is
915  easier to track Tk releases.
Note: See TracBrowser for help on using the repository browser.