source: projects/specs/trunk/p/python-whoosh/python-whoosh-vl.spec @ 12469

Revision 12469, 5.8 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%global with_python3 1
2
3# For bootstrapping sphinxcontrib-websupport
4%bcond_with docs
5
6%global mod_name Whoosh
7
8Summary:        Fast, pure-Python full text indexing, search, and spell checking library
9Name:           python-whoosh
10Version:        2.7.4
11Release:        14%{?_dist_release}
12Group:          programming
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16License:        BSD
17URL:            http://pythonhosted.org/Whoosh/
18Source0:        https://pypi.python.org/packages/source/W/%{mod_name}/%{mod_name}-%{version}.tar.gz
19
20BuildArch:      noarch
21BuildRequires:  python-rpm-macros
22
23BuildRequires:  python2-rpm-macros
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26
27%if %{with docs}
28BuildRequires:  python-sphinx
29%endif
30
31%{?python_provide:%python_provide python2-whoosh}
32
33%if 0%{?with_python3}
34BuildRequires: python3-rpm-macros
35BuildRequires: python3-devel
36BuildRequires: python3-setuptools
37%endif
38
39%description
40Whoosh is a fast, featureful full-text indexing and searching library
41implemented in pure Python. Programmers can use it to easily add search
42functionality to their applications and websites. Every part of how Whoosh
43works can be extended or replaced to meet your needs exactly.
44
45
46%if 0%{?with_python3}
47%package -n python3-whoosh
48Summary:    Fast, Python3 full text indexing, search, and spell checking library
49%{?python_provide:%python_provide python%{python3_pkgversion}-whoosh}
50Group:          programming
51
52%description -n python3-whoosh
53Whoosh is a fast, featureful full-text indexing and searching library
54implemented in pure Python. Programmers can use it to easily add search
55functionality to their applications and websites. Every part of how Whoosh
56works can be extended or replaced to meet your needs exactly.
57%endif
58
59
60%prep
61%setup -q -n %{mod_name}-%{version}
62
63
64%build
65%py2_build
66
67%if %{with docs}
68sphinx-build docs/source docs/html
69rm -f docs/html/.buildinfo
70rm -rf docs/html/.doctrees
71%endif
72
73%if 0%{?with_python3}
74%py3_build
75rm -f docs/html/.buildinfo
76rm -rf docs/html/.doctrees
77%endif
78
79
80%install
81%py2_install
82
83%if 0%{?with_python3}
84%py3_install
85%endif
86
87
88%if 0
89%check
90{__python2} setup.py test
91
92%if 0%{?with_python3}
93%{__python3} setup.py test
94%endif
95%endif
96
97
98%files
99%license LICENSE.txt
100%doc README.txt
101%if %{with docs}
102%doc docs/html/
103%endif
104%{python2_sitelib}/*.egg-info/
105%{python2_sitelib}/whoosh
106
107%if 0%{?with_python3}
108%files -n python%{python3_pkgversion}-whoosh
109%license LICENSE.txt
110%doc README.txt
111%if %{with docs}
112%doc docs/html/
113%endif
114%{python3_sitelib}/whoosh
115%{python3_sitelib}/*.egg-info/
116%endif
117
118
119%changelog
120* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-14
121- rebuilt with python-3.8.
122
123* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7.4-13
124- initial build for Vine Linux.
125
126* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-12
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
128
129* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-11
130- Rebuilt for Python 3.7
131
132* Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7.4-10
133- Bootstrap for Python 3.7
134
135* Wed Feb 28 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.7.4-9
136- Update Python 2 dependency declarations to new packaging standards
137  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
138
139* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-8
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
141
142* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-7
143- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
144
145* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.4-6
146- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
147
148* Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-5
149- Enable tests
150
151* Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.7.4-4
152- Rebuild for Python 3.6
153- Disable python3 tests for now
154
155* Wed Oct 12 2016 Orion Poplawski <orion@cora.nwra.com> - 2.7.4-3
156- Ship python2-whoosh
157- Build python3 package for EPEL7
158- Modernize spec
159
160* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.7.4-2
161- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
162
163* Sun May 01 2016 Robert Kuska <rkuska@gmail.com> - 2.7.4-1
164- Update to version 2.7.4
165
166* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.7.0-2
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
168
169* Mon Oct 12 2015 Robert Kuska <rkuska@redhat.com> 2.7.0-1
170- Update to version 2.7.0
171
172* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-5
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
174
175* Wed Jul 30 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-4
176- Change spec for el6 and epel7
177
178* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.7-3
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
180
181* Fri May 16 2014 Robert Kuska <rkuska@redhat.com> - 2.7.5-2
182- Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
183
184* Mon Mar 03 2014 Robert Kuska <rkuska@redhat.com> - 2.5.7-1
185- Rebase to 2.5.7
186
187* Mon Jan 27 2014 Robert Kuska <rkuska@redhat.com> - 2.5.6-1
188- Rebase to 2.5.6
189
190* Tue Nov 19 2013 Robert Kuska <rkuska@redhat.com> - 2.5.5-1
191- Rebase to 2.5.5
192
193* Mon Sep 09 2013 Robert Kuska <rkuska@redhat.com> - 2.5.3-1
194- Rebase to 2.5.3
195
196* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.1-2
197- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
198
199* Mon Jul 08 2013 Robert Kuska <rkuska@redhat.com> - 2.5.1-1
200- Update source
201- Add python3 subpackage (rhbz#979235)
202
203* Mon Apr 08 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-2
204- Review fixes
205
206* Fri Apr 05 2013 Robert Kuska <rkuska@redhat.com> - 2.4.1-1
207- Initial package
208
Note: See TracBrowser for help on using the repository browser.