source: projects/specs/trunk/p/python-virtualenv/python-virtualenv-vl.spec @ 8880

Revision 8880, 4.8 KB checked in by yasumichi, 10 years ago (diff)

new upstream release

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        1.11.6
7Release:        1%{?_dist_release}
8
9Group:          Development/Languages
10License:        MIT
11URL:            http://pypi.python.org/pypi/%{oname}
12Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14BuildArch:      noarch
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Packager:       yasumichi
19
20BuildRequires:  python-devel
21Requires:       python-devel
22
23BuildRequires:  python-setuptools
24Requires:       python-setuptools
25
26
27%description
28virtualenv is a tool to create isolated Python environments. virtualenv
29is a successor to workingenv, and an extension of virtual-python. It is
30written by Ian Bicking, and sponsored by the Open Planning Project. It is
31licensed under an MIT-style permissive license.
32
33
34%prep
35%setup -q -n %{oname}-%{version}
36%{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
37
38
39%build
40%{__python} setup.py build
41
42
43%install
44rm -rf $RPM_BUILD_ROOT
45%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
46
47 
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51
52%files
53%defattr(-,root,root,-)
54%doc docs/*.rst PKG-INFO
55# For noarch packages: sitelib
56%{python_sitelib}/*
57%attr(755,root,root) %{_bindir}/virtualenv*
58
59
60%changelog
61* Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
62- new upstream release
63- add Vendor, Distribution and Packager
64
65* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
66- rebuild with python-2.7.2
67
68* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
69- updated virtualenv to 1.5.1
70
71* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
72- initial build for Vine Linux
73
74* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
75- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
76
77* Tue Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
78- Fixed EPEL installation issue from BZ#611536
79
80* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
81- Only replace the python shebang on the first line (Robert Buchholz)
82
83* Fri Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
84- update pip to 0.7
85- move regen-docs into bin/
86- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
87unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
88- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
89- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
90- add warning message if PYTHONHOME is set
91
92* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
93- allow script creation without setuptools
94- fix problem with --relocate when bin/ has subdirs (fixes #12)
95- Allow more flexible .pth file fixup
96- make nt a required module, along with posix. it may not be a builtin module on jython
97- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
98
99* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
100- Updated for upstream release.
101
102* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
103- Updated for upstream release.
104
105* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
109- Updated for upstream release.
110
111* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
113
114* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
115- Updated for upstream release.
116
117* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
118- Rebuild for Python 2.6
119
120* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
121- Added missing dependencies.
122
123* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
124- Rebuild for Python 2.6
125
126* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
127- Updated for upstream release
128
129* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
130- Updated for upstream release
131
132* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
133- Updated for upstream release
134
135* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
136- Updated from review notes
137
138* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
139- Updated from review notes
140
141* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
142- Initial Version
Note: See TracBrowser for help on using the repository browser.