source: projects/specs/trunk/p/python-virtualenv/python-virtualenv-vl.spec @ 5701

Revision 5701, 4.6 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        1.5.1
7Release:        2%{?_dist_release}
8
9Group:          Development/Languages
10License:        MIT
11URL:            http://pypi.python.org/pypi/%{oname}
12Source0:        http://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15BuildArch:      noarch
16BuildRequires:  python-devel
17Requires:       python-setuptools, python-devel
18
19BuildRequires:  python-setuptools
20Requires:       python-setuptools
21
22
23%description
24virtualenv is a tool to create isolated Python environments. virtualenv
25is a successor to workingenv, and an extension of virtual-python. It is
26written by Ian Bicking, and sponsored by the Open Planning Project. It is
27licensed under an MIT-style permissive license.
28
29
30%prep
31%setup -q -n %{oname}-%{version}
32%{__sed} -i -e "1s|#!/usr/bin/env python||" virtualenv.py
33
34
35%build
36%{__python} setup.py build
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
42
43 
44%clean
45rm -rf $RPM_BUILD_ROOT
46
47
48%files
49%defattr(-,root,root,-)
50%doc docs/index.txt docs/license.txt docs/news.txt PKG-INFO
51# For noarch packages: sitelib
52%{python_sitelib}/*
53%attr(755,root,root) %{_bindir}/virtualenv
54
55
56%changelog
57* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
58- rebuild with python-2.7.2
59
60* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
61- updated virtualenv to 1.5.1
62
63* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
64- initial build for Vine Linux
65
66* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
67- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
68
69* Tue Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
70- Fixed EPEL installation issue from BZ#611536
71
72* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
73- Only replace the python shebang on the first line (Robert Buchholz)
74
75* Fri Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
76- update pip to 0.7
77- move regen-docs into bin/
78- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
79unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
80- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
81- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
82- add warning message if PYTHONHOME is set
83
84* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
85- allow script creation without setuptools
86- fix problem with --relocate when bin/ has subdirs (fixes #12)
87- Allow more flexible .pth file fixup
88- make nt a required module, along with posix. it may not be a builtin module on jython
89- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
90
91* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
92- Updated for upstream release.
93
94* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
95- Updated for upstream release.
96
97* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
99
100* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
101- Updated for upstream release.
102
103* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
107- Updated for upstream release.
108
109* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
110- Rebuild for Python 2.6
111
112* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
113- Added missing dependencies.
114
115* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
116- Rebuild for Python 2.6
117
118* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
119- Updated for upstream release
120
121* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
122- Updated for upstream release
123
124* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
125- Updated for upstream release
126
127* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
128- Updated from review notes
129
130* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
131- Updated from review notes
132
133* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
134- Initial Version
Note: See TracBrowser for help on using the repository browser.