source: projects/specs/trunk/p/python-virtualenv/python-virtualenv-vl.spec @ 12479

Revision 12479, 6.8 KB checked in by tomop, 4 years ago (diff)

updated 3 packages

chrony-3.5.1-1

oniguruma-6.9.5.rev1-2

python-virtualenv-20.0.31-1

Line 
1%global oname virtualenv
2
3Summary:        Tool to create isolated Python environments
4Summary(ja):    隔離されたPython環境を構築するためのツール
5Name:           python-%{oname}
6Version:        20.0.31
7Release:        1%{?_dist_release}
8Group:          programming
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       yasumichi
12
13License:        MIT
14URL:            https://pypi.python.org/pypi/%{oname}
15Source0:        https://pypi.python.org/packages/source/v/%{oname}/%{oname}-%{version}.tar.gz
16# Add /usr/share/python-wheels to extra_search_dir
17
18BuildArch:      noarch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20
21BuildRequires:  python-rpm-macros
22
23BuildRequires:  python2-rpm-macros
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26Requires:       python-devel
27Requires:       python-setuptools
28
29BuildRequires:  python3-rpm-macros
30BuildRequires:  python3-setuptools
31BuildRequires:  python3-devel
32
33
34%description
35virtualenv is a tool to create isolated Python environments. virtualenv
36is a successor to workingenv, and an extension of virtual-python. It is
37written by Ian Bicking, and sponsored by the Open Planning Project. It is
38licensed under an MIT-style permissive license.
39
40
41%package -n     python3-virtualenv
42Summary:        Tool to create isolated Python environments
43Summary(ja):    隔離されたPython環境を構築するためのツール
44Group:          programming
45Requires:       python3-setuptools
46Requires:       python3-devel
47
48%description -n python3-virtualenv
49virtualenv is a tool to create isolated Python environments. virtualenv
50is a successor to workingenv, and an extension of virtual-python. It is
51written by Ian Bicking, and sponsored by the Open Planning Project. It is
52licensed under an MIT-style permissive license
53
54
55%prep
56%setup -q -n %{oname}-%{version}
57%{__sed} -i -e "1s|#!/usr/bin/env python||" tasks/update_embedded.py
58
59# Remove the wheels provided by RPM packages
60rm src/virtualenv/seed/wheels/embed/pip-*
61rm src/virtualenv/seed/wheels/embed/setuptools-*
62rm src/virtualenv/seed/wheels/embed/wheel-*
63
64test ! -f src/virtualenv/seed/embed/wheels/*.whl
65
66
67%build
68# Build code
69%{py2_build}
70%{py3_build}
71
72
73%install
74rm -rf %{buildroot}
75%{py2_install}
76# The versioned 2.x script was removed from upstream. Add it back.
77cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python_version}
78cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-2
79rm %{buildroot}/%{_bindir}/virtualenv
80
81%{py3_install}
82# The versioned 3.x script was removed from upstream. Add it back.
83cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-%{python3_version}
84cp %{buildroot}/%{_bindir}/virtualenv %{buildroot}/%{_bindir}/virtualenv-3
85
86
87%clean
88rm -rf %{buildroot}
89
90
91%files
92%defattr(-,root,root,-)
93%license LICENSE
94%doc docs/*rst README*
95%{_bindir}/virtualenv-2
96%{_bindir}/virtualenv-%{python_version}
97%{python_sitelib}/*
98
99%files -n python3-virtualenv
100%license LICENSE
101%doc docs/*rst README*
102%{_bindir}/virtualenv
103%{_bindir}/virtualenv-3
104%{_bindir}/virtualenv-%{python3_version}
105%{python3_sitelib}/virtualenv
106%{python3_sitelib}/virtualenv-*.egg-info/
107
108%changelog
109* Sat Aug 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.0.31-1
110- new upstream release.
111- made python3 primary (/usr/bin/virtualenv).
112- dropped Patch0.
113
114* Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.1.0-1
115- new upstream release.
116- added Patch0.
117- made to use python{,3}-rpm-macros.
118- added a sub-package for python3.
119
120* Sat Aug 02 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.11.6-1
121- new upstream release
122- add Vendor, Distribution and Packager
123
124* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.1-2
125- rebuild with python-2.7.2
126
127* Mon Nov 22 2010 Shu KONNO <owa@bg.wakwak.com> 1.5.1-1
128- updated virtualenv to 1.5.1
129
130* Sat Sep 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.8-1
131- initial build for Vine Linux
132
133* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.4.8-4
134- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
135
136* Wed Jul  7 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-3
137- Fixed EPEL installation issue from BZ#611536
138
139* Tue Jun  8 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-2
140- Only replace the python shebang on the first line (Robert Buchholz)
141
142* Wed Apr 28 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.8-1
143- update pip to 0.7
144- move regen-docs into bin/
145- Fix #31, make activate_this.py work on Windows (use Lib/site-packages)
146unset PYTHONHOME envioronment variable -- first step towards fixing the PYTHONHOME issue; see e.g. https://bugs.launchpad.net/virtualenv/+bug/290844
147- unset PYTHONHOME in the (Unix) activate script (and reset it in deactivate())
148- use the activate.sh in virtualenv.py via running bin/rebuild-script.py
149- add warning message if PYTHONHOME is set
150
151* Fri Apr 2 2010 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.6-1
152- allow script creation without setuptools
153- fix problem with --relocate when bin/ has subdirs (fixes #12)
154- Allow more flexible .pth file fixup
155- make nt a required module, along with posix. it may not be a builtin module on jython
156- don't mess with PEP 302-supplied __file__, from CPython, and merge in a small startup optimization for Jython, from Jython
157
158* Tue Dec 22 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.3-1
159- Updated for upstream release.
160
161* Thu Nov 12 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.4.2-1
162- Updated for upstream release.
163
164* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
166
167* Tue Apr 28 2009 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.3-1
168- Updated for upstream release.
169
170* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
172
173* Thu Dec 25 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.2-1
174- Updated for upstream release.
175
176* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-4
177- Rebuild for Python 2.6
178
179* Mon Dec  1 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-3
180- Added missing dependencies.
181
182* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.3.1-2
183- Rebuild for Python 2.6
184
185* Fri Nov 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3.1-1
186- Updated for upstream release
187
188* Sun Sep 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.3-1
189- Updated for upstream release
190
191* Sat Aug 30 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.2-1
192- Updated for upstream release
193
194* Fri Aug 29 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-3
195- Updated from review notes
196
197* Thu Aug 28 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-2
198- Updated from review notes
199
200* Tue Aug 26 2008 Steve 'Ashcrow' Milner <me@stevemilner.org> - 1.1-1
201- Initial Version
Note: See TracBrowser for help on using the repository browser.