source: projects/specs/trunk/p/python-utils/python-utils-vl.spec @ 12545

Revision 12545, 4.4 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1Name:           python-utils
2Version:        2.5.6
3Release:        1%{?_dist_release}
4Summary:        Python Utils is a module with some convenient utilities
5
6License:        BSD
7URL:            https://github.com/WoLpH/python-utils
8Source0:        %{url}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
9BuildArch:      noarch
10
11BuildRequires:  make
12BuildRequires:  python3-devel
13#BuildRequires:  python3-pytest-runner
14#BuildRequires:  python3-pytest
15BuildRequires:  python3-setuptools
16BuildRequires:  python3-six
17BuildRequires:  python3-sphinx
18
19%?python_enable_dependency_generator
20
21%description
22Python Utils is a collection of small Python functions and classes which
23make common patterns shorter and easier. This module makes it easy to
24execute common tasks in Python scripts such as converting text to numbers
25and making sure a string is in unicode or bytes format.
26
27
28%package -n     python3-utils
29Summary:        %{summary}
30%{?python_provide:%python_provide python3-utils}
31
32%description -n python3-utils
33Python Utils is a collection of small Python functions and classes which
34make common patterns shorter and easier. This module makes it easy to
35execute common tasks in Python scripts such as converting text to numbers
36and making sure a string is in unicode or bytes format.
37
38
39%prep
40%autosetup -p1 -n %{name}-%{version}
41# Remove bundled egg-info
42rm -rf %{name}.egg-info
43
44# Stop linting code in %%check and measuring coverage, this is upstream's business
45sed -Ei '/--(cov|pep8|flakes)/d' pytest.ini
46
47
48%build
49%py3_build
50# generate html docs
51sphinx-build docs html
52# remove the sphinx-build leftovers
53rm -rf html/{.doctrees,.buildinfo,*.inv}
54
55
56%install
57%py3_install
58
59
60#%check
61#%{__python3} setup.py pytest --addopts --ignore=build
62
63
64%files -n python3-utils
65%doc README.rst html
66%license LICENSE
67%{python3_sitelib}/python_utils
68%{python3_sitelib}/python_utils-%{version}-py%{python3_version}.egg-info
69
70
71%changelog
72* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.5.6-1
73- initial build for Vine Linux.
74- new upstream release.
75
76* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-3
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
78
79* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.0-2
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
81
82* Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 2.4.0-1
83- Update to 2.4.0 (#1809705)
84
85* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 2.3.0-10
86- Rebuilt for Python 3.9
87
88* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-9
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
90
91* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 2.3.0-8
92- Rebuilt for Python 3.8.0rc1 (#1748018)
93
94* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 2.3.0-7
95- Rebuilt for Python 3.8
96
97* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-6
98- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
99
100* Mon May 13 2019 Orion Poplawski <orion@nwra.com> - 2.3.0-5
101- Add patch to build docs with python 3 (bugz#1709063)
102- Drop unneeded BR on pytest-cache
103
104* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-4
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
106
107* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.0-3
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
109
110* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 2.3.0-2
111- Rebuilt for Python 3.7
112
113* Sat May 05 2018 Miro Hrončok <mhroncok@redhat.com> - 2.3.0-1
114- New version 2.3.0 (#1474328)
115- Use automatic dependency generator
116
117* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-3
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
119
120* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
122
123* Thu Jun 15 2017 Miro Hrončok <mhroncok@redhat.com> - 2.1.0-1
124- New version 2.1.0 (#1438625)
125
126* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-3
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
128
129* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 2.0.1-2
130- Rebuild for Python 3.6
131
132* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.0.1-1
133- Updated, added LICENSE file
134
135* Sun Dec 04 2016 Miro Hrončok <mhroncok@redhat.com> - 2.0.0-1
136- Initial package
Note: See TracBrowser for help on using the repository browser.