source: projects/specs/trunk/p/python-urwid/python-urwid-vl.spec @ 5023

Revision 5023, 2.3 KB checked in by kudoh, 13 years ago (diff)

%{!?python_sitearch: %global python_sitearch %(%{python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}

Name: python-urwid
Version: 1.0.0
Release: 2%{?_dist_release}
Summary: Console user interface library
Summary(ja): コンソールユーザーインターフェースライブラリ

Group: Development/Libraries?
License: LGPLv2+
URL:  http://excess.org/urwid/
Source0:  http://excess.org/urwid/urwid-%{version}.tar.gz

BuildRoot?: %{_tmppath}/%{name}-%{version}-root
BuildRequires?: ncurses-devel
BuildRequires?: python-devel
BuildRequires?: python-setuptools
BuildRequires?: python-twisted
BuildRequires?: pygobject

%description
Urwid is a Python library for making text console applications. It has many
features including fluid interface resizing, support for UTF-8 and CJK
encodings, standard and custom text layout modes, simple markup for setting
text attributes, and a powerful, dynamic list box that handles a mix of widget
types. It is flexible, modular, and leaves the developer in control.

%prep
%setup -q -n urwid-%{version}
find urwid -type f -name "*.py" -exec sed -i -e '/#!\, 1d' {} \;
find urwid -type f -name "*.py" -exec chmod 644 {} \;

%build
CFLAGS="%{optflags}" %{python} setup.py build

%check
#./test_urwid.py
python setup.py test

%install
rm -rf %{buildroot}
%{python} setup.py install --skip-build --no-compile --root %{buildroot}
rm -f tmpl_tutorial.html
mkdir examples
cp -p *.py examples/
rm -f examples/test_urwid.py examples/docgen_*.py

%clean
rm -rf %{buildroot}

%files
%defattr(-,root,root,-)
%doc CHANGELOG *.html examples
%{python_sitearch}/urwid
%{python_sitearch}/urwid-%{version}*.egg-info

%changelog

  • Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@…> - 1.0.0-2
  • added BuildRequires?: python-setuptools
  • run %%check
  • Fri Sep 23 2011 Toshiharu Kudoh <toshi.kd2@…> - 1.0.0-1
  • new upstream release
  • Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@…> - 0.9.9.2-1
  • new upstream release
  • Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.9.9.1-2
  • rebuilt with rpm-4.8.1 for pkg-config
  • Fri May 28 2010 Toshiharu Kudoh <toshi.kd2@…> - 0.9.9.1-1
  • initial build for VineSeed
  • Wed May 19 2010 David Cantrell <dcantrell@…> - 0.9.9.1-1
  • Initial package
RevLine 
[1156]1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name:          python-urwid
[4835]4Version:       1.0.0
[5023]5Release:       2%{?_dist_release}
[1156]6Summary:       Console user interface library
7Summary(ja):   コンソールユーザーインターフェースライブラリ
8
9Group:         Development/Libraries
10License:       LGPLv2+
11URL:           http://excess.org/urwid/
12Source0:       http://excess.org/urwid/urwid-%{version}.tar.gz
13
14BuildRoot:     %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ncurses-devel
16BuildRequires: python-devel
[5023]17BuildRequires: python-setuptools
[1156]18BuildRequires: python-twisted
19BuildRequires: pygobject
20
21%description
22Urwid is a Python library for making text console applications.  It has many
23features including fluid interface resizing, support for UTF-8 and CJK
24encodings, standard and custom text layout modes, simple markup for setting
25text attributes, and a powerful, dynamic list box that handles a mix of widget
26types.  It is flexible, modular, and leaves the developer in control.
27
28%prep
29%setup -q -n urwid-%{version}
30find urwid -type f -name "*.py" -exec sed -i -e '/^#!\//, 1d' {} \;
31find urwid -type f -name "*.py" -exec chmod 644 {} \;
32
33%build
34CFLAGS="%{optflags}" %{__python} setup.py build
35
[5023]36%check
[4835]37#./test_urwid.py
[5023]38python setup.py test
[1156]39
40%install
41rm -rf %{buildroot}
42%{__python} setup.py install --skip-build --no-compile --root %{buildroot}
43rm -f tmpl_tutorial.html
44mkdir examples
45cp -p *.py examples/
46rm -f examples/test_urwid.py examples/docgen_*.py
47
48%clean
49rm -rf %{buildroot}
50
51%files
52%defattr(-,root,root,-)
53%doc CHANGELOG *.html examples
54%{python_sitearch}/urwid
55%{python_sitearch}/urwid-%{version}*.egg-info
56
57%changelog
[5023]58* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-2
59- added BuildRequires: python-setuptools
60- run %%check
61
[4835]62* Fri Sep 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
63- new upstream release
64
[4624]65* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.2-1
66- new upstream release
67
[1951]68* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.1-2
69- rebuilt with rpm-4.8.1 for pkg-config
70
[1156]71* Fri May 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.1-1
72- initial build for VineSeed
73
74* Wed May 19 2010 David Cantrell <dcantrell@redhat.com> - 0.9.9.1-1
75- Initial package
Note: See TracBrowser for help on using the repository browser.