source: projects/specs/trunk/p/python-urwid/python-urwid-vl.spec @ 5254

Revision 5254, 2.4 KB checked in by kudoh, 12 years ago (diff)

python-urwid-vl.spec

Line 
1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
2
3Name:          python-urwid
4Version:       1.0.1
5Release:       1%{?_dist_release}
6Summary:       Console user interface library
7Summary(ja):   コンソールユーザーインターフェースライブラリ
8
9Group:         Development/Libraries
10License:       LGPLv2+
11URL:           http://excess.org/urwid/
12Source0:       http://excess.org/urwid/urwid-%{version}.tar.gz
13
14BuildRoot:     %{_tmppath}/%{name}-%{version}-root
15BuildRequires: ncurses-devel
16BuildRequires: python-devel
17BuildRequires: python-setuptools
18BuildRequires: python-twisted
19BuildRequires: pygobject
20
21%description
22Urwid is a Python library for making text console applications.  It has many
23features including fluid interface resizing, support for UTF-8 and CJK
24encodings, standard and custom text layout modes, simple markup for setting
25text attributes, and a powerful, dynamic list box that handles a mix of widget
26types.  It is flexible, modular, and leaves the developer in control.
27
28%prep
29%setup -q -n urwid-%{version}
30find urwid -type f -name "*.py" -exec sed -i -e '/^#!\//, 1d' {} \;
31find urwid -type f -name "*.py" -exec chmod 644 {} \;
32
33%build
34CFLAGS="%{optflags}" %{__python} setup.py build
35
36%check
37#./test_urwid.py
38python setup.py test
39
40%install
41rm -rf %{buildroot}
42%{__python} setup.py install --skip-build --no-compile --root %{buildroot}
43rm -f tmpl_tutorial.html
44mkdir examples
45cp -p *.py examples/
46rm -f examples/test_urwid.py examples/docgen_*.py
47
48%clean
49rm -rf %{buildroot}
50
51%files
52%defattr(-,root,root,-)
53%doc CHANGELOG *.html examples
54%{python_sitearch}/urwid
55%{python_sitearch}/urwid-%{version}*.egg-info
56
57%changelog
58* Sat Dec 03 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.1-2
59- new upstream release
60
61* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-2
62- new upstream release
63- added BuildRequires: python-setuptools
64- run %%check
65
66* Fri Sep 23 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.0.0-1
67- new upstream release
68
69* Sat Aug 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.2-1
70- new upstream release
71
72* Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.1-2
73- rebuilt with rpm-4.8.1 for pkg-config
74
75* Fri May 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.9.9.1-1
76- initial build for VineSeed
77
78* Wed May 19 2010 David Cantrell <dcantrell@redhat.com> - 0.9.9.1-1
79- Initial package
Note: See TracBrowser for help on using the repository browser.