source: projects/specs/trunk/p/python-sphinx/python-sphinx-vl.spec @ 7722

Revision 7722, 8.4 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%global upstream_name Sphinx
4
5Name:       python-sphinx
6Version:    1.1.3
7Release:    1%{?_dist_release}
8Summary:    Python documentation generator
9
10Group:      Development/Tools
11
12# Unless otherwise noted, the license for code is BSD
13# sphinx/util/stemmer.py Public Domain
14# sphinx/pycode/pgen2 Python
15# jquery (MIT or GPLv2)
16License: BSD and Public Domain and Python and (MIT or GPLv2)
17URL:        http://sphinx.pocoo.org/
18Source0:    http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
19Patch1: Sphinx-1.1.3-fix_quoting_in_inheritance.patch
20
21BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
22BuildArch:     noarch
23BuildRequires: python-devel >= 2.4
24BuildRequires: python-setuptools
25
26#%if %{?_dist_release} == "vl5"
27#BuildRequires: python-simplejson
28#BuildRequires: docutils
29#%else
30BuildRequires: python-docutils
31#%endif
32
33BuildRequires: python-jinja2
34BuildRequires: python-nose
35#%if %{?_dist_release} == "vl5"
36#Requires:      docutils
37#%else
38Requires:      python-docutils
39#%endif
40Requires:      python-jinja2
41Requires:      python-pygments
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47Sphinx is a tool that makes it easy to create intelligent and
48beautiful documentation for Python projects (or other documents
49consisting of multiple reStructuredText sources), written by Georg
50Brandl. It was originally created to translate the new Python
51documentation, but has now been cleaned up in the hope that it will be
52useful to many other projects.
53
54Sphinx uses reStructuredText as its markup language, and many of its
55strengths come from the power and straightforwardness of
56reStructuredText and its parsing and translating suite, the Docutils.
57
58Although it is still under constant development, the following
59features are already present, work fine and can be seen "in action" in
60the Python docs:
61
62    * Output formats: HTML (including Windows HTML Help) and LaTeX,
63      for printable PDF versions
64    * Extensive cross-references: semantic markup and automatic links
65      for functions, classes, glossary terms and similar pieces of
66      information
67    * Hierarchical structure: easy definition of a document tree, with
68      automatic links to siblings, parents and children
69    * Automatic indices: general index as well as a module index
70    * Code handling: automatic highlighting using the Pygments highlighter
71    * Various extensions are available, e.g. for automatic testing of
72      snippets and inclusion of appropriately formatted docstrings.
73
74
75%package doc
76Summary:    Documentation for %{name}
77Group:      Documentation
78License:    BSD
79Requires:   %{name} = %{version}-%{release}
80
81
82%description doc
83Sphinx is a tool that makes it easy to create intelligent and
84beautiful documentation for Python projects (or other documents
85consisting of multiple reStructuredText sources), written by Georg
86Brandl. It was originally created to translate the new Python
87documentation, but has now been cleaned up in the hope that it will be
88useful to many other projects.
89
90This package contains documentation in reST and HTML formats.
91
92
93%prep
94%setup -q -n %{upstream_name}-%{version}
95%__sed '1d' -i sphinx/pycode/pgen2/token.py
96%patch1 -p1
97
98%build
99%{__python} setup.py build
100pushd doc
101%__make html
102%__rm -rf _build/html/.buildinfo
103%__mv _build/html ..
104%__rm -rf _*
105popd
106
107
108%install
109%__rm -rf %{buildroot}
110
111%{__python} setup.py install --skip-build --root %{buildroot}
112
113
114# Manpages not in beta release yet
115#pushd doc
116# Deliver man pages
117#install -d %{buildroot}%{_mandir}/man1
118#mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
119#popd
120
121# Deliver rst files
122%__mv doc reST
123
124# Move language files to /usr/share in association with %patch1
125pushd %{buildroot}%{python_sitelib}
126
127for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
128do
129  install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
130  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
131  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
132     %{buildroot}%{_datadir}/sphinx/locale/$lang/
133  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
134    %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
135  %__rm -rf sphinx/locale/$lang
136done
137popd
138%find_lang sphinx
139
140# Language files; Since these are javascript, it's not immediately obvious to
141# find_lang that they need to be marked with a language.
142(cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
143  's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
144  >> sphinx.lang
145
146
147%clean
148%__rm -rf %{buildroot}
149
150
151%check
152%__make test
153
154
155%files -f sphinx.lang
156%defattr(-,root,root,-)
157%doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
158%{_bindir}/sphinx-*
159%{python_sitelib}/*
160%{_datadir}/sphinx/
161%exclude %{_datadir}/sphinx/locale/*/sphinx.js
162#%{_mandir}/man1/*
163
164%files doc
165%defattr(-,root,root,-)
166%doc html reST
167
168
169%changelog
170* Sun Jun 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.3-1
171- new upstream release
172
173* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-2
174- rebuild with python-2.7.2
175
176* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.7-1
177- new upstream release
178- add BuildRequires: python-simplejson for Vine5
179- add Vendor and Distribution tags
180
181* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
182- update sphinx to 1.0.5
183
184* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
185- initial build based on Fedora development
186
187* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
188- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
189
190* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
191- Update to 1.0 beta 2
192- Fixes problem building html documentation in non-English locales
193
194* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
195- Update to 1.0 beta 1
196
197* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
198- Update to 0.6.6
199
200* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
201- Few minor tweaks to Gareth's spec file update
202
203* Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
204- Update to 0.6.5
205- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
206- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
207- Minor tweaks to spec file
208- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
209  package
210- Deliver man pages for sphinx-build & sphinx-quickstart
211- Deliver rst documentation files to reST directory in doc sub-package
212- Add %%check section for Python2 and add BR on python-nose
213
214* Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
215- Update to 0.6.4
216- Fixes a problem using autodoc with pylons projects.
217
218* Fri Sep  4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
219- Update to 0.6.3
220
221* Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
222- Update to 0.6.2 -- upstream bugfix requested inside bz#512438
223
224* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
226
227* Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
228- Add a patch to use our own setuptools package
229
230* Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
231- Update to 0.6.1
232
233* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
235
236* Fri Jan  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
237- Update to 0.5.1
238
239* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
240- Rebuild for Python 2.6
241
242* Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
243- Update to 0.5
244
245* Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
246- Update to 0.4.3
247
248* Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
249- Fix for EL-5 build.
250
251* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
252- Update to 0.4.2
253
254* Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
255- Update to 0.3
256
257* Fri May  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
258- Split documentation into subpackage
259- Exclude C files (not built by default anyway)
260
261* Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
262- Build html documentation, include it and include the rst
263  documentation.
264
265* Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
266- Initial package
Note: See TracBrowser for help on using the repository browser.