source: projects/specs/trunk/p/python-sphinx/python-sphinx-vl.spec @ 12476

Revision 12476, 13.1 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

createrepo_c-0.16.0-1

dovecot-2.3.11.3-2

libsmbios-2.4.3-2

python-sphinx-3.2.1-2

python-sphinxcontrib-jsmath-1.0.1-10

rspamd-2.5-3

strongswan-5.9.0-1

system-storage-manager-1.4-1

trousers-0.3.14-1

Line 
1%bcond_with bootstrap
2
3%global upstream_name Sphinx
4%global py3_default 0
5
6Summary:        Python documentation generator
7Name:           python-sphinx
8Version:        3.2.1
9Release:        2%{?_dist_release}
10Group:          publishing,programming
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14# Unless otherwise noted, the license for code is BSD
15# sphinx/util/stemmer.py Public Domain
16# sphinx/pycode/pgen2 Python
17# jquery (MIT or GPLv2)
18License: BSD and Public Domain and Python and (MIT or GPLv2)
19URL:        http://sphinx.pocoo.org/
20
21Source0:    https://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
22
23# Allow extra themes to exist. We pull in python[23]-sphinx-theme-alabaster
24# which causes that test to fail.
25Patch1: sphinx-test_theming.diff
26
27BuildArch:     noarch
28BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: python-rpm-macros
30
31%description
32Sphinx is a tool that makes it easy to create intelligent and
33beautiful documentation for Python projects (or other documents
34consisting of multiple reStructuredText sources), written by Georg
35Brandl. It was originally created to translate the new Python
36documentation, but has now been cleaned up in the hope that it will be
37useful to many other projects.
38
39Sphinx uses reStructuredText as its markup language, and many of its
40strengths come from the power and straightforwardness of
41reStructuredText and its parsing and translating suite, the Docutils.
42
43Although it is still under constant development, the following
44features are already present, work fine and can be seen "in action" in
45the Python docs:
46
47    * Output formats: HTML (including Windows HTML Help) and LaTeX,
48      for printable PDF versions
49    * Extensive cross-references: semantic markup and automatic links
50      for functions, classes, glossary terms and similar pieces of
51      information
52    * Hierarchical structure: easy definition of a document tree, with
53      automatic links to siblings, parents and children
54    * Automatic indices: general index as well as a module index
55    * Code handling: automatic highlighting using the Pygments highlighter
56    * Various extensions are available, e.g. for automatic testing of
57      snippets and inclusion of appropriately formatted docstrings.
58
59
60%package -n python3-sphinx
61Summary:       Python documentation generator
62Group:         publishing,programming
63
64BuildRequires: python3-rpm-macros
65BuildRequires: python3-devel
66BuildRequires: python3-setuptools
67
68BuildRequires: python3-six
69BuildRequires: python3-jinja2
70BuildRequires: python3-docutils
71BuildRequires: python3-snowballstemmer
72BuildRequires: python3-babel
73BuildRequires: python3-sphinx-theme-alabaster
74BuildRequires: python3-imagesize
75BuildRequires: python3-requests
76BuildRequires: python3-packaging
77
78Requires:      python3-setuptools
79Requires:      python-sphinx-locale = %{version}-%{release}
80Requires:      python3-six
81Requires:      python3-jinja2
82Requires:      python3-docutils
83Requires:      python3-snowballstemmer
84Requires:      python3-babel
85Requires:      python3-sphinx-theme-alabaster
86Requires:      python3-imagesize
87Requires:      python3-requests
88Requires:      python3-packaging
89
90%if !%{with bootstrap}
91BuildRequires: python3-pygments
92BuildRequires: python3-sphinxcontrib-websupport
93BuildRequires: python3-sphinxcontrib-serializinghtml
94BuildRequires: python3-sphinxcontrib-applehelp
95BuildRequires: python3-sphinxcontrib-devhelp
96BuildRequires: python3-sphinxcontrib-htmlhelp
97BuildRequires: python3-sphinxcontrib-qthelp
98BuildRequires: python3-sphinxcontrib-jsmath
99Requires:      python3-pygments
100Requires:      python3-sphinxcontrib-websupport
101Requires:      python3-sphinxcontrib-serializinghtml
102Requires:      python3-sphinxcontrib-applehelp
103Requires:      python3-sphinxcontrib-devhelp
104Requires:      python3-sphinxcontrib-htmlhelp
105Requires:      python3-sphinxcontrib-qthelp
106Requires:      python3-sphinxcontrib-jsmath
107%endif
108
109%description -n python3-sphinx
110Sphinx is a tool that makes it easy to create intelligent and
111beautiful documentation for Python projects (or other documents
112consisting of multiple reStructuredText sources), written by Georg
113Brandl. It was originally created to translate the new Python
114documentation, but has now been cleaned up in the hope that it will be
115useful to many other projects.
116
117Sphinx uses reStructuredText as its markup language, and many of its
118strengths come from the power and straightforwardness of
119reStructuredText and its parsing and translating suite, the Docutils.
120
121Although it is still under constant development, the following
122features are already present, work fine and can be seen "in action" in
123the Python docs:
124
125    * Output formats: HTML (including Windows HTML Help) and LaTeX,
126      for printable PDF versions
127    * Extensive cross-references: semantic markup and automatic links
128      for functions, classes, glossary terms and similar pieces of
129      information
130    * Hierarchical structure: easy definition of a document tree, with
131      automatic links to siblings, parents and children
132    * Automatic indices: general index as well as a module index
133    * Code handling: automatic highlighting using the Pygments highlighter
134    * Various extensions are available, e.g. for automatic testing of
135      snippets and inclusion of appropriately formatted docstrings.
136
137%package locale
138Summary:        Locale files for %{name}
139Group:          publishing
140License:        BSD
141
142%description locale
143Sphinx is a tool that makes it easy to create intelligent and
144beautiful documentation for Python projects (or other documents
145consisting of multiple reStructuredText sources), written by Georg
146Brandl. It was originally created to translate the new Python
147documentation, but has now been cleaned up in the hope that it will be
148useful to many other projects.
149
150This package contains locale files for Sphinx
151
152%package doc
153Summary:    Documentation for %{name}
154Group:      documentation
155License:    BSD
156
157
158%description doc
159Sphinx is a tool that makes it easy to create intelligent and
160beautiful documentation for Python projects (or other documents
161consisting of multiple reStructuredText sources), written by Georg
162Brandl. It was originally created to translate the new Python
163documentation, but has now been cleaned up in the hope that it will be
164useful to many other projects.
165
166This package contains documentation in reST and HTML formats.
167
168
169%prep
170%autosetup -n %{upstream_name}-%{version} -p1
171
172# fix line encoding of bundled jquery.js
173perl -pi -e 's/\r//' ./sphinx/themes/basic/static/jquery.js
174
175
176%build
177%py3_build
178
179%if !%{with bootstrap}
180export PYTHONPATH=$PWD
181pushd doc
182export SPHINXBUILD="%{__python3} ../sphinx/cmd/build.py"
183make html SPHINXBUILD="$SPHINXBUILD"
184make man SPHINXBUILD="$SPHINXBUILD"
185rm -rf _build/html/.buildinfo
186mv _build/html ..
187popd
188%endif
189
190%install
191%__rm -rf %{buildroot}
192%py3_install
193
194# Clean up non-python files
195rm -f %{buildroot}%{python3_sitelib}/sphinx/locale/.DS_Store
196rm -rf %{buildroot}%{python3_sitelib}/sphinx/locale/.tx
197
198%if !%{with bootstrap}
199pushd doc
200# Deliver man pages
201install -d %{buildroot}%{_mandir}/man1
202for f in _build/man/sphinx-*.1;
203do
204    cp -p $f %{buildroot}%{_mandir}/man1/$(basename $f)
205done
206popd
207%endif
208
209# Deliver rst files
210rm -rf doc/_build
211sed -i 's|python ../sphinx-build.py|/usr/bin/sphinx-build|' doc/Makefile
212mv doc reST
213rm reST/make.bat
214
215# Move language files to /usr/share;
216# patch to support this incorporated in 0.6.6
217pushd %{buildroot}%{python3_sitelib}
218
219for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -not -path '*/\.
220*' -printf "%f "`;
221do
222  test $lang == __pycache__ && continue
223  install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
224  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
225  mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
226     %{buildroot}%{_datadir}/sphinx/locale/$lang/
227  mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
228    %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
229  rm -rf sphinx/locale/$lang
230done
231popd
232
233# Create the sphinxcontrib directory, so we can own it
234# See https://bugzilla.redhat.com/show_bug.cgi?id=1669790 for rationale
235mkdir %{buildroot}%{python3_sitelib}/sphinxcontrib
236
237%find_lang sphinx
238
239# Language files; Since these are javascript, it's not immediately obvious to
240# find_lang that they need to be marked with a language.
241(cd %{buildroot} && find . -name 'sphinx.js') | sed -e 's|^.||' | sed -e \
242  's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
243  >> sphinx.lang
244
245
246%clean
247%__rm -rf %{buildroot}
248
249
250%check
251#__make test
252
253
254%files -n python3-sphinx
255%license LICENSE
256%doc AUTHORS CHANGES EXAMPLES README.*
257%{_bindir}/sphinx-*
258%{python3_sitelib}/sphinx/
259%{python3_sitelib}/Sphinx-%{version}-py%{python3_version}.egg-info/
260%dir %{python3_sitelib}/sphinxcontrib/
261%dir %{_datadir}/sphinx/
262%if !%{with bootstrap}
263%{_mandir}/man1/sphinx-*
264%endif
265
266%files locale -f sphinx.lang
267%license LICENSE
268%dir %{_datadir}/sphinx/
269%dir %{_datadir}/sphinx/locale
270%dir %{_datadir}/sphinx/locale/*
271
272%files doc
273%defattr(-,root,root,-)
274%license LICENSE
275%if !%{with bootstrap}
276%doc html reST
277%endif
278
279
280%changelog
281* Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-2
282- added R:python3-sphinxcontrib-jsmath.
283
284* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
285- new upstream release.
286- built with python3 only.
287
288* Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.9-2
289- fixed R:.
290
291* Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.9-1
292- new upstream release.
293- dropped Patch2.
294- imported Patch0-1 from rawhide.
295- added python3 support.
296
297* Wed May 09 2018 Toshiaki Ara <ara_t@384.jp> 1.1.3-3
298- added patch2 from RedHat
299
300* Thu Jul  2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.3-2
301- added patch0.
302
303* Sun Jun 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.3-1
304- new upstream release
305
306* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-2
307- rebuild with python-2.7.2
308
309* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.7-1
310- new upstream release
311- add BuildRequires: python-simplejson for Vine5
312- add Vendor and Distribution tags
313
314* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
315- update sphinx to 1.0.5
316
317* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
318- initial build based on Fedora development
319
320* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
321- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
322
323* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
324- Update to 1.0 beta 2
325- Fixes problem building html documentation in non-English locales
326
327* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
328- Update to 1.0 beta 1
329
330* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
331- Update to 0.6.6
332
333* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
334- Few minor tweaks to Gareth's spec file update
335
336* Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
337- Update to 0.6.5
338- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
339- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
340- Minor tweaks to spec file
341- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
342  package
343- Deliver man pages for sphinx-build & sphinx-quickstart
344- Deliver rst documentation files to reST directory in doc sub-package
345- Add %%check section for Python2 and add BR on python-nose
346
347* Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
348- Update to 0.6.4
349- Fixes a problem using autodoc with pylons projects.
350
351* Fri Sep  4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
352- Update to 0.6.3
353
354* Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
355- Update to 0.6.2 -- upstream bugfix requested inside bz#512438
356
357* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
358- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
359
360* Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
361- Add a patch to use our own setuptools package
362
363* Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
364- Update to 0.6.1
365
366* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
367- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
368
369* Fri Jan  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
370- Update to 0.5.1
371
372* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
373- Rebuild for Python 2.6
374
375* Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
376- Update to 0.5
377
378* Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
379- Update to 0.4.3
380
381* Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
382- Fix for EL-5 build.
383
384* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
385- Update to 0.4.2
386
387* Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
388- Update to 0.3
389
390* Fri May  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
391- Split documentation into subpackage
392- Exclude C files (not built by default anyway)
393
394* Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
395- Build html documentation, include it and include the rst
396  documentation.
397
398* Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
399- Initial package
Note: See TracBrowser for help on using the repository browser.