source: projects/specs/trunk/p/python-sphinx/python-sphinx-vl.spec @ 2258

Revision 2258, 7.7 KB checked in by owa, 13 years ago (diff)

python-* new upstream

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%global upstream_name Sphinx
4
5Name:       python-sphinx
6Version:    1.0.5
7Release:    1%{?_dist_release}
8Summary:    Python documentation generator
9
10Group:      Development/Tools
11
12# Unless otherwise noted, the license for code is BSD
13# sphinx/util/stemmer.py Public Domain
14# sphinx/pycode/pgen2 Python
15# jquery (MIT or GPLv2)
16License: BSD and Public Domain and Python and (MIT or GPLv2)
17URL:        http://sphinx.pocoo.org/
18Source0:    http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
19
20BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
21BuildArch:     noarch
22BuildRequires: python-devel >= 2.4
23BuildRequires: python-setuptools
24BuildRequires: python-docutils
25BuildRequires: python-jinja2
26BuildRequires: python-nose
27Requires:      python-docutils
28Requires:      python-jinja2
29Requires:      python-pygments
30
31
32%description
33Sphinx is a tool that makes it easy to create intelligent and
34beautiful documentation for Python projects (or other documents
35consisting of multiple reStructuredText sources), written by Georg
36Brandl. It was originally created to translate the new Python
37documentation, but has now been cleaned up in the hope that it will be
38useful to many other projects.
39
40Sphinx uses reStructuredText as its markup language, and many of its
41strengths come from the power and straightforwardness of
42reStructuredText and its parsing and translating suite, the Docutils.
43
44Although it is still under constant development, the following
45features are already present, work fine and can be seen "in action" in
46the Python docs:
47
48    * Output formats: HTML (including Windows HTML Help) and LaTeX,
49      for printable PDF versions
50    * Extensive cross-references: semantic markup and automatic links
51      for functions, classes, glossary terms and similar pieces of
52      information
53    * Hierarchical structure: easy definition of a document tree, with
54      automatic links to siblings, parents and children
55    * Automatic indices: general index as well as a module index
56    * Code handling: automatic highlighting using the Pygments highlighter
57    * Various extensions are available, e.g. for automatic testing of
58      snippets and inclusion of appropriately formatted docstrings.
59
60
61%package doc
62Summary:    Documentation for %{name}
63Group:      Documentation
64License:    BSD
65Requires:   %{name} = %{version}-%{release}
66
67
68%description doc
69Sphinx is a tool that makes it easy to create intelligent and
70beautiful documentation for Python projects (or other documents
71consisting of multiple reStructuredText sources), written by Georg
72Brandl. It was originally created to translate the new Python
73documentation, but has now been cleaned up in the hope that it will be
74useful to many other projects.
75
76This package contains documentation in reST and HTML formats.
77
78
79%prep
80%setup -q -n %{upstream_name}-%{version}
81%__sed '1d' -i sphinx/pycode/pgen2/token.py
82
83%build
84%{__python} setup.py build
85pushd doc
86%__make html
87%__rm -rf _build/html/.buildinfo
88%__mv _build/html ..
89%__rm -rf _*
90popd
91
92
93%install
94%__rm -rf %{buildroot}
95
96%{__python} setup.py install --skip-build --root %{buildroot}
97
98
99# Manpages not in beta release yet
100#pushd doc
101# Deliver man pages
102#install -d %{buildroot}%{_mandir}/man1
103#mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
104#popd
105
106# Deliver rst files
107%__mv doc reST
108
109# Move language files to /usr/share in association with %patch1
110pushd %{buildroot}%{python_sitelib}
111
112for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
113do
114  install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
115  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
116  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
117     %{buildroot}%{_datadir}/sphinx/locale/$lang/
118  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
119    %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
120  %__rm -rf sphinx/locale/$lang
121done
122popd
123%find_lang sphinx
124
125# Language files; Since these are javascript, it's not immediately obvious to
126# find_lang that they need to be marked with a language.
127(cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
128  's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
129  >> sphinx.lang
130
131
132%clean
133%__rm -rf %{buildroot}
134
135
136%check
137%__make test
138
139
140%files -f sphinx.lang
141%defattr(-,root,root,-)
142%doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
143%{_bindir}/sphinx-*
144%{python_sitelib}/*
145%{_datadir}/sphinx/
146%exclude %{_datadir}/sphinx/locale/*/sphinx.js
147#%{_mandir}/man1/*
148
149%files doc
150%defattr(-,root,root,-)
151%doc html reST
152
153
154%changelog
155* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
156- update sphinx to 1.0.5
157
158* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
159- initial build based on Fedora development
160
161* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
162- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
163
164* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
165- Update to 1.0 beta 2
166- Fixes problem building html documentation in non-English locales
167
168* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
169- Update to 1.0 beta 1
170
171* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
172- Update to 0.6.6
173
174* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
175- Few minor tweaks to Gareth's spec file update
176
177* Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
178- Update to 0.6.5
179- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
180- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
181- Minor tweaks to spec file
182- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
183  package
184- Deliver man pages for sphinx-build & sphinx-quickstart
185- Deliver rst documentation files to reST directory in doc sub-package
186- Add %%check section for Python2 and add BR on python-nose
187
188* Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
189- Update to 0.6.4
190- Fixes a problem using autodoc with pylons projects.
191
192* Fri Sep  4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
193- Update to 0.6.3
194
195* Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
196- Update to 0.6.2 -- upstream bugfix requested inside bz#512438
197
198* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
199- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
200
201* Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
202- Add a patch to use our own setuptools package
203
204* Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
205- Update to 0.6.1
206
207* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
209
210* Fri Jan  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
211- Update to 0.5.1
212
213* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
214- Rebuild for Python 2.6
215
216* Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
217- Update to 0.5
218
219* Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
220- Update to 0.4.3
221
222* Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
223- Fix for EL-5 build.
224
225* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
226- Update to 0.4.2
227
228* Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
229- Update to 0.3
230
231* Fri May  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
232- Split documentation into subpackage
233- Exclude C files (not built by default anyway)
234
235* Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
236- Build html documentation, include it and include the rst
237  documentation.
238
239* Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
240- Initial package
Note: See TracBrowser for help on using the repository browser.