source: projects/specs/trunk/p/python-sphinx/python-sphinx-vl.spec @ 9655

Revision 9655, 8.5 KB checked in by tomop, 9 years ago (diff)

python-sphinx-1.1.3-2

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3%global upstream_name Sphinx
4
5Name:       python-sphinx
6Version:    1.1.3
7Release:    2%{?_dist_release}
8Summary:    Python documentation generator
9
10Group:      Development/Tools
11
12# Unless otherwise noted, the license for code is BSD
13# sphinx/util/stemmer.py Public Domain
14# sphinx/pycode/pgen2 Python
15# jquery (MIT or GPLv2)
16License: BSD and Public Domain and Python and (MIT or GPLv2)
17URL:        http://sphinx.pocoo.org/
18Source0:    http://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
19Patch0: sphinx-docutils-0.10.patch
20Patch1: Sphinx-1.1.3-fix_quoting_in_inheritance.patch
21
22BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildArch:     noarch
24BuildRequires: python-devel >= 2.4
25BuildRequires: python-setuptools
26
27#%if %{?_dist_release} == "vl5"
28#BuildRequires: python-simplejson
29#BuildRequires: docutils
30#%else
31BuildRequires: python-docutils
32#%endif
33
34BuildRequires: python-jinja2
35BuildRequires: python-nose
36#%if %{?_dist_release} == "vl5"
37#Requires:      docutils
38#%else
39Requires:      python-docutils
40#%endif
41Requires:      python-jinja2
42Requires:      python-pygments
43
44Vendor: Project Vine
45Distribution: Vine Linux
46
47%description
48Sphinx is a tool that makes it easy to create intelligent and
49beautiful documentation for Python projects (or other documents
50consisting of multiple reStructuredText sources), written by Georg
51Brandl. It was originally created to translate the new Python
52documentation, but has now been cleaned up in the hope that it will be
53useful to many other projects.
54
55Sphinx uses reStructuredText as its markup language, and many of its
56strengths come from the power and straightforwardness of
57reStructuredText and its parsing and translating suite, the Docutils.
58
59Although it is still under constant development, the following
60features are already present, work fine and can be seen "in action" in
61the Python docs:
62
63    * Output formats: HTML (including Windows HTML Help) and LaTeX,
64      for printable PDF versions
65    * Extensive cross-references: semantic markup and automatic links
66      for functions, classes, glossary terms and similar pieces of
67      information
68    * Hierarchical structure: easy definition of a document tree, with
69      automatic links to siblings, parents and children
70    * Automatic indices: general index as well as a module index
71    * Code handling: automatic highlighting using the Pygments highlighter
72    * Various extensions are available, e.g. for automatic testing of
73      snippets and inclusion of appropriately formatted docstrings.
74
75
76%package doc
77Summary:    Documentation for %{name}
78Group:      Documentation
79License:    BSD
80Requires:   %{name} = %{version}-%{release}
81
82
83%description doc
84Sphinx is a tool that makes it easy to create intelligent and
85beautiful documentation for Python projects (or other documents
86consisting of multiple reStructuredText sources), written by Georg
87Brandl. It was originally created to translate the new Python
88documentation, but has now been cleaned up in the hope that it will be
89useful to many other projects.
90
91This package contains documentation in reST and HTML formats.
92
93
94%prep
95%setup -q -n %{upstream_name}-%{version}
96%__sed '1d' -i sphinx/pycode/pgen2/token.py
97%patch0 -p1
98%patch1 -p1
99
100%build
101%{__python} setup.py build
102pushd doc
103%__make html
104%__rm -rf _build/html/.buildinfo
105%__mv _build/html ..
106%__rm -rf _*
107popd
108
109
110%install
111%__rm -rf %{buildroot}
112
113%{__python} setup.py install --skip-build --root %{buildroot}
114
115
116# Manpages not in beta release yet
117#pushd doc
118# Deliver man pages
119#install -d %{buildroot}%{_mandir}/man1
120#mv sphinx-*.1 %{buildroot}%{_mandir}/man1/
121#popd
122
123# Deliver rst files
124%__mv doc reST
125
126# Move language files to /usr/share in association with %patch1
127pushd %{buildroot}%{python_sitelib}
128
129for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -printf "%f "`;
130do
131  install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
132  install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
133  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
134     %{buildroot}%{_datadir}/sphinx/locale/$lang/
135  %__mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
136    %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
137  %__rm -rf sphinx/locale/$lang
138done
139popd
140%find_lang sphinx
141
142# Language files; Since these are javascript, it's not immediately obvious to
143# find_lang that they need to be marked with a language.
144(cd %{buildroot} && find . -name 'sphinx.js') | %__sed -e 's|^.||' | %__sed -e \
145  's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
146  >> sphinx.lang
147
148
149%clean
150%__rm -rf %{buildroot}
151
152
153%check
154%__make test
155
156
157%files -f sphinx.lang
158%defattr(-,root,root,-)
159%doc AUTHORS CHANGES EXAMPLES LICENSE README TODO
160%{_bindir}/sphinx-*
161%{python_sitelib}/*
162%{_datadir}/sphinx/
163%exclude %{_datadir}/sphinx/locale/*/sphinx.js
164#%{_mandir}/man1/*
165
166%files doc
167%defattr(-,root,root,-)
168%doc html reST
169
170
171%changelog
172* Fri Jul  3 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.3-2
173- added patch0.
174
175* Sun Jun 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.3-1
176- new upstream release
177
178* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-2
179- rebuild with python-2.7.2
180
181* Thu May  5 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.7-1
182- new upstream release
183- add BuildRequires: python-simplejson for Vine5
184- add Vendor and Distribution tags
185
186* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
187- update sphinx to 1.0.5
188
189* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
190- initial build based on Fedora development
191
192* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
193- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
194
195* Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
196- Update to 1.0 beta 2
197- Fixes problem building html documentation in non-English locales
198
199* Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
200- Update to 1.0 beta 1
201
202* Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
203- Update to 0.6.6
204
205* Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
206- Few minor tweaks to Gareth's spec file update
207
208* Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
209- Update to 0.6.5
210- Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
211- Enforce that Sphinx requires Python 2.4 or later via an explicit BR
212- Minor tweaks to spec file
213- Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
214  package
215- Deliver man pages for sphinx-build & sphinx-quickstart
216- Deliver rst documentation files to reST directory in doc sub-package
217- Add %%check section for Python2 and add BR on python-nose
218
219* Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
220- Update to 0.6.4
221- Fixes a problem using autodoc with pylons projects.
222
223* Fri Sep  4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
224- Update to 0.6.3
225
226* Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
227- Update to 0.6.2 -- upstream bugfix requested inside bz#512438
228
229* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
231
232* Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
233- Add a patch to use our own setuptools package
234
235* Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
236- Update to 0.6.1
237
238* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
240
241* Fri Jan  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
242- Update to 0.5.1
243
244* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
245- Rebuild for Python 2.6
246
247* Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
248- Update to 0.5
249
250* Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
251- Update to 0.4.3
252
253* Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
254- Fix for EL-5 build.
255
256* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
257- Update to 0.4.2
258
259* Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
260- Update to 0.3
261
262* Fri May  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
263- Split documentation into subpackage
264- Exclude C files (not built by default anyway)
265
266* Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
267- Build html documentation, include it and include the rst
268  documentation.
269
270* Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
271- Initial package
Note: See TracBrowser for help on using the repository browser.