source: projects/specs/trunk/p/python-six/python-six-vl.spec @ 12545

Revision 12545, 3.3 KB checked in by tomop, 3 years ago (diff)

rpm-4.16.1.2-1 and requirements

Line 
1%define pkgname six
2
3# Basic Information
4Name:           python-six
5Version:        1.15.0
6Release:        2%{?_dist_release}
7Group:          programming
8Vendor:         Project Vine
9Distribution:   Vine Linux
10Packager:       yasumichi
11
12License:        MIT
13URL:            https://pypi.python.org/pypi/six/
14Source0:        https://pypi.python.org/packages/source/s/%{pkgname}/%{pkgname}-%{version}.tar.gz
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17Summary:        Python 2 and 3 compatibility utilities
18Summary(ja):    Python 2 および 3 の互換ユーテリティ
19
20BuildArch:      noarch
21# Dependency
22Requires:       python
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25BuildRequires:  python3-devel
26BuildRequires:  python3-setuptools
27
28%description
29for smoothing over the differences between the Python versions with the goal of
30writing Python code that is compatible on both Python versions.  See the
31documentation for more information on what is provided.
32
33Six supports every Python version since 2.5.  It is contained in only one Python
34file, so it can be easily copied into your project. (The copyright and license
35notice must be retained.)
36
37Online documentation is at http://pythonhosted.org/six/.
38
39Bugs can be reported to http://bitbucket.org/gutworth/six.  The code can also be
40found there.
41
42For questions about six or porting in general, email the python-porting mailing
43list: http://mail.python.org/mailman/listinfo/python-porting
44
45%package -n     python3-six
46Summary:        Python 2 and 3 compatibility utilities
47Summary(ja):    Python 2 および 3 の互換ユーテリティ
48Group:          programming
49Requires:       python3
50
51%description -n python3-six
52for smoothing over the differences between the Python versions with the goal of
53writing Python code that is compatible on both Python versions.  See the
54documentation for more information on what is provided.
55
56Six supports every Python version since 2.5.  It is contained in only one Python
57file, so it can be easily copied into your project. (The copyright and license
58notice must be retained.)
59
60Online documentation is at http://pythonhosted.org/six/.
61
62Bugs can be reported to http://bitbucket.org/gutworth/six.  The code can also be
63found there.
64
65For questions about six or porting in general, email the python-porting mailing
66list: http://mail.python.org/mailman/listinfo/python-porting
67
68
69%prep
70%setup -q -n six-%{version}
71
72
73%build
74%py_build
75%py3_build
76
77
78%install
79%{__rm} -rf ${RPM_BUILD_ROOT}
80%py_install
81%py3_install
82
83
84%clean
85%{__rm} -rf ${RPM_BUILD_ROOT}
86
87
88%files
89%defattr(-,root,root)
90%license LICENSE
91%doc README*
92%{python_sitelib}/six-%{version}-py*.egg-info
93%{python_sitelib}/six.py*
94
95%files -n python3-six
96%defattr(-,root,root)
97%license LICENSE
98%doc README*
99%{python3_sitelib}/six-%{version}-py*.egg-info
100%{python3_sitelib}/six.py*
101%{python3_sitelib}/__pycache__/six.*
102
103
104%changelog
105* Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.0-2
106- rebuilt with rpm-4.16.
107
108* Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.0-1
109- new upstream release.
110
111* Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.0-1
112- new upstream release.
113
114* Wed Jan 31 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
115- new upstream release.
116- added a subpackage for python3.
117
118* Sun Nov 15 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
119- new upstream release.
120
121* Sat Sep 20 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.8.0-1
122- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.