source: projects/specs/trunk/p/python-simplejson/python-simplejson-vl.spec @ 5701

Revision 5701, 5.7 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

RevLine 
[1741]1%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
[521]2
[1741]3%global _use_internal_dependency_generator 0
4%global __find_provides /bin/sh -c "%{_rpmconfigdir}/find-provides | grep -v -E '(_speedups.so)' || /bin/true"
5%global __find_requires /bin/sh -c "%{_rpmconfigdir}/find-requires | grep -v -E '(_speedups.so)' || /bin/true"
[521]6
[1741]7Name:           python-simplejson
[521]8
[2258]9Version:        2.1.2
[5701]10Release:        2%{?_dist_release}
[1741]11Summary:        Simple, fast, extensible JSON encoder/decoder for Python
[521]12
[1741]13Group:          System Environment/Libraries
14# The main code is licensed MIT.
15# The docs include jquery which is licensed MIT or GPLv2
16License: MIT and (MIT or GPLv2)
17URL:            http://undefined.org/python/#simplejson
18Source0:        http://pypi.python.org/packages/source/s/simplejson/simplejson-%{version}.tar.gz
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
[521]20
[1741]21BuildRequires:  python-devel
22BuildRequires:  python-setuptools
23BuildRequires:  python-nose
[521]24
[1741]25
[521]26%description
[1741]27simplejson is a simple, fast, complete, correct and extensible JSON
28<http://json.org> encoder and decoder for Python 2.5+. It is pure Python code
29with no dependencies, but includes an optional C extension for a serious speed
30boost.
[521]31
[1741]32simplejson is the externally maintained development version of the json library
33included with Python 2.6 and Python 3.0, but maintains backwards compatibility
34with Python 2.5.
[521]35
36The encoder may be subclassed to provide serialization in any kind of
37situation, without any special support by the objects to be serialized
38(somewhat like pickle).
39
[1741]40The decoder can handle incoming JSON strings of any specified encoding (UTF-8
41by default).
[521]42
43
44%prep
45%setup -q -n simplejson-%{version}
46
47
48%build
49%{__python} setup.py build
50
51
52%install
[1741]53%__rm -rf $RPM_BUILD_ROOT
54%{__python} setup.py install --skip-build --root=$RPM_BUILD_ROOT
[521]55
56%check
57nosetests -q
58
59%clean
[1741]60%__rm -rf $RPM_BUILD_ROOT
[521]61
62
63%files
64%defattr(-,root,root,-)
65%doc docs LICENSE.txt
66%dir %{python_sitearch}/simplejson
[1741]67%{python_sitearch}/simplejson-*.egg-info
[521]68%{python_sitearch}/simplejson/*.py*
69%{python_sitearch}/simplejson/tests/*.py*
70%{python_sitearch}/simplejson/_speedups.so
71
72
73%changelog
[5701]74* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.1.2-2
75- rebuild with python-2.7.2
76
[2258]77* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> - 2.1.2-1
78- updated simplejson to 2.1.2
79
[1741]80* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 2.1.1-1
81- initial build based on Fedora development
[521]82
[1741]83* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.1-3
84- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
[521]85
[1741]86* Wed Jun 30 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 2.1.1-2
87- Filter unnecessary provides
88- License tag update
89- Minor spec file cleanups
90
91* Mon Jun 21 2010 Kyle VanderBeek <kylev@kylev.com> - 2.1.1-1
92- Update to 2.1.1
93
94* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.9-3
95- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
96
97* Fri Jun  5 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-2
98- Remove ill-advised gcc BuildRequires
99
100* Thu Jun  4 2009 Kyle VanderBeek <kylev@kylev.com> - 2.0.9-1
101- Update to 2.0.9
102- Make sure to require gcc to the speedups get compiled
103- Fix description since we're not "pure" python
104- Change to pypi instead of cheesehop
105
106* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.7-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
108
109* Tue Jan 06 2009 Luke Macken <lmacken@redhat.com> 2.0.7-1
110- Update to 2.0.7
111
[521]112* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.3-3
113- Rebuild for Python 2.6
114
115* Thu Oct 23 2008 Luke Macken <lmacken@redhat.com> 2.0.3-2
116- Use nose to run the simplejson test suite
117
118* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> 2.0.3-1
119- update to 2.0.3
120
121* Wed Oct 01 2008 Luke Macken <lmacken@redhat.com> - 2.0.1-1
122- Update to 2.0.1, which contains many optimizations and bugfixes
123
124* Wed Sep 24 2008 Luke Macken <lmacken@redhat.com> - 1.9.3-1
125- Update to 1.9.3, which includes a significant decoding speed boost, and
126  various bug fixes.
127
128* Tue May 06 2008 Luke Macken <lmacken@redhat.com> - 1.9.1-1
129- Update to 1.9.1
130
131* Wed Apr 02 2008 Luke Macken <lmacken@redhat.com> - 1.8.1-1
132- Update to 1.8.1
133
134* Thu Feb 28 2008 Luke Macken <lmacken@redhat.com> - 1.7.4-1
135- Update to 1.7.4
136
137* Fri Feb  8 2008 Luke Macken <lmacken@redhat.com> - 1.7.3-3
138- Rebuild for gcc 4.3
139
140* Wed Oct 24 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-2
141- Include the LICENSE.txt
142
143* Wed Oct  3 2007 Luke Macken <lmacken@redhat.com> - 1.7.3-1
144- 1.7.3
145
146* Sun Sep  2 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-3
147- Update for python-setuptools changes in rawhide
148
149* Tue Aug 21 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-2
150- Rebuild
151
152* Sun Jul  8 2007 Luke Macken <lmacken@redhat.com> - 1.7.1-1
153- 1.7.1
154
155* Wed Mar 21 2007 Luke Macken <lmacken@redhat.com> - 1.7-2
156- Use python_sitearch instead of sitelib
157
158* Tue Mar 20 2007 Luke Macken <lmacken@redhat.com> - 1.7-1
159- 1.7 (Bug #233212)
160
161* Sat Mar  3 2007 Luke Macken <lmacken@redhat.com> - 1.5
162- 1.5
163
164* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-4
165- Add python-devel to BuildRequires
166
167* Sat Dec  9 2006 Luke Macken <lmacken@redhat.com> - 1.4-2
168- Rebuild for new python
169
170* Fri Nov 24 2006 Luke Macken <lmacken@redhat.com> - 1.4-1
171- 1.4
172
173* Sun Sep  3 2006 Luke Macken <lmacken@redhat.com> - 1.3-4
174- Rebuild for FC6
175
176* Mon Aug 14 2006 Luke Macken <lmacken@redhat.com> - 1.3-3
177- Include .pyo's instead of just ghosting them
178
179* Wed Jul 12 2006 Luke Macken <lmacken@redhat.com> - 1.3-2
180- Add --single-version-externally-managed flag to install
181
182* Mon Jul 10 2006 Luke Macken <lmacken@redhat.com> - 1.3-1
183- Initial package
Note: See TracBrowser for help on using the repository browser.